Jump to content
davejones

Share your knowledge...

11 posts in this topic

Recommended Posts

Is it ok to keep booting my Hackintosh with the "-s" command on the EFI v.80 boot menu? The reason I ask is because this is the only way I can get my sound card to work & stay after each reboot (otherwise it always disappears).

 

What exactly does the "-s" do & are there any disadvantages or negative effects of always booting with it?

 

Lastly, is there anyway to boot with it enabled permanently (without me having to press F8 & type "-s" at each boot up?)

 

Thanks

Share this post


Link to post
Share on other sites
Advertisement

If -s is the only wayt that you can get it to work, perhaps don't worry about it.

 

I'd be a bit worried personally, since I work in security (-s is the single user bootup switch right). That sort of logs you in to OS X as the 'root' user, so you are logged on with full admin rights, etc. Typically not the best idea on a modern multi-user aware operating system.

 

Double check that you set the permissions correctly when you did your sound card changes (this is wrong thread, though), or perhaps run the repair permissions tools after making it work.

Share this post


Link to post
Share on other sites

Hi cyrana,

 

You are right, but if I don't boot with "-s", after a reboot I lose all audio (including entries in System Profiler), but I have to keep typing exit everytime after mention of a Firewire error that is defaulting to full speed???

 

Regarding permissions, I edited a script to clear the relevant caches (see below):

 

#!/bin/sh

. /etc/rc.common

sudo chown -R root:wheel /System/Library/Extensions/AppleHDA.kext

sudo chmod -R 755 /System/Library/Extensions/AppleHDA.kext

sudo touch /System/Library/Extensions

sudo rm -R /System/Library/Extensions/Cache

sudo rm -R /System/Library/Extensions.kextcache

sudo rm -R /System/Library/Extensions.mkext

sudo rm -R /System/Library/Caches/com.apple.kernelcaches

echo "Done !"

 

I even tried it with and without AppleHDA.kext at the end! Followed by a Disk Utility "Repair Disk Permissions", but the result is still the same everytime?...

 

Any ideas... BTW I appreciate all your advise.

 

Cheers mate,

 

davejones

Share this post


Link to post
Share on other sites

try booting without the -s flag and go to terminal and type

 

sudo -s

kextload -t /System/Library/Extensions/AppleHDA.kext

 

if it loads, u can make a script to load the kext everytime u boot up your computer

Share this post


Link to post
Share on other sites

I'm not going to be any help at fixing the problem, but I can tell you how to permanently enable the -s boot.

 

Navigate to /Library/Preferences/SystemConfiguration/

Drag "com.apple.Boot.plist" to the desktop

Open the file with TextEdit

Locate the line below: "<key>Kernel Flags</key>

It will probably look like this: "<string></string>" it might have something already entered into it, like: -v -legacy etc.

You want to change it to: "<string>-s</string>"

After doing that, drag the file back into the folder, replace it, and then repair permissions.

 

Hope I helped

Share this post


Link to post
Share on other sites

Hi,

 

Thanks for that murphidaho, it worked perfectly, but do you (or anyone else?) know how I can bypass having to keep typing "exit" everytime before the hackintosh boots into OSX (in the unix command prompt area)?

 

Thank you all :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×