Jump to content

10.5.3 is available as an update

53 posts in this topic

Recommended Posts

Didn't try it yet though :D


Nice, thanks for the update, I'm going to update my MBP, hack, maybe later :P




Updating now, it's a biggie, 420MB. I'm going to take apart the package and see what's new :)


I might just brave it and update it on my hack and see what happens. Neither the delta nor combo updates are on apple as standalone installers yet.

Share this post

Link to post
Share on other sites

Apple today released the highly anticipated 10.5.3 update to it’s Mac OS X Leopard operating system. The Mac OS X 10.5.3 Update, which weighs in at an astonishing 420Mb, is recommended for all users running Mac OS X 10.5 and includes general operating system fixes that enhances stability, compatibility and security. However, at the time of writing this article, the update had not been tested on non-branded Apple systems, so proceed with caution or await further instructions.




  • Fixes a font issue that could result in Helvetica Narrow being used in applications instead of Helvetica.
  • Addresses an issue with stuttering video and audio playback in certain USB devices.
  • Resolves stability issues with Word of the Day, iTunes Artwork, and Slideshow screen savers.
  • Fixes an issue in which certain attached hard drives may not show up in the Finder.
  • Addresses an issue with .Mac syncing of Dashboard widgets over multiple Macs that use different screen resolutions.
  • Includes additional RAW image support for several cameras.
  • Improves the accuracy of the Software Update progress bar indicator.
  • Addresses an issue in which Finder may not be available if the computer name is blank in Sharing preferences.
  • Improves Active Directory binding and login.
  • Eliminates a delay when logging in as an Active Directory user in a .local domain.
  • Improves Spotlight searches on a AFP file server volumes.
  • Clients can now change their password at the login window when bound to a Mac OS X 10.4 Open Directory server.
  • Improves Safari reliability when connecting to the Internet through a Microsoft ISA proxy.

Address Book


  • Addresses reliability issues when searching for contacts using built-in search.
  • Resolves issues with mapping addresses that contain an ampersand character (&).



  • Improves 802.1X behavior and reliability.
  • Improves reliability when using Time Capsule.



  • Addresses an issue in which some actions may not work with the “Show When Run” option enabled.
  • Resolves an issue in which the “New iCal Event” action may not work.
  • Resolves an issue that prevents workflows from being saved in the Finder’s contextual menu.
  • Fixes reliability issues for Automator scripts that search for files by date.
  • Resolves an issue that prevents workflows from being saved in the Finder’s contextual menu.
  • Addresses an issue in which Automator workflows as Finder plugins do not work when the workflow begins with the “Get Selected Finder Items” action.
  • Fixes an issue in which the “Copy Files” action does not reliably work when added from Automator’s warning dialog.



  • Addresses potential privacy issues by allowing events to be marked as private.
  • Resolves an issue in which the inspector does not show capacity and availability info for conference rooms within a building.
  • Addresses an issue in which the current day could appear in the left-most column of the weekly view.
  • Addresses reliability issues with meeting alarms, invitations and attachments.
  • Resolves issues with reliability when restoring from iCal backups.
  • Fixes accuracy issues with auto-completion, availability data and location names.
  • Resolves an issue in which iCal may send cancellation notices for events in the past after a calendar is deleted.
  • Fixes reliability issues with iCal syncing.



  • Addresses reliability issues with screen sharing.
  • Resolves an issue in which saved chat transcripts may reported as “still in use” after opening and closing them in iChat.
  • Resolves an issue with group chats not being indexed in Spotlight.
  • Only the last 250 messages of an active chat are saved. Fixed to save unlimited number of lines.
  • Addresses issues with echo cancellation that may occur on portable Macs.



  • Resolves an issue in which Mail may prevent idle sleep when set to automatically check for new messages every minute.
  • Addresses stability issues that may be encountered when dragging large attachments into an email message.
  • Fixes an issue that could occur if two compose windows are open when dragging a file to the Mail icon in the Dock.
  • Addresses reliability issues when changes are made to a mailbox while offline.
  • Resolves wrapping issues that may be found with consecutive spaces in plain text.
  • Fixes issues with certain web pages appearing garbled when emailed from Safari.
  • Fixes an issue in which the Sent, Drafts, and Outbox mailboxes incorrectly list the “cc” recipients in the “To” column.
  • Addresses reliability issues with attachments added to plain text notes.
  • Fixes reliability issues with authenticated RSS feeds.
  • Resolves an issue in which attaching an alias to an email message may not send the actual file.

Parental Controls


  • Addresses reliability issues with application logging and time limits.
  • Resolves an issue in which Parental Controls may prevent forced sleep.
  • Addresses performance issues with web content filters.
  • Fixes an issue with managed accounts in which iChat transcripts may not be created.
  • Addresses issues with 4-byte files and whitelist.



  • Resolves an issue in which switching to a different space and returning back to the original space may reorder the application windows with a different active window.
  • Resolves an issue in which activating an application from the Dock switches to a different space, even if there is a window for that application in the current space.
  • Fixes an issue in which Command-Tab may incorrectly switch to a new space.
  • Addresses reliability issues with Spaces when syncing preferences over .Mac.

Time Machine


  • Includes fixes for Time Machine compatibility with Time Capsule.
  • Resolves certain issues when backing up a portable Mac that is on battery power.
  • Addresses compatibility issues with Aperture 2.
  • Addresses reliability issues when performing a full restore from a Time Machine backup.
  • Fixes an issue in which certain function keys may be disabled after using Time Machine.
  • Fixes a possible alert message that incorrectly states a backup volume does not have enough space.
  • Updates Time Machine to reliably restore attachments and messages in Mail.



  • Includes Braille Update 1.0 which enables GW Micro, HandyTech, HIMS, Nippon, and Papenmeier Refreshable Braille displays.
  • Addresses an issue with Braille dot 7 and 8 underlining.
  • Fixes an issue in which HTML page anchors may be ignored by the VoiceOver cursor.
  • Fixes an issue that prevented Hot Spots from being used in text areas.
  • Resolves an issue with spell checking in which VoiceOver may only announce the first misspelled word if there are multiple words spelled incorrectly.

Share this post

Link to post
Share on other sites

One note.. It depends on your system to determine size of download. My iMac (Intel First Gen) was a 198 download. My new MacBook (Core2Duo) is the 420 MB download. Haven't started the downloads yet on my two remaining G4s or my Hack to see what it comes in at.

Share this post

Link to post
Share on other sites

Okay, I'll be the guinea pig, I'll run the update on my hack :-/


Once I run it, I'm going to go into my other install and remove AppleIntelCPUPowerManagement and reload dsmos because I'm sure they'll disable that or something.

Share this post

Link to post
Share on other sites

No dedicated installer available yet. =(

Share this post

Link to post
Share on other sites

Okay, I looked on my MBP and here are the extensions that were affected by the 10.5.3 update:









Within the OpenGL Framworks Folder:




Libraries (folder)


Plenty of other stuff but those are the things I thought of.

Share this post

Link to post
Share on other sites
i'm still DL the update (slow connection here), you can take a peek on what kext's are affected by using Pacifist.


Use the combo update and get rid of AppleIntelCPUPowerManagement. Look at my new thread.

Share this post

Link to post
Share on other sites

Well At this point I don't have 3D acceleration after the update. Everything else is running fine.


Anyone know how to get back the NVidia 8500gt support that i had in leo4all v3?




I updated the NVidia drivers using these: http://scottdangel.com/blog/?p=23

Still not working. Is there anything else I should try?


World of Warcraft Starts up with: "World of Warcraft was unable to start up 3D acceleration". It worked right before the update.



*EDIT 2*

I noticed this as well:

Graphics by NVIDIA:


Chipset Model: Graphics by NVIDIA

Type: Display

Bus: PCIe

PCIe Lane Width: x16

VRAM (Total): 512 MB

Vendor: NVIDIA (0x10de)

Device ID: 0x0421

Revision ID: 0x00a1

ROM Revision: NVinject 0.2.1



Resolution: 1680 x 1050 @ 60 Hz

Depth: 32-bit Color

Core Image: Software

Main Display: Yes

Mirror: Off

Online: Yes

Quartz Extreme: Not Supported

Display Connector:

Status: No display connected



Software Core Image support? Quartz Extreme not supported? This is definitely the problem.

Share this post

Link to post
Share on other sites

Finally, maybe some people have their Radeon issues fixed too. :)


Working fine - iBook G4 1.42 GHz 1 GB RAM :)

Share this post

Link to post
Share on other sites
did someone here with vanillla kernel try the software update?


I did, it borked my GPU acceleration too, as well as borking my ALCinject.


I'm thinking maybe Apple is playing some games (possibly to screw with the Psystar people... DAMN YOU OpenMac!!).

Share this post

Link to post
Share on other sites

I am going to attempt to update it with Zephy's updater ;p in a bit


EDIT: choosing modify only, the AMD system update found no cpuids which i found odd. Im reading up first before i hose my test partition.


Test Partition Hosed !


I tried to install with pacifist, leaving out the new kernel, system kext, SMBIOS and AppleIntelCPUPowerManagement.kext, but alas it froze on me and i was forced to reboot into a non-working OS. Bleh ! I'll wait for the Osx86 gods to release their goodies.

Share this post

Link to post
Share on other sites

Ok first open terminal

sudo -s

*type password*

while sleep 1; do rm -rf /System/Library/Extensions/AppleIntelCPUPowerManagement.kext; done

Open 10.5.3 Update Installer


Go back to your terminal and press Control C to end the script

In terminal type:

nano /System/InstallAtStartup/scripts/1

Replace the line Dont Steal Mac OS X.kext with dsmos.kext

Restart and boot with -v

It will start loading and then you will get the message MACH_REBOOT, there you can hard reboot your computer. When you reach the darwin boot screen again, boot with -v again just for safe measure and it will boot fine.


Share this post

Link to post
Share on other sites

Hello all,

if you haven't already seen them there are kalyway & jas for intel SSE3, and an AMD specific combo update at your favorite spots :angel:


go check em out

Share this post

Link to post
Share on other sites

Same problem here, used the kalyway Combo Update and it just screwed up any 3d Graphic acceleration.

Share this post

Link to post
Share on other sites

Trying to read enough before I try this :-)


I see the instructions here, and on an older thread for 10.5.2 update.


I had no luck previously trying to install 10.5.1, so currently I am running a version of 10.5.0 that was installed as a complete image from a file called "leopard-x86-flat-img".


So my question is - should I be able to install the 10.5.3 update over 10.5.0, or is it a requirement to upgrade (or install) 10.5.1, then 10.5.2 before finally installing the 10.5.3 upgrade?

Share this post

Link to post
Share on other sites

n00b question.


If the update goes bad for any reason. Is it possible to reinstall Mac OS X (leo4allv3) and keep all my personal settings and apps I have installed, Or would I need to start all over again?



Share this post

Link to post
Share on other sites
Same problem here, used the kalyway Combo Update and it just screwed up any 3d Graphic acceleration.


Try re-installing your graphics drivers (NVInject).

Share this post

Link to post
Share on other sites
Try re-installing your graphics drivers (NVInject).



I gave kalyway update a shot and it shelled my kalyway 10.5.1 updated to 10.5.2 install. but the hackintosh panic'd before i could apply the kernel pkg that was included. i didn't have time to do much else last night but i'll try and fiddle later tonight . -x -v or booting normally gets me to "firewire device.../defaulting to full-secure mode" and maybe 2 lines more about ATA device then hangs forever ....



:) on another note, i'm slightly annoyed that i had an almost exact post placed up yesterday and the mod's deleted it for what reason i have no clue. I mentioned that the 10.5.3 update for kalyway, jas and also an amd specific update was available at your favorite spots" and that you could go and check it out... Now i see tons of more literal posts on these forums suggesting or even naming websites or indeces to go and search for things.

just pisses me off a little...

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.