Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Oxtie

Creative SB [Live!, Audigy, Audigy2, EMU10kX eDSPs] OSX Driver info here!

850 posts in this topic

Recommended Posts

Who cares about any of that stuff! ? :)

 

I just want the sound out to work, and if it supports 5.1 that will be icing on the cake!

Share this post


Link to post
Share on other sites

Well hopfuly this will allow some audigy/x-fi support in mac os. But we wont know what works until we can all go home and try out the new driver lol.

Share this post


Link to post
Share on other sites

damn, I sold my audigy 2 a long time ago when I got an X-Fi

 

I hope eventually there will be an x-fi driver, the audio on my board is garbage with OSX. I only get bad sounding 2.1 with generic drivers with no line-in or anything else, if I use taruga drivers then I get line-in but absolutely no bass at all for output.

Share this post


Link to post
Share on other sites
damn, I sold my audigy 2 a long time ago when I got an X-Fi

 

I hope eventually there will be an x-fi driver, the audio on my board is garbage with OSX. I only get bad sounding 2.1 with generic drivers with no line-in or anything else, if I use taruga drivers then I get line-in but absolutely no bass at all for output.

 

X-Fi uses different chip then 10kx so, there are 99% chances that it will NOT be supported by kX drivers.

More information on X-fi is available from DJ_Stick and Eugene himself HERE --> http://www.driverheaven.net/general-discus...aster-x-fi.html

 

hmmm :) they changed the color of forum from black to blue :)

Share this post


Link to post
Share on other sites
Look like someone deserves a donation =D

 

Yup, I was willing to donate earlier, but then "E" mentioned the date, so not willing to get charged by transfer company (WU) twice :) It is also good to donate if others want to, besides how many cool coders are out there? specially who can bring almost all main features of original CT drivers to OS-xxx? :) well, regard-less of donations, E would continue the work as usual but with some "Pizzas" it can be fun and fast :)

 

You know, I once thought to donate 5$ extra so that Russ (over there) becomes mod :)

Share this post


Link to post
Share on other sites

Hi,

I have a sound card CREATIVE SOUND BLASTER 5 and MAC OS X 1.5.2 does not recognizes it. How can I get it to work?

Thanks..

Share this post


Link to post
Share on other sites
Hi,

I have a sound card CREATIVE SOUND BLASTER 5 and MAC OS X 1.5.2 does not recognizes it. How can I get it to work?

Thanks..

 

Mach In Tosh, please read the first post of this thread (page 1) and check whether your model is listed or not :) If your card is based on Emu10K(1 or 2) then continue to read the first post if not, then it may not be suppored :)

Share this post


Link to post
Share on other sites
Mach In Tosh, please read the first post of this thread (page 1) and check whether your model is listed or not :) If your card is based on Emu10K(1 or 2) then continue to read the first post if not, then it may not be suppored :wacko:

 

Wow, you're nice to reply. Posts like the GP annoy me that they are too lazy to even read the thread. It's why I don't come by here as much as I used to, all the annoying lazy users.

Share this post


Link to post
Share on other sites

Great news... i have Audigy 2 zs on my hackinstosh... i use in windows for games...

 

maybe Taruga can help..

Share this post


Link to post
Share on other sites

I'm sure they'll come out. If anyone can get Creative drivers working in OS X it's these guys. They know the hardware inside-out. The only real obstacle would be CoreAudio.

 

Right now I have a fully-working Leopard install minus sound because I can't be bothered to enable the onboard chip (and switch the speaker cable between XP and Leo sessions) . I'll just sit in silence until these come along :)

Share this post


Link to post
Share on other sites

Ya, well they said August 14. So it is soon. WOW, if this happens this is going to be HUGE. I will switch to OSx86 full time as sound will work!

Share this post


Link to post
Share on other sites
Ya, well they said August 14. So it is soon. WOW, if this happens this is going to be HUGE. I will switch to OSx86 full time as sound will work!

 

Same, i'm going to go OSX full time now :)

 

The sound was the only thing holding me back.

Share this post


Link to post
Share on other sites
Only 5 days to go until everything's working on my OSX install. The onboard audio may work, but I didn't feel like moving everything to the onboard audio.

 

 

Well, we will see if it really is August 14. Given there isn't much in terms of updates on the date, I would be pleasantly surprised if it was really August 14.

Share this post


Link to post
Share on other sites

It'll be worth the wait anyway. I ended up enabling onboard audio and there's no way I could use this full time. It sounds like {censored}. Same as it did in XP. How can they call this "High Definition" audio when my 8-year old SBLive Value blows it away.

Share this post


Link to post
Share on other sites

OS X driver released - version 1.0b2

 

get it from here (don't forget to review 'known issues' and 'unimplemented' stuff):

 

http://www.driverheaven.net/mac-os-x-driver/

 

post your comments and bug reports to driverheaven forum please, since I cannot read both forums regularly

--

 

Lama, please update your topic:

* official site is www.kxproject.com

* E-DSP will only work if you boot OS X after Windows (with kX for Windows installed) - because E-DSP FPGA microcode needs to be loaded, and no such option exists for OS X at the moment

* DELL OEM card will never be supported

 

E.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×