Jump to content
seppa

LOGIC 8 BENCHMARK

133 posts in this topic

Recommended Posts

i began with kalway 10.5.2 updated to kalway 10.5.3 and now

i am running 10.5.4 (directly downladed in system update) with new kernel.

for me gave that update no improvements to 10.5.3 in logic. (maybe i get lower result in 10.5.2 anyway)

 

i was asking some friends with 4 core mac pros (3 ghz) they can open only 25-35 tracks with latest update.

 

what i really dont understand is that issue between actitivy monitor and logic cpu show. same on mac pro too.

 

the next thing what i really want to know, is how its possible that we users here, have so big differences in our results.

 

can somebody tell if he/ she has the same issue like me in following thing:

 

when i do a big project, for example:

20 audio tracks + 10 synth (cpu usement max 100% in actitvy monitor)

then i view to automations on all tracks... and my grafik stocks. its not anymore in nice framerates.

same happens when i show some eqs / compressors (when they are in front to see)... the grafic begin to become really slow.

 

anyone can tell me the same issue?

 

The max you can squeze out of a single quadcore cpu (like the q6600) based hack is probably round 30 tracks with this test. If you OC your cpu you probably get closer to 30 than if you not. If a real 4 core Mac manages round the same well our hackpros works just amazingly good. If the video starts messing up it might be a video card related problem? Maby the card is just not good enough? 20 audio + 10 synth tracks that is pretty amazing for a q6600 hackpro I´d say anyway, that probably gives you round 40 - 50 audiotracks without the synths and that is not bad at all.

Share this post


Link to post
Share on other sites
Advertisement
Hmm, how do you select multiple tracks in Logic?

 

 

hold shift and select each track, when i remember right...

 

@starobrno1

 

of course for hackmac pretty good... and i am sure, that there is no difference at all to a real mac with same cores.

 

The grafic-Issue can not be related to my grafic-card, its a F***ing 8800gt :P it have to work well.

 

yesterday i testet a bit more, i put my macbook pro on my monitor and open same project (what i use for testing that grafic-problem) same happens on macbook pro, when resolution is 1920x1200. so maybe its a logic related problem.

Share this post


Link to post
Share on other sites

Yeah it probably is, I´ve got a cheap ga 7300gs 256 mb pcie card 1680 * 1050 resolution, I´ll try load up a bunch of tracks toninght if I can find the time and see what happends. I´m using a NVinject.kext for this card I found round here somewhere and I modified it so I can use dual displays (DVI VGA, QEs working to). I figure round 10 of the tracks from this test and a bunch of wavs from one of my songs should do it, it´ll sound stupidly crazy :tomato: but it will work as a test. If this works with say 10 synths and round 20 wavs got to be a resolution problem then I guess. Ok I´ll be back.

 

You from Scandinavia? I am

Share this post


Link to post
Share on other sites

Well erikk I´ve got 15 tracks from this multicore Logic Benchmark test and 40 wav tracks running and on 20 of these wav tracks I´ve got a various bunch of Logic channelstrip presets loaded. Coretemperature just round 50 Celsius, disk IO round 50% and some of the wav probably streamimg from my USB harddrive if I understand it right. 3 cores on red but it´s working. No slugish video it´s acceptable. Now after 15 minutes of checking and typing this I got the overloadmessage. Gonna mute one synthtrack and see what happends just a sec. Well I reduced the benchmarktracks with one and jumped over to youtube to watchsome movies and Logics still behaving. Got 5 different songs loaded and 3 Safari windows open (one streaming youtube videos) at the same time as I type this. After 20 minutes of doing this I finally got the overload message so it just have to be a Logic resoloution problem you get.

Share this post


Link to post
Share on other sites

There seems to be a bug...if I open the mixer and select tracks when holding shift sometimes the channel strips are selected instead. However, this is totally random.

 

Btw, I have another quick question (OT, I know): is it possible to send more than one midi track to a software instrument? If not, how do you work with different takes/voices on just one track? The same way as with audio tracks?

Share this post


Link to post
Share on other sites
I tried that (surprise :whistle: ), but it didn't work. I have the latest version.

 

 

LOL

 

the shift key in hackintosh is the WINDOWS key (that MS key that says start)

Share this post


Link to post
Share on other sites
There seems to be a bug...if I open the mixer and select tracks when holding shift sometimes the channel strips are selected instead. However, this is totally random.

 

Btw, I have another quick question (OT, I know): is it possible to send more than one midi track to a software instrument? If not, how do you work with different takes/voices on just one track? The same way as with audio tracks?

 

yes - create as many tracks you need in arrange window for that instrument. define different midi-channels in the inspector on the left. this way I program always my drumtracks ,strings or other multi-instruments before I finally merge them into one track and define midi to"all Channels" in inspector.

Share this post


Link to post
Share on other sites
LOL

 

the shift key in hackintosh is the WINDOWS key (that MS key that says start)

 

No, that's 'option'. Shift and control are the same (and of course I tried every damn key).

Share this post


Link to post
Share on other sites
yes - create as many tracks you need in arrange window for that instrument. define different midi-channels in the inspector on the left. this way I program always my drumtracks ,strings or other multi-instruments before I finally merge them into one track and define midi to"all Channels" in inspector.

 

Ok, got it. But is it possible to add more tracks for an instrument later? Making a new track with duplicate settings results in a completely seperate instrument track.

Share this post


Link to post
Share on other sites
Ok, got it. But is it possible to add more tracks for an instrument later? Making a new track with duplicate settings results in a completely seperate instrument track.

 

yes it´s possible - select the instrument track in arrange window. now press shift + enter

Share this post


Link to post
Share on other sites
yes it´s possible - select the instrument track in arrange window. now press shift + enter

 

It's a myth that Mac software is logical. :D There are always important functions that are only accessible via key commands, like getting the total size of multiple files (cmd + option + I).

Share this post


Link to post
Share on other sites

starbrno1: thx mate for testing out.

 

i was affraid and clean my system completly, now i feel that logic works a bit better. i got more tracks in performance test.

and i feel that the graphic thing is a bit better, but it still "stocks" (like a 10 fps 3d shooter) when i can see 5 eqs with analyzer "on"... but when i tried out this, i found a good usefull part for my macbook while producing. over AUsend i turn my macbook to a analyzer while using audfile Spectre... yeah!

 

at all now i can go up to 320% in activty monitor when i work in logic, but if a plugin is in front, i see activy monitor jump up to 340%-350% and system becomes a bit slow... but ok, to get these cpu load its not anymore music, what i listen :hysterical:

 

in my common projects "electronic music" i get around 140 % cpu load, with around 5 synth, 30 audio tracks, many compressors, eqs, a good mastering section and 3 synth tracks by my virus ti polar.

 

and no i dont come from scandinavia, i come from germany... live at the f***ing capitel of electronic music... hehe.

 

you still work 100% now on your hackmac, or its more a game for you?

Share this post


Link to post
Share on other sites

Ok you mean you can use your macbook to make the load less heavy for you hack that´s a good tips man I´ve got a Mac Mini. I´ve only been using it for Logic Node so far but this opends up new possibilitys.

 

Ok Germany yeah good country musicwize, I´m from Sweden. I gave my daughter my PC so it´s all mac now, planning to buy a real mac pro as soon as I can but for now I´m working with this one. My music well it´s just amateur stuff but it´s fun, moastly a mix of traditional stuff I´m an old guy 50+. Got a couple of homemade electronicas :hysterical: but they´re not so serious. If you want to have a listen PM me and I´ll ship over the link to my SC site got some 50+ songs in various condition :hysterical: . Have it good man over and out :hysterical:

Share this post


Link to post
Share on other sites

50+ ???? wow... like my father... but he didnt know how to turn on a pc... or whats the differens between mac and pc.. haha

 

anyway,

i have crazy way with apple, pc and hackmac.

 

was coming from single g5 to dual amd pc (windows), back to quad g5 mac, and then quad intel pc (windows)...

 

now i am on intel quad with osx only and work serious on it, but planing to buy a macpro octo next few month.

 

logic nodes i never used, cause it works for me only on logic plugins, no third party! and logic plugs dont need much performance for me.

 

when you like to listen what i do: check: www.myspace.com/electrixxx

 

:dev:

Share this post


Link to post
Share on other sites

Well comparing some of your stuff to mine shows I´m not so bad anyway ;) . Just kidding man but take a listen to this one. It´s about two yers old and just a raw mix no adlimiter nothing.

 

What the hell happend the file does´nt load man, oh theese internet forums they suck big time just promise but do´nt deliver I´ll try it again. Oh well it showed it was 2.4 megs and the max here is 2 megs. Man what is this music under 2 megs forget it you could just as well start beating your tambourine and wistle/sing acapella.

Share this post


Link to post
Share on other sites

one test more...

 

guys... its really important that you installed the full content of logic 8 for this benchmark.

 

yesterday i made blank install of 10.5.4 and copy only the logic pro application to my application folder. There was no

Content installed for Logic on this harddrive.

 

When i run benchmark i got amazing 37 Tracks and was really excited, that a blank install of 10.5.4 gave me so many more performance.

 

Then ok... installation went on... i installed complete package of logic 8 (first dvd, with impulse response and reverb presets)

 

then i open performance test again... and see: only 28-29 tracks (same like before reinstall my system)

 

try here try there... i de-install logic content and got back 36-37 tracks.

 

so guys, this performance test is only for full content installs, or it doesnt show the correct power of your system.

Share this post


Link to post
Share on other sites

It doesn´t need the full installation. It uses a sample response for spacedesigner which is included in the (around 8 Gb) installer circulating on the "net".It also includes a sample to EXS24 which is also included in that package. The full installation is around 40 Gb and is not required for the test.

Share this post


Link to post
Share on other sites

yes... but i am sure... that many here use the logic pro pkg only :( which is only 230 mb

 

of course i mean the difference between that installation (230 mb logic pro only) and the first dvd content.

Share this post


Link to post
Share on other sites

Since updating to 10.5.5 my q6600@ 2.8ghz can now play 28 tracks at 256 buffer, five more than I could play before. I'll be hopefully overclocking it to 3.6ghz this week once I get a new cooler hope I can push it above the 35 track mark.

Share this post


Link to post
Share on other sites

Same here. 23 is about the upper limit of being able to play back for a long period. It ranges from 22-25 but 23 sounds about right.

 

This is Q6600 at 2.8Ghz on a GA-x48-ds4, 4GB DDR2 5/5/5/15. Sadly Logic is only using about 215% of the possible 400% before it runs out of gas. Hopefully Logic 9 and Grant Central will fix that!!!

 

I have a max of 23 tracks playing on a q6600 @ 2.8ghz running at a 256 buffer on a {censored} soundblaster card.

 

Two things i noticed though was that i had to disable the I/0 safety buffer in the audio prefs also in the activity monitor my most maxed out core is only about 75% where as in logic its touching the top. Tried with the logic script fix posted on here same results as without.

 

Leo4all v2 10.5.2 and logic 8.0.2

 

No chnge here on 10.5.5 on my q6600 @ 2.8. My memory isnt the best tho its only 5/5/5/15 which probably explains the difference.

 

 

Since updating to 10.5.5 my q6600@ 2.8ghz can now play 28 tracks at 256 buffer, five more than I could play before. I'll be hopefully overclocking it to 3.6ghz this week once I get a new cooler hope I can push it above the 35 track mark.

 

I'd; like to see a benchmark of someone running DDR-3 memory. I'd also like to see a comparison of CAS2/3/4/5 if anyone has a different pair of dimms at different speeds can you try swapping them?

 

I suggest ensuring this test run for 10 minutes without a glitch. Only then can you call it a success.. there is too much variation otherwise.

Share this post


Link to post
Share on other sites

DDR3 over DDR2 should increase your computer perfs about 2or 3%... nothing more, nothing less... For the price difference, you should considere buying an UAD 1 (used) that doesn't cost much more than the difference on 8 Gigs of memory.

You'll get acces to incredible souding plugs and your system will thank you to stress it a bit less ;) and for sure, You'll have more than the 3 % (1 or 2 more tracks...) increased global perfs...

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×