Jump to content
kemikal-aa

Silicon Image SIL 3512 SATA Comtroller

19 posts in this topic

Recommended Posts

I have a PCI Silicon Image SIL 3512 SATA Comtroller In a dell Dimension 3000 I was wondering if anyone has tried this out with a JAS 10.5.2 Install DVD. I wanna know if im going to have issues before I even get to installing it. I have searched the forums and found nothing on this card.

Share this post


Link to post
Share on other sites
Advertisement

@ kemikal-aa

Sil 3512 works great. You can boot from it.

u need to add ID,s inserted int kext and permitions correctly setup.

generally

~/Extensons/AppleVIAATA.kext/Contents/info.plist

or

~/Extensons/IOATA.kext/Contents/Plugins/AppleVIAATA.kext/Contents/info.plist

if you don't have AppleVIAATA in your leo setup get it from a Tiger DVD using pacifist

my IDs are

<string>0x43791002 0x43761002 0x528810B9 0x31491106 0x35121095 0x00e310de 0x005410de 0x005510de 0x2360197b 0x2361197b 0x2363197b 0x2365197b 0x2366197b 0x00ee10de 0x28258086 0x28208086</string>

do not forget to chown and chmod and touch

sudo -s

chown -R root:wheel /Volumes/... yr full patch to .../Extensions/*.*

chmod -R 755 /Volumes/... yr full patch to .../Extensions/*.*

touch /Volumes/... yr full patch to .../Extensions

Share this post


Link to post
Share on other sites

Hi guys, I see you both have a working sil 3512 setup. I just bought a PCI card with this chipset, but I can't get RAID to work.

 

I installed using the Kaliway 10.5.2 which has the AppleVIAATA.kext with the correct values already in there. Is there something else I have to do? When I create a raid set in the bios, the 2 disks get unrecognized in OSX.

Share this post


Link to post
Share on other sites

"Working" is a relative term here.. the hack used basically forces AppleVIAATA.kext to load for the hardware, as this a very general-purpose IDE controller driver, it loads & works. What this is *not* is a working driver intended for SiL 3512 hardware, so any clever functions (such as RAID) are unlikely to work. The SiL 3132 has a proper driver, iirc, which supports RAID etc.

Share this post


Link to post
Share on other sites

Would this allow a Sil 3512 Cardbus adaptor to work on my Powerbook G3 (Pismo)? I'm looking at the Rosewill RC-604 card, which isn't advertised as being Mac compatible but does have the Sil 3512 chipset that seems to working for some people. The card is cheap enough that I may just buy it and try it, but I wanted to check here first to see if anybody has any idea.

Share this post


Link to post
Share on other sites
The SiL 3132 has a proper driver, iirc, which supports RAID etc.

 

that´s the half of the truth. the sil3132 driver doesn´t work proper on leo if you use more than 3.5GB ram. in this case you will have kp´s and freezes. still waiting desperately for the 64Bit driver

 

just wanted to mention that before someone is going to spend some money for it :(

Share this post


Link to post
Share on other sites

Hi,

 

I have this chipset on a pcmcia card plugged into my d630. I'm trying to make it work but it don't seems to be ok.

I tried to flash the bios in windows but I don't know if it worked or not because it was not able to give me info with the -v in SiFlashBios something.

 

 

I've edited the viaata.kext as it is said in the thread.

 

In my system profiler, I've got a PC card known as

 

pci1095,3512:

 

Function: Mass Storage Controller

Vendor: Unknown

Type: CardBus

Vendor ID: 4245

Device ID: 13586

 

It seems to be ok but I can't see any Hard drive. In the serial ata device tree I only see my internal HDD and a slot for another one but no trace of my external HDD.

 

What can I do ?

Share this post


Link to post
Share on other sites

Oh sorry, the SI3512

Actually I'm experiencing big problemswith the card on vista (blue screen during the boot sequence when there is the green thing moving ^^)

Share this post


Link to post
Share on other sites

No there is not. I tried what is written at the beginning of the thread but it did not work. Actually I might have a problem on my card because it is not working at all on Vista (blue screen when booting ...)

Share this post


Link to post
Share on other sites

I managed to make work an eSata / SATA - RAID card based on Sil3512 chipset with AppleVIAATA.kextv0.2 under 10.5.6 Retail Leopard install on GA-P35-DS3L.

 

I edited the .kext as said in the begining of the topic : added 0x35121095 ID's in Info.plist

 

The kext can be found via google there is a google group so you should find it. I can't post mine (already modified) in here (rules).

 

Anyway, i just figured out that it doesn't work anymore. It just worked once and without hot-pluging.

 

Trying to figure it out...

Share this post


Link to post
Share on other sites

5723 is a steelvine hardware controller. after a correct configuration the raid should be recognized by the os.

usually it´s done by some hardware settings - jumper?

Share this post


Link to post
Share on other sites
5723 is a steelvine hardware controller. after a correct configuration the raid should be recognized by the os.

usually it´s done by some hardware settings - jumper?

 

Thanks peach-os but could you be a little more specific? The steelvine controller works great with windows 7. What kind of jumper should i change and how will it affect my raid configuration. Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×