Jump to content

BitPIM Errors Upon Launch


1 post in this topic

Recommended Posts

Anyone know how to work around an error in BitPim where it launches and immediately throws the error:


BitPim version: 1.0.5-unofficial

An unexpected exception has occurred.

Please see the help for details on what to do.


Traceback (most recent call last):

File "gui.pyo", line 248, in OnClose

File "gui.pyo", line 245, in goforit

File "gui.pyo", line 548, in makemainwindow

File "gui.pyo", line 839, in __init__

File "phone_root.pyo", line 111, in __init__

File "wx/_core.pyo", line 7576, in Yield

PyAssertionError: C++ assertion "wxAssertFailure" failed at /BUILD/wxPython-src- in Yield(): wxYield called recursively


I get the same error in Tiger and Leopard (in Leopard it takes 5-10 seconds after running - in Tiger it never seems to progress to displaying the Bitpim gui). I tried removing the folder which contains the BitPim settings at



BitPim worked for about a year so I'm wondering if there may be a separate prefs file I'm not removing when I delete the folder referenced above. (I was thinking it might have coincided with the update to 10.4.11 but I do get the same behavior in both OS's.)


TIA for any additional suggestions.


Edit: Rolled back to 10.4.8 from 10.4.11 and it works fine.

Link to comment
Share on other sites


  • Create New...