Jump to content

Kalyway 10.5.2 working on Acer Veriton 7800


Braeden101
 Share

3 posts in this topic

Recommended Posts

I have tried numerous times to get OS X working on my PC, each time with mixed results.

 

This time however, it went near perfectly. My PC is a (mostly) stock Acer Veriton 7800:

 

 

CPU Type DualCore Intel Pentium D 830, 3000 MHz (15 x 200)

Motherboard Name Acer G945MK

Motherboard Chipset Intel Lakeport-G i945G

System Memory 2048 MB (DDR2-533 DDR2 SDRAM)

BIOS Type Award Modular (12/13/05)

 

 

 

Audio Adapter Realtek ALC880(D) @ Intel 82801GB ICH7 - High Definition Audio Controller [A-1]

 

IDE Controller Intel® 82801G (ICH7 Family) Ultra ATA Storage Controllers - 27DF

IDE Controller Intel® 82801GB/GR/GH (ICH7 Family) Serial ATA Storage Controller - 27C0

Storage Controller SCSI/RAID Host Controller

 

Network Adapter Marvell Yukon 88E8052 PCI-E ASF Gigabit Ethernet Controller (10.12.72.250)

 

Monitor ViewSonic VA1912w Series [19" LCD] (QBK073270460)

 

Video Adapter Intel GMA950 Integrated

 

 

Originally the video adapter was a Radeon X1300 Series Secondary (256 MB), but after installing kalyway 10.5.2 (sleep kernel 9.1 and the x1000 family drivers and natit that came packaged) I would reboot, get the grey background and apple logo quickly followed by the screen being striped black and pink.

 

Removing the x1300 allowed me to boot off the bat, resolution stuck at 1024x768. Using pacifist to get the GMA950 kext off the kalyway dvd, clearing extensions.mkext , repairing permissions and one reboot later and onboard video adapter was fully working.

 

My network adapter also required a modified kext. I installed the IONetworkingfamily.kext from the update .dmg available from apple (macOSXUpd10.4.5intel.dmg), then I used terminal with root access to edit the appleyukon.kext's info.plist (System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleYukon.kext/Contents/Info.plist) to include my device id's, cleared extensions.mkext, repaired permissions, loaded the kext IONetworkingfamily.kext. I then opened Network preferences and switched "configure" to Off, then to Manual, then to Using DHCP.

 

After that my network worked like a charm.

 

Audio works 100% despite System Profiler reporting that no onboard audio is present.

 

 

Note: Here are the bits of the appleyukon.kext's info.plist that I edited (this is after the editing)

 

<key>IOKitPersonalities</key>

<dict>

<key>Yukon-88E8052</key>

 

-

 

<key>IOPCIPrimaryMatch</key>

<string>0x436011AB</string>

 

-

 

string>IOPCIDevice</string>

<key>Model</key>

<string>Yukon Gigabit Adapter 88E8052</string>

 

 

As far as I can tell, everything is working 100% bar the X1300, for which I have little hope. This is really a shame, as I really, really want dual screens.

 

If there is anyone out there looking for help on similar hardware, I'd love to lend a hand.

 

Cheers,

 

Braeden

Link to comment
Share on other sites

  • 5 weeks later...

Nice. I am assuming you booted with IDE devices as opposed to SATA?

 

I have a K45 Shuttle KPC, and the SATA will not recognize under any release I have tried (10.5.1/2).

 

If you did manage to succeed with SATA, please share your trick!

 

Thanks a ton,

lzthqx

Link to comment
Share on other sites

  • 6 months later...

thanks Braeden, you're rocks !!. Now my Marvel Yukon 88E8052 PCI-E ASF in Toshiba L200 is working !

i just have to edit the AppleYukon.kext inside IONetworkingFamily.kext and change the IOPCIMatch section,repair permission,reboot with '-f' then eureka ! the network adapter recognized as en0

 

but the dhcp service seems not working, so i have to set the ip manually.

 

ideneb 1.3 - leopard 10.5.5

risnandar

Link to comment
Share on other sites

 Share

×
×
  • Create New...