Jump to content

Search the Community: Showing results for tags 'uhd630'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • InsanelyMac Lounge
    • Front Page News and Rumors
    • Reader News and Reviews
    • Forum Information and Feedback
  • OSx86 Project
    • New Releases and Updates
    • New Users Lounge
    • Developers Corner
    • Tutorials (The Genius Bar)
    • Technical FAQ
    • Installation
    • Post-Installation
    • DSDT and SSDT
    • Hardware Components and Drivers
    • Desktops
    • Notebooks
    • Netbooks
    • Tablets
    • MacMod of the Month
    • Multi-booting and Virtualisation
  • International
    • Your Language
    • Deutsch
    • Español
    • Français
    • Italiano
    • Português
    • Русский
  • Apple World
    • Mac OS X
    • Apple Computers and Hardware
    • iOS Devices
    • Mac Applications
    • Mac Programming and Development
    • iOS Programming and Development
    • Mac Gaming
    • Mac Accessories
  • Discuss and Learn
    • Windows Discussion
    • *nix
    • Apple Opinions and Discussion
    • The Great Debates
    • Internet(s), Servers, and Networks
    • Buying Thoughts, Reviews, and Recommendations
    • Mods and Overclocking
    • The Big Issues [Real Life]
  • Everything Else
    • Creativity
    • Thunderdome (Random Stuff)
    • Laughs
    • The Marketplace

Categories

  • Kexts
    • Graphics Cards
    • Audio
    • LAN and Wireless
    • Other
  • Kernels
  • Bootloaders
  • DSDTs
    • Patches
  • Pandora
  • Apps
  • Miscellaneous
  • Customization

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 8 results

  1. Hi guys, Though native graphics acceleration is supported on i3 from Mojave, I'm not able to manage to get it. This is my system configuration : Motherboard: Asus Prime H370-Plus CPU: i3-8100 (UHD 630) OS: Mojave 10.14.2 I'm trying every possible way to get full graphics acceleration. But whatever I try it shows only 4MB video memory or leads to Kernal Panic. Here are some ways I have tried so far: Prerequisites: Installed latest Lilu+WEG on L/E. set DMVT prealloc to 64MB on bios. Option 1: IntelGFX-> 0x3E928086, ig-platform-id-> 0x3E9B0007, Inject Intel = true. Output: Kernal Panic Option 2: Blank IntelGFX, blank ig-platform-id, Inject Intel = false Output: Kernal Panic Option 3: IntelGFX-> 0x3E928086, ig-platform-id-> 0x5912000, Inject Intel = true. Output: Booted Successfully but no graphics acceleration. I knew that ig-platform-id-> 0x5912000 doesn't work in mojave and its works only for high sierra but I set this because with this ig-platform-id I can boot. Another way I can boot it by setting invalid Fake IntelGFX value like 0x12345678. Option 4: Downloaded Intel FBPatcher & followed this guide. But as I opened the app, its shows like this: It clearly indicates it neither can detect Intel CPU generation nor GPU memory (currently shows 0 MB). I changed to different PlatformId from the drop down but no improvement. Anyway I applied a patch with SMBIOS ->Macmini8,1 by someione's recommendation . I attached a config file (config_fbpather.plist) for this. Output: Kernal Panic I have tried the upper mentioned methods with SMBIOS like iMac14,2 / iMac18[1,2,3] and Macmini8,1. I'm using HDMI port for display output. Now I don't know whats wrong with theses methods but maybe someone can help me to figure out this problem. I have also attached those config.plist files. Thanks in advance. config_fakeid_0x3E928086.plist config_fbpatcher.plist config_fbpatcher_with_device_id.plist config_platform-id_0x59120000.plist
  2. Introduction 30th October Brooklyn, New York, Apple announced a "re-engineered" Mac Mini - the first update to small sized desktop Mac since 2014. Surprisingly, they also unveiled a new i3 8th generation based "affordable" Mac Mini which costs $799. Cool...right? Not cool for me. So, I decided to build a really "affordable" hackintosh mac mini instead and successfully managed to build it around $614 .This is my 4th hackintosh build. Hardware Asus Prime H370-Plus Intel Core i3 8100 3.6GHz Corsair Vengeance 2400MHz DDR4 16 GB RAM Kingston SSDNow A400 240GB Cooler Master MWE 450 Bronze, 80+ Bronze Certified 450W Power Supply LG VGA Monitor (1366x768) HDMI to VGA Adapter DVI-D to VGA Adapter (Optional) Logitech USB Keyboard & Mouse Software used macOS Mojave 10.14.2 Clover EFI Bootloader 2.4k r4813 Clover Configurator 5.3.2.0 What works Graphics Audio All USB ports Sleep/Wake iMessage/FaceTime Instructions BIOS Settings: Use "Delete" to enter you UEFI setup. Load Optimized Defaults Disable VT-d Disable Secure Boot Mode Set OS Type Other Turn off internal Serial port Turn off Network stack for boot Set XHCI Handoff to Enabled Enable HD Audio Don't enable decode over 4G Set Primary Display to iGPU Set DMVT pre-alloc to 64MB or 128 MB Set USB legacy to enabled Activate XMP profile 1 Set ERP to enable Installation: I used the default command to create a bootable Mojave Installer on a 8GB USB drive. Then I installed the Clover_v2.4k_r4813 pkg on the bootable drive with these options: Also select EmuVariableUefi-64.efi from UEFI Drivers list which will fix the rebooting issue if you may face during Mojave installation. Next, mount the USB's EFI partition and navigate to Clover/kexts/Other and place FakeSMC.kext & USBInjectAll.kext into that. Now go back to Clover folder and delete config.plist file and paste an empty config.plist file. I have attached it at the end of the post. Plug the USB to your machine and press F8 and select your bootable drive. Next Format the drive using disk utility & install macOS. During installation the computer will reboot several times but every time press F8 and select your bootable drive and then select Install Mojave from your SSD/hard drive. Post Installation: Run Clover Configurator and go to TOOLS > Mount EFI > Mount Partition > Open Partition (choose your macOS drive) Copy the EFI folder from USB's EFI to your drive's EFI. Gather the necessary kexts. FakeSMC.kext Realtek Lan Driver a.k.a RealtekRTL8111.kext Lilu.kext WhateverGreen.kext for graphics AppleALC.kext for audio USBInjectAll.kext for USB ports Now open Terminal and type the following one by one: sudo chmod -R 755 /System/Library/Extensions/* sudo chmod -R 755 /Library/Extensions/* sudo chown -R root:wheel /System/Library/Extensions/* sudo chown -R root:wheel /Library/Extensions/* sudo chown root:admin / This will fix ownership and permissions... Copy & paste all kexts to Desktop & use any Kext Installer to install them to /Library/Extensions/. Then run the following command into terminal: sudo kextcache -i / Open /EFI/EFI/CLOVER/config.plist with Clover Configurator Next, we have to edit config.plist file . First make a backup of the empty config file. Download the latest Clover Configurator and open the config file. Next I have done the following modifications: ACPI: HDAS -> HDEF, HECI -> IMEI, GFX0 -> IGPU, XHC1 -> XHC, EHC1 -> EH01, EHC2 -> EH02 Under Generate Options, check PluginType Under Fixes, check FixShutDown, FixHPET, FixIPIC Under Drop Tables, check Halt Enabler, FixHeaders, FixMCFG Boot: Arguments: dart=0 Devices: IntelGFX=0x3E928086, USB-> check Inject, FixOwnership, Audio=1, check ResetHDA GUI: Under Hide Volume, Click + and enter "Preboot" Graphics: Inject Intel, ig-platform-id=0x3E9B0007 SMBIOS: iMac 18,1 Rt Variables: Click the dropdown and select "UseMacAddr0", in MLB enter the Board Serial Number from SMBIOS section. Double check if CsrActiveConfig value is set to 0x67 or not. Reboot. Graphics: This is where I stuck nearly 1 month. After setting IntelGFX=0x3E928086 & Inject Intel with ig-platform-id=0x3E9B0007 it should work right after reboot as WhateverGreen handles the rest. But it didn't work, the display goes off whenever I tried to boot. I have tried the other combination like, IntelGFX & ig-platform-id to blank with uncheck Inject Intel as i3 8th gen UHD 630 is natively supported in mojave. But no luck. I only able to boot with a invalid IntelGFX. Next, I followed @headkaze's framebuffer patching using WhateverGreen guide. I tried to use Intel FB-Patcher a.k.a Hackintool, but its shows me like this: That means it can't detect the CPU generation & also the video memory. No matter what SMBIOS I tried. Even ioreg showed no "AppleIntelFrameBufferX". So forget about framebuffer patching. Though I tried different combinations of framebuffer patching which I found in this forum but it didn't work. Detecting CPU generation & Video memory is really important if you want a framebuffer patch. I also tried different Lillu+WEG versions. I even upgraded the BIOS to the latest version. Then I found a framebuffer patch which also consists a connectors patch, which worked for ASUS H370M-Plus motherboard, worked for me. As I have only HDMI, DVI-D & VGA video port. Row 1: Index 2, BusID 0x02, Type HDMI Row 2: Index 3, BusID 0x04, Type HDMI <-- assumes HDMI here Row 3: Index 1, BusID 0x01, Type DP Just go to Deviecs->Properties and paste this: Save the config file & restart. Now I have 1536 MB Intel UHD 630. YESS !!! The patch works for both DVI-D & HDMI even I don't have to change type HDMI to DVI-D. So you see how connectors patch plays a crucial part if you want to use your Intel iGPU & onboard HDMI, DVI-D & DP connectors. After applying the patch the Hackintool looks like: And here are the connectors tab for HDMI & DVI-D respectively. USB Port Fix: I followed the @headkaze's USB port patching guide mentioned in his thread. Now, as my USB controller's device id is 8086:A36D I had to install XHCI-unsupported.kext in Clover/kexts/Other. So after removing unused ports General->USB tab looks like this: Next, after rebooting with -uia_exclude_hs uia_include=HS09,HS10 boot flag it looks like this: Now, I used “Export” button to generate the USBPorts.kext & copied the file into EFI/CLOVER/kexts/Other. Removed unnecessary files like boot flags (-uia_exclude_ss -uia_exclude_hs uia_include=x), USBInjectAll.kext, Clover Renames (XHC, EH01, EH02). After rebooting the USB port limit is fixed. I have attached the kext files also if anybody needs it. config_usb.plist config.plist USBPorts.kext.zip
  3. Installing macOS Mojave 10.14 on Gigabyte Z370N WIFI + i7 8700K + UHD 630 Changelog: 10/17/2018 08:12h GMT-0 - Fix Kexts permissions commands adjusted. - Removed FrameBuffer patch that is not needed. - Added audio solution and HDMI. - Unfortunately DisplayPort does not work. - Replaced Wifi/BT with DW1560 (BCM94352Z) 10/11/2018 04:15h GMT-0 - Added USB 3.0 patch. - Adjusted some steps. - Changed text formatting. 10/11/2018 03:42h GMT-0 - Added missing UEFI configuration. 10/07/2018 00:36h GMT-0 - First version. What works and what does not - Processor -> Work. All SpeedStep stages.- Video Card -> Work. QE/CI and Metal.- Chipset -> Work.- HDMI (1st) -> Work. - HDMI (2nd) -> Work. - DP -> Not work. - Audio -> Work. - HDMI Audio -> Work.- WiFi/Bluetooth -> Work. Replaced. - Ethernet (1st) -> Work.- Ethernet (2nd) -> Not work.- USB3.0 -> Work.- Sleep -> Work. Todo - Make audio work. - Make HDMI audio work. - Test DisplayPort. - Make second ethernet work. - Replace Wifi/Bluetooth. What you need to install- Running install of macOS- One USB flash drive of 8GB or bigger- macOS Mojave install app- Clover EFI - Clover Configurator - Some KEXTsHow create create the install flash drive Prepare install flash drive Format the flash drive with GUID partition mapping and name it "Install".- Open Disk Utility.- Click in View, then "Show All Devices".- Select the destination flash drive, then Erase.- Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map Create install flash driveOpen terminal and run this command: sudo /Applications/Install\ macOS\ .app/Contents/Resources/createinstallmedia --volume /Volumes/Install--nointeraction This will take about 30 minutes. Install bootloaderDownload the CloverEFI (used 4674) and install with this options on "Install macOS Mojave": - Install for UEFI booting only- Install Clover in the ESP- UEFI Drivers - ApfsDriverLoader-64- UEFI Drivers - AptioMemoryFix64 Make things worksWill be created a partition named EFI and mounted in Desktop. Edit the /Volumes/EFI/CLOVER/config.plist inside this new partition, open with Clover Configurator (used 5.2.1.0) Full UHD630 Acceleration config.plist (Clover Configurator): - Uncheck: Acpi - Fixes - FixDisplay - Uncheck: Acpi - Fixes - AddHDMI - Change value: Gui - Screen Resolution to 3840x2160 (Your screen resolution, mine is 4k) - Change value: Rt Variables - CsrActiveConfig to 0x3 - Select value: SMBIOS - Up/Down arrows - iMac18,1 - Intel Core i5-7360U @ 2.30Ghz (I know, it's not our processor, but is that option) Download those Kexts and put in /EFI/CLOVER/kexts/10.14/ - Download the Lilu.kext from here. I used the version 1.2.7. - Download the WhateverGreen.kext. I used the version 1.2.3.RELEASE. All USBs (2.0, 3.0, Type-C, internal) config.plist (Clover Configurator): - Add value: Kernel and Kext Patches - KextsToPatch: Name*: com.apple.driver.usb.AppleUSBXHCI Find* [HEX]: 83FB0F0F 83030500 00 Replace* [HEX]: 83FB0F90 90909090 90 Comment: disable port limit in XHCI kext (credit PMHeart) MathOS: 10.14.x Sleep/Wake config.plist (Clover Configurator): - Check: Boot - Arguments - dart=0 Audio onboard and HDMI config.plist (Clover Configurator): - Change: Device - Audio Injection - layout-id to 7 Download those Kexts and put in /EFI/CLOVER/kexts/10.14/ - Download the Lilu.kext from here. I used the version 1.2.7. (already installed above) - Download the AppleALC.kext from here. I used the version 1.3.2. Wifi and Bluetooth (DW1560 / BCM94352Z) Download those Kexts and put in /EFI/CLOVER/kexts/10.14/ - Download the FakePCIID.kext and FakePCIID_Broadcom_WiFi.kext from here. I used the version 2018-1014. - Download the BrcmFirmwareRepo.kext, BrcmPatchRAM.kext and BrcmNonPatchRAM.kext from here. I used the version 2018-0505. Mandatory Kexts Download those Kexts and put in /EFI/CLOVER/kexts/10.14/ - Download the FakeSMC.kext from here. I used the version 2018-0915. - Download the IntelMausiEthernet.kext from here. I used the version 2018-0424. Put the Clover installer on the flash drive too. Now you can start the instalation without problem (I guess). How install UEFI Setup Configuration and InstallationUEFI configuration - Shutdown and insert the flash.- Power on with DEL pressed to enter BIOS setup.- Change value: Periphelrals - Initial Display to IGP- Change value: Periphelrals - USB Configuration - XHCI Hand-off to ENABLE- Change value: Chipset - VT-d to DISABLE- Change value: Chipset - Internal Graphics to ENABLE- Change value: Chipset - DVMT Pre-Allocated to 128M - Change value: Chipset - Wake On Lan to DISABLE - Save & Exit Setup - Now, hold the F12 - In the list, select your flash drive. - It will show twice. One with UEFI prefix and another without. - Select with UEFI prefix. Ie.: "UEFI: Sandisk Cruzer" The installer will start. Format destination diskFormat the disk with GUID partition mapping and name it "HD".- Select Disk Utility in the list, then press Continue.- Click in View, then "Show All Devices".- Select the destination Disk, then Erase.- Name: HD, Format: APFS and Scheme: GUID Partition MapClose Disk Utility.Select "Install macOS", then Continue.Follow instructions in screen.After installAfter first part install the system will reboot.The second part of the installation will begin. This will take 16 minutes. Post installationInstall bootloader When the second part of install finish, the system will reboot again.After performing the user initial setup and go to the desktop, you need to install Clover on internal disk.Open the Clover installer inside flash drive that you copied before.Use same options above but choose the system partition this time.Now you need to replace the config.plist inside your destination disk EFI parittion with config.plist inside flash card EFI partition.The flash drive EFI partition is unmounted. Mount with terminal "sudo diskutil mount /dev/rdiskXs1". To know what X is, use "diskutil list", most likely is 1. Last step Copy all Kexts from flash drive to /Library/Extensions, with those commands in Terminal: sudo cp -R /Volumes/EFI/EFI/CLOVER/kexts/10.14/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -system-prelinked-kernel sudo kextcache -system-caches Restart the system. It's done! And last but not least I would like to thank the following community members, by making these dream possible:@crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas and all others members involved directly or indirectly.
  4. Hi! Newbie here. Been browsing the forums for a while and trying to setup a Mojave 10.14.3 with the following hardware: Motherboard: ga-z370n-wifi - BIOS revision F5 CPU: Intel i7-8700k RAM: G.Skillz Trident Z 32gb (2x 16gb) DDR4-3000 HDD: Samsung 860 Evo M.2 1 TB PSU: Corsair RX750 USB used is 2.0 I've run into an issue where I'm trying to load the installer, but I am getting a panic error before getting to the Grey install screen. Followed this guide: See attached Screenshot for kernel panic. If I need to provide more info, let me know and I'll do my best to provide the info Also i'm not sure how to get the panic logs since I don't get shell unless I boot into single-user mode. (That of which I noticed a panic error whenever I try to run diskutil from single user mode)
  5. Copying this over from the other major forum as things seem pretty dead over there. Didn't see a dedicated "builds" forum here so hope this is the right spot. People on other social media recommended coming here. Alright, so the build has commenced, just waiting on the power supply (ended up not realizing that I bought the compatible power brick for the HDPlex 400w and then bought the PicoPsu 160, so that is going back and HDPlex is on its way) and monitor to get here. Found a smoking deal on an Acer-K272HUL-Dbmidpx 27" IPS display through Newegg ($216 shipped to my door) that has gotten great reviews, be careful when looking for this as the EBmidpx (different model) looks the exact same but is a TN Panel and comes up in many of the searches. Anyways, here is specs for final build... - Mobo - ASRock Z370m-itx/ac [$120 amazon] - RAM - Crucial Ballistix Sport LT 8gb [$49 amazon] - WiFi/BT - Lenovo Broadcom BCM94352Z [$13 ebay] - SSD - Samsung EVO860 1tb [$128 amazon] - CPU - Intel Core i5 8400 [$185 newegg] - Cooler - Noctua L9i [$40 amazon] - Case - Wesena ITX4 v3 [$97 perfect home theater] - PSU - HDPlex 400w [$95 hdplex] - PSU Brick - Dell PA-9E 240w [$37 ebay] - Monitor - Acer K272HUL 27" IPS [$216 newegg] Total: $883 (shipping included in prices, most were free shipping) This build will be mainly for your everyday computing needs, paying bills, watching YouTube videos and the occasional light photo editing session (have other expensive hobbies now so photography has fallen to the wayside). This is coming from a mid-2011 iMac 21.5" base model that is slowly dying (getting graphical artifacts on a constant basis now and the occasional sudden reboot). The iMac is no longer compatible with any new Mac OS upgrades (no Mojave) so I figured she had a good life over the last 8yrs and it was time to pick-up something new. Since I was fairly unimpressed with the specs for the money with regards to the new Mac Mini's I figured this would be a good chance for me to do a hackintosh. Install will be a Vanilla High Sierra build, since that is the only version I have access to on my iMac. From my research I have downloaded the following kexts for install. - Broadcom Fix (both the firmware repo and firmware patch) - IntelMausiEthernet - WhateverGreen - Lilu I am using the two following builds on the other forum as my baseline as they are very similar builds to mine. Suneys Mini Cube from the other forum and the Tiny But Might build from the same forum. With that said, I plan to use Morgonaut's guide from YouTube to build the hackintosh up (hopefully next weekend). Once everything is running stable in High Sierra I will hopefully be able to update to Mojave without any major issues and then keep moving forward with life. So, am I forgetting anything?
  6. Hello everyone, i have managed to install mac os mojave on my new hack i was able to get some basics working but i can not get graphics to work UHD 630 of i5 8400 it only shows 7mb of memory i have tried a lot of guides with no result i have tried installing whatevergreen and lilu, changing platform id and such, also i want to mention that i was able to boot only by setting platform id to 0x12345678 otherwise it would restart in gloscreenlock 3 hs0 now 0 sm0xo i am relatively new to hackintosh any help would be appreciated. thank you!
  7. Prima un saluto alla Community più yeah, che esista. Difficile trovare questa disponibilità e competenza da altre parti, rete o non rete. Dopo i salamelecchi, passo alle mie note dolenti: Ho installato Sierra da solo (Wow!) seguendo le solite guide qua sul forum. Ma ora sono allo scoglio insuperabile della postinstallazione.. E percio vi chiedo aiuto. Per la scheda Uhd 630 sono state provate infinite combinazioni tra FakeID e IGFX su Clover ma niente. Sul Bios UEFI Ho settato 128 di SharedMemory. Riguardo alla LAN, ccredo di aver messo le Kext giuste ma evidente mi sbaglio. Allego subito la mia EFI presente sul disco di avvio.. Grazie a cih vorrà aiutarmi. Massimo ----------- A parte che non so come editare la firma qua sul Forum, il mio Hardware in oggetto è: AsRock B360M - I5 8400 - 256 Kingstone SSD - 8Gb Ram EFI per sierra.zip
  8. Hello everyone I can not optimally configure my integrated video card on a gigabyte H370M DS3H motherboard. Would someone kindly help me? Thank you Send me.zip
×