Jump to content

Search the Community: Showing results for tags 'Thinkpad T430'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • InsanelyMac Lounge
    • Front Page News and Rumors
    • Reader News and Reviews
    • Forum Information and Feedback
  • OSx86 Project
    • New Releases and Updates
    • New Users Lounge
    • Developers Corner
    • Tutorials (The Genius Bar)
    • Technical FAQ
    • Installation
    • Post-Installation
    • DSDT and SSDT
    • Hardware Components and Drivers
    • Desktops
    • Notebooks
    • Netbooks
    • Tablets
    • MacMod of the Month
    • Multi-booting and Virtualisation
  • International
    • Your Language
    • Deutsch
    • Español
    • Français
    • Italiano
    • Português
    • Русский
  • Apple World
    • Mac OS X
    • Apple Computers and Hardware
    • iOS Devices
    • Mac Applications
    • Mac Programming and Development
    • iOS Programming and Development
    • Mac Gaming
    • Mac Accessories
  • Discuss and Learn
    • Windows Discussion
    • *nix
    • Apple Opinions and Discussion
    • The Great Debates
    • Internet(s), Servers, and Networks
    • Buying Thoughts, Reviews, and Recommendations
    • Mods and Overclocking
    • The Big Issues [Real Life]
  • Everything Else
    • Creativity
    • Thunderdome (Random Stuff)
    • Laughs
    • The Marketplace

Categories

  • Kexts
    • Graphics Cards
    • Audio
    • LAN and Wireless
    • Other
  • Kernels
  • Bootloaders
  • DSDTs
    • Patches
  • Pandora
  • Apps
  • Miscellaneous
  • Customization

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. Download http://goo.gl/qlWGgU UPDATE 10.10.1 - Nov 18, 2014: - Updated to 10.10.1 - Use modified Apple's IOBluetoothFamily.kext version for Bluetooth. - Switch back to Apple's AppleHDA.kext. - Patch on the fly using CLOVER for AppleHDA and AppleIntelFramebufferCapri - Use NVIDIA Web Driver, URL to download from this thread: topic/301416-nvidia-web-driver-updates-for-yosemite/ - BIOS settings: set boot mode to Both (UEFI & Legacy), UEFI First to avoid problem with Optimus and NVIDIA Discrete mode 10.10 beta 5 - Oct 13, 2014: - Updated to 10.10 beta 5 - Added package for 10.10: Bluetooth work with old IOBluetoothFamily.kext from 10.9.x. Updated DSDT for NVIDIA, Optimus and Intel only. - Move to mega.co.nz for better hosting and versioning. 10.10 beta 3 - Sep 26, 2014: Anyone tried 10.10 Yosemite? I tried last night and it's work with some issues, but useable. I have updated to Beta 3 also. Here is some screenshots: Short summary: - Bluetooth - NVIDIA not work (DP1, not tested on Beta3) - Intel HD4000: native res but no QE/CI - Sound: Need to patch AppleHDA.kext for layout 28 - Battery: need new patch in DSDT (use tluck's T420 DSDT work) - Sleep / Shutdown work as Mavericks Quick way: - Update your CLOVER first to latest: sourceforge.net/projects/cloverefiboot/files/latest/download - Create bootable usb or partition using this guide: http://www.insanelymac.com/forum/topic/298521-easy-yosemite-1010-usb-installer-updated-9-2-2014/ Note: you will need to copy BaseSystem.dmg (it is big as 470MB) so you will need at least 8GB USB. I have 6.5GB partition and it is fit for setup size but I don't have room for modding (kext, backup...) - Download CLOVER package from tluck's topic then extract, backup your kexts and copy all EFI/CLOVER/kexts/10.10/*.kext to /S/L/E/ - Add kext-dev-mode=1 to CLOVER kernel argument. - After install / upgrade you will need to re-copy all kexts. Update 1: Never mind, NVIDIA work well after repair permission. System FAN and Thermal Sensor for NVIDIA not show (need to patch with new DSDT) Update 2: - System FAN, GPU and other thermal sensor work after update DSDT, updated HW Monitor and latest FakeSMC. - NVIDIA Work but not detect / turn on built-in monitor, need to detect displays in displays settings to turn it on after boot. - Bluetooth still not work - Sound work with VoodooHDA - Battery work Look like CPU throttled too much, it is stick at 3Ghz most time and temperature is about 90oC @@, might need to generate SSDT or can be Yosemite issue. The temperature is about ~50-60oC with Intel HD4000. 10.9.3: ​HWMonitor version 6.8.1307 support FAN sensor (Check for update inside app and install FakeSMC and all it's plugins) NVIDIA: new version not work, replace with old working kexts (NV*.kext) Intel HD 4000 Capri: patch with Platform-ID `0300 6601` - Hex: `01 00 00 00 02 00 00 00 30 02 00 00` AppleHDA: patch-hda-3.1 NOT work - Work with VoodooHDA 2.8.4 (download from zip file here or pkg installer here AppleIntelCPUPowerManagement.kext patch with AICPMPatch Bluetooth: using modified kext from #26 (thanks @eilatuno) Others old kexts: AppleACPIPlatform.kext, IOUSBFamily.kext Shutdown / Restart / Sleep work well using latest CLOVER r2671 10.9.1: ​Sound stop working as AppleHDA.kext updated for VoiceOver bug fix, re-patch with patch AppleHDA script 3.1 from this thread Everything work well as 10.9.0 as last. Still have problem with Shutdown / Restart / Sleep STATUS * Working parts: Intel HD 4000 (Capri): Full resolution: 1600x900, QE/CI NVIDIA GF108M (NVS 5400M): Full resolution: 1600x900, QE/CI VGA, Display Port Wired network / Ethernet Think Light, Keyboard backlit (BIOS controlled) Webcam Mic, Speaker, Audio Jack Bluetooth Trackpoint, Touchpad USB 3.0 Battery UEFI with CLOVER r2366 Keyboard. Multimedia keys: Sleep, Prev / Play / Pause / Next (Brightness control with Fn-F8/F9 not work) Shutdown / Restart / Sleep * NOT working parts: Intel Centrino Advanced-N 6205 Wireless adapter Card reader HOW TO 1. Create Mac OS X Maverick 10.9 USB installer: Google it! 2. Install CLOVER EFI bootloader or Chameleon Use my config.plist if you install CLOVER NOTE: need to change the SMBIOS hardware section and CustomUUID to your own hardware. 3. Backup and copy kexts from attached file 4. Option: install LCD display profile 5. Option: install HWMonitor.app 6. DSDT: Use diff tool to apply diff changes a) I'm using 3 different DSDT file for 3 graphic config mode: DSDT.d.dsl / DSDT.d.aml: for Discrete graphic only BIOS config VGA, Mini-DP work well but hottest Temperatures on my machine: CPU: avg: 65oC, range: 60-85 GPU: avg: 60oC, range: 56-74 DSDT.o.dsl / DSDT.o.aml: for Optimus graphic BIOS config - NOTE: you will need to backup & remove /S/L/E/NVDA* because of OS X not support Optimus mode and it caused conflict loading video driver. DSDT.i.dsl / DSDT.i.aml: for Integrated graphic only BIOS config Optimus & Integrated gave me much more cooler temperatures but NO VGA, Min-DP - I usually use Integrated mode for travelling and Discrete mode for work because I need extend to my external Dell monitor. c) Temperatures when using Integrated only mode: CPU: avg: 45oC, range: 40-70-80 d) I added FAN control to DSDT based on T420 / W520 guides, Thinkvantage button will be used to toggle turbo fan mode. 7. SSDT: I used auto generated P-States and C-States CLOVER's option Hardware Specifications - Model: Thinkpad T430 2344BMU - lshw -numeric on Ubuntu 13.10 Hardware specs Big thanks for everyone who has involved in this thread and who created stuffs, guides, tools... Thanks for @tluck & experts in this thread to provide related update and information which I used in my package. Feel free to ask and discussion here about Mac OS X on T430 series, I will try to help if I can in my spared time.
  2. Uoc Nguyen

    Thinkpad T430 NVS 5400M 1GB VRAM

    Hello guys, I'm currently running OS X Mavericks 10.9.0 on my Thinkpad T430. Almost everything work except some minor problems. My laptop have 2 card: Intel Ivy HD 4000: Full QE/CI NVIDIA NVS 5400M (GF180M) with 1GB of VRAM: unusable Screen resolution: 1600x900 I tried many ways but can not make it work: Use older patched kexts: KP Patch DSDT: Loaded NVIDIA Startup, Resman, GF100, show corrected info in System Information, 1GB VRAM but can not get Login screen. Error in dmesg: NVDAStartup: Official Apple16X50PCI22: Identified 1 Serial channels at PCI Bus=0 Dev=22 Func=3 NVDAGF100HAL loaded and registered Previous Shutdown Cause: 5 SMC::smcInitHelper ERROR: MMIO regMap == NULL - fall back to old SMC mode Apple16X50UARTSync22: Detected 16550AF/C/CF FIFO=16 MaxBaud=115200 **** [IOBluetoothHostControllerUSBTransport][start] -- completed -- result = TRUE -- 0xd400 **** **** [BroadcomBluetoothHostControllerUSBTransport][start] -- Completed -- 0xd400 **** init probe start DSMOS has arrived [IOBluetoothHCIController][staticBluetoothHCIControllerTransportShowsUp] -- Received Bluetooth Controller register service notification -- 0xd400 [IOBluetoothHCIController][start] -- completed No interval found for . Using 8000000 [IOBluetoothHCIController::setConfigState] calling registerService **** [IOBluetoothHCIController][protectedBluetoothHCIControllerTransportShowsUp] -- Connected to the transport successfully -- 0x8000 -- 0x5800 -- 0xd400 **** flow_divert_kctl_disconnect (0): disconnecting group 1 nspace-handler-set-snapshot-time: 1383677494 AppleIntelE1000e(Info): e1000e NIC Link is Up 100 Mbps Full Duplex, Flow Control: Rx/Tx ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out WARNING: IOPlatformPluginUtil : getCPUIDInfo: this is an unknown CPU model 0x3a -- power management may be incomplete or unsupported NVDA::rmStart failed NVDA,Display-B: Not usable IOHIDSystem::registerScreenGated: Screen 0 recycled from pid 85 IOHIDSystem::registerScreenGated: Screen 0 recycled from pid 130 **** [IOBluetoothHostControllerUSBTransport][SuspendDevice] -- Suspend -- suspendDeviceCallResult = 0x0000 (kIOReturnSuccess) -- 0xd400 **** IOHIDSystem::registerScreenGated: Screen 0 recycled from pid 501 IOHIDSystem::registerScreenGated: Screen 0 recycled from pid 502 IOHIDSystem::registerScreenGated: Screen 0 recycled from pid 503 IOHIDSystem::registerScreenGated: Screen 0 recycled from pid 504 IOHIDSystem::registerScreenGated: Screen 0 recycled from pid 505 IOHIDSystem::registerScreenGated: Screen 0 recycled from pid 506 IOHIDSystem::registerScreenGated: Screen 0 recycled from pid 508 IOHIDSystem::registerScreenGated: Screen 0 recycled from pid 509 IOHIDSystem::registerScreenGated: Screen 0 recycled from pid 528 IOHIDSystem::registerScreenGated: Screen 0 recycled from pid 533 IOHIDSystem::registerScreenGated: Screen 0 recycled from pid 540 IOHIDSystem::registerScreenGated: Screen 0 recycled from pid 541 IOHIDSystem::registerScreenGated: Screen 0 recycled from pid 543 As far as I known that old Fermi card is not working well on Mavericks even with some MacBook Pro model. But I think it can be solve with patched DSDT and binary patch for Kext. I saw there are some guys have working card with Thinkpad W520 (Quadro 1000M/2000M), Thinkpad T420 (NVS 4200M). Anyone has solution for this problem please share! Thanks in advanced!
×