Jump to content

Search the Community: Showing results for tags 'Multi-BOOT'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • InsanelyMac Lounge
    • Front Page News and Rumors
    • Reader News and Reviews
    • Forum Information and Feedback
  • OSx86 Project
    • New Releases and Updates
    • New Users Lounge
    • Developers Corner
    • Tutorials (The Genius Bar)
    • Technical FAQ
    • OSx86 Installation
    • Post-Installation
    • DSDT
    • Hardware Components and Drivers
    • Complete Desktops
    • Notebooks
    • Netbooks
    • Tablets
    • MacMod of the Month
    • Multi-booting and Virtualisation
  • International
    • Your Language
    • Deutsch
    • Español
    • Français
    • Italiano
    • Português
    • Русский
  • Apple World
    • Mac OS X
    • Apple Computers and Hardware
    • iOS Devices
    • Mac Applications
    • Mac Programming and Development
    • iOS Programming and Development
    • Mac Gaming
    • Mac Accessories
  • Discuss and Learn
    • Windows Discussion
    • *nix
    • Apple Opinions and Discussion
    • The Great Debates
    • Internet(s), Servers, and Networks
    • Buying Thoughts, Reviews, and Recommendations
    • Mods and Overclocking
    • The Big Issues [Real Life]
  • Everything Else
    • Creativity
    • Thunderdome (Random Stuff)
    • Laughs
    • The Marketplace

Categories

  • Kexts
    • Graphics Cards
    • Audio
    • LAN and Wireless
    • Other
  • Kernels
  • Bootloaders
  • DSDTs
    • Patches
  • Pandora
  • Apps
  • Miscellaneous
  • Customization

Categories

  • OSx86
  • Apple News

Found 8 results

  1. Hello and happy new year everyone, I have been trying to get my "old" computer running completely on Sierra for a few weeks now (before Christmas). I had been on Snow Leopard for 6 or 7 years. Was a fast setup then. Will build new rig in next couple months... anyhow. I have a stable running Sierra. No freezes, have internet, sound, video. Have 2 issues main issues; Issue 1 - Clover cannot detect Windows 10. Clover cannot auto-boot. > Sierra is on SSD > Windows 10 & Snow Leopard are on different partitions of WD 2TB HDD > Connected to Intel SATA 0, 1, 2, 3 slots > Upon boot, Clover only displays the 2 apple drives; OS X Sierra & Recovery (does not auto boot) > Here's the strange thing. When I navigate to EXIT CLOVER, Clover resets/refreshes/reboots. Now it can see all the attached drives. > From here, I can select Windows or Sierra. Not the best experience. Issue 2 - OS X does not shut down. > So many people that have this issue. On Shutdown, screen goes black, systems just hangs. What I've tried. > Pressing F2 at First Clover boot (the 2 drives) and also on second iteration (all drives displaying). This shows the preboot.log. Seems the first time, Scanning doesn't work for some reason. > I have attached preboot1 and reboot 2 for context. > Clover Configurator - I have selected FixShutdown and Halt Enabler in ACPI. Doesn't do anything for Shutdown. > Scan is set to Legacy. Timeout set to 3 seconds. > DefaultBootVolume set to LastBootedVolume Attached 1. 2 screens; Volumes from Finder / the 2 screens from Clover. 2. preboot logs 3. config.plist So many thanks for anyone willing to take a look and help me troubleshoot. Been tinkering over 2 weeks now. ~Eric config.txt preboot1.txt preboot2.txt
  2. Hi.. I am running El Capitan using clover on HP Laptop (Intel Core i5 CPU 4210U, HD4400, SSD 480GB) i want to install Windows 10 on my MS-DOS (FAT) partition for dual boot. I boot windows 10 using UEFI and at formatting Win Partition it does not give me next option to install window then i used these codes to format it into ntfs using Command prompt on windows installation, diskpart select disk 0 list partition select partition x (x is the partition for Windows) format fs=ntfs label="Windows" quick active But after using these codes when i enter to select partition for Win10 installation it shows me partition as "System" and unable to format it. Any further guide to sort it out. Thank You for your consideration.
  3. Update: Despite 99% of the research I did suggesting the cause was a corrupt boot sector/MBR, the issue appears to be isolated to my Clover boot loader because upon attempting to boot with a Chimera USB Win 7 booted perfectly fine. Background: I have a machine that was previously dual booting legacy El Capitan and Windows 7 off of the same drive on a non-UEFI board. Issue: When I try to boot the Win 7 entry through Clover I get a "Disk Read Error". Possible causes: The El Capitan install is a recent fresh replacement of the Mavericks install. I will try to retrace my steps that may have caused this but the troubleshooting took place about a month ago and was a lengthy process. 1. If I recall correctly, upon first installing the new El Capitan, Clover was not loading off the drive and instead I was getting a Windows boot menu. To remedy this I think I had to switch the Boot0 to AF or SS. After that I can say with certainty the system was booting both OSs fine. 2. Then there was an issue at some point where the EFI was improperly formatted as HFSJ so I had to set it back to FAT32 and I think at this point the dual booting was still in tact. 3. At a later point I tried to format the EFI again in order to troubleshoot another issue but accidentally improperly formatted it. In order to fix that I found a post on Stack Exchange that detailed out to swap the EFI out from starting to ending byte with the EFI from my boot USB. 4. I reset my BIOS to factory defaults. These are the possible things that may have caused this issue but I'm not sure. Questions: • Is my boot partition damaged? • Is there BIOS or Clover setting causing this issue? • Is there a possible way to examine the boot partition or see a detailed log that may hint at what is causing the "Disk Read Error"? • Is there any possible way I can repair this with out having to install both OSs from scratch?
  4. Edit: this post can be deleted, internet lag created 2
  5. Hello, For the last couple weeks I have been trying to find the "perfect" guide to dual-boot. I came across with SO many methods (tonymac,niresh,myhack,iAtkos,and about 100 000 other methods) that I'm very confused. Here is my problem: I'd like to dual-boot windows and mavericks on the same drive, but from what I read during my researches, they mentioned multiple times reinstalling Windows. So I'd like to know if there is any way to do this without losing my data or if there's not and then I have to backup all my system. I have mavericks running smoothly in vmware workstation 10 if that's of any use. My computer specs are the following: OS name Microsoft Windows 8.1 Version 6.3.9600 Compilation 9600 ASUSTeK COMPUTER INC. Model X55A x64-based PC SKU system ASUS-NotebookSKU Processor Intel® Pentium® CPU 2020M @ 2.40GHz, 2400 Mhz, 2 cores, 2 logic processors Date/Bios version American Megatrends Inc. X55A.415, 09/11/2012 SMBIOS 2.7 BIOS mode UEFI If you could me to a guide telling what to do after the USB creation, I would appreciate. Thanks in advance! ps: sorry if I'm on the wrong section and sorry for bad english :s 4gb ram
  6. Hi there, I have decided to put a little bit of advice on this idea - how to keep all your files in once place, across all your OSes. This generally has to be a planned choice before you set up your computer: working through this in retrospect can be quite a pain in the neck. The technique here is to use a common partition for everything: Your Documents, Music, Videos, Pictures, etc. Step 1 - Partition your hard drive correctly To have a common partition for all your files, it has to be accessible to all your OSes. This means in the first three partitions of a GPT/GUID formatted hard drive (if you install Windows using UEFI, then you can put it anywhere. However, I would still recommend to keep it at the start of the drive just in case). You also need to ensure that your hard drive is the right format. NTFS will make it read-only by default on Mac and Linux, and generally only be read-write from Windows (yes, there are ways around it, but this is more tricky). HFS+ requires a commercial solution for Windows called MacDrive, and for Linux, it is read-only when the drive is journaled. Ext2/3/4 is generally difficult to set up on Windows and Mac. FAT also has a limitation to maximum file size, and has issues when you create a partition over 32GB. Hence, my personal recommendation is that you format a large partition as exFAT near the start of your hard drive. This can be done in Disk Utility, or if you make a FAT partition, you can then format it later in Windows to exFAT. Step 2 - Configuring your OSes to use the drive Mac and Windows will be able to detect your partition and mount it automatically. Linux? Not immediately. Also, you want to make sure saving things are as easy as possible. I am not an advocate for storing {censored} loads of stuff to the desktop, and I keep things in Documents, Videos, Music, Pictures, Downloads, etc. I will walk through how to make sure that everything works the way you want. ASSUMPTIONS I am assuming first of all that: the partition is the second one on your first hard drive (after EFI boot): On linux, it will be sda2. On mac it will be disk0s2. I am also calling the drive common : you can call it whatever you want. On our exFAT partition, I suggest making it look like this: A folder for your user Folders in that folder of: Documents Downloads Music Pictures Videos Linux exFAT by default is not installed on linux. No problem however, we can easily fix that. Open up a terminal and type in: sudo apt-get install exfat-fuse exfat-utils If it doesnt exist, and you are using ubuntu, try this: sudo apt-add-repository ppa:relan/exfat sudo apt-get update sudo apt-get install exfat-fuse exfat-utils This will allow you to mount exFAT partitions. Second thing we need is to make sure it mounts on boot. In your terminal, sudo nano /etc/fstab (or use your favourite editor) and put this line at the bottom: /dev/sda2 /common exfat rw,async,umask=0 0 0 (Again, check the assumptions bit I put. Change each bit that is different for you in this line, otherwise it won't work). Make your folder and mount it: sudo mkdir /common mount /common and viola - your common partition is ready in linux. Mapping your folders. This is for convenience purposes - so when you save your files, they will all be in the same place.   cd rm -rf Documents Downloads Music Pictures Videos (NOTE: PLEASE MAKE SURE THESE FOLDERS ARE EMPTY FIRST! I am not taking responsibility for lost data) (Please check your files first) ln -s /common/<your user here>/Documents ln -s /common/<your user here>/Downloads ln -s /common/<your user here>/Music ln -s /common/<your user here>/Pictures ln -s /common/<your user here>/Videos Now in your home directory, all those folders will link to the common drive on boot. Windows Thankfully Windows will recognise exFAT on boot, and assign it a letter name. All you have to do in this instance is to go through your Windows Libraries in My Computer, and map everything to the drive. If things don't work, you can use this tool here: http://zornsoftware.codenature.info/?page_id=37&did=2 For Windows 8, it does things a bit differently (do the above as well). Open up My Computer, and see the list of folders. You can right click on them, go to properties, and change the paths one by one. Mac Similar to linux, but the partition should auto mount. cd cd rm -rf Documents Downloads Music Pictures Videos (NOTE: PLEASE MAKE SURE THESE FOLDERS ARE EMPTY FIRST! I am not taking responsibility for lost data) (Please check your files first) ln -s /Volumes/common/<your user here>/Documents ln -s /Volumes/common/<your user here>/Downloads ln -s /Volumes/common/<your user here>/Music ln -s /Volumes/common/<your user here>/Pictures ln -s /Volumes/common/<your user here>/Videos Other Notes For your web browsers, I suggest manually changing the download location to your common drive. Occasionally, I have had to scan the exFAT partition on windows manually for errors, but hopefully your experiences should be better. Happy multi-booting
  7. Ah well, since I didn't find a most appropiate thread to post this in, I opened a new one. Before anything, please note, that the following work has been done on hardware, which already has been made into a Hackintosh (with myH*ck I think), but can easily adapted by experienced users to a fresh installation, as it "only" depends on the right BIOS setup, extensions and bootloader flags. Just wanted to confirm, that a 5 display setup with the Asus X58 Motherboard, a 'new' GTX 650Ti and the totally outdated GeForce 210, which is in service already for 2 years in this machine, is possible and working more-or-less out-of-the box, assuming you do a sane post-installation as shown in this post. The Hardware specs: Asus X58 Sabertooth (v1304) Intel i7-950 (3.07 GHz) 2 x 4 GB RAM (I think Kingston) Asus GTX 650Ti (1GB RAM, 1 HDMI, 2 DVI, 1 VGA) Gigabyte GeForce 210 (1 GB RAM, DVI, HDMI, VGA) 3 HDDs (Mac, Linux+WinXP, Win7) 1 Optical Drive The usual periphery devices Tested with: 1 x 32" Panasonic TV (HDMI) 2 x 19" Medion (DVI) 1 x Samsung SyncMaster (DVI) 1 x Dell (VGA) Final Variant: 3 x 24" Samsung SyncMaster (DVI, 1920x1200) (on the desktop table) 2 x 19" Medion (DVI, 1600x900) (above the three displays) (5 x DVI with 2 HDMI<->DVI adapters of course) The Software specs Mac OS X 10.8.4 Chameleon r2286 org.chameleon.Boot.plist: darkwake=0 npci=0x2000 UseKernelCache=Yes EthernetBuiltIn=Yes GeneratePStates=Yes GenerateCStates=Yes GraphicsEnabler=No SMBIOS.plist: SMproductname = MacPro3,1 Setup of the BIOS Storage/HDD: AHCI Sleep: S3 Video repost on resume: Yes Optional: set the cpu and chassis fans to manual and then to a sane rpm value (about 900 - 1,000 for example) for a slient machine and the other usual stuff for this board, found on the insanelymac forum or somewhere else; boot order is set to the mac disk first. The tests of the Hardware This is a machine only for serious work (programming and stuff) and NOT for gaming, so the 1GB RAM on each card is totally enough. Since the Mac OS X does NOT support "old" analog video outputs, you may only use the (in total) 2 HDMI and 3 DVI connectors. Furthermore, Kubuntu 13 had no problem at all to use also the analog outputs together with the digital ones (so, I assume, it would even work with 6 displays, using the vga output on the gtx 650ti) and Win XP (SP3) gets stuck with only 2 displays per adapter (in total 4, but ok). Windows 7 SP1 is installed too, and I think it will be as capable as Kubuntu, so up to 6 in total, but I did not test this; right now it works with the three connected displays. When the new/final displays arrive, I will make some nice photo for 'the proof' and attach it. Right now, to be able to work again until they arrive, it's 1 x Panasonic and 2 x Medion. I do not expect any different behaviour with 3 x 1920x1080 and 2 x 1600x900 displays, but we will see. The Software installation (Mac): To determine the correct configuration of Extensions and "/Extra" content, so everything is working (Network, Audio, etc.), I had some painful time, mainly consisting of booting into Safe Mode to correct things, which always took extra long, until I decided to throw all away (from the previous installtion, based on myH*ck/M*ltiB**st), and start clean again as possible, since some extensions from previous installations of M*ltiB**ast/myHack/whatever may still reside in the Extensions directory?! I removed all extensions I certainly knew they were connected with some Hackintosh-stuff AND by the way moved some others to "/System/Library/Extensions.disabled" (yep, you would have to create that one first), such as the drivers for ATI cards, ATTO hardware, Apple iSight, AppleIntel Framebuffer, Apple Thunderbolt, etc., as they are not necessary for this machine and the test runs with the "-v" or "-f" flags for the bootloader are now a little bit faster. In the end, it was much easier, than I feared: Install the extension FakeSMC.kext into "/System/Library/Extensions" ("S/L/E"). Install a patched AppleACPIPlatform.kext (by ErmaC), which is only for this MoBo, into "S/L/E". This can be done with M*ltiB**st 5.5.5 (Drivers & Bootloaders > Drivers > System > AppleACPIPlatform Rollback > 10.6.8 Rollback) or manually Install a patched AppleIntelCPUPowerManagement.kext. This can be done with M*ltiB**st 5.5.5 (Drivers & Bootloaders > Drivers > System > Patched AppleIntelCPUPowerManagement > OS X 10.8.0 - 10.8.4) or manually Install the DSDT.aml file by ErmaC for the Asus X58 MoBo in "/Extra" and perform a small edit (with MaciASL) of the "HDEF" device: change the "layout-id" to "0x01, 0x00, 0x00, 0x00". This enables the internal audio speakers. Adjust the smbios.plist file to "SMproductname=MacPro3,1" (you can do that with Chameleon Wizard); if you should have issues with AppStore, try changing the "SMserial" or "SMboardproduct" values (search for them on the web) Optional, but maybe handy: Install the "lspcidrv.kext" (if this is necessary nowadays anyway?!) in "/Extra/Extensions" and some nice theme (with Cham. Wizard) As always after installation of Kernel extensions, run "Kext Utility 2.5.1" to re-generate the Kernel Cache and maybe use the Apple Disk Utility to repair permissions on your boot volume. Set the above mentioned settings (with Chameleon Wizard) within the org.chameleon.Boot.plist file. I think someone mentioned somewhere, that "darkwake=0" is not necessary anymore. Well, it certainly doesn't make any problems. Maybe I forgot some detail (such as installing/patching the AppleHDA.kext with M*ltiB**ast, but this is the essential way. Maybe steps 2.) and 3.) are not really necessary, as the DSDT.aml file may fix it all, but I'm not sure. Someone else would have to test that. =) Status OK Video OK Audio OK Network OK USB 2.0 ?? USB 3.0 (have no hardware to test, I think; maybe I can confirm this some time later) OK Sleep OK Restart OK App Store OK Boot from Chameleon into Win XP or Win 7 on other disks In the end quite a powerful and silent machine (due to two extra chassis fans I also got recently) for programming. What now needs to be done is some fine-tuning within Mac OS. For example, I installed OSXFUSE and NTFS-3G, to be able to read AND write to the Win volumes from Mac OS and so I want to mount them at startup time with commands such as: mkdir /Volumes/WinXP && sudo mount -t ntfs-3g /dev/disk1s1 /Volumes/WinXP/ mkdir /Volumes/Win7 && sudo mount -t ntfs-3g /dev/disk2s1 /Volumes/Win7/ This would enable me to work with them as built-in HDD icons on the desktop with their correct names. Just have to figure out, how to do that exactly, since editing the "/etc/fstab" file doesn't seem to work in ML. In Kubuntu 13 and Windows XP/7 there was no further special treatment necessary, as they would see all hardware out-of-the-box. Happy hacking people! A small side note: If anyone knows how to enable more than 16 Spaces in Mac OS X 10.8.4, it would be nice to tell me. I did some digging into the private APIs of Apple's frameworks and the Dock, but in the little time i had to test this, it was not possible to program a tool to have more than 16 and I would like to have about 64 - don't ask why. But may be this will become obsolete with 5 displays and 16 spaces.
  8. Triboot of Microsoft Windows Vista ultimate,Windows 7 Ultimate, Mac OS X Leopard ICH ÜBERNEHME KEINERLEI HAFTUNG FÜR EGAL WAS!! ALLES AUF EIGENE GEFAHR BLABLABLA Benötigt: funktionierendes iso von vista ultimate, win 7 UND XxX 10.5.6 Leo 4 All (sollte aber auch mit anderen versionen funktionieren) also für meinen triboot verwende ich zwei bootloader in kombination zum einen den von windows 7 und zum andren darwin bootloader vom mac betriebsystem vorab möchte ich noch anmerken dass ihr einen mac os x eintrag beim windows 7 bootloader habt der nicht verrwendbar ist und bei darwin bootloader funktioniert nur der windows vista und leopard eintrag ist aber rein funktionell nicht relevant...ich habe schon einen post aufgemacht um anzufragen wie man den darwin bootloader bearbeiten kann...keine antwort bis jetzt..ich werde neuigkeiten posten als erstes muss vista installiert werden, dann windows 7 dann bootloader so bearbeiten wie man ihn haben will wenn beides bootbar ist, erstellt man ein neues volume mit hilfe der datenträgerverwaltung von windows 7 -> start rechtsklick auf computer ->verwaltung->datenträgerverwaltung->neues einfaches volume erstellen dieses volume wird nur erstellt nicht formatiert oder irgendwo eingehängt!! dann installiert man, auf das neu erstellte volume mac os: boot mit -v flag ACHTUNG: partition muss als MAC OSX Jurnaled Extendend formatiert werden!! ->utilities->disk utility->letztes volume wählen solte irgendetwas in der art "disk03" sein->erase und oben MAC OSX jurnaled extendend auswählen danach mit cd neu starten und beim ersten systemstart f8 drücken und mit -s booten dann folgendes eingeben: fdisk -e /dev/rdisk0 flag 1 quit reboot cd rausnehmen nun bootet ihr in den windows bootloader dort windows 7 auswählen chain0 datei von der mac install disk suchen sollten in einem unterordner mit dem name standalone und dann i363 oder so sein->in root von vista und win7 kopieren im windows 7 mit win+r->cmd die konsole öffnen bcdedit /copy {current} /d “Mac OS X” bcdedit bcdedit /set {GUID} PATH \chain0 {guid} steht für den zahlen/buchstaben-code des mac os x eintrages (bei discription steht mac os x oder was in den " eingefügt wurde) konsole schließen und neu starten dann wieder die konsole öffnen und diskpart eingeben list disk (zeigt eine liste der festplatten auf) select disk xy (xy steht für eure festplatte auf der ihr mac vista und win7 installed habt) list partition (zeigt partitionen auf datenträger) select partition ab (ab steht für eure mac osx partition) active (markiert die gewählte partition als aktiv; ihr könnt nur EINE aktive partition haben davon wird gebootet) dann konsole schließen neu starten dann bootet automatisch mac os (wenn ihr den darwin bootloader mit all den auswahlmöglichkeiten seht könnt ihr diesen schritt überspringen) wenn ihr in mac seit richtet ihn ein und öffnet dann den finder dort sucht ihr euch zur com.apple.boot.plist durch und öffnet diese mit dem "editor" nun fügt ihr am ende( aber vor </dict> </plist> ) das ein: <key>Timeout</key> <string>5</string> nun ist euer boot timeout 5 sekunden und ihr könnt zwischen den einträgen wählen nachdem ihr aufgefordert wurdet eine beliebige taste zu drücken (natürlich müsst ihr das erst machen um etwas auszuwählen) einträge testen UND keine panik bekommen wenn ein eintrag nicht funktioniert...einfach neu starten und andren ausprobieren) bei mir ist es so, dass beim darwin bootloader der eintrag "windows 7" nicht funktioniert. wenn man aber den eintag "windows vista" wählt gelangt man in das windows bootmenü wo einem drei einträge gezeigt werden zum einen windows 7 und windows vista zum andren aber auch noch mac os x. dieser eintrag führt zur system wiederherstellung...also einfach nicht beachten , denn mac wird ja über den darwin bootloader gebootet ein weiteres schönheitsproblem ist dass man den windows bootloader nicht mehr nachträglich bearbeiten kann...keine ahnung warum das so ist... wenn ihr alles habt solltet ihr in der lage sein über den darwin bootloader euer leopard zu booten und ins windows bootmenü zu gelangen im windows bootmenü einfach zwischen windows 7 und vista wählen...mac os x eintrag nicht beachten... FERTIG ich hab keine ahnung wie es aussieht wenn man ein system neu installieren muss...(also ich weeiß nicht ob der mbr überschrieben wird bzw wie man das wieder hinbekommt...) für fragen stehe ich euch gerne zur verfügung... hoffentlich habe ich euch weiterhelfen können meine quellen waren: http://inihilist.wordpress.com/2008/04/05/...and-fool-proof/ und mein erfindeergeist,mut etwas neues zu testen und verzweiflung weil ich ein halbes jahr lang gebraucht habe... Mikey aka Germac (GER)
×