Jump to content

Search the Community: Showing results for tags 'Audio'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • InsanelyMac Lounge
    • Front Page News and Rumors
    • Reader News and Reviews
    • Forum Information and Feedback
  • OSx86 Project
    • New Releases and Updates
    • New Users Lounge
    • Developers Corner
    • Tutorials (The Genius Bar)
    • Technical FAQ
    • Installation
    • Post-Installation
    • DSDT and SSDT
    • Hardware Components and Drivers
    • Desktops
    • Notebooks
    • Netbooks
    • Tablets
    • MacMod of the Month
    • Multi-booting and Virtualisation
  • International
    • Your Language
    • Deutsch
    • Español
    • Français
    • Italiano
    • Português
    • Русский
  • Apple World
    • Mac OS X
    • Apple Computers and Hardware
    • iOS Devices
    • Mac Applications
    • Mac Programming and Development
    • iOS Programming and Development
    • Mac Gaming
    • Mac Accessories
  • Discuss and Learn
    • Windows Discussion
    • *nix
    • Apple Opinions and Discussion
    • The Great Debates
    • Internet(s), Servers, and Networks
    • Buying Thoughts, Reviews, and Recommendations
    • Mods and Overclocking
    • The Big Issues [Real Life]
  • Everything Else
    • Creativity
    • Thunderdome (Random Stuff)
    • Laughs
    • The Marketplace

Categories

  • Kexts
    • Graphics Cards
    • Audio
    • LAN and Wireless
    • Other
  • Kernels
  • Bootloaders
  • DSDTs
    • Patches
  • Pandora
  • Apps
  • Miscellaneous
  • Customization

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 61 results

  1. Hi all! I recently updated my Yosemite to the latest release but I noticed one things to fix: my audio works if I'm using the laptop's subwoofer, otherwise if I connect devices to the 3,5mm jack, it continues to come off the laptop instead of earphones/headphones. This is was happens if I use power supply without battery connected to the laptop. When I connect my battery to the laptop, headphones start to work, and they continue to work even if I remove the battery, which seems to be nothing but an injector. If I reboot the computer, without battery connected, again: subwoofers work regardless of whether headset are connected or not. When I was under Yosemite 10.10.2 or 10.10.4 the same thing happened, with the difference that just after the first time that I connected the battery, headphones started to work also without battery and also after reboot. Not only, just after update I removed audio kext (from terminal with "sudo su" "rm -r /System/Library/Extensions/KextName.kext") and I rebooted the OS. At login I noticed that audio was working, but soon after Yosemite installation without the kext I use audio was off! So my suspicion is that 10.10.5 update has modified something but honestly I don't know what.. Here I've attached also my audio kext. Thanks in advance to everyone who'll help me! IDT92HD91BXXInject.kext.zip
  2. MAC IN TOSH

    VoodooHDA

    Version 2.8.7

    6,701 downloads

    This VoodooHDA 2.8.7 can enable ALC888 audio on OS X Yosemite. Install it, restart you Hackintosh. You may hear some noise. To fix the noise, go to VoodooHDA pref pane in System Preferences and decrease Input Grain. Enjoy. Should work with Mavericks Will Work with Yosemite Might work with other audio devices on yosemite
  3. toleda

    Realtek ALC889 AppleHDA Audio

    Version v2.3.7

    3,669 downloads

    Realtek ALC889 edited AppleHDA.kext_v2.3.7 for Mountain Lion 10.8.4. Expected to work in 10.8.5 and 10.9. Do not repost or distribute kext or included files. This kext requires Audio ID Injection for sound, see Realtek ALC AppleHDA Audio Injection - Sound - InsanelyMac Forum. No additional patching is required. Three Realtek ALC889 Audio_IDs, select one Audio_ID: 1 supports 5 and 6 port ALC8xx onboard and/or AMD/Nvidia HDMI audio Audio_ID: 2 supports 3 port ALC8xx onboard (analog 5.1) and/or AMD/Nvidia HDMI audio Audio_ID: 3 supports 3, 5 and 6 port ALC8xx onboard HD4K/HD3K HDMI audio with or without AMD/Nvidia HDMI audio Four Realtek ALC889 Audio ID injection techniques, select one and install 1. No dsdt/audio enabler/Audio_ID: toleda/audio_kext_enabler 2. dsdt/HDEF/Audio_ID: toleda/audio_ALCInjection 3. ssdt/HDEF/Audio_ID: toleda/audio_ssdt_enabler 4. Clover/Config.plist/PCI/HDAInjection/Audio_ID: toleda/audio_ALCInjection Installation 1. Verify Realtek ALC889 Audio ID injection installed 2. Backup installed S/L/E/AppleHDA.kext and delete 3. Install Downloads/AppleHDA.kext with preferred kext installer, i.e., Kext Wizard, Kext Utility, etc. Capabilities/Guides/Not Supported/Customization/Support/Credit 1. See Mountain Lion Realtek ALC AppleHDA Audio - OSx86 10.8 (Mountain Lion) - InsanelyMac Forum AppleHDA HDMI Audio 1. See Mountain Lion HDMI Audio - OSx86 10.8 (Mountain Lion) - InsanelyMac Forum
  4. toleda

    Realtek ALC892 AppleHDA Audio

    Version v2.3.7

    5,829 downloads

    Realtek ALC892 edited AppleHDA.kext_v2.3.7 for Mountain Lion 10.8.4. Expected to work in 10.8.5 and 10.9. Do not repost or distribute kext or included files. This kext requires Audio ID Injection for sound, see Realtek ALC AppleHDA Audio Injection - Sound - InsanelyMac Forum. No additional patching is required. Three Realtek ALC892 Audio_IDs, select one 1. Audio_ID: 1 supports 5 and 6 port ALC8xx onboard and/or AMD/Nvidia HDMI audio 2. Audio_ID: 2 supports 3 port ALC8xx onboard (analog 5.1) and/or AMD/Nvidia HDMI audio 3. Audio_ID: 3 supports 3, 5 and 6 port ALC8xx onboard HD4K/HD3K HDMI audio with or without AMD/Nvidia HDMI audio Four Realtek ALC892 Audio ID injection techniques, select one and install 1. No dsdt/audio enablerAudio_ID: toleda/audio_kext_enabler 2. dsdt/HDEF/Audio_ID: toleda/audio_ALCInjection 3. ssdt/HDEF/Audio_ID: toleda/audio_ssdt_enabler 4. Clover/Config.plist/PCI/HDAInjection/Audio_ID: toleda/audio_ALCInjection Installation 1. Verify Realtek ALC892 Audio ID injection installed 2. Backup installed S/L/E/AppleHDA.kext and delete 3. Install Downloads/AppleHDA.kext with preferred kext installer, i.e., Kext Wizard, Kext Utility, etc. Capabilities/Guides/Not Supported/Customization/Support/Credit 1. See Mountain Lion Realtek ALC AppleHDA Audio - OSx86 10.8 (Mountain Lion) - InsanelyMac Forum AppleHDA HDMI Audio 1. See Mountain Lion HDMI Audio - OSx86 10.8 (Mountain Lion) - InsanelyMac Forum
  5. toleda

    Realtek ALC898 AppleHDA Audio

    Version v2.3.7

    1,656 downloads

    Realtek ALC898 edited AppleHDA.kext_v2.3.7 for Mountain Lion 10.8.4. Expected to work in 10.8.5 and 10.9. Do not repost or distribute kext or included files. This kext requires Audio ID Injection for sound, see Realtek ALC AppleHDA Audio Injection - Sound - InsanelyMac Forum. No additional patching is required. Three Realtek ALC898 Audio_IDs, select one 1. Audio_ID: 1 supports 5 and 6 port ALC8xx onboard and/or AMD/Nvidia HDMI audio 2. Audio_ID: 2 supports 3 port ALC8xx onboard (analog 5.1) and/or AMD/Nvidia HDMI audio 3. Audio_ID: 3 supports 3, 5 and 6 port ALC8xx onboard HD4K/HD3K HDMI audio with or without AMD/Nvidia HDMI audio Four Realtek ALC898 Audio ID injection techniques, select one and install 1. No dsdt/audio enabler/Audio_ID: toleda/audio_kext_enabler 2. dsdt/HDEF/Audio_ID: toleda/audio_ALCInjection 3. ssdt/HDEF/Audio_ID: toleda/audio_ssdt_enabler 4. Clover/Config.plist/PCI/HDAInjection/Audio_ID: toleda/audio_ALCInjection Installation 1. Verify Realtek ALC898 Audio ID injection installed 2. Backup installed S/L/E/AppleHDA.kext and delete 3. Install Downloads/AppleHDA.kext with preferred kext installer, i.e., Kext Wizard, Kext Utility, etc. Capabilities/Guides/Not Supported/Customization/Support/Credit 1. See Mountain Lion Realtek ALC AppleHDA Audio - OSx86 10.8 (Mountain Lion) - InsanelyMac Forum AppleHDA HDMI Audio 1. See Mountain Lion HDMI Audio - OSx86 10.8 (Mountain Lion) - InsanelyMac Forum
  6. _Cute_Kitty_

    Audio Lenovo Mahobay

    Hi all, Lenovo Thinkcentre m92p. I can't for the life of me find what the audio chipset is on my board. When I open it up it says "foxconn" on the audio port. My motherboard doesn't have a model number or anything, it's literally just called "Lenovo Mahobay." Basically I would like to know what I need to do to get audio working on my Hack. OTHER SPECS: i5 2400 GTX 750ti 8 GB RAM Google yields this: All the Lenovo site states is that it's using "integrated audio" https://support.lenovo.com/us/en/documents/pd024409 no idea what that means.. Google also yields tons of different codecs for what m92p uses https://www.google.com/search?q=lenovo+m92p+audio+output&biw=1395&bih=782&source=lnms&sa=X&ved=0ahUKEwiszvKN0e3QAhWIAsAKHZtcBVMQ_AUIBSgA&dpr=1#q=lenovo+m92p+audio+codec+
  7. SAMEH209

    AMD 5570 HDMI Audio not working

    Hi all, I just installed Yosemite on my pc..everything is working fine till now except HDMI audio..it's not showing up in the "Output" in sound preferences..on-board is working fine. My specs are: M.B: Gigabyte G41MT-S2P VGA: AMD 5570 1GB connected to Samsung monitor through HDMI. RAM: 4GB Please help..Thanks!
  8. Having a black screen while playing video , even after installing the Perian codec, any suggestions? I'm running MacOS Sierra VMware image on Intel i7 4th Gen
  9. distro

    VoodooHDA vs AppleHDA

    Hi everyone, I have audio & AppleHDA working on my hackintosh (Toleda's Clover script & CodecCommander), so "no audio" is not the issue here. I've searched around but couldn't find any threads about this. I'm mostly concerned about how VoodoHDA and an AppleHDA patch compare with respect to usability, stability, and most importantly, sound quality. Cheers!
  10. lucasponciano

    Problema com Lion 10.7.2 (iAtkos L2)

    Bom, na ultima semana, troquei minha placa de vídeo, de uma GeForce GTS 250 para uma EVGA GTX 460 (ambas de 1 GB). Instalei o Lion 1.7.2 com o dvd do iAtkos L2, com sucesso, porém utilizando dois comandos que foram necessários para que o sistema inicializasse ("GraphicsEnabler=No" e "npci=0x2000"). Consegui inicializar o sistema e atualizar o kext da placa de vídeo. Porém, ficou sem áudio, e todos os kexts de áudio que eu tentei, deu kernel panic. Alguma sugestão ? Segue as configurações do meu pc: Core i7 920 @2.66 GHz (1ª Geração) Asus P6T (Normal) 6GB Ram (Triple Channel com 2GB OCZ³ 1.333 GHz) EVGA GTX 460 1GB 120 GB HD Agradeço desde já.
  11. Well, I succesfully installed Lion 1.7.2 on my computer using iAtkos L2. I changed my graphic card from GeForce GTS 250 to EVGA GTX 460 (both 1GB), and i got an audio issue. When I was using the GTS 250, all was working fine (sound crackling a little bit, nothing important). Now, i install lion with "GraphicsEnabler=No" and "npci=0x2000", to instal the vga kext after installing the system. Well, when i try to install any audio kexts I get a kernel panic. Any suggestions ? My Computer Configuration: Core i7 920 @2.66 GHz 6GB Ram (3x OCZ³ 2GB 1.333 in triple channel) Asus P6T (Normal) EVGA GTX460 1GB 120 GB HD Thanks ! Lucas Ponciano
  12. Hello everyone, For the past few days, I have been trying to get the audio working on my ThinkPad T510 with macOS Sierra. I have read all of the guides on the forum, I can link them if anyone needs them, and I still have no audio. As far as I know, the T510 uses the Conexant CX20585. For most people, this seems to work with kexts they have posted. Below are the methods I tried: - Using .kext s people have provided under Guides and Downloads on the InsanelyMac forum. Not Working - Modifying AppleHDA through Clover. Not Working - Try other verison of Mac OS X (Sierra, El Capitan, Yosemite, Mavericks). Not Working This has led me to believe that I am ether completely missing a step in a guide, or I am doing something wrong. Or, that my specific ThinkPad T510 uses a different audio codec. Any help I can get, will be appreciated. I hope someone here could help me. Thanks In Advance.
  13. Hi there, I had to reinstall El Capitan on my Hackintosh, as it was installed in Clover Legacy Mode before (with everything working just fine). Now I installed it again in UEFI mode and since then, Audio (ALC892) is not working anymore (Neither in UEFI or Legacymode). I tried to install the same 2 Kexts as before (AppleHDA modified and HDAEnabler1) using Kextutility (wich was working fine before as well). It always fails to install AppleHDA, as it cannot Backup or modify the Original AppleHDA in System/Extensions (Can't copy sourcefile). I also tried the same, using the root Account, using terminal with kextunload / load and even a script for clover. They all fail to modify / delete the Original AppleHDA. Trying to rename / move or delete the Original file with Terminal or Finder is not working as well, I get an Error, saying that the file cannot be modified because OS X requires it. So how can I install the Kext to get my audio working again? System is El Capitan (10.11.6)... Thank You!
  14. Ho installato mavericks su ssd, avvio super veloce tutto perfetto ma l'audio non viene rilevato, ho letto in giro di usare all'avvio la combinazione mela(in questo caso ho usato il tasto windows)+alt+p+r ma niente mi avvia osx in modalità sicura...sono senza idee... Inizialmente ero riuscito a fare tutto anche l'audio che funzionava regolarmente, ma avendo un nvidia quadro 600 volevo installare i kext, ma una vilta installati, al riavvio ho avuto un kernel panic, e ho reinstallato tutto da capo e da allora ho sto problema.. Aiutatemi non ho la più pallida idea di come risolvere questo grave problema...Grazie in Anticipo (:
  15. Eduardo Daniel

    GeForce 770 GTX HDMI Audio [Need Help]

    I would like to know how to proceed in this situation. I'm using the Clover EFI. I would like to understand what is the best solution to have the HDMI audio definitely. Some errors occurred when I tried to apply the patch and compile. Setup: Mac OS X Maverick 10.9.4 Clover EFI Bootloader GA-B75M-D3H F15 GeForce GTX 770 8GB RAM 32GB SSD ADATA 1TB HDD Xeon 1240v2
  16. I am trying to install the proper kexts for my Realtek Audio chipset however, after inserting the code in the DSDT, I get this error. I honestly don't even know how it possible to have an error because of... whatever the F*** that is! Error: http://i.imgur.com/RBtGruw.png Any help will be greatly appreciated Thanks, DerpleNerple2000
  17. Hola a toda la comunidad de InsanelyMac Vengo en busca de un poco de ayuda con mi proyecto hackintosh Poseo una Intellistation z pro 922872u con: 8G de memoria RAM Nvidea Quadro FX 4500 2 Procesadores XEON 5140 (Doble Nucleo) A la cual logre Instalarle OSX 10.8.5 (NIRESH) Sin lograr detectarme Audio y Network. El primer paso fue instalar la tarjeta de Red una BCM5752 para lo cual utilice BCM5722D.kext en su version para Mountain Lion, debido a que su actulizacion de version 2.3.1 le da soporte a mi tarjeta desde el siguiente enlace http://www.insanelymac.com/forum/files/file/79-bcm5722d/ Luego Intente instalar el sonido sin ningun tipo de exito, probando con diferentes versionde del VoodooHDA.kext VoodooHDA 0.2.1 Kernel Panic VoodooHDA 0.2.2 No detecto nada ni produjo Kernel Panic VoodooHDA 0.2.56 Kernel Panic VoodooHDA 0.2.61 Kernel Panic VoodooHDA 2.7.2 Kernel Panic VoodooHDA 2.7.2 (VT 2021) No detecto nada ni produjo Kernel Panic VoodooHDA 2.7.3 Kernel Panic VoodooHDA 2.8.2 No detecto nada ni produjo Kernel Panic VoodooHDA 2.8.4 No detecto nada ni produjo Kernel Panic Para la grafica me detecto 2 Kext AppleMCCSControl.kext IONDRVSupport.kext Apararece el nombre de la tarjeta con los 512 megas detectados, pero no estoy seguro de que me este activado la caracteristica QE/CI el monitor trabaja a una resolucion distinta a la recomendada y la imagen presenta parpadeo. ¿De que forma puedo saber si mi grafica esta activando QE/CI? Mi duda es saber si es recomendado hacerle una inyeccion a la grafica con los drivers originales cosa que intente con 10.8.3 y me dejo la pantalla con la manzana congelada. O si seria mejor utilizar una App que recien aparece en la pagina principal de InsanelyMac para actulizar el video: http://www.insanelymac.com/_/osx86/nvidia-web-driver-updater-r1048 Dejare una imagen del System Info por si alguien con experiencia puede ayudarme con los Kext, se lo agradeceria inmensamente. Gracias
  18. Hi folks, does anyone have the talent to see why Antipop doesn't seem to work in macOS Sierra Public Beta? I have used this for several previous OS X versions right up to El Capitan without issue but although it installs ok it has no effect on fixing the "pop" from the speakers if audio isn't used for a while. I have checked the log files and don't see anything like the entries present in El Capitan. AntiPop v1.0.2.dmg
  19. Juunin

    Sem audio

    Olá, recentemente instalei o el capitan em meu notebook, esta funcionando tudo bem, ja esta com a placa gráfica habilitada (intel hd 4400), mais estou sem som estou com a VoodooHDA instalada mais aparece no VodooHDA devices found, o som só funciona se dou boot usando o pendrive com clover. alguém sabe o que pode ser? Obrigado (OBS: Meu bootloader é clover)
  20. Hola a toda la comunidad! Este es mi segundo tema. ya había hecho uno sobre la instalación de El Capitan, y este es sobre Sierra. Antes que nada, quiero decirles que soy muy novato en este tema, no entiendo todavía, la gran mayoría de acciones, términos, etc. Así que espero puedan entenderme y sepan disculpar si es que esta mal ubicado el tema y demás. Bueno paso a comentarles. Primero les dejo las specs de mi PC: Micro: i5 4690k Mother: Gigabyte Z97X Gaming 3 Ram: Kingston 10GB en DDR3 a 1300Mhz VGA: GTX 970 4GB Acabo de terminar mi instalación de Sierra 10.12.5 en mi pc. Seguí la guía de RampageDev para la instalación, y se hizo sin ningún problema ni complicación. El problema por así decirlo es que al reiniciar, inicia normalmente pero no tengo audio, hice la instalación con el archivo command que se ve en la imagen... Ejecuto el command, sigo las instrucciones, me detecta el codec, lo instalo lo mas bien, me pide reiniciar, lo hago y cuando inicia, sigo sin audio, lo comprobé en el apartado Audio de las preferencias del sistema y me dice que no hay dispositivo de salida.... A todo esto cuando inicie el equipo me doy cuenta que apareció una carpeta en el escritorio con unos kexts adentro, aquí les muestro... Que tengo que hacer con esos archivos? Tengo que montar la partición EFI? (No se como se monta jejeje...) Bueno, y mi segundo problema es el video... Siguiendo la guía de Rampage como dije, en el momento de elegir el config.plist, elijo el que activa los WebDrivers. Ahora, en la pagina de Rampage hay otras guías sobre la instalación de los drivers de las VGA, pero por ningún lado veo para poder instalar los WebDrivers. Yo pensaba que al elegir el config.plist que activa estos últimos bastaba con descargar los WebDrivers, instalarlos y ya, pero no quiero hacer nada sin antes consultar, no quiero joder la instalación. Bueno, basicamente esos son mis dos problemas. Desde ya les agradezco su ayuda, muchas gracias!
  21. stevelord

    Riavvio all'accensione

    Ciao a tutti, ho un problema con l'avvio del mio Hackintosh Sierra 10.12.1 dopo l'installazione dei driver audio. prima di fare il fix dei kext audio il pc si avviava velocissimo, non caricava neanche tutta la schermata della mela che già si era avviato. ora dopo aver fixato l'audio con una guida trovata su youtube "How to Fix Audio Problems in macOS Sierra (All ALC Codec)" che devo dire è stata l'unica che mi ha risolto il problema. quando avvio il pc arriva alla schermata con la mela, partono delle scritte come se partisse in verbose ( a volte anche non lo fa) poi ci mette un bel po ad arrivare in fondo, si riavvia e rifà il boot completo partendo da spento, dopodiché si avvia e tutto parte normalmente. dopo aver inserito la password osx mi avvisa che "il pc è stato spento per dei problemi". secondo voi cosa potrebbe essere? la post installazione iniziale l'ho fatta con un prodotto della concorrenza ben noto =( ma non ero a conoscenza di questo forum italiano prima il bootloader è clover e ho fatto varie configurazioni con clover configurator. qualunque file che vi serve ve lo posto.
  22. renzo9713

    HDMI audio not working

    Hi everyone, recently I installed VoodooHDA 2.8.8 The audio input and output, is ok. But, HDMI audio doens't work. Yesterday i installed AppleHDA, but i had a problem with the audio input so i installed VoodooHDA. Someone know any patch or kext to make work the audio HDMI? My audio codec is Conexant CX20752 Thanks in advance.
  23. I recently installed iPc 10.5.6 on my HP 6530b laptop. Everything went fine, but i cant get any sound or internet what so ever. After I installed voodooHDA I managed to turn the audio up or down, and my mic worked, but no sound came out. When it comes to internet i've tried installing the broadcom kext, some Intel PRO kexts, but nothing will work. Not even plugging it into an ethernet cable works. Please help me Specs: Intel core 2 duo P8400 2,26 GHz 2GB RAM Ethernet Type 10/100/1000 Mbps Wireless Ethernet - 540 Mbps IEEE802.11n Wifi Type 802.11 n
  24. Version

    1,109 downloads

    Patched AppleHDA kext to work with alc269vc codec tested on lenovo g580 20157 edit: corrected pathmaps apply audio layout 3 and IRQ fix on dsdt (thanks to rehabman) audio layout 3: #Maintained by: RehabMan for: Laptop Patches#audio_HDEF-layout12.txt# Note: Change your layout ID if you need something different# Inject Audio infointo method label _DSM parent_label HDEF remove_entry;into device label HDEF insertbeginMethod (_DSM, 4, NotSerialized)\n{\n If (LEqual (Arg2, Zero)) { Return (Buffer() { 0x03 } ) }\n Return (Package()\n {\n "layout-id", Buffer() { 0x03, 0x00, 0x00, 0x00 },\n "hda-gfx", Buffer() { "onboard-1" },\n "PinConfigurations", Buffer() { },\n //"MaximumBootBeepVolume", 77,\n })\n}\nend; IRQ fix: #Maintained by: RehabMan for: Laptop Patches#system_IRQ.txt# This can fix non-working audio and also has an affect on HPET.## Use this if you have issues with patched AppleHDA (required on almost all laptops)# or if you have issues with HPET (restart after wake).# IRQ fixinto device name_hid PNP0000 code_regex IRQNoFlags\s\(\)\n\s+\{(\d+)\} remove_matched;into device name_hid PNP0100 code_regex IRQNoFlags\s\(\)\n\s+\{(\d+)\} remove_matched;into device name_hid PNP0B00 code_regex IRQNoFlags\s\(\)\n\s+\{(\d+)\} remove_matched;into device name_hid PNP0103 code_regex IRQNoFlags\s\(\)\n\s+\{.*\} removeall_matched;into device name_hid PNP0103 code_regex Name\s\(([^,]+),\sResourceTemplate\s\(\).*\n\s+\{((?:.|\n)*)\}\) replace_matchedbeginName (%1, ResourceTemplate()\n{\n IRQNoFlags() { 0, 8, 11, 15 }\n%2})\nend; CREDITS FOR:EMlyDinESH. Mirone,BCC9, Rehabman and others
  25. grisno

    IDT 92HD87B2/4

    Version 1.20

    1,380 downloads

    Hi people, This is a preliminary installer to activate the sound card IDT 92HD87B2/4 (111D:76D9) in MacOS. This new version of the installer does not contain AppleHDA patched Kext. To work properly, it must be installed over vanilla AppleHDA Kext. I want to thank the whole community for their efforts and content provided, because without these it would not be possible to create this installer. I would appreciate comments and suggestions!! Status: Speakers : OKHeadphones : OKHDMI Audio : OK (Intel HD3K/4K Tested)LineIn : OKMicInt : OKMicIntNoiseReduction : OKMicExt : OKAutoDetectLineIn : OKSleep : OKWakeUp : OKAutoSleep : OKHibernate : OKSiri : OK Tested Laptops: - HP Pavillion G6-2209SS - HP Probook 4440S Coming Soon: - Unified installer for the different supported operating systems Original Verbs: 00a71cf0 00a71d00 00a71ef0 00a71f4000b71c1f 00b71d10 00b71e21 00b71f0400c71c20 00c71d10 00c71ea1 00c71f0400d71c10 00d71d01 00d71e17 00d71f9000f71cf0 00f71d00 00f71ef0 00f71f4001171c30 01171d01 01171ea3 01171fd5 Modified Verbs: 00A71CF0 00A71D00 00A71EF0 00A71F4001371C40 01371D10 01371E21 01371F0400C71C20 00C71D10 00C71E81 00C71F0401471C10 01471D01 01471E17 01471F9000F71C50 00F71D00 00F71EF0 00F71F4001171C30 01171D01 01171EA0 01171F90 AppleHDAHardwareConfigDriver.kext > Info.plist <key>HDAConfigDefault</key><array><dict><key>AFGLowPowerState</key><data>AwAAAA==</data><key>Codec</key><string>IDT 92HD87B2/4</string><key>CodecID</key><integer>287143641</integer><key>ConfigData</key><data>AKcc8ACnHQAApx7wAKcfQAE3HEABNx0QATceIQE3HwQAxxwgAMcdEADHHoEAxx8EAUccEAFHHQEBRx4XAUcfkAD3HFAA9x0AAPce8AD3H0ABFxwwARcdAQEXHqABFx+Q</data><key>FuncGroup</key><integer>1</integer><key>LayoutID</key><integer>3</integer></dict></array> DSDT: Patch to apply with MaciASL in your DSDT ######################################### HDEF########################################into device label HDEF insertbeginMethod (_DSM, 4, NotSerialized)\n {\n Store (Package ()\n {\n "built-in", \n Buffer (0x04)\n {\n 0x00\n }, \n "MaximumBootBeepVolume", \n Buffer (0x04)\n {\n 0x4D\n }, \n "hda-gfx", \n Buffer (0x04)\n {\n "onboard-1"\n }, \n "layout-id", \n Buffer (0x04)\n {\n 0x03, 0x00, 0x00, 0x00\n }, \n "PinConfigurations", \n Buffer (Zero) {}\n }, Local0)\n DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))\n Return (Local0)\n }\nend;######################################### DTGP########################################into method label DTGP remove_entry;into definitionblock code_regex . insertbeginMethod (DTGP, 5, NotSerialized)\n{\n If (LEqual (Arg0, Buffer (0x10)\n {\n /* 0000 */ 0xC6, 0xB7, 0xB5, 0xA0, 0x18, 0x13, 0x1C, 0x44, \n /* 0008 */ 0xB0, 0xC9, 0xFE, 0x69, 0x5E, 0xAF, 0x94, 0x9B\n }))\n {\n If (LEqual (Arg1, One))\n {\n If (LEqual (Arg2, Zero))\n {\n Store (Buffer (One)\n {\n 0x03\n }, Arg4)\n Return (One)\n }\n If (LEqual (Arg2, One))\n {\n Return (One)\n }\n }\n }\n Store (Buffer (One)\n {\n 0x00\n }, Arg4)\n Return (Zero)\n}\nend;
×