Jump to content

Search the Community: Showing results for tags '2560x1440'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • InsanelyMac Lounge
    • Front Page News and Rumors
    • Reader News and Reviews
    • Forum Information and Feedback
  • OSx86 Project
    • New Releases and Updates
    • New Users Lounge
    • Developers Corner
    • Tutorials (The Genius Bar)
    • Technical FAQ
    • OSx86 Installation
    • Post-Installation
    • DSDT and SSDT
    • Hardware Components and Drivers
    • Complete Desktops
    • Notebooks
    • Netbooks
    • Tablets
    • MacMod of the Month
    • Multi-booting and Virtualisation
  • International
    • Your Language
    • Deutsch
    • Español
    • Français
    • Italiano
    • Português
    • Русский
  • Apple World
    • Mac OS X
    • Apple Computers and Hardware
    • iOS Devices
    • Mac Applications
    • Mac Programming and Development
    • iOS Programming and Development
    • Mac Gaming
    • Mac Accessories
  • Discuss and Learn
    • Windows Discussion
    • *nix
    • Apple Opinions and Discussion
    • The Great Debates
    • Internet(s), Servers, and Networks
    • Buying Thoughts, Reviews, and Recommendations
    • Mods and Overclocking
    • The Big Issues [Real Life]
  • Everything Else
    • Creativity
    • Thunderdome (Random Stuff)
    • Laughs
    • The Marketplace

Categories

  • Kexts
    • Graphics Cards
    • Audio
    • LAN and Wireless
    • Other
  • Kernels
  • Bootloaders
  • DSDTs
    • Patches
  • Pandora
  • Apps
  • Miscellaneous
  • Customization

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 4 results

  1. Hi, my new Dell U2515H is connected via DisplayPort to a Intel HD4600. I like this monitor very much but with the native resolution of 2560x1440 pixel system-font looks really small. So I activated HiDPI from the terminal: sudo defaults write /Library/Preferences/com.apple.windowserver.plist DisplayResolutionEnabled -bool true but with the "1280x720 HiDPI" resolution the screen is to small After a long search I found a solution - display overrides. For this I put an override-file 'DisplayProductID-d06f' with the code below to /System/Library/Displays/Contents/Resources/Overrides/DisplayVendorID-10ac/DisplayProductID-d06f <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>DisplayProductName</key> <string>Dell U2515H (HiDPI)</string> <key>DisplayVendorID</key> <integer>4268</integer> <key>DisplayProductID</key> <integer>53359</integer> <key>scale-resolutions</key> <array> <data>AAAPAAAACHAAAAAB</data> <!-- 3840x2160 to get 1920x1080 HiDPI --> <data>AAAMgAAABwgAAAAB</data> <!-- 3200x1800 to get 1600x900 HiDPI --> <data>AAALQAAABlQAAAAB</data> <!-- 2880x1620 to get 1440x810 HiDPI --> </array> </dict> </plist> The Monitor use another ProductID if it's connected to HDMI. Therefore I need another override file. To verify the ProductID, I use this from terminal: ioreg -l -w0 -d0 -r -c AppleDisplay | grep ID | grep -v IO This override has a patched EDID to support RGB color mode with HDMI (see http://embdev.net/topic/284710 for more info) <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>DisplayProductName</key> <string>Dell U2515H (HiDPI + RGB)</string> <key>IODisplayEDID</key> <data>AP///////wAQrG/QTEE0MCkZAQSlNx94JkRVqVVNnSYPUFSlSwCzANEAcU+p QIGAd4ABAQEBVl4AoKCgKVAwIDUAKTchAAAaAAAA/wBYWFhYWFhYWFhYWFgK AAAA/ABERUxMIFUyNTE1SAogAAAA/QA4Vh5xHgEKICAgICAgAKM=</data> <key>DisplayVendorID</key> <integer>4268</integer> <key>DisplayProductID</key> <integer>53360</integer> <key>scale-resolutions</key> <array> <data>AAAPAAAACHAAAAAB</data> <!-- 3840x2160 to get 1920x1080 HiDPI --> <data>AAAMgAAABwgAAAAB</data> <!-- 3200x1800 to get 1600x900 HiDPI --> <data>AAALQAAABlQAAAAB</data> <!-- 2880x1620 to get 1440x810 HiDPI --> </array> </dict> </plist> Reboot and done For easy resolution switching I wrote a command-line tool based on RetinaDisplayMenu. I put SetDisplayResolution to /usr/local/bin and use Karabiner to create the keyboard shortcuts. From my private.xml <vkopenurldef> <name>KeyCode::VK_OPEN_URL_SHELL_SetDisplayResolution_2560x1440</name> <url type="shell">/usr/local/bin/SetDisplayResolution -w 2560 -h 1440 -s 1</url> </vkopenurldef> <vkopenurldef> <name>KeyCode::VK_OPEN_URL_SHELL_SetDisplayResolution_1920x1080_HiDpi</name> <url type="shell">/usr/local/bin/SetDisplayResolution -w 1920 -h 1080 -s 2</url> </vkopenurldef> <vkopenurldef> <name>KeyCode::VK_OPEN_URL_SHELL_SetDisplayResolution_1600x900_HiDpi</name> <url type="shell">/usr/local/bin/SetDisplayResolution -w 1600 -h 900 -s 2</url> </vkopenurldef> <vkopenurldef> <name>KeyCode::VK_OPEN_URL_SHELL_SetDisplayResolution_1440x810_HiDpi</name> <url type="shell">/usr/local/bin/SetDisplayResolution -w 1440 -h 810 -s 2</url> </vkopenurldef> <vkopenurldef> <name>KeyCode::VK_OPEN_URL_SHELL_SetDisplayResolution_1280x720_HiDpi</name> <url type="shell">/usr/local/bin/SetDisplayResolution -w 1280 -h 720 -s 2</url> </vkopenurldef> <item> <name>Apple Magic Keyboard</name> <item> <name>BRIGHTNESS_DOWN+COMMAND_L to SetDisplayResolution 2560x1440</name> <identifier>apple.magic-keyboard.sdr_2560x1440</identifier> <device_only>DeviceVendor::Apple_Bluetooth, DeviceProduct::MAGIC_KEYBOARD</device_only> <autogen>__KeyToKey__ KeyCode::BRIGHTNESS_DOWN, ModifierFlag::COMMAND_L, KeyCode::VK_OPEN_URL_SHELL_SetDisplayResolution_2560x1440, Option::NOREPEAT</autogen> </item> <item> <name>BRIGHTNESS_UP+COMMAND_L to SetDisplayResolution 1920x1080 (HiDPI)</name> <identifier>apple.magic-keyboard.sdr_1920x1080_hidpi</identifier> <device_only>DeviceVendor::Apple_Bluetooth, DeviceProduct::MAGIC_KEYBOARD</device_only> <autogen>__KeyToKey__ KeyCode::BRIGHTNESS_UP, ModifierFlag::COMMAND_L, KeyCode::VK_OPEN_URL_SHELL_SetDisplayResolution_1920x1080_HiDpi, Option::NOREPEAT</autogen> </item> <item> <name>BRIGHTNESS_UP+COMMAND_L to SetDisplayResolution 1600x900 (HiDPI)</name> <identifier>apple.magic-keyboard.sdr_1600x900_hidpi</identifier> <device_only>DeviceVendor::Apple_Bluetooth, DeviceProduct::MAGIC_KEYBOARD</device_only> <autogen>__KeyToKey__ KeyCode::BRIGHTNESS_UP, ModifierFlag::COMMAND_L, KeyCode::VK_OPEN_URL_SHELL_SetDisplayResolution_1600x900_HiDpi, Option::NOREPEAT</autogen> </item> <item> <name>BRIGHTNESS_UP+COMMAND_L to SetDisplayResolution 1440x810 (HiDPI)</name> <identifier>apple.magic-keyboard.sdr_1440x810_hidpi</identifier> <device_only>DeviceVendor::Apple_Bluetooth, DeviceProduct::MAGIC_KEYBOARD</device_only> <autogen>__KeyToKey__ KeyCode::BRIGHTNESS_UP, ModifierFlag::COMMAND_L, KeyCode::VK_OPEN_URL_SHELL_SetDisplayResolution_1440x810_HiDpi, Option::NOREPEAT</autogen> </item> <item> <name>BRIGHTNESS_UP+COMMAND_L to SetDisplayResolution 1280x720 (HiDPI)</name> <identifier>apple.magic-keyboard.1280x720</identifier> <device_only>DeviceVendor::Apple_Bluetooth, DeviceProduct::MAGIC_KEYBOARD</device_only> <autogen>__KeyToKey__ KeyCode::BRIGHTNESS_UP, ModifierFlag::COMMAND_L, KeyCode::VK_OPEN_URL_SHELL_SetDisplayResolution_1280x720_HiDpi, Option::NOREPEAT</autogen> </item> </item> Have Fun! DisplayProductID-d06f.zip SetDisplayResolution.zip DisplayProductID-d070.zip
  2. Hi there Today I bought a new 27" display from Dell, the u2715h. Since my system is running with a gt8800 and I just have a dvi dual output I had to connect a hdmi adapter to a dvi d cable to connect this display. However, everything fine running this display at 2048 x 1152 @ 60 Hz but when I try to get full resolution to 2560 x 1440 @ 60 Hz I just get a black screen, the display tells me that it needs proper input, can't handle the signal. Any idea what I could try to fix this problem? Thx
  3. Hi everybody, I am currently working on getting a 2 Screen setup to work with my system. I have a recent 27" Shimian QH270 (DVI) with 2560x1440 max. and a pretty old MEDION MD7218AR (VGA) with 1280x1024 max. The very first step was to make my ports work. For this I edited my Duckweed Personality after reading Alexander Martinez' Guide, and bcc9's Thread. My first problem was I had no Windows Partition and no HDD lying around. Tried for days to get almost every Windows working on externals without luck. Then stumbled upon this Guide from rampagedev which is basically a round-up of all the others and went for the DOS way. When I was already set up to work my way through all personalities I found fffeee's Post who has exactly my card. So I thought I'd give it a try and just edit my Duckweed as he did. This is the as-is for now. My DVI Ports both work, which is what I needed. (Can't even test HDMI and DP) [ DVI-I(DL) ]✔ [ HDMI ] [ DP ] [ DVI-D(DL) ]✔ My Problem: When I connect the DVI-D Cable of the 27" to the DVI-D Port I don't get support for no-VESA resolutions (which is 2560x1440). When I connect it to the DVI-I Port, the Screen gets full resolution support. This is troublesome, since I have no chance to connect the VGA Adapter to any other port than the DVI-D. I came across this thread about VESA modes but it actually refers to the boot screen only. I did try to edit my ROM and load it with AtiROM=Yes but failed in editing I suppose since system didn't even load. My Boot.plist Custom DSDT GraphicsEnabler=Yes AtiConfig=Duckweed AtiPorts=4 GraphicsMode=2560x1440x32 My Question(s): 1) Is there anybody out there with a) experiences with similar cards + edited framebuffers + screen sizes or even with similar working setups? 2) Do you have any ideas/tips for me on what to work on to get support for the desired resolution on that port? (VESA/Framebuffer/Other?) My System: Mainboard: GA-H77-D3H (EFI F10) CPU: Intel Xeon E3-1230V2 GPU: Sapphire HD6870 1024MB (Barts XT RV940) GPU VenID: 1002 GPU DevID: 6738 GPU SubSysID: 174b OS: 10.8.3 (12D78) For further input I can post more details if necessary. Hope anybody has some ideas floating in their head. Greetings Deri~
  4. I'm trying to find out if anyone have similar setup with Dual (2) Apple LED Cinema Display MC007LL/A 27-Inch. (http://www.amazon.co....ema display 27) I would like to setup (2) Apple Cinema Displays 27" via MiniDisplayPort connection with my existing hackintosh build. Resolution should be 2560x1440 on both displays I'm looking to replace Gigabyte ATI HD 5770 1GB with a video card that can handle this setup, any advice which card(s) would work? hackintosh build GA-X58A-UD5 Core i7 950 | 16GB DDR3-1600 | Gigabyte ATI HD 5770 1GB Thanks!
×