Jump to content

Search the Community: Showing results for tags 'vm'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • InsanelyMac Lounge
    • Front Page News and Rumors
    • Reader News and Reviews
    • Forum Information and Feedback
  • OSx86 Project
    • New Releases and Updates
    • New Users Lounge
    • Developers Corner
    • Tutorials (The Genius Bar)
    • Technical FAQ
    • Installation
    • Post-Installation
    • DSDT and SSDT
    • Hardware Components and Drivers
    • Desktops
    • Notebooks
    • Netbooks
    • Tablets
    • MacMod of the Month
    • Multi-booting and Virtualisation
  • International
    • Your Language
    • Deutsch
    • Español
    • Français
    • Italiano
    • Português
    • Русский
  • Apple World
    • Mac OS X
    • Apple Computers and Hardware
    • iOS Devices
    • Mac Applications
    • Mac Programming and Development
    • iOS Programming and Development
    • Mac Gaming
    • Mac Accessories
  • Discuss and Learn
    • Windows Discussion
    • *nix
    • Apple Opinions and Discussion
    • The Great Debates
    • Internet(s), Servers, and Networks
    • Buying Thoughts, Reviews, and Recommendations
    • Mods and Overclocking
    • The Big Issues [Real Life]
  • Everything Else
    • Creativity
    • Thunderdome (Random Stuff)
    • Laughs
    • The Marketplace

Categories

  • Kexts
    • Graphics Cards
    • Audio
    • LAN and Wireless
    • Other
  • Kernels
  • Bootloaders
  • DSDTs
    • Patches
  • Pandora
  • Apps
  • Miscellaneous
  • Customization

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 10 results

  1. I'm running Ubuntu 11 and have Lion installed to a vmdk and running in VirtualBox. I have an unformatted 30gb partition that I want to move the installation to. How can I format that partition HFS+ and copy the contents of my vmdk to it? The main step is to dd something to that partition, right? A couple of caveats: I don't have a USB flash drive to help. I do have an install DVD with Chameleon on it, but it won't get further than the bootloader. But if, for now, I need it for now to actually boot from that partition, that's OK. Thanks for your wisdom!
  2. Hello all. I am new to these forums and Hackintoshes in general. I successfully installed OS X Snow Leopard using an official Snow Leopard install DVD I own and some other booting tools. I suppose I don't have an official Hackintosh in the sense that I run OS X from as a guest machine. If it helps, I use Oracle's VirtualBox. The VM runs perfectly fine. I used a combined update to update from the first version of Snow Leopard (available on the install disk) to the last/latest version of Snow Leopard. So, with that being said, is it possible to update the operating system while my guest is running without having to change things around? I'd ideally like to be running OS X Yosemite. The Yosemite OS update is available from the App Store for free right now, but I'm a little hesitant to run it at the moment. I was reading somewhere that you should only update your Hackintosh with combined updates from Apple. Any truth to this? I sincerely apologize for my ignorance. As you can tell, I'm still learning. Any help would be greatly appreciated. Thanks!
  3. Hi - been working on getting an upgrade together for my current workstation. Not having a huge budget and needing as much bang for buck I want to keep as much as possible and replace as little as possible (red goes, green stays): Asus P5Q Pro Intel P45 (Socket 775) PCI-Express DDR2 Motherboard Intel Core 2 Quad Q9550 LGA775 'Yorkfield' 2.83GHz 12MB-cache (1333FSB) Processor OCZ 4GB (2x2GB) PC2-8500C5 1066MHz Dual Channel Platinum Series DDR2 NVidia GeForce 8800 GTX Samsung 830 128 GB SSD Western Digital VelociRaptor 300GB 10000RPM SATA-II 16MB Cache - OEM 2 - Western Digital Caviar Green WD20EARS 2TB 2 - Western Digital Caviar Black 1TB SATA-II Lian-Li PC-B25B Aluminium Midi-Tower - Black (No PSU) Thermalright Ultra-120 Extreme CPU Cooler (Socket AM2/LGA775) Samsung SH-S223F/BEBE 22x DVDąRW SATA Dual Layer ReWriter (Black) - OEM Noctua NF-S12 800RPM 120mm Silent Case Fan - 3 Pin Hiper 630W HPU-4M630 SLi Certified PSU The new hardware that I am so far gravitating towards is as follows: Supermicro X9SRA Intel Xeon Processor E5-2620 2 x Kingston ValueRAM - ECC Memory - 16 GB - DIMM AMD FirePro V4900 Professional Graphics Supermicro SNK-P0050AP4 - Cooler I would use a number of VM's for development purposes (using RHEL, Windows Server for work) and then ML as my everyday machine (photo editing with Aperture, web surfing, a little video editing). With little experience on the VMware ESX side any feedback would be most appreciated; specifically around how to get sound the ALC889 working in ML - would it be possible to do iopath/passthrough with sound ? I have seen evidence of the V4900 GPU working being passed through to VM from ESX here: https://docs.google....d1alRUTlE#gid=0 and working in ML here: http://www.insanelym...00#entry1897975 Finally wireless; I am currently using a Linksys WMP300N - would passthrough be possible here. I suspect not from what I have read plus only two passthroughs are allowed per VM. Otherwise I would be going with this a WUMC710. Advice would be most appreciated.
  4. I'm not sure how right or wrong my idea is, but I have been wanting to share this with someone for ages now. It may sound crazy and impossible to some but pretty possible to others. Anyway, let this thread be open for discussion. So here is my idea: Creating a really stripped down version of Linux with just the drivers and the modules to run OS X in a virtual environment (Xen or VirtualBox). Linux would disable the need for some drivers on the system, since it would be able to simply interpret all it needs in its own way, acting as one big driver? Such a Linux setup would leave loads of resources for the guest OS to use. I will admit I am unaware of how the main OS deals with the guest OS and its request, such as sound playback, pluggable devices etc. So, would this be possible and useful, at all? Or should I forget it and carry on with my life?
  5. Dear all, I'm a proud owner of MBP (Mid 2012) 13'. Running OSX 10.9 (Maverick) with the latest version of VirtualBox (3.4.6 I think...) I've tried to setup Maverick on VB for performing tests on it but couldn't make it. I've used the App Store Maverick installation .app to make it both bootable ISO & .dmg (with & without AppleTyMCEDriver) Any time I'm booting the machine its freezing, screenshot attached. If needed, my MBP info: Any ideas whats causing this issue? or how can I solve it? Thanks in advance!
  6. Hello there! I'm trying to install High Sierra in VMware Fusion for a command line driven Vagrant box, in order to make it easier to compile applications for macOS. I actually managed to automate macOS installation entirely with PC-compatible keyboard input in https://www.packer.io/, so that's pretty cool I guess. Unfortunately, the boot after SetupAssistant fails: Trace Installing: About 15 minutes remaining ... Installing on "Macintosh HD" ... An error occurred installing macOS. To use Apple Diagnostics to check your Mac hardware, shut down, press the power button, and immediately hold the 'D' key until diagnostics begins. Quit the installer to restart your computer and try again. Restart Screenshots System Specs Guest OS: macOS 10.13 High Sierra Host OS: macOS 10.13 High Sierra Hypervisor: VMware Fusion 10 Physical hardware: mid-2013 13" MacBook Air Configuration VMX: https://gist.github.com/mcandre/df4a69809afb8103ef37ae32371c6e23 ISO generation scripts, packer configuration, and VMX settings are available as a work-in-progress "macos" branch in my packer templates repository: https://github.com/mcandre/packer-templates/tree/macos Mitigation steps attempted I've already tried: Re-generating the installer ISO image. Re-running the packer VM build. Tweaking VMX settings. Disabling SMC (which results in a VM that never finishes booting). Increasing virtual RAM to 4GB. Specifying the virtual hard drive as a solid state drive. Using VirtualBox (unfortunately, packer sends the wrong scancodes to VirtualBox for macOS guests, so packer + macOS guests + VirtualBox doesn't integrate very well at the moment). Pressing 'D' during boot (no change in behavior, no diagnostics displayed). If anyone else has experience getting macOS to boot in VMware, let me know how the VMX configuration can be improved, or if some kind of SMC toggling intervention is necessary to get the thing to boot better. I've already tossed so many hacks and workarounds into the mix that I'm starting to run out of ideas I'm new to hackintoshing, so I'm not sure if I'm missing some critical VMX configuration, or perhaps if High Sierra introduces further complications compared to earlier editions of macOS. Or even if an alternative EFI bootloader (Clover?) is necessary, I just don't know. I'd prefer to install macOS with as vanilla/default a configuration as possible. ( Also posted to Reddit just in case. https://www.reddit.com/r/hackintosh/comments/7gaebu/vmware_high_sierra_an_error_occurred_installing/ )
  7. I recently embarked on a mission to set up the fastest virtual machine possible (OS X Mavericks running on Windows 8.1). I think I'm almost there. Note: This is not at all about hardware. My mission is simply to remove all bottlenecks. Background I wanted a Hackintosh. But I have a Dell Latitude E4310 with a BCM4313, a WiFi card which is not compatible with OS X, so I set out to run the OS in a virtual machine Software I'm using VMware Workstation 10, though Player 6 will probably also work, running on Windows 8.1 x64 Hardware Dell Latitude E4310, with Intel i5 processor and Intel HD Graphics (1st generation). 4GB RAM. 150GB WD Scorpio Black 7200RPM. Initial bottlenecks & issues Disk Graphics Network RAM Bottlenecks removed Disk Network Bottlenecks almost removed Graphics RAM Process Hardware & host First off, disk. Using a virtual disk was probably the largest bottleneck in the initial setup, so I knew I had to find another way. After some searching, this has been completely solved. Here's how. Create a partition on the hard drive. Mine is 38GB. Add this physical partition to the VM Edit the VMDK file. Remove all extent descriptions except the correct partition. Remove all of the UUID stuff. At the top, change createType to "fullDevice". Here's my VMDK file: # Disk DescriptorFile version=1 encoding="windows-1252" CID=4752fba3 parentCID=ffffffff isNativeSnapshot="no" createType="fullDevice" # Extent description RW 79687680 FLAT "\\.\PhysicalDrive0" 211916800 # The Disk Data Base #DDB ddb.adapterType = "ide" ddb.geometry.biosCylinders = "1024" ddb.geometry.biosHeads = "255" ddb.geometry.biosSectors = "63" ddb.geometry.cylinders = "16383" ddb.geometry.heads = "16" ddb.geometry.sectors = "63" ddb.longContentID = "00ccb28b97ee4e6bd3d16fec4752fba3" ddb.toolsVersion = "9409" ddb.uuid = "60 00 C2 93 91 9e 74 ec-87 2e a4 eb c3 51 f9 db" ddb.virtualHWVersion = "10" Network was easier. I use NAT since Bridged didn't always work for me. There shouldn't be any issues here. RAM shouldn't be too much of an issue. Just don't run anything other than VMware. I run my VM with 2.5GB, and it seems to work okay (I can run Chrome with a few tabs while running Activity Monitor, iTerm2, and Sublime Text). Software & Guest Time for graphics. Install the latest VMware tools and the awesome VMsvga2 driver (http://sourceforge.net/projects/vmsvga2/). Big thanks to Zenith432 for that! Set the vram size to 128MB. However, VMware imposes a 128MB limit for vram. I'm trying to find a way around this. Zenith says that VMsvga allocates more video memory when needed, but OS X doesn't recognize this. Graphics performance is still a bit laggy. This is meant to be a discussion thread. Post your suggestions! Cheers, Alfred
  8. Hey guys, Previously I have a VM (on VMware Workstation 10) which runs OSX 10.8 (host is Windows 8), I've installed VMsvga2 on it and it has improved the graphics performance by quite a bit. Today I made a new VM for OSX 10.10 DP1 - it installed fine but VMsvga2 doesn't work properly on it - the desktop wallpaper will just keep flashing on and off (looks like the desktop is constantly crashing and restarting itself), Finder and other apps will just crash as well. So without VMsvga2 the performance is just terrible. Anyone know how to get VMsvga2 to work properly on DP1? Or is there another solution to improving the performance? Thanks.
  9. I'm Attempting to install ML (retail) in to a VM on ESXi vSphere 5.1 // HP Proliant Microserver N36L (AMD) but I'm having a mouse input issue. Followed the following guide, but I used the AMD kernel from the development thread: http://www.insanelym...-for-beginners/ As per the guide I used my retail ML dmg to restore to USB, installed chameleon, extracted the packages from basesystem, AMD_kernel from the AMD dev thread, FakeSMC r615 and NullCPUPowerManagement kexts. I went with iMac 10,1 for the SMBios. To run the install I extracted the USB to a dmg and uploaded it to a datastore then connected the cd drive to the dmg. VM is set for OS X 10.7 (highest it goes to, but apparently this works). I have also unlocked ESXi to run OS X on non-apple hardware (I have previously got OS X SL 10.6 running using the legacy kernel). My issue was the installer loads to the language selection menu, but with no mouse and keyboard support so I can't get any further. I have used USB Bus fix, Graphics enabler, Force 64bit, Ethernet Built in and cpus=1. (didn't work). I then started adding in kexts from my SL install with which I got a stable 10.60 install, (I did find that any tweaks on that previous system did cause it to loose mouse/keyboard input through the console and over vnc, so it seems to be pretty fussy): AppleACPIPS2Nub.kext ApplePS2Controller.kext IOAHCIBlockStorageInjector.kext IOATAFamily.kext IONetworkingFamily.kext NullCPUPowerManagement.kext TotallyFixStillWaiting.kext fakesmc.kext I then got keyboard, but no mouse input - any ideas how to get this working? Kind of important as I need to use disk utility to format the disk before install! Lastly I then tried the following as a latch ditch effort: AHCI_Extended_Injector.kext AHCIPortInjector.kext AppleAHCIPort.kext But with no success. Any insight on what to try next?
  10. I'm currently running my VM on OSX 10.8.3 and I have fully spoofed my machine as a legitimate Macbook Pro (with Chameleon Wizard), with an Applecare covered retina display serial number. I can successfully use iCloud, but when I try to use iMessage it asks me to contact apple support. If someone could help me out that would be great, thanks! I used this guide to spoof my VM.
×