Jump to content

Search the Community: Showing results for tags 'dsdt'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • InsanelyMac Lounge
    • Front Page News and Rumors
    • Reader News and Reviews
    • Forum Information and Feedback
  • OSx86 Project
    • New Releases and Updates
    • New Users Lounge
    • Developers Corner
    • Tutorials (The Genius Bar)
    • Technical FAQ
    • Installation
    • Post-Installation
    • DSDT and SSDT
    • Hardware Components and Drivers
    • Desktops
    • Notebooks
    • Netbooks
    • Tablets
    • MacMod of the Month
    • Multi-booting and Virtualisation
  • International
    • Your Language
    • Deutsch
    • Español
    • Français
    • Italiano
    • Português
    • Русский
  • Apple World
    • Mac OS X
    • Apple Computers and Hardware
    • iOS Devices
    • Mac Applications
    • Mac Programming and Development
    • iOS Programming and Development
    • Mac Gaming
    • Mac Accessories
  • Discuss and Learn
    • Windows Discussion
    • *nix
    • Apple Opinions and Discussion
    • The Great Debates
    • Internet(s), Servers, and Networks
    • Buying Thoughts, Reviews, and Recommendations
    • Mods and Overclocking
    • The Big Issues [Real Life]
  • Everything Else
    • Creativity
    • Thunderdome (Random Stuff)
    • Laughs
    • The Marketplace

Categories

  • Kexts
    • Graphics Cards
    • Audio
    • LAN and Wireless
    • Other
  • Kernels
  • Bootloaders
  • DSDTs
    • Patches
  • Pandora
  • Apps
  • Miscellaneous
  • Customization

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 270 results

  1. Hello! I've been trying to install 10.8 on my Asus N53SV-DH72 with the following specs: Intel i7-2670QM 2.2 Intel HD3000, device id 0116 NVIDIA Geforce GT 540M, device id 0DF4 Atheros AR9002WB-1NG Wireless, device id 002B Realtek PCIe GBE, device id 8168 Realtex High Definition audio, device id 0269 I created my usb following this guide. My first error loading the installer was the PowerManagement kernel panic, which I solved using myHack instead of making my usb as this reply suggested. I got further on the installer, but it stalled in the [iOBluetoothHCIController][start] -- completed part. I created my own dsdt following this guide and used the remaining extra files of this reply and I got passed the bluetooth part. After all the files are loaded all I get is a black screen. When I press fn+f8 I see what seems to be the installer, but with a lot of glitches, as you can see in this video. The mouse can be seen and moved normally though. I've tried the some boot flags like DisplayEnabler and cpus, etc. I also tried making a myHack 10.9 installer with my dsdt file, and the results were almost the same. I get stalled in the glitches of the installer GUI. Any clue? Thanks!
  2. Hello people, I have a working build and patched DSDT for my build running: GA-z97x-UD3H with latest F8 bios i7-4970K (with custom SSDT to enable PM) Angelbird SSD with native TRIM Integrated HD4600 graphics (AZUL B patch from Toleda to use HDMI properly, even HDMI audio). Integrated ALC1150 (used Toleda RealtekALC). I use both Clover and Chimera, both installed, clover as EFI only. Respective config files totally empty. With patched DSDT and SSDT (latter only to enable PM). Clover appears most stable, the only option i use in Clover is XMPDetection=Yes (to detect RAM correctly) under clover configurator and iMac 15,1 5K definition My minimal issues: I only notice ramdom bugs or kernel panic after sleep, but not always. Can you check my WAK method ? Or anything that might be causing that... Also I was not successful in renaming GFX0 to IGPU, everytime i did it I got a freeze or kernel panic at boot. Finally, I'm not sure about the OSI definitions. I don't see darwin in there. Issue 1 is the only real priority. Can you guys please take a look at my DSDT and fix anything you see isn't right ? Or advise me otherwise... Attached is my present working DSDT, SSDT (just in case you need it, but normally needs no change), and IOJones output. Cheers GA-z97x-UD3H DSDT and more.zip
  3. Heya. I got my Acer Aspire 5750-6636 up and running fairly well. I've got graphics up and running with the Macbook Pro 8,1 system description, sound's working as well, got wireless with a kext for my Atheros 9287 card, and keyboard/trackpad working. I've yet to test my mic, but in the Sound Preferences, it appears to be picking up audio. Even my function keys appear to be working. However, there are still a few outstanding issues. Sleep doesn't work. The screen goes black, I assume it begins to write a hibernate image (there's an image header error in Chameleon when I reboot), but it stops there. The screen remains black, LED indicators remain lit, etc. It stays like this until I power it off manually. I don't have the ability to adjust brightness. The screen remains on 100% brightness, which is murdering my battery. From what I can tell, these are ACPI issues. I used the DSDT editor to extract my DSDT, but I'm not really sure what to do from here. Can I get any help with this? I attached my DSDT.dsl to this post. Any help would be appreciated. Specs: Intel Core i3 2310M Built in HD Graphics 3000 4 GB DDR3-1066 RAM Atheros 9287 Wireless Adapter (PCIe) Chipset: Intel HM65 Express DSDT.dsl: http://cl.ly/3Q0h3p310g0z2D3G1h0A
  4. I have been using my hackintosh for more than a year. My hackintosh has a gigabyte p35-ds3l, Sapphire Radeon HD5770, Q6600. Running 10.7.3. In /E/E, I have following kexts: AHCIPortInjector.kext ALC8xxHDA.kext AppleHDA.kext AppleRTC.kext FakeSMC.kext HDAEnabler888.kext IOAHCIBlockStorageInjector.kext JMicron36xATA.kext So far, everything is good except following issues: 1. After system gone sleep, it can't be woken up. After the machine sleeps properly, when it is woke up by keyboard or power button, it goes to black screen directly. The power is on, fans spinning, but no output to screen. I have to shutdown the machine to bring it back. I’ve tried patching AppleRTC file, using SleepEnabler, set darkwake to 0, but none of them works (all black screen). I also disabled the onboard LAN, and replaced it with a "Presto Gigabit Ethernet Pro PCIe Card", which is supported by Apple natively, but still no help. Now I'm stucked. Any suggestion? My DSDT file is attached, which is already patched by using DSDT auto patcher (http://www.insanelymac.com/forum/index.php?showtopic=275658). 2. iStatMenu doesn't detect all sensors -- only CPU and harddrive temps. No fan speed etc (see pic attached). How do I enable them? 3. Sound: I still need ALC8xxHDA, AppleHDA, HDAEnabler888 to make my sound work. Is there any patch for DSDT to eliminate these kexts so that I can just use all vanilla kexts? dsdt.aml.zip
  5. Hello and thanks in advance for your help.. I recently installed 10.8.5 on an old Acer Aspire m5630 pc (Gigabyte/Acer EG31m motherboard upgraded to a Quad Core Xeon CPU). The install went smoothly but I'm not able to get any sound or usb 2 speeds. After searching the inter webs, I have not been able to fix either of these issues. I've attached my DSDT in hopes that someone can take a look and let me know if it good or not. I should mention that I've tried deleting AppleHPET and some other fixes that I've read on other hackintosh sites but none of them have helped with the USB issue. I was able to get audio working via VooDoo, but I found the volume was fluctuating during songs and am hoping to find a better solution. Again, thanks for any suggestions and please let me know if there's other information that would help to diagnose these issues. Tim DSDT.aml.zip
  6. After installing 10.8.2 on my computer and getting almost everything to work, I now have two issues. My AMD 7950, and sleep. Unfortunately, to get 7950 to work, I need sleep to work due to a cold boot bug which no one has been able to fix. I use a DSDT.aml.zipDSDT which is selfgenerated, and then fixed by Rampage Dev to include 7950. I also have a SSDT.aml for my 2600K, and will post it if needed. As far as I know, I have no strange kexts, but a full ls -l lsl.txt.zip is included. I boot with no switches in my bootloader.
  7. lucasR

    Disable nvidia card in DSDT

    i got a Lg a550, with a i5-3210m and an Gt 640m, i need to disable the Gt 640m so i can save battery, i extracted the ssdt and i found the OFF method in SSDT4 but i can't find any information on where to put the OFF method, so i am asking for help to do this. i really hope that anyone can help me. thanks. NVD.zip
  8. Hi! First of all thank you so much for taking the time to help me in case you do, it's something that I appreciate so much The problem that I have is that I can't find my Speakers in the Output Audio Section, and I also want to fix the sleep if it's possible. My specs: Gigabyte GA-Z170-HD3P Skylake i7 6700K (HD 530) Active graphics: AMD Radeon HD 7950 3Gb I'll leave my DSDT in a zip file, thank you! DSDT.zip
  9. EuMesmo

    Clover e sleep

    Olá, embora seja meu primeiro post no fórum já ando "rondando" por aqui algum tempo, lendo bastante coisa e testando tantas outras, mas indo ao que importa meu problema é o seguinte: Fiz o hackintosh, instalei o clover e algumas kexts (apenas duas, uma é a GenericUSBXHCI.kext e a outra é RealtekR1000SL.kext), até aí "ok" mas agora estou testando o Sleep Mode e ele não funciona 100%, digo, se eu tentar "acordar" o sistema via teclado/mouse não funciona, apenas através do botão power ou então para minha surpresa através do mouse/teclado (ou qualquer outro diapositivo) conectado na USB 3.0. Li em alguns lugares que se deve aplicar alguns patchs na DSDT para poder funcionar efetivamente, tentei aplicá-los, o de EHCI e IHC9 mas aparentemente não mudou nada, mas também não tenho certeza se estou fazendo certo. Estou deixando a DSDT sem patch algum e o config.plist do clover para se alguém puder consertar para mim, ou dar uma olhada e me dizer o que fazer. Agradeço. Archive.zip
  10. Hello folks! I've been working on this issue for a few weeks so I guess it's time to ask for your help... My Context I've got an very strange glitch on my laptop built-in display. GLITCH VIDEO: https://docs.google.com/file/d/0B9u_U2zduVk1MzhXVWh6TkdBWm8/view I believe it's not an issue on my graphic card settings since I've got full graphics in a external monitor plugged in my HDMI port. So I guessed that the EDID of built-in monitor is not being grabbed correctly. Even with EDID issues having a different behaviour, I tried overriding the display EDID with EDID grabbed from windows. Also tried FixEDID with no luck. One thing to note is that DarwinDumper output some warnings that may help: EDID block does NOT conform to EDID 1.3! Missing name descriptor Missing monitor ranges Detailed block string not properly terminated My Questions For those with more experience, this really looks like an EDID issue? If not, what else can fix this? An IMEI DSDT Patch?! My Specs Lenovo B490 - i5-3320m - H77M - HD 4000 OS X 10.10.1 Video Ports: Real Ports: 1 LVDS, 1 HDMI, 1 VGA(still disabled) and this model has no MiniDP port Using 0x01660003 1 LVDS, 1 HDMI, 2 DP My config.plist is attached EDID grabbed with DarwinDumper is attached IOReg is attached Specification of the built-in LCD: N140BGE-L22 --------------- Update #1 My conclusion so far is that this monitor has a broken EDID EEPROM. I just need to know how can I build my own EDID based on the monitor specifications... --------------- Update #2 I've also tried to create a EDID from scratch with this very nice tool: http://www.analogway.com/en/products/software-and-tools/aw-edid-editor/ The attached override was under path `/S/L/Displays/Overrides/DisplayVendorID-dae/DisplayProductID-1470`. However it was not loaded (the display name doesn't changed) and I don't know why. I've checked the file permissions and it was identical to the others overrides. --------------- Update #3 So, it's probably not an EDID issue, since the built-in display works properly when QE/CI isn't enabled. Please help... config.plist.txt ioreg.zip DisplayProductID-1470.txt DarwinDumper EDID.txt
  11. LaserFrost

    ALC892 Audio?

    I'm trying to get ALC892 audio to work on my ASUS P8Z77-V LK. I attached my DSDT, which I have tried with layout 1 and layout 4. I made the DSDT with MaciASL and patched it to my motherboard. I have also tried to use HDAEnabler1 and 4 without a DSDT, but still no avail. The AppleHDA I'm using is from this thread. The enablers I was using are also from that thread. I made sure to install with Kext Utility so permissions are correct and the kextcache is rebuilt. Is there anything else I can try? I'm sure it's possible since I had it working with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] on my previous 10.8 install. DSDT.zip
  12. Hi all I got an ASUS U41SV with a discrete NVIDIA graphics card, and I have reached a solution to disable it in OS X. Spec of the laptop CPU: Intel Core i5-2410M 2.3 GHz Memory: 8GB DDR3 1333 MHz Chipset: Intel HM65 Graphics: Intel HD3000 + NVIDIA GeForce GT540M Display: 14" 1366 x 768 Audio codec: Realtek ALC269 WiFi: Atheros 9285 OS X Configuration Niresh's distro of Yosemite A whole SSD reserved for OS X Chameleon bootloader SMBIOS: MacBookPro8,1 (13-inch, Early 2011) Updated to 10.10.1 via App Store Disabling Optimus The guide here does not fit this laptop, but after some modifications, it works on U41SV. I first extracted DSDT under Windows with AIDA64 Back to OS X, I used MaciASL to edit the DSDT extracted from Windows At the begging of the file, I added the following line: // ... DefinitionBlock ("iASLnv4Cgf.aml", "DSDT", 1, "_ASUS_", "Notebook", 0x00000000) { // the line below was added External (\_SB_.PCI0.PEG0.GFX0.SGOF, MethodObj) // ... Then I added the following method before Method (_WAK, 1, Serialized) // ... Method (M_OF, 0, NotSerialized) { If (CondRefOf (\_SB.PCI0.PEG0.GFX0._OFF)) { \_SB.PCI0.PEG0.GFX0._OFF () } If (CondRefOf (\_SB.PCI0.PEG0.GFX0._PS3)) { \_SB.PCI0.PEG0.GFX0._PS3 () } If (CondRefOf (\_SB.PCI0.PEG0.GFX0.SGOF)) { \_SB.PCI0.PEG0.GFX0.SGOF () } } // ... Then called the method M_OF in the method _WAK // ... Method (_WAK, 1, Serialized) { M_OF () // calling M_OF () WAK (Arg0) Return (Package (0x02) { Zero, Zero }) } // ... And called the method M_OF again in the method _INI // ... Scope (_SB.PCI0) { Method (_INI, 0, NotSerialized) { Store (0x07D0, OSYS) M_OF () // calling M_OF () If (CondRefOf (\_OSI, Local0)) { If (_OSI ("Linux")) { Store (0x03E8, OSYS) } // ... Finally clicked compile in MaciASL, and saved the DSDT as /Extra/DSDT.aml And now NVIDIA Optimus is disabled. Edit: HDMI output working, VGA untested, able to adjust brightness of built-in display And here is my edited DSDT. ASUS-U41SV-DSDT.aml.zip Credits Thanks to Whit3Spirit for the guide here
  13. Clemaister

    About : AMD Radeon HD6320

    Hi everyone, I finally got my HP Pavilion dm1-4136sf (AMD E-450 processor) working on Mac OSX 10.9. Now I'm trying to find some kexts to get the display working properly. The matter is that my graphic card is an AMD Radeon HD6320, and I head that for some reasons it is complicated to find kext for it. I tried the kext AMDRadeon6000.kext, but seems not to be loaded when booting according to Kext Wizard (in loaded kext interface). Does anyone has any clue ?
  14. ASUS X99-E-10G WS I76950X Request to optimize Sleep/Wake issues, CPU Power States origin.zip ioregMac Pro.zip config.plist kexts.zip
  15. TomZanna

    Post install Asus X550JX DM217T

    Sto aiutando un ragazzo ad installare High Sierra su un Asus X550JX. Le specifiche sono: i7 4720HQ GTX 950M HDD 1TB RAM 8GB Wi-Fi Atheros AR9462 AR5B22 Siamo a buon punto. Non funziona audio(forse id errato), wifi(se si riesce, so che nel 90% è un no), percentuale della batteria e bisogna disattivare la dedicata(da BIOS non è possibile). Se viene rimosso l'SSDT per disattivare la dedicata(è quello allegato nella guida di Gengik) il sistema non parte più. Se potete dare un occhio al config perché ogni tanto fa qualche glitch grafico. Grazie mille
  16. The CPU seems to have been working because the fan has not stopped. After installing Pandora can not enter the system, can see the disk, go to the screen display +++++++++++ and will restart. DSDT fix I watched the forum tutorial, no me w... I hope the master to help me very grateful DarwinDumper_3.0.3_24.04_17.46.31_MacBookPro11,1_AMI_X64_4049_Sierra_16A323_dell.7z ubuntu_DSDT-tables-.7z
  17. Hi, First, sorry for my bad english My current setup is: ArchLinux, Windows 8.1 and Mavericks 10.9.5 Chameleon svn r2578 http://www.cnet.com/products/asus-x53sj-sx148v-15-6-core-i7-2630qm-windows-7-home-premium-4-gb-ram-500-gb-hdd/specs/ Mavericks seems quite stable, i can update it via apple store with no kernel panic or broken stuff (execpt voodooHDA). i installed Fermi Nvidia Freeze fix and a kext for Atheros wifi. i have full graphics acceleration (qe/ci) with my intel HD 3000 But, there s always a But xD my battery is not detected (even with voodoo battery) i cannot set brightness only 2.4Gb of RAM accessible no cpu power managment wrong turbo boost freqs (max freq is 2.1 while it should be 2.9 and min freq should be 800) hpet causes kernel panic if enabled nvidia is not recognized Graphical glitches from time to time the most important things are the RAM, the cpu frequencies and the graphical glitches. also if possible i would like to disable intel HD and use nvidia (not sure if this is possible on a laptop) i m using a custom SSDT generated with this script: https://github.com/Piker-Alpha/ssdtPRGen.sh i don t understand ACPI language so i hope a kind person can make a DSDT for my pc. i would like to upgrade to Yosemite( Yosemite Zone 10.10.1), but only if i can fix these problems. IMPORTANT NOTE: My BIOS sucks a lot, i cannot switch gpu, UEFI/EFI is not supported and there are no options.If someone have a custom BIOS for my pc with all the options unlocked, please let me know! Let me know if you need some files from my pc. Thanks
  18. Hi guys, I am an experienced user in DSDT paching and Hackintosh in general, and in my Hack everything is running perfect. The only thing remaining to do in this Lenovo Thinkpad L420 is to fix the battery stats in order to use ACPIBatteryManager from RehabMan, but I have tried all the similar model patches to the DSDT and none makes it work. Most of them cause a kernel panic, I can do almost everything on a Hackintosh except patch an AppleHDA from scratch and writing a patch for battery stats in DSDT.. Could anyone kindly help with this? ACPI Lenovo L420.zip
  19. Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771 First... If you need DSDT edits... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Run it, post files generated in your desktop RunMe.app Installation --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/ --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/ --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/ --Replace with my Clover folder CLOVER.zip --Install Sierra/High Sierra and boot into system! Post Installation --Install Clover in HDD/SSD and replace with my folder CLOVER.zip --Reboot and activate video! -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/ -DSDT My DSDT DSDT.GA H97M-DS3P MaLd0n.zip -Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -HDEF -RTC -IRQs -SBUS -MIKEY -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -EC -PNLF -HDMI -FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek -Audio https://github.com/vit9696/AppleALC -LAN https://github.com/Mieze/IntelMausiEthernet -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders! Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others! We're all here to have fun and learn from each other! ENJOY!
  20. ggzz

    Help patch Asus S56CM

    I recently managed to install Mavericks 10.9.5 on my Asus S56CM-DH71-CA http://www.asus.com/Notebooks_Ultrabooks/S56CM/specifications/ Graphics cards: - GeForce GT 635M - Intel HD 4000 Wifi-cards: - Atheros AR9485 (Original card) - Atheros AR5B195 (AR9285) - Card I replaced it with. Audio-card: - Realtek ALC270 Chipset & CPU: - Intel HM76 Express - Intel I7-3517U Motherboard Ver: - K56CM In order to get it out of safe-mode, I deleted all the ATI, AMD, GeForce, IntelHD (except the 4000), Nvidia, kexts. I also deleted the turbo boost kext and the apple ps2 controller + élan touchpad kext. I installed a kext for the mouse and keyboard and it works. I extracted my DSDT (clean) below. Anyone have any patches for it or can help me patch it? I found some DSDTs online for Mountain Lion and the K56CM model and I used those and parts of it work (Audio did not, Wifi did not). Wifi doesn't work out of the box but works with the DSDTs I found online. Audio works with Voodoo HDA but it doesn't detect when I plug the earphones in so I have to manually switch the output from speakers to earphones. I'd prefer to have DSDTs for my model and mono. Anyone can help me? I'm really new but I read that DSTDs will help me. DSDT.dsl.zip
×