Jump to content

Search the Community: Showing results for tags '10.12'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • InsanelyMac Lounge
    • Front Page News and Rumors
    • Reader News and Reviews
    • Forum Information and Feedback
  • OSx86 Project
    • New Releases and Updates
    • New Users Lounge
    • Developers Corner
    • Tutorials (The Genius Bar)
    • Technical FAQ
    • Installation
    • Post-Installation
    • DSDT and SSDT
    • Hardware Components and Drivers
    • Desktops
    • Notebooks
    • Netbooks
    • Tablets
    • MacMod of the Month
    • Multi-booting and Virtualisation
  • International
    • Your Language
    • Deutsch
    • Español
    • Français
    • Italiano
    • Português
    • Русский
  • Apple World
    • Mac OS X
    • Apple Computers and Hardware
    • iOS Devices
    • Mac Applications
    • Mac Programming and Development
    • iOS Programming and Development
    • Mac Gaming
    • Mac Accessories
  • Discuss and Learn
    • Windows Discussion
    • *nix
    • Apple Opinions and Discussion
    • The Great Debates
    • Internet(s), Servers, and Networks
    • Buying Thoughts, Reviews, and Recommendations
    • Mods and Overclocking
    • The Big Issues [Real Life]
  • Everything Else
    • Creativity
    • Thunderdome (Random Stuff)
    • Laughs
    • The Marketplace

Categories

  • Kexts
    • Graphics Cards
    • Audio
    • LAN and Wireless
    • Other
  • Kernels
  • Bootloaders
  • DSDTs
    • Patches
  • Pandora
  • Apps
  • Miscellaneous
  • Customization

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 54 results

  1. Hey, long time no post! Apologies if this has been answered, every time I search I get a timeout on the site and I can't seem to get the search to work I've been sitting pretty with Yosemite for a while , but a recent hardware upgrade (Audio interface) means I can jump from Yosemite. I've successfully upgraded Clover, then the OS and for the most of it, it seems great. Everything works but the Graphics Driver (NVidia GeForce GTX670.) I can only boot into Mac if disable the NVIDIA drivers with the boot flag nv_disable=1 however that's not great I end up with one monitor working at 1024 x 768. I've updated the NVIDIA web drivers to the latest my build of sierra can take. I have the boot flag for web driver to be enabled (can't remember off the top of my head.. I'm on the work pc, soon to be home) Any ideas would be grateful, I spent much of last night and morning on this. Many Thanks UPDATE: I've managed to load successfully, between a combination of changing the SMBIOS to MacBook 14,2 and loading lilukext with NVIDIAgraphicsfixer. Everything is the same as Yosemite, except I do not have HDMI audio or onboard sound. I do have a dedicated audio interface so I'm not at a true loss.
  2. Hello

I installed sierra on my laptop but i cant fix a problem.
 
 HDMI dont work. if i put on, the lcd and monitor start to blink. If i close laptop and open, monitor ok but lcd stay brigness 0. i cant seee nothing. 
 I add a video for see the problem. 
 
 Thank you. 
 EDIT: 
 The problem was with the tipe of connector. It put me connector-type <00 04 00 00> but I need <00 08 00 00>. 
 Im try to patch via CLOVER but dont work ... debug_14911.zip
  3. Hi, I am rather new to the hackintosh scene. and being new I need quite a bit of help. My dilemma is that I cannot get 10.12 to boot without errors. Clover is a pain to configure for my setup. And lastly, post-installations always break the install. What I am asking for is help to get me up and running with Sierra on my rig. My specs (will add to profile sig): ASUS P8Z68-V LX Intel Core i5-2500K (SANDYBRIDGE) Integrated GPU (HD 3000) 4GB Kingston HyperX Blu Currently I am using a VGA setup but I should receive a set of DVI cables tomorrow. I would like to add that others with the same setup have gotten 10.12 Sierra working but for whatever reason I seam unable to. Thanks in advance! Regards, Mohamed
  4. Hello. Can somebody please help me with installation of the 10.12 Sierra. I tried many bottflags, kext, kext patches, read a lot of forum post, try different efi folders found on forum post, but with no success. I came close but i can not boot to install screen. I get stuck at apple logo with bar at the end (attached screen shoot is ). :wallbash: Please help. my configuration is: GA X99-UD-5 WiFi (BIOS F23), i7 5960x, Crucial Sport 32GB Ram, Kingston SSD 256 GB, PNY GTX 970. Bios at Optimized defaults. best jaka EFI.zip
  5. This Post is for helping users with issue that come with Whatevergreen Feel free to join in and help users if you know your stuff also get the dev's of whatever green to join as well Whatevergreen has a few issues Multi-monitor Support is lacking as 2 monitors seems to be the limit for some even if the devs say it's not users say it's true Some Id's are wrong or missing (hence the nano and 390X not working) some GPU names are wrong ( which has been reported many times) FOR RYZEN OWNERS with Polaris : Modified kext:/S/L/E/AMD9510Controller.kext//Contents/Info.plistfrom:<key>IOPCIMatch</key><string>0x67EF1002</string>to:<key>IOPCIMatch</key><string>0x67FF1002</string> Updating clover to Clover_v2.4k_r4152 and using the config.plist here https://pastebin.com/TYiTEVcMwithbusratio=36 and npci=0x3000 ALSO THIS THREAD IS NOT FOR WHINING in anyway please do not post off topic if you don't like given support in this forum that's all you but majority of use need it. Source code: repository. FAQ and documentation: link. a real SSDT example https://www.dropbox.com/sh/el66izg1lmk1jiu/AADCZUEjyQyiWWELlmzW2ix-a?dl=0 Credits to Pavo for the hard work of decoding the mess Boot argumentsAdd -raddbg to enable debug printing (available in DEBUG binaries).Add -radvesa to disable ATI/AMD video acceleration completely.Add -radoff to disable WhateverGreen.Add -radbeta to enable WhateverGreen on unsupported os versions (10.13 and below are enabled by default).Add -rad24 to enforce 24-bit display mode.Add -radlogo to patch boot logo distortion.Add -raddvi to enable DVI transmitter correction (required for 290X, 370, etc.)Add radpg=15 to disable several power-gating modes (see FAQ, required for 7xxx GPUs). If you Don't Want To use WEG or LILU clover 4297 has a new patch that fixes the same issues without kexts You have to set in config.plist <key>Graphics</key> <dict> <key>RadeonDeInit</key> <true/>
  6. After booting when I get to the Clover screen that displays icons for devices on which there are operating systems plus "EFI" and "Recovery" ICONS. I want "SIERRA" to be the default and system to to SIERRA without any action by me. It is not happening. EFI is the default volume/device. For Example if the Clover Screen shows ICONS for: EFI -----Sierra------ Windows 10---------- Recovery Default seems to be EFI. Even though the BOOT SECTION of config.plist lists default volume is "SIERRA". The EFI icon is highlighted when the Clover screen is displayed. I have to click the SIERRA icon if I want to boot to that drive. NOTE: "UEFI Sierra" is listed as the number one location in my BIOS setup. Also the "-v" for verbose & the "5" second timeout do not work either. Is that an indication that I am making Sierra the default volume in the wrong config.plist, IF I WANT TO CONTROL BEHAVIOR of THE CLOVER SCREEN ? I'm sure the extracts shown here are from Sierra's config.plist. Sierra>EFI>Clover>config.plist Here are 2 extracts from config.plist for SIERRA device -------------------------------------------------------------------------------------------- key>Boot</key> <dict> <key>Arguments</key> <string>dart=0 -v</string> <key>Debug</key> <true/> <key>DefaultVolume</key> <string>Sierra</string> <key>Legacy</key> <string>PBR</string> <key>Secure</key> <false/> <key>Timeout</key> <integer>5</integer> <key>XMPDetection</key> <false/> ---------------------------------------------------------------- <dict> <key>Hide</key> <array> <string>Windows</string> <string>\EFI\BOOT\BOOTX64.EFI</string> </array> <key>Language</key> <string>en:0</string> <key>Mouse</key> <dict>
  7. So i have created a mac os 10.12 install media with the --createinstallmedia command in terminal, i installed clover onto the USB plugged it into my machine, the machine has an Asus Z170A with 16gb DDR4 Memmory, a GTX 960 SSC. I have Execute disable bit and VT-d disabled, i have XHCI Handoff enabled. The installer wont boot and pauses at System Uptime in nanoseconds: xxxxxxxxx Here is a screenshot, Im not sure if this says anything or not but any help is much appreciated!
  8. Hi guys I am currently facing some problems here I got a tower with: MSI Z170A SLI PLUS board G.Skill 32GB DDR4 Memory Intel i5 6500 Overclocked to 4.51GHz Gainward GTX 1060 6GB Here is the BIOS files I am using Windows are working extremely fine here, stable temperature, no thermal throttling Ubuntu also works after disabing c-state in grub using intel_idle.max_cstate=0 I cannot seems to get macOS 10.12 working with the overclocked chip, macOS works complete fine without overclock The symptoms are the same if I didn’t add the boot argument in Linux, no USB, No hard drive, no signal output from monitor, no nothing The question is: How do I disable C State complete while CLOVER executing the EFI file? seems it's a Darwin/Unix/Linux Kernel limitation. Thanks a lot Update: Solved, see post #10
  9. I'm having a problem, when I was installed OS Sierra o my laptop Acer Aspire E5 574G the video is almost ok, just one problem that is when i open the Intellij IDEA or other IDE based on it. the screen start to flick at some points, i don't know if its related to the IDEA or related to JDK, I think is IDE because at Eclipse IDE it isn't happening. other thing is that I see one small area flickering on top left corner. System DSDT.zip
  10. Hi all, I have a Dell Optiplex 780 Desktop that I turned into a Hackintosh. Everything is okay so far, other then a few things; I cannot buy a Wifi adapter at this point in time because my router is far away from my Hackintosh and long range adapters are very expensive, far more then I want to spend. I have a MGM Electronics WiFi USB (Part number 831-3397) laying around, is it compatible with macOS Sierra? It worked on Windows 7 when it was installed. I also created my installer with a universal beast that is titled 7.0.1, and the Clover version is 3766. I have a bunch of kexts and configs that do not work well with the latest version on Clover, and when booting, sends me into a kernel panic. Is there anyway I can install 3766 to my HDD, or do I have to use a new set of configs? I used this setup: CLOVER.zip Can someone help me install Clover to my hard drive and have these files work for it? Thank you all so much in advance
  11. I updated this Xserve to 10.12.2 using the patcher tool, It worked successfully however the integrated graphics no longer work due to driver issues. I installed a low-profile Nvidia GT 210 and installed drivers for it and it works perfectly. The problem is the ATI x1300 which is integrated in the machine is acting as if the monitor is plugged into it so when I VNC or Screen share from my Macbook into it, it shows 2 screens and has major lag issues due to that. Is there anyway I can disable the ATI?? EDIT: I've found a solution for anyone looking. Either using SwitchRezX for a less permanent solution or removing the X1300 from just under the PCI-E slot where the mini DVI is found. Did the latter and it's working fine now, However if you plan on doing OS upgrades that require you to get into the boot menu you're going to have to put the old card back in and use Mini DVI.
  12. SONY VAIO FIT macOS SIERRA 10.12.3 UNDER CONSTRUCTION AGAIN. --- Sorry guys, there have been some things missing, or had been in wrong order. Because of the extrem long guide, I removed the content temporarily. Will be fixed soon.
  13. After a full week of patching DSDT and finding kexts I have an almost fully working HackBook. It is a HP Pavilion 15-an002nv. I have changed the on-board WiFi (NGFF) to a Dell DW1560, and although it has a single antenna it has excellent signal strength. The problem is that when plugging in HDMI the Built-In display goes black and I can only see on the HDMI monitor (Both displays are detected at that time and I can choose to mirror or not) Removing the HDMI cable doesn't fix the issue and I have not output until reboot. CPU: i5-6200 GPU: Intel HD520 + (DIsabled via DSDT) nVidia GT940M Build: 16D32
  14. Oi pessoal, recentemente instalei o MacOS Sierra(10.12) em um HP Probook 4430s, depois de instalar, rodei o Vietnam Hackintosh Tools e consegui instalar o wifi usando a própria placa de rede interna dele. Porém ao tentar acessar o Youtube percebi que o som não está funcionando e também testei arquivos mp3 que eu tinha e nada. Tenho um HP Probook 4530s que está rodando o El Capitan com som, tentei usar a kext de audio que eu tinha usado pra instalar o som nele, mas não funcionou, alguém sabe de alguma forma de habilitar o som no Sierra? Atenciosamente, Fábio
  15. Hi all and thanks for this forum ! I have created a VMware VM using VMware Fusion 8 on my MacBook Pro (late 2013) and then I copied it over to Proxmox with encouraging but non functionning results. Here is what I did, and how it failed. 1. Create VM (hdd 40G: disk1.vmdk) using the Mac OS X (Mavericks) recovery tools. 2. The VM boots without problem so I upgraded to Sierra and installed XCode. 3. I copied the disk to my Debian 8/Proxmox 4.3 machine but I couldn't start it. 4. After several attempts, I managed to get it to boot. 4.1 The vmdk file must first be converted from growable to pre-allocated before being copied over. 4.2 On the Proxmox host, I converted it from .vmdk to .qcow2 to support live migration on a cluster. 4.3 I installed a boot loader : enoch_rev2839_boot. 4.4 I played with the .conf file and the pve-q35.cfg file to suppress early errors in the boot process. Unfortunately, it took 30 minutes approx. for the VM to boot on a quad core i5-2410M with 8GB RAM and it kept stuck at the end of the boot process. This was on Proxmox 4.3. I migrated the VM to a quad core i5-5250U with 16GB RAM running Proxmox 4.4. Same .conf, same pve-q35.cfg, enoch_rev2839_boot. Here, it starts booting the same way : it is the Darwin - Enoch boot screen, prompting me to choose from which partition to boot : hd(0,2) (10.12) Macintosh HD hd(0,3) (10.9) Macintosh HD The first one is selected by default, so I just have to press enter. It then displays a screen with 'Proxmox' and 'Press ESC for boot menu' during a few seconds before returning to the Darwin - Enoch boot screen. In the mean time, I found it good to have both Proxmox nodes running the same version so I upgraded 4.3 to 4.4 on the host where the VM booted :-) I then realised that the boot process under 4.4 was not working but it was too late... Any help welcome as usual ! Here is my .conf (I cannot attach it). args: -device ahci,id=ide -device isa-applesmc,osk="ourhardworkbythesewordsguardedpleasedontsteal©AppleComputerInc" -smbios type=2 -readconfig /usr/share/qemu-server/pve-q35.cfg -machine q35 -kernel /etc/pve/qemu-server/enoch_rev2839_boot bootdisk: ide0 cores: 4 cpu: Penryn ide0: data:101/disk2.qcow2,size=40G ide2: none,media=cdrom memory: 4096 name: OSX net0: e1000-82545em=32:34:66:62:38:64 numa: 0 ostype: other sockets: 1 tablet: 0 vga: std
  16. Hey, so I just installed Sierra using the iAtkos SR and everything works except my Graphics... It shows that I have only 5MB Video memory.. My card is AMD Radeon R9 270. Tried different stuff when installing, like different framebuffers like Hamachi, Futomaki, Dayman, but nothing seems to be working. Tried installing extra stuff with a "AMD Radeon GPU Injector Tool" but nothing worked. The weird thing is, everything worked flawlessly on Yosemite. I even updated without problems via the AppStore, and I never did anything special for my graphics back then as far as I remember. I was running a pretty stable hackintosh on Yosemite (It was iAtkos too), but wanted to upgrade. Has someone with the same graphics card encountered this issue, and fixed it? Thank you in advance!
  17. Version 1.0

    221 downloads

    i5 5410U 4GB DDR3 - 1600Mhz 1TB hdd Not Working : Inbuilt WiFi Sleep ​Working : Everything Else. Fixed : DISPLAY : Injected patched display EDID using clover. USB : USB ports now works even after sleep with the patched kext. * I am using a cheap Usb Wifi(RT2870) which I got for $2
  18. Hi I have my laptop, which it is dell Inspiron 3521. So is there any guide on how to install mac os 10.12 on my laptop dell 3521, because I try to install by making standard USB installation but not work. Can anyone help me, please? Thanks
  19. Hello guys! Apple has released the open source Darwin code of macOS Sierra. You can download your stuff in this new (updated) Apple address: Apple Open SourceEnjoy! Click here to view the article
  20. Hello guys! Apple has released the open source Darwin code of macOS Sierra. You can download your stuff in this new (updated) Apple address: Apple Open Source Enjoy!
  21. UpwindManager

    Can't boot install USB

    Hi, Just created a Sierra USB. Boots to clover fine but get a line of plus symbols after selecting the USB in clover. Bootflags: nv_disable=1 UseKernelCache=No i5-6400 MSI B150 Nvidia GTX 960
  22. Centinho

    Installazione Sierra su Asus x556u

    Salve a tutti ragazzi, vorrei installare Sierra sul mio Asus. Potete darmi una mano per favore?
  23. Hi insanelymac friends! I had a near-perfect build with El Cap, but after I decided to update to Sierra some problems came up. Specs: i7-6700k ASUS Z170-E mobo EVGA GTX 960 And here's my config.plist With iMac17,1 SMBIOS, my display sleeps on boot. I can boot okay with nv_disable=1. I have done the AGDP patch (AGDPfix.app by shilohh). I should also note, I have two monitors connected to my GPU, one with DVI, one on DisplayPort. If I only plug in the DVI monitor and use an iMac14,2 SMBIOS, I can boot okay with NVIDIA drivers. But this doesn't work if the DP monitor is plugged in. Also, I've set BIOS graphics to PCI-E, and the new NvidiaWeb thing is set in Clover. Any suggestions are welcome!!! Thanks!
  24. midi-sama

    [GUIDE] [10.12] Sierra on Tab!

    Sierra on Tab! [DISCONTINUED] MY TAB'S MOTHERBOARD FRIED! First of all, I would like to thanks everyone on the Tablets > Samsung section for making OS X on XE700T1C possible, first from Yosemite up to El Capitan. This thread, however, is for Sierra installation, thanks to this thread (and the users there for the help), we gathered some information about our device capabilities and limitation on Sierra: What works: Everything but: What's not working/issues: PS/2 buttons (volume/rotation/Home buttons) - driver problem, needs kext edits For some: WiFi disconnections Wacom Driver (as for now, drivers for Sierra not released yet) They have been released. Intel Wifi/BT (no need to ask why, check the old threads for this device) Battery level may (most of the time) be wrong, please check HWMonitor for the real values, somehow macOS reads it wrong, and at some point it may even show "Replace Soon" (LOL). Battery may be stuck at "Charging" icon if woken up from sleep while being charged and then unplugged, to fix that, replug and unplug the charger. Before starting, neither me nor insanelymac.com is held responsible if anything goes wrong to your computer, or your cat died because you didn't feed it or a nuclear war. We are here to show you how to do stuff, you do it and take full responsibility of it. Part 1: Prepare your Computer: Before doing anything stupid, BACKUP YOUR FREAKING DATA! Don't come crying at me because you've lost your work files, notes or the secret recipe of Krusty Krab, I'll point my finger at you and laugh to my heart's content (yes, but I warned you, and as they say in arabic: 9ad a3thara man anthar قد أعذر من أنذر) YOU HAVE BEEN WARNED! For that, you can use Samsung's tool (if you still have it), Microsoft Windows' tool (under windows 8/10 > File History, or under windows 10 using one of these) or using 3rd party tools like CCC or CloneZilla (open-source and totally free, recommended, backup partitions instead of disk, will help to restore single partitions instead of erasing the whole ssd), and if you're under OS X already, use Time Machine to backup, Linux users know what to do (CloneZilla, Aptik...). UPDATE your UEFI Firmware to the latest version, using Samsung Update, don't do anything stupid, let the updater do its thing and fulfill its requirements (full battery, no running program ..). May break your device if you do anything stupid here, don't be stupid then (I just solved world stupidity, praise me!). Prepare your tools: a OS X/macOS computer/VM (deal with it) one 8GB USB (or two, second may be small for clover only, recommended, external HDDs will work too) your ATIV (duh!) your brain, you can buy one if needed (mostly black markets, watch out: illegal) optionally, external USB mouse, as the internal one doesnt have scroll feature, blame ELAN for making the USB drivers not close to PS/2 ones Other than that, prepare yourself mentally, this will be tremendously long you'll pop your eyes out, so do this on a lit room and better in the morning when you're wide-awake, thank me later for that. Make some snakes while you're at it, you'll need them. Part 2: Prepare your install - Install! On your OS X/macOS computer Download (or build) Clover from here (or build from here) Download FakeSMC.kext (choose Binaries) toledaARPT.kext (only for AR9280/5 or compatible, optional) for BCM users, refer please to the older thread, must be the same for you, thought I've read that Sierra has some problems with some BCM cards, good luck then :3 Internet is NEEDED later, and AppleALC.kext and lastly HFSPlus.efi Download PlistEditor (google) Download macOS Sierra from the AppStore (by now the final release should be already published) Open Disk Utility and plug your USB stick. Select Erase > Name it whatever you want > Format: Mac OS Extended (Journaled) > Scheme : GUID Partition Table (GPT) > ERASE!!! You better have already saved what was there lol Select then Partition > hit + > Make a Clover partition of 500MB MS-DOS (FAT) partition and the rest Installer partition with Mac OS Extended (Journaled) Apply Note 1: for smartasses saying "Why GPT, why not MBR?", A: for some reason El Capitan/Sierra Disk Utility wouldn't let me partition it later on, I don't know what's going on, but only GPT partitioning was permitted, somebody please confirm/fix this. Thanks. Note 2: for smartasses saying "Why did you make a Clover partition instead of using the existing EFI partition from the GPT formatting", A: having a partition to automount is better than mounting a hidden one each time! Thou art done with Disk Utility, Thou shalt close it! Install Clover on the CLOVER (well fat partitions are renamed with capital letters) partition LEAVE only these folders/files from CLOVER folder: ACPI drivers64UEFI kexts > Other misc ROM themes tools CLOVERX64.EFI Copy the kexts from 2. in Other folder under kexts. Copy HFSPlus.efi under driver64uefi and remove VBoxHFS.efi Download this config.plist (credits @rehabman, also, right click on the link > Save Link As ... > and make sure it ends with .plist NOT .txt, if it doesn't, change the Format under it to All Files, and remove .txt) Open it with PlistEditor (haha, aint spoilin') Save and rename it to config.plist then replace CLOVER > EFI > CLOVER > config.plist with this new one. Open Terminal (I use iTerm, better): run this sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --applicationpath /Applications/Install\ macOS\ Sierra.app --volume /Volumes/Installer Sip some tea, or watch whatever you like (huhuhuuhhuuh), it will take a while (unless you're one of those plebs with ULTRA FAST WHATEVER WHATEVER usb keys) Once done, close terminal, you're ready to rock! On your ATIV! (the exciting part) Boot to your Firmware Setup (aka BIOS Setup, but the name before is the correct one), by using ONE of these methods: Power off > Press and hold Windows button under the screen > Power On > Once you see the SAMSUNG logo, release the Windows Button > TADAA! Power off > Press and hold Volume Down button > Power On > Choose "Enter Setup" > TADAA! Power off > Press repeatedly F2 > Power On [keep pressing] > TADAA! Power off > Press repeatedly F10 > Power On [keep pressing] > Choose "Enter Setup" > TADAA! If you're on windows already: Method 1 Plug a keyboard (dock or usb keyboard) Click on the power off icon (in the charm bar in win 8.x, in Start in win 10) Hover on Reboot Hold Shift while clicking on reboot You should see "Please Wait" Method 2 Open Settings Go to Updates and Recovery (win 8.x) or Update and Security (win 10) Go to Recovery Select Advanced Startup It should start the Advanced menu while showing "Please Wait" Once done, go to Troubleshoot > Advanced Options > UEFI Firmware Settings TADAA! If you have GRUB2 UEFI> Select System Setup > TADAA! Once in, do these changes: Advanced > Fast BIOS Mode OFF USB S3 Wake-up OFF (you can make it ON, but will drain battery as the dock will stay ON and may also be annoying and has an effect on sleep) AHCI Mode Control Auto Boot > BIOS Adaptive Brightness ON/OFF depending on choice (ON to help your eyes at night) Secure Boot OFF OS Mode Selection UEFI OS Plug your USB key, hit Save, and furiously keep pressing F10 Now you'll see your USB drive in the BOOT menu, select it, and Clover will start up Start up macOS Installer (eat a sandwich meanwhile, unless you have those SUPER ULTRA FAST WHATEVER usb keys!) Open Disk Utility At this point you can still back up and start saving up your files! LAST WARNING! Erase your WHOLE SSD (remember that I told you to save your stuff? Now you know why!) To this point, YOU. ARE. DONE. Close and Install macOS Note 1: You'll see it stuck at "One second left" for more than one second (lol), wait until it reboots. Note 2: If your tablet rebooted after the 1st phase but didnt start the USB key automatically, open the BOOT menu and run clover and start up the Installer, it will resume the Install as it should Note 3: I forgot to mention this, but you should have common sense without me telling that to you, PLUG YER CHARGER! Once done, we'll get to the next step. Part 3: Configure and Fix up your install Congratulations, you've successfully installed macOS Sierra on your Tab, you can clap now! For now, it's all about your IQ level (hope you have 3 digits, and you should if you made it up to here). Now, finish up your install and first boot, and make sure you're connected to the internet (Internal Wi-Fi, Bluetooth, USB Dongles... I dont care, deal with it, or you may just do Copy-Pasta from another computer, but that wont help for DSDT, for people experienced in OSx86, you know what you can do if you dont have internet). Once on your desktop, test the audio: Go to System Preferences Go to Sound Check if you see an Output device, if yes then proceed, if not, reboot again, if still not: Check your config.plist > Devices > Audio > Inject : 6 Check the kext AppleALC is under kexts > Other and no other folder under kexts but Other. Power off and boot the device up (cold boot) Select "Play feedback when volume is changed Change the volume using the keyboard keys, the buttons on the side wont work (lack of PS/2 drivers) Check TRIM: Hold Alt and click on the Apple menu > System Information Select SATA/SATA Express Select your drive Check TRIM Support : Yes in the description IF NOT: Open terminal Type sudo trimforce enable Accept and confirm Wait until the computer reboots (it will take a while, no worries) SIP and add "Anywhere" to open any app Disabling SIP Reboot to recovery Open terminal Type in: csrutil disable Reboot Enable "Anywhere" under Security and Privacy to allow foreign/unsigned apps Open terminal Type in: sudo spctl --master-disable Done Clover Open terminal and type: diskutil mount disk0s1 Copy the EFI folder in the USB to the EFI partition, so you'll get a EFI folder inside EFI partiton Make a folder named BOOT under folder EFI (so EFI > EFI > BOOT), copy CLOVERX64.EFI from CLOVER folder to it, rename it then (in BOOT folder) to BOOTX64.EFI You'll be able to boot Clover from your SSD UPDD Rewind If you want to buy the UPDD software with the gestures and other stuff, head to http://touch-base.com/and order your software for $171.00 or 133.00 Euros (if you're a superrich pleb!). This software will then be updated and supervised by Touch-Base. If you're broke and want a free (but annoying alternative) follow this: If you want UPDD to control Wacom digitizer and you dont mind recalibrating it each time, download ONE of these: Digitizer ignores pen proximity (no hover) LINK Digitizer reacts to pen proximity (hover) LINK Q: Why do I have to recalibrate the pen after each reinstall? A: Because this driver was made initially for Samsung Slate 7 (the father of our Tab 7) and it had only HD screen (not like our FHD one) and so, when you move the pen over the screen it only reacts to the "HD" resolution portion of the screen. This is what I think, correct me if I'm wrong. if you only want touch with UPDD and want to wait until Wacom releases its driver LINK (this is the driver used by Surface 1 and possibly 2 too) - RECOMMENDED! Now either way, you have to use some of these tools (made by Automator, not some fancy coding or anything): Download this file containing the tools: RE:UPDD (huhuhuhuh) (thanks to @thanh for UPDDrewind) Extract them and throw them in Applications folder Mount the UPDD dmg, throw the installer under /Library/ Run re-updd and let it do its thing (confirm and type your password when asked) Notes: Please go to Part 4 > 7, below before running UPDDrewind After each reboot (under less than 24 hours from the time of the install) run UPDDrewind, you can add it to autorun at boot by adding it to the list in System Preferences > Users and groups > Your Username > Login items After each 24 hours of usage, run re-updd, it will reinstall and ask to run the driver program Reboot (now it should boot from your SSD) DSDT TIME On Clover menu, hit F4, then boot normally Once on the desktop, open MaciASL Copy patched folder from CLOVER > EFI > CLOVER > ACPI > patched to your Desktop Copy DSDT.aml and SSDT-0.aml (check that SSDT-0 is SataTabl, how? open it with MaciASL and look for OEM Table ID, id it's not, look into all your SSDTs and get the correct one) to a new directory on your desktop name it patched Open DSDT.aml Go to MaciASL > Preferences > Source > + Name: RehabMan repo URL: http://raw.github.com/RehabMan/Laptop-DSDT-Patch/master Note: You may remove the others, you're free to choose. iASL > ACPI Specifications : 5.1 Close the Preferences and go to the Patch menu, apply these: [bat] Samsung Ativ Book 7 [igpu] Rename GFX0 to IGPU [syn] Fix _PLD Buffer/Package Error [syn] Fix *pnp/pnp lower case Error [usb] 7-series/8-series USB [usb] USB3 _PWR 0x0D (instant wake) For AR9285 only: [wifi] AR9285 WiFi RP02-PXSX : change RP02 in the 5th line to RP01 Download this patch file, click on Open in MaciASL's patch window, select Patch.txt and apply it. Save your DSDT Open terminal and copy this (everything): curl -o ~/ssdtPRGen.sh https://raw.githubusercontent.com/Piker-Alpha/ssdtPRGen.sh/Beta/ssdtPRGen.sh && \ chmod +x ~/ssdtPRGen.sh && \ sh ~/ssdtPRGen.sh && \ diskutil mount /dev/disk0s1 && \ cp ~/Library/ssdtPRGen/ssdt.aml /Volumes/EFI/EFI/CLOVER/ACPI/patched/ && \ cp ~/Desktop/patched/* /Volumes/EFI/EFI/CLOVER/ACPI/patched/ && \ echo "All done." Hit enter and reboot Download these kexts (extract them if needed) and put them in Clover > kext > Other (mount your EFI volume using diskutil mount disk0s1): ACPIBacklight: https://bitbucket.org/RehabMan/os-x-acpi-backlight/downloads ACPIBatteryManager: https://bitbucket.org/RehabMan/os-x-acpi-battery-driver/downloads VoodooPS2Controller: https://bitbucket.org/RehabMan/os-x-voodoo-ps2-controller/downloads Reboot. Part 4: Extras and level up your macOStouch experience: Congrats again! Now you have a fully functional macOS tablet ... not yet! Why? Cuz it sux! like really! Just try it! Well then, to make it "suck less", we need to fix a number of things (HiDPI -cuz 1080p is ultra smoll-, LaunchPad size and UPDD Gestures fixes/enhancements, also wacom and 3G). ALL THESE ARE OPTIONAL, so: HiDPI Fix Open terminal and type: sudo defaults write /Library/Preferences/com.apple.windowserver.plist DisplayResolutionEnabled -bool true Install and go to Unknown Monitor > Custom Resolutions > + > Scaled Resolution (on top): Here you can add any "Scaled" resolution. I recommend 1366x768 HiDPI resolution, so I add a scaled resolution of 2732x1536 as in a retina display resolution (1366*2 and 768*2) If you want a HiDPI resolution, get the width and heigh, multiply each by two, add it to SwitchResX. Click on Display (on top bar) and hit Write System settings, then File > Save Settings. Reboot LaunchPad 6x3 icons setting: Open terminal and type: defaults write com.apple.dock springboard-rows -int 3; defaults write com.apple.dock springboard-columns -int 6; defaults write com.apple.dock ResetLaunchPad -bool TRUE;killall Dock Result: For UPDD Guestures: Get my configuration here: UPDD Settings You can still use yours, and open UPDD Gestures > Settings Note: Do not put it on full screen, you'll need to force quit it to use it again (then run UPDDrewind) Wacom: Go to Wacom Drivers webpage Select Bamboo under "All" and download its driver Install Reboot For 3G I didn't test/try, you can always check the Yosemite/El Capitan thread in #1 or #20 for instructions and STARTING from #258 onward to get the new drivers and stuff. WIP Annoying Firewire Update Open terminal and type: softwareupdate --ignore ThunderboltFirmwareUpdate1.2 Configure re-UPDD and UPDDrewind re-UPDD: to run it without typing your password (may reveal your password explicitly to anyone knowing how to use Automator) Open Automator > Open > re-updd.app (or drag-n-drop re-updd on Automator) Go to "Run Applescript" part add password *PUT_YER_PASSWORD_HERE* after administrator privileges Hit the Hammer button above the box to check the syntax Save UPDDrewind: Open it with Script Editor Change INSERT_PASSWORD_HERE by your mac password (leave the quotes) Go to File > Export > File Format: Application Check Run-only Save Now your password wont be explicitly shown for this application, because we made it to run only, no edition/viewing is permitted afterwards. Delete the source UPDDrewind (if you save it somewhere else) KeyUP: download and throw in Applications Brightness: Download: http://bergdesign.com/brightness/#download Throw it in Applications If you're using black theme in macOS, right click on the app > Show Contents > Contents > Resources Rename: display_icon.png > display_icon_black.png display_icon_white.png > display_icon.png Close and reopen the app. CodecCommander: Check the posts under this one You're done!! You can celebrate your intelligence now! What's still needs to work on: Though we did all that, there are still parts that wouldn't just work right: Make UPDDrewind run when it detects that UPDD Gestures is ran An app to combine both re-updd and UPDDrewind, as they are just scripts and still needs refining (or just one AppleScript for password reasons) 3G/SIM card driver (I just didnt test, still, I'm putting it here) Fix the battery percentage, as I found that HWMonitor gives a precise percentage, like I have 98% in HWmonitor while the OS reports 100%, 96% in HWmonitor while OS reports 98% (they align at 50% and they diverge again) 100click/24hours for UPDD Driver (meh! but it's annoying to reinstall each time) VoodooPS2 driver configuration Microphone may stop working in the middle of work. Workaround: use your headphone with microphone or do a sleep-wake cycle. These are not in any given order, and they all matter to the smooth work on our devices. Credits: I would like to give to everyone who has done some work to get this device work: @Rehabman for drivers and DSDT patches @Apple for the SW @HWmonitor team for HWmonitor and FakeSMC and other drivers @everyone in Tablets Forum for every piece of information and work, especially in these threads: Yos/ElC 10.12 report First thread for XE700T1C @anyone I forgot to mention (PM me to add you here, you deserve it) Thank you all Guys, if anything is wrong, just report it, I'll fix it ASAP, thanks
  25. E' stata rilasciata la versione pubblica 10.12.1
×