Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

khalednabil

Members
  • Content count

    4
  • Joined

  • Last visited

About khalednabil

  • Rank
    InsanelyMac Protégé
  1. [GUIDE] Thinkpad T420 with (Mountain) Lion

    Now I am having a fully functional hackintosh on my T420 (4180-AH4) using the attached DSDT, you may check it out. dsdt.tar
  2. [GUIDE] Thinkpad T420 with (Mountain) Lion

    I have already tried yours and it didn't work for me, got me a black screen after booting, maybe you can try the DSDT i posted earlier, but still I am having some troubles about it, always get a self assigned IP and static IPs are not working
  3. [GUIDE] Thinkpad T420 with (Mountain) Lion

    Hi Ludacrisvp, You can check this URL: http://www.tonymacx86.com/viewtopic.php?f=15&t=28851&sid=226821bbd11d66837a0f00229b33ce1c for more details about your issue. It seems we both have the same configuration, I passed through this step, and used an already modified dsdt (in the above post) but causing another issues I would prefer if you can patch yours to include the dual link fix, and please report back if it's working with you
  4. [GUIDE] Thinkpad T420 with (Mountain) Lion

    Hello, I have Lenovo T420 "4180-AH4" with the following specifications: - Intel ® Core™ i5-2520 M - Only Integrated HD 3000 "0x0126" - Ram DDR3 4GB - Intel 82579LM Gigabyte Network Connection I managed in installing Lion (10.7 - Then updated with Combo update 10.7.2) on my external HDD WS "250 GB" formatted in MBR. When I have used the attaced DSDT file in the initial post and it cause the screen to be black after the booting "Dual Link-Backlight" as described in the link below , but I think network was working fine, so I used a patched DSDT file found on the internet and now display is working fine but with these issues - Enthernet is now connecting but fail to obtain intenet connectivity "DHCP-Manaually" - EthernetbuildIn used in start up - Kext AppleIntelE1000 - The battery/AC is not recognizable by the system http://www.tonymacx8...a0f00229b33ce1c Also I am having another trouble installed XCode, it says you have to upgrade to Mac OS 10.6.6, Altough "About Mac" says that I have version 10.7.2 I have tried to edit the DSDT file but I am not that experienced enough to do so (, so if someone can help me about it, that would be GREAT. The used files are attached, I need to compine the two 2 DSDT files, so I can use the one in the initial post but contains the fix for dual link as described in the above link. Thanks a lot. DSDT.zip
×