Jump to content

winning0308

Members
  • Content count

    14
  • Joined

  • Last visited

About winning0308

  • Rank
    InsanelyMac Protégé

Profile Information

  • Gender
    Male
  • Location
    Vietnam
  1. winning0308

    Lenovo ThinkPad T420 with UEFI Only

    Go to this thread and download OS X 10.10 Install USB.raw file, then use a tool named SUSE Studio ImageWriter to wirte .raw file to USB, if you use Windows 8 or Windows 10, you can read the EFI partition on bootable USB then replace EFI folder on USB with EFI folder by @tluck.
  2. winning0308

    Lenovo ThinkPad T420 with UEFI Only

    @tluck: wow, now the sound work perfectly after I reinstall Yosemite and do all your guides step-by-step. I really appreciated your help Have a nice weekend! P/S: This is my result minhnts-MacBook-Pro:MacOS minhnt$ kextstat |grep HDA 90 2 0xffffff7f81dad000 0xf000 0xf000 com.apple.iokit.IOHDAFamily (266.5) <5 4 3 1> 91 1 0xffffff7f81dbc000 0x1a000 0x1a000 com.apple.driver.AppleHDAController (266.5) <90 68 12 7 6 5 4 3 1> 103 0 0xffffff7f81ede000 0xa7000 0xa7000 com.apple.driver.AppleHDA (999.99) <102 100 91 90 70 68 42 6 5 4 3 1>
  3. winning0308

    Lenovo ThinkPad T420 with UEFI Only

    Thank you for giving me a hand. I will try then report back
  4. winning0308

    Lenovo ThinkPad T420 with UEFI Only

    Could anyone pls guide me how to get sound working on T420 withe Yosemite, everything on my Hackintosh works well except sound, I followed the @tluck tutorial but the sound still doesn't work. Thanks!
  5. winning0308

    Lenovo ThinkPad T420 with UEFI Only

    Nothing change after I installed new Clover bootloader, the sound still no working. I tried to replace all files in AppleHDA.kext content with appropriate files in Utilities/HDA folder (attached by @tluck), then install new AppleHDA kext files with Kext Utility app but no result.
  6. winning0308

    Lenovo ThinkPad T420 with UEFI Only

    My current Clover is v2.3k_r3259, I installed Clover on my OS X partition and then copy EFI folder to EFI partition (mounted by Clover Configurator), I also renamed config.1366x768.list (my LCD is 1366x768) and coppied it to 2 above EFI/CLOVER folders. Do I need to reinstall Clover_v2.3k_r3261.pkg.zip?
  7. winning0308

    Lenovo ThinkPad T420 with UEFI Only

    I've installed Clover Configurator and in Kernel and Kexts Patches it show only Apple RTC patched.
  8. winning0308

    Lenovo ThinkPad T420 with UEFI Only

    Here is system.log file, still don't have sound. Thank you very much for helping me! system.log.zip
  9. winning0308

    Lenovo ThinkPad T420 with UEFI Only

    I have already coppied the config.plist from your attached's zip and pasted in EFI's Clover partition, but in Utilities folder there is a folder named HDA and I donno how to run _install-hda.bash file to patched HDA
  10. winning0308

    Lenovo ThinkPad T420 with UEFI Only

    nothing happened when I manually try to load kext by command. here is information with minhnts-MacBook-Pro:~ minhnt$ kextstat|grep HDA 80 2 0xffffff7f81e32000 0xf000 0xf000 com.apple.iokit.IOHDAFamily (266.5) <5 4 3 1> 81 1 0xffffff7f81e41000 0x1a000 0x1a000 com.apple.driver.AppleHDAController (266.5) <80 68 12 7 6 5 4 3 1> 106 0 0xffffff7f820a4000 0xa7000 0xa7000 com.apple.driver.AppleHDA (999.99) <105 103 82 81 80 68 42 6 5 4 3 1> system.log.zip
  11. winning0308

    Lenovo ThinkPad T420 with UEFI Only

    Thanks for your reply, I tried all command in Terminal, reboot (without kext caches) but the sound still doesn't work
  12. winning0308

    Lenovo ThinkPad T420 with UEFI Only

    Wow, I've have installed successfully Yosemite dual boot with Windows 10 on my T420, . But the sound doesn't work, I've installed AppleHDA_20672.kext both in S/L/E and L/E but no luck. And I also don't know how to run _install-hda.bash files in Utilities/HDA to patch HDA (I've tried to open Terminal then drag that file to terminal's window but nothing happend, can any one show me? Thanks!
  13. winning0308

    Lenovo ThinkPad T420 with UEFI Only

    First of all, thank you for your very useful and detail guide. I have installed successful Yosemite on my T420 laptop, but I was failed to make dual boot Windows 10 and Yosemite on my HDD (I have 1 drive and split it to 2 GUID Partition Table, one for Yosemite and one for Windows 10). This is all my steps when installing Yosemite and Windows 10: 1) Making an Yosemite bootable USB Installer 2) Setup UEFI booting settings in my ThinkPad Setup as your guide: - Set Config / Serial ATA (SATA) / SATA = AHCI - Set Security / Memory Protection / Execution Prevention = Enabled - Other settings set to their default. 3) Boot with USB installer and use Disk Utility to split my HDD to 2 GUID Partition Table, 1st partition format with Mac OS Extended (Journale), 2nd partition format with MSDOS FAT. 4) Install Yosemite. 5) After install Yosemite, I boooted to OS X and install Clover to Yosemite partition. 6) Install Windows 10 to 2nd partition. 7) After install Windows 10, I restart laptop but on Bootloader screen the Clover only show Yosemite partition so I cannot choose Windows 10 to boot up. Please help me, thanks!
  14. Here is my dsdt on HP Pavilion g6 1104TX, i'm using Mac OS X Lion 10.7.2 and I've no problem with sleeping. I hope it can help you Regards hp-g6-1104tx-v0.3.aml.zip hp-g6-1104tx-v0.3.dsl.zip
×