Jump to content

MacintoshHealer

Members
  • Content Count

    32
  • Joined

  • Last visited

About MacintoshHealer

  • Rank
    InsanelyMac Protégé

Recent Profile Visitors

1,883 profile views
  1. MacintoshHealer

    Ozmosis

    What kind of mobo do you use? It did work for me on the MSI Z87I AC but not on the AsRock Z87 Extreme9 On the Asrock I am getting the same black screen so I suppose that the OsxAptioFix2Drv is not the right one for this mobo. When you are using clover, you can easily choose which OsxAptioFix to use with your mobo until you find the one which is working but with ozmosis its little bit more complicated for the moment. So my question to uglyJoe and cecekpawon, is it possible to modify/create all the other OsxAptioFix drivers so we can choose the right one for our mobo? For example the OsxAptioFix2Drv-free2000 I would like to try... Thanks
  2. MacintoshHealer

    Ozmosis

    Ok, reading the previous posts helps ;-) Thanks to uglyJoe Ozmosis mod and the OsxAptioFix2Drv I could boot Mojave 10.14.5 on the Intel HD4600! I am very happy about this and very grateful to uglyJoe and cecekpawon! Thanks a lot for your work!!!
  3. MacintoshHealer

    Ozmosis

    I managed to boot Mojave 10.14.4 without Darboot with this Ozmosis release, but I had to disable Intel HD4600 and use a discrete graphics. Otherwise I have black screen straight on. Do you have any hints for me for using Intel HD 4600? I have no graphics injection in ozmosis, everything is done with the DSDT. Same DSDT works with clover with no need of injection or patches to boot Mojave 10.14.4
  4. MacintoshHealer

    Ozmosis

    I think that you know what beta I am speaking about... https://www.hackintosh-forum.de/forum/thread/37862-macos-mojave-ozmosis-beta-oz167x-xmax/?pageNo=1
  5. MacintoshHealer

    Decompiled original Apple DSDTs

    I am looking for an ACPI/IOReg dump of a iMac19,1... someone have it here?
  6. MacintoshHealer

    Ozmosis

    With the latest Ozmosis Beta, do we still need DarBoot in order to start Mojave 10.14.4 ? Or is the KernextPatcher enough?
  7. Do you know if your card's vBIOS is UEFI capable one? did you try to boot your hackintosh in UEFI only fastboot mode with video GOP support?
  8. Hello Friends! Here comes a step by step guide how to make an Intel NUC 100% Vanilla with the help of Ozmosis. This guide will cover the 1st and 2nd generation of Intel NUC (Ivy Bridge and Haswell) as I have successfully tested it on these machines, but it might work on newer NUCs as well although I have not tested it! I was often asked to write a tutorial and as I am quite busy, to make this guide possible, i will split this guide in general steps and publish one step at time. So here we go... 1: Extracting and flashing the ROM file with an SPI programmer and clips 2: Preparing the BIOS: Unlocking the MSR 0xE2 and making space for Ozmosis and kexts 3: Injecting Ozmosis and kexts with the help of OZMTool 4: Extracting, patching and injecting DSDT and SSDTs using UEFITool, OZMTool and MaciASL 5: Configuring Ozmosis by editing the OzmosisDefaults.plist 6: Setting up UEFI for UEFI only boot, compatibility and speed 7: Installation of OS X 10.8-10.11 and post installation + tweaking
  9. MacintoshHealer

    Ozmosis

    It is not complicated, i did it on Ivy Bridge NUC. First i read the rom with a clips and spi programmer, than I injected my DSDT and Ozmosis with OZMtool inside the rom. Than i flashed it back with SPI programmer + clips. Do you want my rom file to see what is inside? It is for the i3 NUC Only problem is that sometimes it does not power off correctly and the sleep works not always. Once a while (once in a month or two) i have to reset the nv-ram by pulling out the battery because it will not boot at all - not even video output. Otherwise it is great!
  10. MacintoshHealer

    Ozmosis

    I have used a clips, but if i had an IR station or a good hot air soldering gun i would desolder it. My clips is little bit tricky, you have to press it all the time against the chip to ensure good contact.
  11. MacintoshHealer

    Ozmosis

    Actually i have ozmosis running on Intel NUC so the problem was more how to get modified BIOS into Intel MoBo.... I used a flash programmer to read the BIOS and to flash it back and it works!
  12. MacintoshHealer

    IntelMausiEthernet.kext for Intel onboard LAN

    Yeah, the error was located inside of the plugin folder of my IONetworkingFamily.kext... there was still a copy of your IntelMausi V2 kext! Oops... Now V1 loads too ;-) Curiously and thanks God the new V2 kext did load first, otherwise i would be still searching the problem Big thank for making v2 working under ML, you are doing great work - keep on going!
  13. MacintoshHealer

    IntelMausiEthernet.kext for Intel onboard LAN

    Great, v2 is loading! I am very happy! Thank you! Edit: Interesting is that the v1 from your new sources is still not loading with the same error as before (and i am sure that 10.8 is selected everywhere where it needs to) But since i want to use v2 it does not matter for me. Just for curiosity, could you build a v1 for 10.8 from this new sources and post it here or send it to me so i can test if it loads?
  14. MacintoshHealer

    IntelMausiEthernet.kext for Intel onboard LAN

    Hello Mieze I do get the same error with v1 build Jul 11 00:14:01 localhost com.apple.kextd[12]: Load com.insanelymac.IntelMausiEthernet failed; removing personalities from kernel. Jul 11 00:14:01 localhost kernel[0]: kxld[com.insanelymac.IntelMausiEthernet]: The super class vtable '__ZTV20IOEthernetController' for vtable '__ZTV10IntelMausi' is out of date. Make sure your kext has been built against the correct headers. Jul 11 00:14:01 localhost kernel[0]: Can't load kext com.insanelymac.IntelMausiEthernet - link failed. Jul 11 00:14:01 localhost kernel[0]: Failed to load executable for kext com.insanelymac.IntelMausiEthernet. Jul 11 00:14:01 localhost kernel[0]: Kext com.insanelymac.IntelMausiEthernet failed to load (0xdc008016). Jul 11 00:14:01 localhost kernel[0]: Failed to load kext com.insanelymac.IntelMausiEthernet (error 0xdc008016). Jul 11 00:14:01 localhost kernel[0]: Previous Shutdown Cause: 5 I build with Xcode 5.1.1 and I selected 10.8 for Base SDK and for deployment target for every kext and also for the main project. i can send you screenshots of my Xcode settings if you like, i dont think that this is the problem. I have some programming knowledge/skills, if you explain me where to find the right headers i could try to build against that ones suitable for ML. Would it be enough to exchange some headers with the ones for 10.8 or does your source code also need some adoption to these older headers as well?
  15. MacintoshHealer

    IntelMausiEthernet.kext for Intel onboard LAN

    Hi Mieze can you help me please, i build your kext for 10.8 following yours instructions in the first page but neither v1 nor v2 loads. here is the kernel log output concerning the kext. I can send you full kernel log if you want. Jul 10 15:57:27 localhost kernel[0]: kxld[com.insanelymac.IntelMausiEthernet]: The super class vtable '__ZTV20IOEthernetController' for vtable '__ZTV10IntelMausi' is out of date. Make sure your kext has been built against the correct headers. Jul 10 15:57:27 localhost kernel[0]: Can't load kext com.insanelymac.IntelMausiEthernet - link failed. Jul 10 15:57:27 localhost kernel[0]: Failed to load executable for kext com.insanelymac.IntelMausiEthernet. Jul 10 15:57:27 localhost kernel[0]: Kext com.insanelymac.IntelMausiEthernet failed to load (0xdc008016). Jul 10 15:57:27 localhost kernel[0]: Failed to load kext com.insanelymac.IntelMausiEthernet (error 0xdc008016). Jul 10 15:57:27 localhost kernel[0]: Couldn't alloc class "IntelMausi" Jul 10 15:57:27 localhost kernel[0]: mbinit: done [96 MB total pool size, (64/32) split] Jul 10 15:57:27 localhost kernel[0]: Pthread support ABORTS when sync kernel primitives misused I am trying to make it work since yesterday. My machine is running the latest release of Mountain Lion. Thank You
×