Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About Lya_Castled

  • Rank
    InsanelyMac Protégé
  1. what's your videocard's type? how did you make it work well? I tried to modify ATI1600Controller.kext, but unlucky, I can't output my ROM directly as it's locked. the only thing from my VBIOS I can find is below: RadeonDump -d Found a device of class RadeonPCI: IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PEGP@1/IOPCI2PCIBridge/GFX0@0/RadeonPCI it matched on name "display" RadeonDump regnum Found a device of class RadeonPCI: IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PEGP@1/IOPCI2PCIBridge/GFX0@0/RadeonPCI it matched on name "display" 0x7200: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 RadeonDump -i Found a device of class RadeonPCI: IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PEGP@1/IOPCI2PCIBridge/GFX0@0/RadeonPCI it matched on name "display" Detected ATI Mobility Radeon X1400 (device id: 0x7145) Start I2C dump ATOM BIOS detected ATOM BIOS Rom: SubsystemVendorID: 0x17aa SubsystemID: 0x2006 IOBaseAddress: 0x2000 Filename: BR25482.bin BIOS Bootup Message: M64CSP/M62CSP/M54CSP/M52CSP BIOS " Bios Connector table: Port1: DDCType-0x7e50, DACType-7, TMDSType-0, ConnectorType-0, hpd_mask-0x0 Port3: DDCType-0x7e60, DACType-1, TMDSType-1, ConnectorType-0, hpd_mask-0x1 EDID for connector 0: Read data failed EDID for connector 1: Read data failed EDID for connector 3: 0x0000: 00FFFFFFFFFFFF0030AE224000000000 0x0010: 000F0103801D1578EA2D059757518A27 0x0020: 23505421080081800101010101010101 0x0030: 010101010101302A7820511A10403070 0x0040: 13001ED61000001925237820511A1040 0x0050: 307013001ED6100000190000000F0090 0x0060: 43329043280F01004CA35034000000FE 0x0070: 004C544E31343150342D4C30320A0019 It's so few, I don't know how to do it. As you know, x1400 is Wormy, that's no solution in that topic now, and I keep waitting the lastest RadeonHD.kext In ATIRadeonX1000.kext, I can't find any " Disable_PPLib" or "PPLib". In IOReg, about "GLContext", there're really words, but no "AGPM" existed. Now the only thing I feel possible to do, is still to modify the words in #1, but I don't know how to relate the code from my VBIOS with AppleGraphicsPowerManagement.kext\Contents\Info.plist . __________________ my files below 10.6.8_ATIRadeonX1000.kext_Info.plist.txt 10.6.8_AppleGraphicsPowerManagement.kext_Info.plist.txt
  2. Thanks to reply . Too, I have no information with "ioreg | grep CSTInfo". My dock works well, and those icons like bettery showed a little delay. If I edit AppleGraphicPowerManagement.kext that delete the words, dock also die when desktop start. My DSDT is here, It's base on silencer's of thinkpads forum. dsdt.aml.zip
  3. I tested with openGL, It showed better FPS in MAC10.6.8 than WIN7, I think it's effected. But I can't find any information in LOG, so AppleGraphicsPowerManagement.kext maybe not loaded. I had compared my T60 with the real MBP info, and now be sure that MacBook Pro 2,2 is best for me. MBP2,2 use T7600 as me, and X1600 that similar to X1400, and APPLE official says MBP2,2 surpport 10.6.8 and 10.7 , But it seems no information I can find about macbookpro2,2 and X1600. To drive my videocard, I use ATIRadeonX1000.kext and RadeonHD.kext, they make X1400 work with QE. So it's not base on AppleGraphicsPowerManagement.kext in most status. But I need it to enable the function of SLEEP and WAKE. In AppleGraphicsPowerManagement.kext\Contents\Info.plist of 10.6.8, I find it's different with other SnowLeopard's code, I guess the code maybe Lion. I can see 3 types code that below ----1. IGPU ----2. GFX0 ----3. Vendor****Device**** I guess the1 IGPU is the default INTEL card ,maybe the no_pcie card; and the2 GFX0 is the default N card, mostly pcie card; those the3 Vendor****Device**** means direct HardwareID. e.g. Vendor8086 is INTEL, Vendor10de is N, Vendor1002 is ATI. I guess it's not direct surpported in old IOreg, but surpported with KEXT in newer system. In some tips somewhere, I find different manufacturers' code may be common, if it's suitable.
  4. I made my T60's OSX 10.6.8 work with original CPU power management, and had some other edit, including modify AppleGraphicsPowerManagement.kext . so , it can go sleep and wake good. but my videocard X1400 become very hot sometime, I guess it's be overclock with some wrong thing in AppleGraphicsPowerManagement.kext\Contents\Info.plist . I edit it as below: add code <key>MacBookPro2,2</key> <====== I use smbios as MBP 15" 2,2 <dict> <key>Vendor1002Device7145</key> <====== my X1400's ID is 0x71451002 <dict> <key>QSC</key> <dict> <key>Enabled</key> <integer>1</integer> <key>Mode</key> <integer>1</integer> <key>hwPState</key> <array> <integer>0</integer> <integer>0</integer> <integer>0</integer> <integer>1</integer> <integer>1</integer> <integer>1</integer> <integer>1</integer> <integer>1</integer> <integer>2</integer> </array> <key>qscOnTime</key> <array> <integer>0</integer> <integer>2240</integer> <integer>3520</integer> <integer>0</integer> <integer>3680</integer> <integer>4960</integer> <integer>6720</integer> <integer>9120</integer> <integer>0</integer> </array> </dict> <key>control-id</key> <integer>17</integer> <key>max-power-state</key> <integer>8</integer> <====== 8 states as my screen light control with fn+Home(End) </dict> </dict> these code are copied from the original below: <key>MacBookPro8,2</key> <dict> <key>IGPU</key> <dict> <key>Heuristic</key> <dict> <key>BusyDownThresholdPercent</key> <integer>70</integer> <key>BusyUpThresholdPercent</key> <integer>90</integer> <key>DiagnosticModeDefault</key> <integer>0</integer> <key>EvaluateDownInterval</key> <integer>350000</integer> <key>EvaluateUpInterval</key> <integer>66000</integer> <key>ID</key> <integer>2</integer> <key>SensorOption</key> <integer>1</integer> </dict> <key>control-id</key> <integer>16</integer> <key>max-power-state</key> <integer>15</integer> <key>min-power-state</key> <integer>0</integer> </dict> <key>Vendor1002Device6741</key> <dict> <key>QSC</key> <dict> <key>Enabled</key> <integer>1</integer> <key>Mode</key> <integer>1</integer> <key>hwPState</key> <array> <integer>0</integer> <integer>0</integer> <integer>1</integer> <integer>1</integer> <integer>1</integer> <integer>1</integer> <integer>1</integer> <integer>1</integer> <integer>2</integer> </array> <key>qscOnTime</key> <array> <integer>0</integer> <integer>1440</integer> <integer>0</integer> <integer>2400</integer> <integer>4000</integer> <integer>5760</integer> <integer>7680</integer> <integer>9760</integer> <integer>0</integer> </array> </dict> <key>control-id</key> <integer>17</integer> <key>max-power-state</key> <integer>8</integer> </dict> <key>Vendor1002Device6760</key> <dict> <key>QSC</key> <dict> <key>Enabled</key> <integer>1</integer> <key>Mode</key> <integer>1</integer> <key>hwPState</key> <array> <integer>0</integer> <integer>0</integer> <integer>0</integer> <integer>1</integer> <integer>1</integer> <integer>1</integer> <integer>1</integer> <integer>1</integer> <integer>2</integer> </array> <key>qscOnTime</key> <array> <integer>0</integer> <integer>2240</integer> <integer>3520</integer> <integer>0</integer> <integer>3680</integer> <integer>4960</integer> <integer>6720</integer> <integer>9120</integer> <integer>0</integer> </array> </dict> <key>control-id</key> <integer>17</integer> <key>max-power-state</key> <integer>8</integer> </dict> </dict> I think the main problem is those words , because MBP 8,2 use the advanced videocard. I don't know what's the meaning of those words , and there're only information of AppleGraphicsPowerManagement.kext about N card that I can find on the Internet. Is somebody can tell me those code's meaning, or way to make it suits to my X1400 ? sorry for my poor English!