Jump to content

XAVIDENIA

Members
  • Content count

    143
  • Joined

  • Last visited

About XAVIDENIA

  • Rank
    InsanelyMac Geek

Contact Methods

  • MSN
    MEGLIN@HOTMAIL.COM

Profile Information

  • Gender
    Male
  1. XAVIDENIA

    (SOLUCIONADO)Ocultar efi en clover

    solucionado pero no como tu me aconsejaste pues tras estar un buen rato probando no conseguí el resultado que quería , así que dejo solucion por si a alguien mas le pasa..... la solución paso por desconectar el resto de discos duros , para no tener tanta información , crear un dump con el darwindumper y sorpresa el nuevo boot de Ubuntu lleva entradas o path para todas las distribuciones, como podrás ver aquí...... con lo cual no se trataba de ocultar shimx64.efi, sino de especificarle la entra exacta a Ubuntu , según la distribución instalada , añadiendole el path a uuid volume efi en mi caso el volume uuid es 7149364A-458C-496B-8EFA-3D6E62F073F0 y el path \EFI\ubuntu\grubx64.efi y simplemente con eso ya sale solo una entrada de Ubuntu al iniciar el pc Gracias maniac
  2. XAVIDENIA

    (SOLUCIONADO)Ocultar efi en clover

    Hola buenas noches a ver si me podeis ayudar con mi problema.... tengo una dual boot osx high sierra y ubuntu, el problema es que ubuntu tiene 2 efi.... una que es grubx64.efi que es la que arranca ubuntu sin secure boot y otra que es shimx64.efi que es la que arranca ubuntu en secure boot, aunque si no está el secure boot activado arranca igual el ubuntu pues llama a grubx64.efi y ahí el problema.... que al configurar la custom entri de ubuntu en clover me monta dos accesos de ubuntu a la hora de elegir el sistema operativo con el que quiero arrancar... y solo quiero que me salga un acceso de ubuntu. Hay alguna forma de ocultar una entrada por ejemplo la entrada que arranca desde shimx64.efi????? Gracias y saludos
  3. Gracias maniac ya lo tengo todo funcionando. En cuanto a lo de que me Es porque en el antiguo clover si no tenias bien el path, UUID o GUID no te sacaba el nombre personalizado, ni las imágenes, no se si era normal o no , pero así era , ahora me he dado cuenta de que amenos en esta versión no es así..... en cuanto a lo de los iconos , es que no me salían los que tenia en el tema dedicados a la partición osx del sistema , y se me ha ocurrido de lo tenia nombrado como vol_internal_hfs.icns y no detectaba ese sistema de ficheros, porque no existe por lo que me sacaba el de por defecto, sin la manzana así que he duplicado el icono y lo he renombrado a vol_internal_apfs.icns y ya me ha reconocido el sistema de ficheros , sacándome el icono que yo queria que era el que tenia en sierra , que era hfs... me faltara pulir algunas cosillas del reinicio y apagado y reposo que no funcionan muy bien , pero para eso ya abriré otro hilo, no?? y subire el config.plist final y un dump del sistema creado con el DarwinDumper.... Al final se ha solucionado todo reinstalando a la nueva versión de Clover que salió ayer , la 4674 y creándome yo mismo el config.plist , por eso no acaban de funcionar bien el apagado y reinicio, el reposo aun no lo he probado.... aparte de los problemillas de apagado, reinicio y reposo, en lo que se refiere a las entradas , tengo un problemilla con la entrada de Ubuntu(Linux) y es que me la saca doble y desde las dos inicia..... He probado yendo a Ubuntu , y editando el grub para que me oculte todas las entradas, dejando solo una , la referente a la entrada del sistema.... También he probado a cambiar ALL kernel a Most recent, ya sabes por eso de que Ubuntu suele tener varios kernel y sigo en lo mismo... sabrías decirme como ocultar, una de esas entradas??? subo config.plist final, por si le quieres echar un vistazo supongo que tendré que pulir el powermanagement, para lo que si no te molesta , me gustaría que me echaras una mano, pues ahí si que me pierdo total... Gracias nuevamente y saludos P.D Nos vemos, o hablamos cuando habrá el nuevo hilo config.plist
  4. Solucionado ahora mi problema es que no detecta o no me da los UUID de las particiones efi de windows Supongo que tendré que instalar los drivers ntfs.efi pero me dice que no lo encuentra..... en su lugar hay un driver que se llama grubntfs.efi , es el mismo driver que diferencia hay entre uno y otro???? Como activo para que me muestre disco linux y como funciona el custom Icons de la sección guí , pq en clover wiki pone para que sirve, pero no lo acabo de entender y no se extienden mucho en la explicación. ... Gracias y saludos
  5. bueno esta tarde he ido ha arrancar , para configurar las entradas de los otros sistemas operativos y sorpresa , no arranca , así que he tenido que arrancar con el usb que lleva puesto la carpeta de Clover de olarila y he conseguido arrancar , me he bajado el config.plist que ,me pasaste el otro día y lo he reemplazado por si, sin querer había modificado algo ..... y nada que no arranca con tu config plist , me da un kp, al final he tenido que poner la carpeta de Clover de olarila , para poder arrancar .... intento configurar la entrada a osx desde el clover de olarila en el arranque en verbose me detecta estos discos..... busco esos datos en el bootlog del Darwin y encuentro esto...... [09]: 'OS X High Sierra' 1:638 0:180 AddLoaderEntry for Volume Name=OS X High Sierra 1:677 0:038 hibernated: set as never [09]: Volume: PciRoot(0x0)\Pci(0x1F,0x2)\Sata(0x3,0xFFFF,0x0)\HD(2,GPT,56442A9C-8E3C-4367-ABB4-A80A59BD6119,0x64028,0x746A2D60)\VenMedia(BE74FCF7-0B7C-49F3-9147-01F4042E6842,D187D11566F24F43BBFBA11A0460B223) y de aqui deduzco lo siguiente: este volume esta bien : HD(2,GPT,56442A9C-8E3C-4367-ABB4-A80A59BD6119,0x64028,0x746A2D60) este otro también : BE74FCF7-0B7C-49F3-9147-01F4042E6842 pero este otro como me comentabas el otro día hace byteflop con algunos pares.... así que ya no se que mas hacer..... he probado así : 15D187D1-F266-434F-BBFB-A11A0460B223 asi: 15D187D1-F266-434F-BBFB-A11A0460B223\boot.efi asi: D187D115-66F2-4F43-BBFB-A11A0460B223\boot.efi asi: D187D115-66F2-4F43-BBFB-A11A0460B223 asi: BE74FCF7-0B7C-49F3-9147-01F4042E6842 asi: BE74FCF7-0B7C-49F3-9147-01F4042E6842,D187D11566F24F43BBFBA11A0460B223 asi: BE74FCF7-0B7C-49F3-9147-01F4042E6842,15D187D1F266434FBBFBA11A0460B223 asi: BE74FCF7-0B7C-49F3-9147-01F4042E6842,15D187D1-F266-434F-BBFB-A11A0460B223 asi: BE74FCF7-0B7C-49F3-9147-01F4042E6842,D187D115-66F2-4F43-BBFB-A11A0460B223 asi: BE74FCF7-0B7C-49F3-9147-01F4042E6842,15D187D1-F266-434F-BBFB-A11A0460B223\boot.efi asi: BE74FCF7-0B7C-49F3-9147-01F4042E6842,D187D115-66F2-4F43-BBFB-A11A0460B223\boot.efi poniéndolos en path y en volume.... también he probado poniendo en volume HD(2,GPT,56442A9C-8E3C-4367-ABB4-A80A59BD6119,0x64028,0x746A2D60) y en path alguna de las combinaciones anteriores aqui el esquema de particiones según diskutil y continuo con el mismo problema subo Darwindumper, actual por si hay algo mal.... DarwinDumper_3.0.4_19.09_18.38.10_iMac14,2_AMI_X64_4630_High Sierra_17G65_xavidenia.zip
  6. Gracias Maniac con ese config si que me arranca y puedo personalizar las entradas , en cambio si pongo la carpeta Clover de olarila no ....... cuando cambio la carpeta clover y pongo la de olarila , no hay forma de configurar las entradas custon, pq esa configuracion que me has puesto tu , ya la probe yo , y si le pongo el config plist tuyo teniendo la carpeta clover de olarila idem de lo mismo , no funciona me da un KP,, asi que es de deduciir que hay algo en esa carpeta que hace que no dectete bien las particiones o que todo vaya tan fluido como deberia,,,, instalando clover desde cero y poniendo tu config plist ya me arranca y me muestra la entrada , los unicos inconvenientes , es que no me muestra el DriveImage que yo le he puesto, y que no me destecta el disco de Ubuntu(Linux), esto ultimo supongo que sera pq lo tengo instalado en un ssd y debo de instalarle el trimenabler, si no me equivovo, no??? mantengo el hilo abierto hasta que termine con la configuracion por si surgiera algo mas... gracias y saludos
  7. Nada , no hay forma ya he probado de todo eliminando el UUID, cambiandolo por ...74F05C8B66B1304B97F9A35E18095977 camiando en volumen a 2F3A18D2-3DB1-4797-9575-F035A00A879D y a HD(2,GPT,2F3A18D2-3DB1-4797-9575-F035A00A879D...) incluso poniendo en volume el nombre de la particion y nada consigo que arranque el osx pero no consigo personalizar la entrada ..... voy a probar a reinstalar pero esta vez dejando la particion Time Machine en hfs+ en vez de en apfs que esta , alomejor el tener 2 particiones en apfs , da error , o crea confusion en el sistema...
  8. Lo que no entiendo es pq no coincide lo que dice el log con lo que dice el config.....??? Ok quitaré el volume o lo reemplazar por ...... En cuanto al UUID le dejo el que tengo o pongo el otro??? El config.plist es el mismo..... Que lo salte pq esta oculto, no es normal pues sólo tengo ocultas las entradas Preboot y Recovery y la EFI (que uso para ocultar las entradas EFI de los demás sistemas operativos), pero la Partición os x High Sierra no está oculta no se pq dice eso.... Gracias por tu tiempo y saludos Aver si puedo solucionar esto ya de una vez......
  9. curioso hace un byteflop, entonces con eso ya puedo crear mis entradas personalizadas , incluyendo la de osx..... voy a probar gracias por tu respuesta. Solo me queda uns duda de dobde sacas el path?? en mi caso solo necesito sacar el path del disco o particion que usas el high sierra para iniciar.... ya he ocultado los volumenes Preboot y Recovery... ahora necesito personalizar la entrada del osx high Sierra , simplemente por cambiarle el nombre y que no me ponga boot from osx high sierra from osx high sierra y el icono de inicio..... subo debug de arranque y config.plist para que le eches un vistazo si puedes a ver si a mi se me escapa algo... ahora mismo solo tiene el disco osx conectado y solo una custom entrie... saludos... debug.log.zip config.plist.zip
  10. ahora mi duda lo anterior esta bien?? mi duda es que el nuevo Colver Configurator ya te dice tanto los volúmenes UUID como los Disk UUID.... de que me tengo que fiar de Clover o de lo expuesto anteriormente???? porque según lo expuesto anteriormente PreBoot--->\8B5CF074-B166-4B30-97F9-A35E18095977 Recovery---->\8B5CF074-B166-4B30-97F9-A35E18095977 High Sierra---->\8B5CF074-B166-4B30-97F9-A35E18095977 según Clover: Preboot Volume UUID: 7EAB530C-5D2C-4928-8116-8D8836554D23 Disk UUID:7EAB530C-5D2C-4928-8116-8D8836554D23 Recovery Volume UUID: 6D30228C-E337-4E7B-9C97-018127F513C2 Disk UUID: 6D30228C-E337-4E7B-9C97-018127F513C2 High Sierra Volume UUID: 8B5CF074-B166-4B30-97F9-A35E18095977 Disk UUID: 8B5CF074-B166-4B30-97F9-A35E18095977 segun lo anterior tanto el volumen High Sierra , Preboot y Recovery Usan el mismo UUID que seria :8B5CF074-B166-4B30-97F9-A35E18095977 Según clover, cada uno tiene su propio UUID , como demuestro 2 lineas mas arriba... pues ninguno de los UUID que ma da el clover Configurator , aparece en nada de lo que he expuesto en mi exposición anterior.... Gracias y saludos espero podáis responder a mis dudas....
  11. hola buenas noches , sigo intentando hacer funcionar el Clover en ose High Sierra y tratando de configurar las entradas personalizadas. me he acogido a este post..... https://www.insanelymac.com/forum/topic/326527-create-custom-entries-to-hide-preboot-and-recovery-apfs-volumes-fusion-drive-installation-with-clover-configurator/?tab=comments#comment-2485054 y siguiendo este post he hecho lo siguiente ..... desde consola he sacado los datos de los discos primero con diskutil List y me ha arrojado estos datos..... luego con diskutil apfs List , puesto que el disco ahora es apfs y me ha arrojado estos datos..... Luego he generado un bootlog desde la consola con el siguiente comando... he abierto el bootlog con un editor de texto y he buscado la sección scanLoader donde me da estos datos... lo cual me esta diciendo las distintas entradas que hay en el disco con formato apfs y estas serian mis entradas..... Volumen EFI ———> [03] Volumen Preboot ——> [06] Volumen High Sierra ——-> [07] Volumen Recovery ———> [08] Volumen VM ———> [09] Ahora debo de buscar estas entradas en bootlog en la sección ScanVolumes según los datos extraídos tanto del bootlog como de los volcados con diskutil estos deberían de ser los UUID´s de mis particiones....... ============================================================ disk3s2(según diskutil apfs List) disk1s2(según mi criterio) Volumen 06 = Preboot ——>1:609 0:000 - [06]: Volume: PciRoot(0x0)\Pci(0x1F,0x2)\Sata(0x3,0xFFFF,0x0)\HD(2,GPT,2F3A18D2-3DB1-4797-9575-F035A00A879D,0x64028,0x5181A028)\VenMedia(BE74FCF7-0B7C-49F3-9147-01F4042E6842,0C53AB7E2C5D284981168D8836554D23) Partición UUID =2F3A18D2-3DB1-4797-9575-F035A00A879D(según el bootlog) Vol UUID = 0C53AB7E2C5D284981168D8836554D23(según bootlog) Path=/Volumes/Preboot/8B5CF074-B166-4B30-97F9-A35E18095977/System/Library/CoreServices/boot.efi ========================================================== disk3s1(según diskutil apfs List) disk1s1(según mi criterio) Volumen 07 = High Sierra ——>1:609 0:000 - [07]: Volume: PciRoot(0x0)\Pci(0x1F,0x2)\Sata(0x3,0xFFFF,0x0)\HD(2,GPT,2F3A18D2-3DB1-4797-9575-F035A00A879D,0x64028,0x5181A028)\VenMedia(BE74FCF7-0B7C-49F3-9147-01F4042E6842,74F05C8B66B1304B97F9A35E18095977) Partición UUID =2F3A18D2-3DB1-4797-9575-F035A00A879D Vol UUID = 74F05C8B66B1304B97F9A35E18095977 ========================================================== disk3s3(según diskutil apfs List) disk1s3(según mi criterio) Volumen 08 = Recovery ——>1:609 0:000 - [08]: Volume: PciRoot(0x0)\Pci(0x1F,0x2)\Sata(0x3,0xFFFF,0x0)\HD(2,GPT,2F3A18D2-3DB1-4797-9575-F035A00A879D,0x64028,0x5181A028)\VenMedia(BE74FCF7-0B7C-49F3-9147-01F4042E6842,8C22306D37E37B4E9C97018127F513C2) Partición UUID =2F3A18D2-3DB1-4797-9575-F035A00A879D Vol UUID = 8C22306D37E37B4E9C97018127F513C2 Path=/Volumes/Recovery/8B5CF074-B166-4B30-97F9-A35E18095977/boot.efi ========================================================== disk3s4(según diskutil apfs List) disk1s4(según mi criterio) Volumen 09 = VM ——>1:609 0:000 - [09]: Volume: PciRoot(0x0)\Pci(0x1F,0x2)\Sata(0x3,0xFFFF,0x0)\HD(2,GPT,2F3A18D2-3DB1-4797-9575-F035A00A879D,0x64028,0x5181A028)\VenMedia(BE74FCF7-0B7C-49F3-9147-01F4042E6842,467CEBB5266EE54CA1A552A2CD1FE5DC) Partición UUID =2F3A18D2-3DB1-4797-9575-F035A00A879D Vol UUID = 467CEBB5266EE54CA1A552A2CD1FE5DC ========================================================== ahora debería se montar las unidades recovery y preboot para determinar la ruta a boot.efi para dichas particiones...... monto las unidades des terminal con el comando.... al intentar montarla utilizando las numeraciones de disk marcadas arriba en rojo me da error , me arroja un "unable to find disk for diskxsx" así que probado en vez de con disk3sx con disk1sx porque según mi criterio es disk1 y no disk3 como me dice el bootlog y ahora si que me ha montado esas particiones, abro el directorio volumes desde consola con el comando hasta aqui todo bien.... ahora despliego el volumen preboot y localizo el archivo boot.efi que esta en Preboot/System/Library/coreservices/boot.efi y lo arrastro a consola dándome este resultado... /Volumes/Preboot/8B5CF074-B166-4B30-97F9-A35E18095977/System/Library/CoreServices/boot.efi hago lo mismo con el volumen recovery localizo el archivo boot.efi en Recovery/8B5CF074-B166-4B30-97F9-A35E18095977/boot.efi y lo arrastro también a la terminal dándome este resultado... /Volumes/Recovery/8B5CF074-B166-4B30-97F9-A35E18095977/boot.efi con lo que los Paths para crear las entradas personalizadas , ya sea para ocultar esas particiones o para otras cosas serian los siguientes: PreBoot--->\8B5CF074-B166-4B30-97F9-A35E18095977\System\Library\CoreServices\boot.efi Recovery---->\8B5CF074-B166-4B30-97F9-A35E18095977\boot.efi con lo cual el UUID en las rutas para boot.efi para ambos Volúmenes Recovery y Preboot , es el mismo UUID del Volumen del High Sierra comprobado aquí , por la consola....
  12. buenas noches maniac te comento lo que he hecho por ahora , he cogido el config.plist de olarila , lo he abierto con el plist editor pro me he ido a la opcion boot la he desplegado y le he activado el modo debug , poniendolo a yes y he guardado cambios..... Acto seguido me he ido a la pestaña opcion gui ali he cambiado el tema por el mio, cambiando el nombre del tema de olarila a iclover, que es un tema que me tunee cambiando iconos y otras cosas..... agregue custom--> entiries y las siguientes entradas 0= EFI tittle-->EFI Volume---> EFI hidden---> Yes (esto para que me oculte las particiones EFI de los sistemas operativos windows y linux) luego particion Time machine tambien le he creado una entrada para que me la oculte del inicio pero que sea accesible desde f3 tb he agregado una particion recovery hdd que tenia en sierra pero que acabare eliminando pq el high sierra la crea , pero que la ocultare para que sea accesible desde f3 y por ultimo he creado la entrada para high sierra, con el guid que me da Darwindumper para high sierra he añadido la opcion scan con la funcion kernel ALL para que me detecte todos los kernels de los otros sistemas operativos (windows y linux) y tb he agregado screenResolution a mi resolucion 1920 x 1080 he guardado todo y he reemplazado el config.plist de la particion EFI por este (el de olarila modificado con plist editor pro) al reiniciar con -v en lo primero que sale , me dice directly panic y continua hasta que llega a un punto y ahi se queda .... ahora voy ha probar con algunas cosas de este post que has seguido tu , aver si hay suerte.... si se te ocurre alguna idea me lo dices estoy abierto a sugerencias.... a todo eso decir que noche reinstale el high sierra y cambie el sistema de archivos a apfs ..... saludos
  13. Buenos días , probaré como tu dices editando el config con el plist editor , y probaré con la versión 3 del darwin dumper a ver si así me lee los guid..... De todas formas ya he probado a arrancar con este uuid sin éxito. ... HD(2,GPT,7C11E1B1-49EF-4101-ACFF-F0FA8A7F8F4F,0x64028,0x5D127C80) otra cosa tanto varía osx sierra de osx high sierra para que no sirva el config plist que tenía en el sierra???? ya comento resultados.... saludos
  14. No entiendo pq los config plist no son iguales ..... lo que he hecho ha sido, con el clover configurator montar la partición efi , ir a la carpeta clover y abrir el config plist que es el de olarilla con clover configurator activar en la sección boot el debug y añadir las entradas en la sección guí guardar tal cual estaba con lo que debería obtener un config plist de olarilla con entradas y en vez de eso , por lo que me dices se cambia todo el config plist.... tampoco entiendo pq el darwin dumper no me da las entradas correctas , será la versión de darwin dumper??? Donde me puedo descargar una versión más acual o más nueva y que versión me aconsejas???? No debería de poder arrancar osx high sierra con el config plist que tenía antes en el osx sierra???? Lo de los kext duplicados ya lo se pues , los puse duplicados para ver si poniéndolos en la carpeta 10.13 arrancaba pero ya los he eliminado la carpeta 10.13. En cuando a lo de que en clover debo de usar la opción guid , bueno he estado mirando pero no encuentro esa opcion
  15. Buenas tardes de nuevo como te decía antes he editado las entradas de los otros sistemas operativos con el Clover Configurator en sección GUI y siguiendo tu consejo he activado la opción debut en la sección boot del Clover Configurator. y bueno ahora mismo ya no arranca la pc desde el Clover que tengo instalado en el disco duro de osx High sierra en la partición efi pero le he dado a F2 creando así un logro prenoto, y también me sale un log debug , pero creo que ese log(Debug) se ha creado al iniciar con en Clover del usb. puede ser que el problema este en las uuids de los discos de osx (os x (sistema) time machine (una partición de 100gb que tenga para copias de seguridad) y recovery Hd(la partición de recuperacion))pues, pues tras hacer un dump con el Darwin dumper cuando me abre la ventana del navegador en la sección disk and uuids me muestra estos uuids de las particiones.... disk0s1 EFI System Partition 0E239BC6-F960-3107-89CF-1C97F78BB46B disk0s2 /Volumes/OSX High Sierra 255D35D9-CDA6-3352-A525-45D8DE4D450B disk0s3 /Volumes/Recovery HD 8FAC18EF-03ED-321F-B472-A2AA186D6BD9 disk0s4 /Volumes/Time Machine EEB7F219-9138-3D4B-8B6A-2F8E21A4835D pero luego al buscar esas uuids en el fichero bootlog que crea el mismo Darwin dumper no me aparecen esas particiones , ni esos uuids, me aparecen otros como..... 4:416 0:018 - [07]: Volume: PciRoot(0x0)\Pci(0x1F,0x2)\Sata(0x3,0xFFFF,0x0)\HD(2,GPT,7C11E1B1-49EF-4101-ACFF-F0FA8A7F8F4F,0x64028,0x5D127C80) ------>Osx High Sierra 4:416 0:000 - [08]: Volume: PciRoot(0x0)\Pci(0x1F,0x2)\Sata(0x3,0xFFFF,0x0)\HD(3,GPT,10ED6616-D689-48CB-882E-107D63314991,0x5D18BCA8,0x135F20) ----->Time Machine 4:417 0:000 - [09]: Volume: PciRoot(0x0)\Pci(0x1F,0x2)\Sata(0x3,0xFFFF,0x0)\HD(4,GPT,8CD9BD3F-4DDC-45C1-A4F7-864717172287,0x5D2C1BC8,0x174051C0) ------>Recovery HD y nada mas , de todas formas te subo el ultimo dump que aje creado con el Darwin dumper, el config plist con las entradas de todos los sistemas operativos añadidas, y lo archivos debug y prebootlog que me ha creado Clover , supuestamente , aver si consigues ver algo que a mi se me escapa.... gracias de nuevo y saludos DarwinDumper_2.9.9.2_AMI_X64_0000_Unknown_xavidenia.zip config.plist.zip debug.log.zip preboot.log.zip
×