Jump to content

Zackptg5

Members
  • Content Count

    137
  • Joined

  • Last visited

Everything posted by Zackptg5

  1. Zackptg5

    New AppleHDA Patcher

    I was using a DummyHDA w/ clover I patched myself since yosemite and it worked fine until the 10.11.4 update. I then used the aDummyHDA generated with this app (providing my files from before) and it works great! Perhaps having the "a" in the beginning affects the load order or something. To anyone else having issues with this, maybe this will help. Great app guys!
  2. Zackptg5

    AppleHDA Patcher

    Fantastic Work. I've been using a DummyHDA kext for a while now and it's been buggy and temperamental but the aDummyHDA from here just works and it generates the files needed if I decide to use another method of applehda patching. Couldn't be happier
  3. I have the Radeon r9 279 graphics card and in order to get proper graphics accel, I have to patch the AMD7000Controller (bin and info.plist patch) and AMDRadeonX4000 (info.plist patch) kexts. For both, I need to replace on of the card ids with mine in the info.plists. For the AMD7000Controller, I need to patch the frame buffer with a custom one I made for my card. I've tried to do this with clover but it doesn't work. The only thing I've found on this is here: http://www.insanelymac.com/forum/topic/282787-clover-v2-instructions/page-3?do=findComment&comment=2108022 and I followed it but it still didn't seem to work. Any ideas?
  4. Is this with the applehda from the previous post or patching applehda yourself with the other files from the last post? If it still isn't working, voodoohda is always an option
  5. Ok, I'm thinking the binary patching or something isn't working right. Try this one. If it doesn't work, I've attached the codec config, modified layout3 and Platforms (all patched already) if you want to give it a shot with the compiling and stuff. Here's a good guide: http://www.insanelymac.com/forum/topic/295001-guide-to-patch-applehda-for-your-codec/ AppleHDA.kext.zip layout3.xml Platforms.xml codecconfig.txt
  6. That's exactly what I said I'm my previous post. Try the one I patched (see last post)
  7. So the first zip attached is the patched 10.10.4 AppleHDA from Mirone's github page (https://github.com/Mirone/AppleHDA_10.10.4). I think it'll still work in 10.10.5 but don't take my word for it. It doesn't appear that you're external mic/line in is enabled in it though so I took the 10.10.5 AppleHDA, implemented Mirone's config to it, and made a few changes to enable it (2nd attachment). You should have 4 devices: internal speakers, headphones, internal microphone, and external microphone (line in). All of those devices except the internal mic are EAPD devices so you'll probably need to use EAPDFix or CodecCommander in addition to this patched AppleHDA to get those to work properly. Try them both and let me know how they work. I believe that all but the ext mic should work with mirone's assuming 10.10.4 AppleHDA will work in the 5th update and hopefully all 4 will work with mine Btw, layout id = 3 in both kexts for any hdaenablers you're using (or dsdt or boot loader) AppleHDA-272.18.1-IDT92HD81B1X5.zip AppleHDA.kext.zip
  8. If voodoo works then great! If you still want to AppleHDA though, try this one. AppleHDA.kext.zip
  9. How does the sound work with voodoohda? Do all of the devices work properly? Which ones are disabled when others are plugged in? Also, after that, try deleting voodoohda and installing the AppleHDA from post #73 with kext wizard (repair cache and such after install and then reboot). Does everything work with it? There are some slight differences between how voodoo is tracing the nodes and how I am
  10. That means that you didn't install the getdump command. First of all, do you have an admin account? You shouldn't need sudo for this command. Second, to verify that it's not installed, type ls /usr/local/bin If you don't see getdump in the resulting list, then it's not installed.
  11. That means you didn't install the get dump command. It's installed automatically into usr/local/bin when you run the voodoohda installer package in my previous post. Here's are the steps: 1. Backup and Delete AppleHDA from S/L/E 2. Delete AppleHDADisabler from S/L/E 3. Install voodoohda2.8.4 package from previous #73 4. Install latest voodoohda (see attached) with kext wizard 5. Repair permissions and kext cache with kext wizard 6. Restart 7. After restart, open terminal and type: getdump > voodoodump.txt 8. Attach the voodoodump.txt file in your user folder I don't recommend using AppleHDADisabler kext and always repair permissions and cache after making any changes to S/L/ extensions VoodooHDA.kext.zip
  12. Try Sudo getdump > voodoodump.txt
  13. Hmmm, did you remove AppleHDADisabler and voodoohda? Install the voodoohda in my previous post, then reinstall the newer voodoohda kext you were using before along with AppleHDADisabler and run the get dump command so I can see what voodoo is doing.
  14. Sounds like you installed just the kext. Install this package to get a working get dump file, then reinstall your current voodoohda kext (the get dump command in the newer versions doesn't work). Also, I goofed in the Platforms.xml which is why the speaker was disabled when the subwoofer was plugged in. Try this one VoodooHDA-v2.8.4.pkg.zip AppleHDA.kext.zip
  15. Post your codec dumps and I can take a look at it later
  16. Run this command in terminal: getdump > voodoo_dump.txt Post the resulting text file
  17. I'm away from my computer at the moment. If voodoohda works, then stick with it. I'll take a look at it again when I get back. Can you post voodoo dump?
  18. Step in the right direction, can you provide screenshots? Input sounds good then. Also, see if this makes a difference. I changed the subwoofer from line out to speaker AppleHDA.kext.zip
  19. Can you try each input/output device and see if they work? Check sound preferences to see if they show up.
  20. Try these. Your subwoofer is strange because unlike most laptops, it is connected by an external jack so I labeled it as a line out. If it shows up (should only show up when plugged in), then you'll need to create a multi-output device in Utilities -> Audio Midi Setup which includes both the sub and the int speakers. Turn the volume of both devices up all of the way, install sound siphon, set passthrough device in sound siphon to the multi-output device, and set sound siphon as your output device. Then you can adjust the volume of both simultaneously and sound will come out of both. Let me know how it works. FYI, use the attached ioreg explorer in the future. Saved ioregs with newer versions can only be opened with that version of ioreg. With this version, you can open them with any version EAPDFix.kext.zip AppleHDA.kext.zip IORegistryExplorer.app.zip
  21. Zackptg5

    Clover General discussion

    Update, this issue is also present with 10.10.4 as well so I guess 10.10.4 and newer have this issue
  22. Zackptg5

    Clover Problems and Solutions

    With El Capitan only (both DP1 and 2), injecting a bin patch with clover for the frame buffer for an amd graphics card doesn't work. It works fine in previous versions of OS X though. I've attached my config.plist In my case, the card is a Radeon R9 270. When I do a manual bin patch (modifying the kext) with the same code, it works fine in El Capitan which leads me to believe that this is a Clover issue. config.plist.zip
  23. I've just gotten yosemite installed on my Gigabyte p35w v2 and have noticed this card type message up top. What is it? It doesn't seem to do anything My 2 guesses: My sd card reader My nvidia card I have an optimus laptop but have disabled the nvidia card or else I can't boot and the sd card reader is a pci-e realtek which doesn't work. Any ideas as to what exactly this is? Thanks **Edit** I found the sd card reader which is a Realtek RTS7227 PCIE card reader in system profiler under pci devices inactive . After hitting power off on the status bar alert, it disappeared so I believe that it is the card reader
  24. I, like many users with notebook hackintoshes have many custom patched kexts and even a few scripts that we need to run to get our system working that aren't present in the main post-install utilities because they're custom and can't be. Which program(s) are used to make this kind of a macpoison-like program?
  25. Zackptg5

    How to Create Post-Installer

    I've used that before. I mean how can I make my own post-installer program?
×