Jump to content

hvolkoff

Members
  • Content Count

    19
  • Joined

  • Last visited


Reputation Activity

  1. Like
    hvolkoff reacted to wmchris in [GUIDE] Dell XPS 15 (9550) Mojave 10.14 / 10.15 Quick Installation   
    i was in contact with the original author @alex.daoud before, and it was quite the opposite of a friendly chitchat. i think his problem is, that he doesnt like to fiddle with any bug reports (quote: "i know all existing bugs") and this binary triggers the usage by people without much knowledge.
    but this is the opposite of an open development, which is very sad.
    i fixed some of the (what the original autor told me as "very hard to fix") bugs like the physical click errors, but i was unable to fix the random crashes. The native and the master branch kexts should be considered as highly unstable and i suggest everyone to stick to VoodooPS2 for now.
    Before someone asks: I didnt push my changes back to the repo, because of the hostile enviroment...  still, if someone is interested in the changes, contact me.
  2. Like
    hvolkoff got a reaction from gujiangjiang in [GUIDE] Dell XPS 15 (9550) Mojave 10.14 / 10.15 Quick Installation   
    New bios 1.2.29:
    http://www.dell.com/support/home/us/en/19/drivers/driversdetails?driverId=F7M6G&fileId=3696502830&osCode=WT64A&productCode=xps-15-9550-laptop&languageCode=en&categoryId=BI
  3. Like
    hvolkoff reacted to wmchris in [GUIDE] Dell XPS 15 (9550) Mojave 10.14 / 10.15 Quick Installation   
    ... 4K Display patch
    ​... again
     
    ... everytime a patch gets released ...
  4. Like
    hvolkoff got a reaction from gujiangjiang in [GUIDE] Dell XPS 15 (9550) Mojave 10.14 / 10.15 Quick Installation   
    Hello,
    Just to let anyone having problems with their audio know, @KNNSpeed just released a new solution for it on the XPS15 9560 thread. I test it on my XPS15 9550 and it is fully compatible (Both the 9560 and 9550 share the same codec), it replaces the CodecCommander kext and the ALCPlugFix, with his VerbStub kext, which solve all sound related problems our machines were facing (Sleep and Line-in for me). If anyone else want to test link is here:
    http://www.insanelymac.com/forum/topic/324366-dell-xps-15-9560-4k-touch-1tb-ssd-32gb-ram-100-adobergb​/page-6#entry2458025
     
    P.S: His solution works alongside AppleALC and Lilu, and, although, his post says it needs a modded version of it, @vit9696 already merged his changed on the official AppleALC repo, so you can grab the latest version from there: (https://github.com/vit9696/AppleALC), you will need to compiled it thought.
  5. Like
    hvolkoff got a reaction from KNNSpeed in [GUIDE] Dell XPS 15 (9550) Mojave 10.14 / 10.15 Quick Installation   
    This is weird.... I applied the "rename ECDV to EC" patch.
    This one:
    <key>Comment</key> <string>change ECDV to EC</string> <key>Disabled</key> <false/> <key>Find</key> <data>RUNEVg==</data> <key>Replace</key> <data>RUNfXw==</data> However the error continues to show up.
     
    EDIT: Sorry, I missunderstood. You meant to change ECDV to EC__ inside the SSDT-Fan. Now everything is working, thanks mate.
    Another thing, can I use the SSDT-Fan from your XPS 9560 build, or is it indifferent/incompatible for the 9550?
  6. Like
    hvolkoff got a reaction from wmchris in [GUIDE] Dell XPS 15 (9550) Mojave 10.14 / 10.15 Quick Installation   
    Hey @wmchris thanks for reposting your tutorial. I think it was really disrespectful what they did to you at TMX, glad to see you here.
    Anyway, just wanted to share some things about the DA200 adapter. Mine came with the Realtek 8153 GBE, and it didn't worked out of the box.
    I had to install this driver: http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=56&Level=5&Conn=4&DownTypeID=3&GetDown=false
    That I found on this gist: https://gist.github.com/MadLittleMods/3005bb13f7e7178e1eaa9f054cc547b0
    Also the USB port on my adapter isn't working with the new hot plug patch (All the rest wok just fine). Maybe is because of the Realtek drive? didn't test before installing it.
    I attached a ioreg saved while the adapter was connected with a pen drive in it's USB port, if something seems wrong please let me know.
    And the DA200 link on the tutorial seems broken, here's a working one: http://accessories.ap.dell.com/sna/productdetail.aspx?c=sg&l=en&s=bsd&cs=sgbsd1&sku=470-abnl
    reg.ioreg.zip
  7. Like
    hvolkoff reacted to Gymnae in [GUIDE] Dell XPS 15 (9550) Mojave 10.14 / 10.15 Quick Installation   
    I decided to join you, it's me, Gymnae.
    I left a goodbye not on the other forum. Such stupid rules
×