Jump to content

Dan ZG

Members
  • Content count

    20
  • Joined

  • Last visited

About Dan ZG

  • Rank
    InsanelyMac Protégé
  1. Clover General discussion

    I tried that ... but it didn't work. In `config.plist` I have: <key>ACPI</key>... <key>DSDT</key>... <key>Name</key> <string>DSDT.aml</string> In ACPI/patched I have: dsdt1.aml dsdt2.aml Clover options shows ACPI DSDT name: `DSDT.aml` -- I left it as is. And yet `bdmesg` *still* shows: Inserting dsdt1.aml from EFI\CLOVER\ACPI\patched ... Success Inserting dsdt2.aml from EFI\CLOVER\ACPI\patched ... Success
  2. Clover General discussion

    I have some questions about DSDT (*.aml) loading in Clover. I've posted in a few places and haven't gotten definitive answers. Say I have 2 (or more) .aml files within EFI/CLOVER/ACPI/patched -- say dsdt1.aml and dsdt2.aml. I want to compare how they affect my machine; as well as NOT loading either of them. So in config.plist I tried 'DSDT Name' set to null, i.e., there is no key/value. But checking bdmesg it shows: Inserting dsdt1.aml from EFI\CLOVER\ACPI\patched ... Success Inserting dsdt2.aml from EFI\CLOVER\ACPI\patched ... Success My questions: Does "Inserting" mean they were both loaded? Or just recognized? Do they have to be called DSDT or can they be called anything? In Clover options /Acpi Patching, if I want to specify which to load, do I include .aml, or just dsdt1? Can I specify a folder in Clover options or does the AML have to reside within /ACPI/patched? If I want to NOT load ANY aml ... Do I need to actually remove them from ACPI/patched? Can I create just an empty file called none.aml and use that in Clover options in order to not load any AML? Is there any definitive way in MacOS to check which (if any) AML has been loaded? (I tried extracting DSDT with "MaciASL.app" but it did not match either of my AML files.) I don't want to remove them from ACPI/patched, because, if for some reason, I can't boot MacOS, then it will be a pain trying to putt them back. Thanks!
  3. Some questions about DSDT (*.aml) loading in Clover

    That's what I thought ... though I typed "xxx" instead of "dsdt3.aml" ... that should block also, yes? So when bdmesg says "Injecting" ... what does that mean? It's not applying them? Is there any way to be sure which AML was loaded, if any?
  4. Say I have TWO .aml files in EFI/CLOVER/ACPI/patched -- dsdt1.aml and dsdt2.aml. I want to compare how they affect my machine. Now, I wanted to try NOT loading either of them. So in config.plist I set 'DSDT Name' set to null, i.e., there is no value. But checking bdmesg it shows Inserting dsdt1.aml from EFI\CLOVER\ACPI\patched ... Success Inserting dsdt2.aml from EFI\CLOVER\ACPI\patched ... Success Does "Inserting" mean they were loaded? Or just recognized? Did BOTH of them get loaded? Do they have to be called DSDT or is that arbitary? Do I need to actually remove them from ACPI/patched in order to NOT load them? I'd like to be able to choose a DSDT, or none, from within Clover at boot. I'm hesitant to remove them because if one option prevents me from booting MacOS, then I'm SOL because putting it back will be a PITA. Can I put them in a different folder and still load one from Clover options? Thanks!
  5. A year or so ago, I upgraded, rather messily, from Chameleon to Clover; and subsequently upgraded OSX a few times (currently 10.12.6). I'm pretty sure my EFI folder, config.plist (and BIOS) contain settings/stuff I don't need and that may actually be hurting. The mobo is a Gigabyte GA-X58A-UD3R and GPU is an Nvidia GTX1050Ti. Hoping someone can give me some advice on what to get rid of... I'm even willing to pay someone for their time (PM me.) 1. In my EFI/CLOVER/kexts/Other/ I have: ACPISensors.kext AppleIntelE1000e.kext AtherosE2200Ethernet.kext CPUSensors.kext FakePCIID_XHCIMux.kext FakePCIID.kext FakeSMC copy.kext FakeSMC.kext GenericUSBXHCI.kext GPUSensors.kext LPCSensors.kext realtekALC.kext RealtekRTL8111.kext 2. In EFI/CLOVER/ I have these empty folders: misc OEM ROM drivers32 drivers32UEFI3. /EFI/CLOVER/drivers64/: AppleImageCodec-64.efi AppleKeyAggregator-64.efi AppleUITheme-64.efi FirmwareVolume-64.efi FSInject-64.efi SMCHelper-64.efi 4. EFI/CLOVER/drivers64UEFI/: AppleImageCodec-64.efi AppleKeyAggregator-64.efi AppleUITheme-64.efi DataHubDxe-64.efi EmuVariableUefi-64.efi FirmwareVolume-64.efi FSInject-64.efi OsxFatBinaryDrv-64.efi SMCHelper-64.efi VBoxHfs-64.efi 5. Do I still need the DSDT.aml in EFI/CLOVER/ACPI/patched/? 6. Do I need EFI/BOOT/BOOTX64.efi? 7. Do I need EFI/APPLE with EXTENSIONS and UPDATERS? 8. In S/L/E I have AppleHDADisabler.kext BrcmFirmwareRepo.kext BrcmNonPatchRAM2.kext BrcmPatchRAM2.kext VoodooHDA.kext Does VoodooHDA replace AppleHDADisabler? 9. I posted my config.plist in this pastebin ... I'm pretty sure there's stuff in there that's no longer relevant, or just wrong, like * DropOEM_DSM * Generate: APLF, APSN, PluginType * darkwake null * USB: Inject, Fix Ownership * A bunch of KextsToPatchin AppleHDA 10. My BIOS settings can be seen here Thanks!
  6. If I were to get a PCIe adaptor ... I need one with a compatible chip, right? What am I looking for? E.g., I see one that says "VL805 + VL812" -- is the the chipset? thanks!
  7. In installed GenericUSBXHCI.kext in S/L/E ... but still nothing. Drive does not appear. Do I have to disable "USB 3.0 onboard controller" in BIOS maybe?
  8. Do you mean from https://bitbucket.org/RehabMan/os-x-generic-usb3/downloads/ ? And install that with Kext Wizard and reboot? Should "onboard USB 3.0" setting be OFF or ON in BIOS? Thanks!
  9. Has anyone been able to get USB 3.0 working on this mobo? I saw the RehabMan github but it's way over my head.
  10. Thanks! Yeah, I'm on amazon now... But I'm wondering ... can I add 2x8GB? I've seen different reports about this mobo having or not having a maximum of 6x4GB. Some people report success with 6x8GB. Could I do 4x4GB + 2x8GB?
  11. Success! Opening the box led me to RTFM of the mobo ... and I discovered I had the 4 chips inserted wrongly. (It's a triple channel 6-slot board, and I was using the wrong slots.) I re-arranged them properly, and now I can see all 4x4. Thanks for all your help!
  12. No XMP option in BIOS anywhere. Set XMP to Yes in config, but made no difference.
  13. XMPDetection = Yes, No, 1, or 2?
  14. It's not set at all in config.plist And by UEFIBIOS you mean in my BIOS settings? I would have to check. Should they both be enabled? thanks!
  15. Anyone have any idea why I can see my my full 16GB RAM (4x4) in BIOS but OSX only shows 12? And 16 TB "wired" .. ha .. Mobo = Gigabyte X58A-UD3R (FH)
×