Jump to content

Glen H

Just Joined
  • Content count

    1
  • Joined

  • Last visited

About Glen H

  • Rank
    InsanelyMac Protégé
  1. Simple Broadcom Wirless Tutorial

    Cloudy: That just means that the card is manufactured by Gemtek using the Broadcom chipset. It shouldn't make a difference, as the card should be detected by its PCI ID, not its MAC address. I have a Compaq C300 family machine and have the same problem with the Broadcom wireless module not being recognized. It does show up in ioreg; here is the entry: | | | +-o PXS3@0 | | | { | | | "AAPL,slot-name" = <"PCI"> | | | "IODeviceMemory" = (({"address"=18446744072904245248,"length"=16384})) | | | "device-id" = <11430000> | | | "IOChildIndex" = 1 | | | "name" = "pci14e4,4311" | | | "acpi-path" = "IOACPIPlane:/_SB/PCI0@0/RP03@1c0002/PXS3@0" | | | "IOName" = "pci14e4,4311" | | | "vendor-id" = | | | "revision-id" = <01000000> | | | "subsystem-vendor-id" = <3c100000> | | | "IOInterruptControllers" = ("io-apic-0") | | | "Power Management private data" = "{ this object = 019b3980, interested driver = 019b3980, driverDesire = 0, deviceDesire = 0, ourDesiredPowerState = 0, previousRequest = 0 }" | | | "Power Management protected data" = "{ theNumberOfPowerStates = 3, version 1, power state 0 = { capabilityFlags 00000000, outputPowerCharacter 00000000, inputPowerRequirement 00000000, staticPower 0, unbudgetedPower 0, powerToAttain 0, timeToAttain 0, settleUpTime 0, timeToLower 0, settleDownTime 0, powerDomainBudget 0 }, power state 1 = { capabilityFlags 00000000, outputPowerCharacter 00000400, inputPowerRequirement 00000400, staticPower 0, unbudgetedPower 0, powerToAttain 0, timeToAttain 0, settleUpTime 0, timeToLower 0, settleDownTime 0, powerDomainBudget 0 }, power state 2 = { capabilityFlags 00000000, outputPowerCharacter 00000002, inputPowerRequirement 00000002, staticPower 0, unbudgetedPower 0, powerToAttain 0, timeToAttain 0, settleUpTime 0, timeToLower 0, settleDownTime 0, powerDomainBudget 0 }, aggressiveness = 0, myCurrentState = 0, parentsCurrentPowerFlags = 00000000, maxCapability = 0 }" | | | "acpi-reg" = <00000000> | | | "IOPCIExpressLinkStatus" = 4113 | | | "class-code" = <00800200> | | | "compatible" = <"pci103c,1363","pci14e4,4311","pciclass,028000"> | | | "subsystem-id" = <63130000> | | | "assigned-addresses" = <1000060200000000000000d00000000000400000> | | | "reg" = <00000600> | | | "IOInterruptSpecifiers" = (<1200000007000000>) | | | } | | | Can anyone provide insight on why the Broadcom kext doesn't find this card?
×