Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

amfbluffer

Members
  • Content count

    2
  • Joined

  • Last visited

About amfbluffer

  • Rank
    InsanelyMac Protégé
  1. 10.6.8 Retail on Dell Inspiron 580 MT (Core i3)

    In case anyone comes back here looking for working NIC drivers after Lion upgrade.. I had upgraded from SL to LION and original BCM5701 drivers from this thread would fail to load. after extensive searching.. found that the Dell 580 MT has a broadcom onboard NIC w/ Device id of 1691 BCM5722 replaced with this one, modified info.plist to show 1691 , reset permissions and worked on first try.. from SL Unknown 57765: Name: ethernet Type: Ethernet Controller Bus: PCI Vendor ID: 0x14e4 Device ID: 0x1691 Subsystem Vendor ID: 0x1028 Subsystem ID: 0x0438 Revision ID: 0x0001 Link Width: x1 BSD name: en0 Kext name: AppleBCM5701Ethernet.kext Firmware version: 255.255 Location: /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleBCM5701Ethernet.kext Version: 2.3.9b6
  2. adding that the Dell 580 MT has a broadcom onboard NIC w/ Device id of 1691 original how-to guide had link for BCM5701 which worked thru SL 10.6.7 upgraded to lion and would fail to load kext on boot. had tried fixing with kext utility to reset permissions which did not work. replaced with this one, modified info.plist to show 1691 , reset oermissions and worked on first try.. spent whole day looking for this.. thanks again..
×