Jump to content

hrox

Members
  • Content count

    15
  • Joined

  • Last visited

About hrox

  • Rank
    InsanelyMac Protégé
  1. I don't find Shrike nor Peregrine in ATIFramebuffer.kext file. I'm using OSX 10.7 Lion. How can I find those?
  2. hrox

    ATI Mobility Radeon HD4330

    I tried to work along mucha's guide. So far, I got this: 02 00 00 00 - 40 00 00 00 - 09 AA - 00 00 - XX - XX - 00 - 07 (LVDS) 00 08 00 00 - 00 02 00 00 - 00 AA - 00 00 - XX - XX - 01 - 08 (HDMI-A) 10 00 00 00 - 10 00 00 00 - 00 AA - 00 00 - XX - XX - 02 - 01 (VGA) For the AAs: Should they be 01 or 00? For the XXs: When I install the RadeonHD.kext my system won't boot up. Sometimes I get a kernel panic, sometimes it just stops before the graphical user interface appears. How can I get those values anyways? Second, I don't know my Device ID. In the system profiler it says: 0x68e0. But when I open chameleon's trunk/i386/libsaio/ati.c file to create a patched boot file and search for 0x68e0 there's no framebuffer related stuff. Last but not least: When I open Lion's ATIFramebuffer with HexEdit and search for the values of Peregrine and others, I get no results. So, that was quite long but I would really appreciate any help since I begin to love OSX on my HackBook ;-) Thanks in advance hrox
  3. Hey mucha and you other guys out there ;-) Hey, I started following mucha's guide. So far I came to this personalities: 02 00 00 00 - 40 00 00 00 - 09 AA - 00 00 - XX - XX - 00 - 07 (LVDS) 00 08 00 00 - 00 02 00 00 - 00 AA - 00 00 - XX - XX - 01 - 08 (HDMI-A) 10 00 00 00 - 10 00 00 00 - 00 AA - 00 00 - XX - XX - 02 - 01 (VGA) For the AAs: Should they be 00 or 01 ? For the XXs: When I load the RadeonHD kext, my system doesn't boot up. Sometimes I get a kernel panic and sometimes it just stops when "DSMOS arrived" appears. No graphical user interface. How can I examine the transmitter and the encoder anyways? Thanks in advance. hrox Another important thing: How can I find out my device ID? In the system profiler it says 0x68e0 but when I open i386/libsaio/ati.c in chamelon's trunk folder, it only says: { 0x68E0, 0x04561028, CHIP_FAMILY_CEDAR, "ATI Radeon HD 5470M", kEulemur }, { 0x68E1, 0x1426103C, CHIP_FAMILY_CEDAR, "ATI Radeon HD 5430M", which has to do neither with the framebuffer nor my ATI Radeon HD4330 card. So that device ID might be wrong?
  4. hrox

    Battery State

    Hey guys, how can I make OSX display my battery's status? In System Settings -> Power Saving it always says 0%. Additionally, I think the CPU fan is always on full power. How can I get Power Management to work on my HP Probook 4720s? thanks in advance hrox Edit: And how can I change the display brightness?
  5. I just installed [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] ([url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]) and ran Kext Utility. I'll try to reboot now The fold /E/E exists now, as does FakeSMC. Edit: It works now! Thanks for your help, Noam AA. Slowly, I get this HackBook to work ;-) By the way: How can I change this forum to display all posts on one site like in most forums?
  6. In my /Extra/ folder there is NO Extensions folder. /Extra/Extensions does NOT exist. (It's OSX 10.7 if that matters )
  7. In the MKext tool I dragged the whole content of my /System/Library/Extensions folder into it and chose build. The resulting file ist 26 MB which can't be correct since the Extensions.mkext on the USB device is only som kB...
  8. Hey, I did what you suggested, but without success. Just to clarify things: The bootloader on the HDD DOES appear, I AM able to select Lion, it DOES start booting up, but right before the graphical interface should appear, it STOPS. The USB stick's bootloader on the other hand continues. hrox I will try this, but at the moment I've installed Chimera on my HDD. Does that make a difference? hrox In the USB stick's Extra folder there's an "Extensions.mkext" file and int the com.apple.Boot.plist file there's an argument "Rescan"="Yes". Is it possible that the bootloader uses additional kernel extensions that are on the USB stick and that are necessary to boot into the graphical system?
  9. Hi, thanks for your reply. I installed them by package. I'm perfectly sure the BIOS boots the right HDD. hrox
  10. Hey guys, I installed OSX Lion via the USB method. I can boot it up only with the bootloader from the USB stick which is Chameleon RC5. I tried installing Chameleon RC5 and Chimera on my PC, I even copied the boot.plist from the USB device to my HDD but still I can only boot by using the USB stick's bootloader. Any ideas how to fix that? Thanks in advance hrox
  11. Hey guys, does anybody know how to get the ATI Mobility Radeon HD4330 to work with OS X 10.7? When I install any ATI kexts, I only get a black screen after the boot. Right now I only have a really bad resolution and everything is _really_ slow. Thanks hrox
  12. Simple and brilliant, thanks so much, it works
  13. Hey guys, I finally created a bootable USB device containing the Lion installer. Additionally, I included the VoodooPS2Controller.kext in the USB stick's System/Library/Extensions for my notebook's internal keyboard and touchpad. After booting the installation with -f flag, the installation gets stuck at a weird animation that probably asks me to power on the keyboard and the mouse. How can I skip forward? The touchpad and keyboard DO work as I can move the cursor. Thanks in advance hrox Edit: This is - basically - what it looks like:
  14. hrox

    Please guide me "how to for Mobility HD 4330"

    Hi Ligerzero459, I did what you said in order to get the graphics working on my HP Probook 4720s with Mobility Radeon 4330. Unfortunately it didn't work so far. I installed the Retail DVD via the OSX86 Mod CD and updated to 10.6.8. I downloaded and installed the QE/CI Exotic Patch for 10.6.8 from kexts.com. [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] was already installed, I reran it with everything you mentioned. I rebooted and in verbose mode, it boots up to DSMOS arrived. Then a black screen appears. Nothing else happens. :-( Do you have any idea what to do? Thanks in advance hrox
  15. /EDIT: Upgraded to Lion
×