Jump to content
InsanelyMac Forum

ultrazonestudios

Members
  • Content count

    22
  • Joined

  • Last visited

About ultrazonestudios

  • Rank
    InsanelyMac Protégé

Profile Information

  • Gender
    Male
  1. ultrazonestudios

    [HOW TO] Modification of AMD FB + Clover injection

    I'm getting the same results with Aji and Hamachi. Thanks!
  2. ultrazonestudios

    [HOW TO] Modification of AMD FB + Clover injection

    Hi ! I believe I need some help on this one... My card is a Sapphire Dual-X R9 280X 3G D5 (1002,6798). It has a DisplayPort connector, an HDMI, a DVI-D and a DVI-I. I want to use three displays, but no matter what I try, only two are able to fire up when reaching the desktop. My displays are connected via DisplayPort, HDMI and DVI-D, and none of the DVI connectors turn on. Every single display works fine when it is the only one connected to the card, and every combination of two monitors works too without problems, so this fact leads me to believe the solution could be easy. These are my radeon & redsock dumps: ATOM BIOS Rom: SubsystemVendorID: 0x174b SubsystemID: 0x3001 IOBaseAddress: 0x0000 Filename: 249L0C00.U46 BIOS Bootup Message: Tahiti B0 XTL C38650 GDDR5 3GB 500e/150m PCI ID: 1002:6798 Connector at index 0 Type [@offset 43578]: DisplayPort (10) Encoder [@offset 43582]: INTERNAL_UNIPHY2 (0x21) i2cid [@offset 43696]: 0x90, OSX senseid: 0x1 HotPlugID: 5 Connector at index 1 Type [@offset 43588]: HDMI-A (11) Encoder [@offset 43592]: INTERNAL_UNIPHY2 (0x21) i2cid [@offset 43723]: 0x91, OSX senseid: 0x2 HotPlugID: 4 Connector at index 2 Type [@offset 43598]: DVI-D (3) Encoder [@offset 43602]: INTERNAL_UNIPHY1 (0x20) i2cid [@offset 43750]: 0x92, OSX senseid: 0x3 HotPlugID: 1 Connector at index 3 Type [@offset 43608]: DVI-I (2) Encoder [@offset 43612]: INTERNAL_UNIPHY (0x1e) i2cid [@offset 43787]: 0x95, OSX senseid: 0x6 HotPlugID: 3 Connector at index 4 Type [@offset 43618]: DVI-I (2) Encoder [@offset 43622]: INTERNAL_KLDSCP_DAC1 (0x15) i2cid [@offset 43787]: 0x95, OSX senseid: 0x6 HotPlugID: 3 249L0C00.U46: Tahiti B0 XTL C38650 GDDR5 3GB 500e/150m Subsystem Vendor ID: 174b Subsystem ID: 3001 Object Header Structure Size: 384 Connector Object Table Offset: 48 Router Object Table Offset: 0 Encoder Object Table Offset: 118 Display Path Table Offset: 12 Connector Object Id [19] which is [DISPLAY_PORT] encoder obj id [0x21] which is [INTERNAL_UNIPHY2 (osx txmit 0x12 [duallink 0x2] enc 0x4)] linkb: false Connector Object Id [12] which is [HDMI_TYPE_A] encoder obj id [0x21] which is [INTERNAL_UNIPHY2 (osx txmit 0x22 [duallink 0x2] enc 0x5)] linkb: true Connector Object Id [4] which is [DVI_D] encoder obj id [0x20] which is [INTERNAL_UNIPHY1 (osx txmit 0x11 [duallink 0x1] enc 0x2)] linkb: false Connector Object Id [2] which is [DVI_I] encoder obj id [0x1e] which is [INTERNAL_UNIPHY (osx txmit 0x10 [duallink 0x0] enc 0x0)] linkb: false Connector Object Id [2] which is [DVI_I] encoder obj id [0x15] which is [INTERNAL_KLDSCP_DAC1 (osx txmit 0x00 enc 0x10?)] linkb: false Here are the framebuffers included in the AMD7000Controller.kext from 10.10.5: -------------------------AMD7000Controller.kext------------------------- Ramen (6) @ 0x1a2c50 LVDS, HDMI, DP, DP, DP, DP 02000000000100002904010020010506 00080000040200000001020010000305 00040000040300000001030711020101 00040000000100000001040321030403 00040000040300000001050712040202 00040000000100000001060322050403 Namako (4) @ 0x1a2d20 LVDS, LVDS, DP, DP 02000000000100000001010322050202 02000000000100000001020312040101 00040000040300000001030711020303 00040000040300000001040721030404 Aji (4) @ 0x1a2dc0 DP, DP, DDVI, HDMI 00040000040300000001010112040501 00040000040300000001020122050402 04000000140200000001030000000306 00080000040200000001040011020104 Buri (4) @ 0x1a2e00 LVDS, DP, DP, HDMI 02000000000100002905010010000505 00040000040300000009020011020101 00040000040300000009030021030202 00080000040200000001040012040303 Chutoro (5) @ 0x1a2e40 LVDS, DP, DP, DP, DP 02000000000100000901010012040303 00040000040300000001020111020101 00040000000100000009030021030202 00040000000100000009040022050404 00040000040300000001050010000505 Dashimaki (4) @ 0x1a2e90 DP, DP, DDVI, HDMI 00040000040300000001010112040202 00040000040300000001020022050305 04000000140200000001030100000404 00080000040200000001040011020101 Ebi (5) @ 0x1a2ed0 LVDS, DP, DP, DP, DP 02000000000100000901010012040303 00040000040300000001020111020101 00040000000100000009030121030202 00040000000100000009040122050404 00040000040300000001050110000505 Gari (5) @ 0x1a2f20 LVDS, DP, DP, DP, DP 02000000000100000901010012040303 00040000040300000001020111020101 00040000000100000009030021030202 00040000000100000009040022050404 00040000040300000001050010000505 Futomaki (4) @ 0x1a2fa0 DP, DP, DDVI, HDMI 00040000040300000001010112040401 00040000040300000001020122050502 04000000140200000001030000000606 00080000040200000001040011020103 Hamachi (4) @ 0x1a2fe0 DP, DP, DDVI, HDMI 00040000040300000001010112040501 00040000040300000001020122050402 04000000140200000001030000000306 00080000040200000001040011020104 OPM (6) @ 0x1a3060 DP, DP, DP, DP, DP, DP 00040000040300000001000111020101 00040000040300000001000121030202 00040000040300000001000112040303 00040000040300000001000122050404 00040000040300000001000110000505 00040000140300000001000120010606 Ikura (1) @ 0x1a30c0 HDMI 00080000040200000001010012040301 IkuraS (6) @ 0x1a30d0 DP, DP, DP, DP, DP, DP 00040000040300000001010711020103 00040000040300000001020721030204 00040000040300000001030712040301 00040000040300000001040722050402 00040000040300000001050710000505 00040000040300000001060720010606 Junsai (6) @ 0x1a3130 DP, DP, DP, DP, DP, DP 00040000040300000001000112040301 00040000040300000001000122050402 00040000040300000001000111020103 00040000040300000001000121030204 00040000040300000001000110000505 00040000040300000001000120010606 Kani (1) @ 0x1a3190 HDMI 00080000040200000001010012040301 KaniS (6) @ 0x1a31a0 DP, DP, DP, DP, DP, DP 00040000040300000001010711020103 00040000040300000001020721030204 00040000040300000001030712040301 00040000040300000001040722050402 00040000040300000001050710000505 00040000040300000001060720010606 DashimakiS (4) @ 0x1a3200 DP, DP, DDVI, HDMI 00040000040300000001010112040202 00040000040300000001020122050305 04000000140200000001030000000404 00080000040200000001040011020101 Maguro (1) @ 0x1a3240 HDMI 00080000040200000001010012040301 MaguroS (6) @ 0x1a3250 DP, DP, DP, DP, DP, DP 00040000040300000001010711020103 00040000040300000001020721030204 00040000040300000001030712040301 00040000040300000001040722050402 00040000040300000001050710000505 00040000040300000001060720010606 Since Clover injects Futomaki by default, this is the framebuffer I chose for editing. It has four ports (like my card) and HDMI audio worked OOB on at least one screen, so I thought it was a good candidate. So I turned what is contained within Futomaki: Futomaki (4) @ 0x1a2fa0 DP, DP, DDVI, HDMI 00040000040300000001010112040401 00040000040300000001020122050502 04000000140200000001030000000606 00080000040200000001040011020103 into: 00040000040300000001010112040501 - DP 00080000000200000001020122050402 - HDMI-A 04000000140200000001030011020103 - DVI-D 04000000040200000001040000100306 - DVI-I ...but it didn't work. The only change was that there were two HDMI audio connections available now (both in the displays that were up and running: DisplayPort and HDMI), so the problem with DVI connection was still there. So I tried again, changing this time the order of initialization of ports to DVI-D, HDMI, DP and DVI-I, but I got the same results. That's why now I'm wondering what could be the best way to keep on trying. So I've attached all the necessary information about my system (DSDT & SSDT, ioregs and config.plist of every change made) in the hope that someone could help me. Sorry for the long post and thanks in advance! ultrazone_baseline.zip
  3. ultrazonestudios

    [Guide] Gigabyte Z77X UD5H Clover UEFI Install/Tweak guide

    I've been using a custom DSDT since Pjalm started offering his patches. I've always extracted my DSDT using Clover and with the LSI FW643 plugged in. No dice... Everytime Pjalm updates his repository of patches I update my DSDT, using the Clover extradited one as the starting point. No difference through all these years... Thanks for sharing your ideas!
  4. ultrazonestudios

    [Guide] Gigabyte Z77X UD5H Clover UEFI Install/Tweak guide

    Yes, I only have shutdown/sleep problems when the StarTech 800mbps card (LSI FW643 based, as you mention) is connected. If I remove it, everything works ok. Regarding onboard Firewire ports, they do work, but occasionally the system hangs. Since I use Pro Tools and a MOTU Firewire interface, an stable Firewire connection is a must for me. That's why I need a PCIe Firewire adapter. Currently I'm using another Firewire card from StarTech (which only supports 400mbps) and with it there is no problem at all. But since I bought the 800mbps version first, I would like to put it to use. It is good to know that your Firewire driver is useless in my setup, but anyway I've found your BIOS to be more stable than F16g. With F16g from time to time BIOS got stuck so the computer didn't boot, and I had to reset CMOS to use the machine again. This has never happened with your F16 version. Thanks! Going back to the Firewire problem, is there anything I can do? In the thread I posted before everyone agrees in a BIOS poor Firewire implementation as the main source of problems with this LSI FW643 card. I've tried with every official BIOS version to no avail. I've also tried mods and betas (mainly F16 based) and I've had the same problems. Right now I use the 400mbps card, but maybe in the future I need 800mbps connectivity and I'm looking for possible solutions. Thanks everyone!
  5. ultrazonestudios

    [Guide] Gigabyte Z77X UD5H Clover UEFI Install/Tweak guide

    Hi again! It is disabled. This mobo seems to have this problem since F14 BIOS version. It is well documented in this thread: http://www.tonymacx86.com/general-help/65531-gigabyte-uefi-bios-startech-firewire-pcie-card-sleep-wake-shutdown-restart-issues-thread.html Thanks in advance!
  6. ultrazonestudios

    [Guide] Gigabyte Z77X UD5H Clover UEFI Install/Tweak guide

    Hi! Your BIOS works great in my system, but it hasn't solved the problem I have related to FireWire: I'm using a PCIe StarTech FireWire card (2 800mbs ports + 1 400mbps port) and it is impossible to shutdown the computer with the card inserted, it just reboots again. Sleep doesn't work neither, it goes to sleep but immediately it wakes up. I've been trying different BIOSes to no avail, this card seems to broke shutdown and sleep. Any ideas on how to solve this? Thanks in advance!
  7. ultrazonestudios

    [Guide] Gigabyte Z77X UD5H Clover UEFI Install/Tweak guide

    Thanks! I'll try your BIOS and post results over here...
  8. ultrazonestudios

    [Guide] Gigabyte Z77X UD5H Clover UEFI Install/Tweak guide

    Hi! Since I use Firewire & USB audio that's not a problem to me. Thanks in advance! I would like to try your BIOS. I'm also on Ivy Bridge, so it seems perfect for me, please send it to me. Thanks in advance!
  9. ultrazonestudios

    [Guide] Gigabyte Z77X UD5H Clover UEFI Install/Tweak guide

    Would you mind sending to me your BIOS? I've had bad experiences with F16g and I would like to try yours. By the way, my board is rev 1.0. Is your BIOS compatible with this revision? Thanks in advance!
  10. ultrazonestudios

    [Guide] Gigabyte Z77X UD5H Clover UEFI Install/Tweak guide

    Thanks ! This BIOS is working great here !
  11. ultrazonestudios

    [Guide] Gigabyte Z77X UD5H Clover UEFI Install/Tweak guide

    Thanks a lot dudes !!! Could someone please post the complete list of mods present in this BIOS ? Right now I'm playing with F16-mod8 from tweaktown. Everything but FireWire spamming seems to be working great, so I would like to know the benefits/changes in your posted BIOS in order to decide which one to use. Thanks again !
  12. ultrazonestudios

    [Guide] Gigabyte Z77X UD5H Clover UEFI Install/Tweak guide

    Thanks ! Your post gives hope but... how ???
  13. ultrazonestudios

    [Guide] Gigabyte Z77X UD5H Clover UEFI Install/Tweak guide

    Hi ! I know it's a little off-topic but, is there a way to completely disable integrated Firewire in this board ? Maybe removing some modules from BIOS (those related to the VIA integrated FW controller) ? I would like to stop spamming about Firewire in Console. I'm using FirewireDriver.efi in my drivers64UEFI folder, but anyway the error appears after wake. I'm not using the integrated FW controller (using a dedicated PCIe adapter), so I would prefer to disable it completely. Thanks in advance !
  14. ultrazonestudios

    Ozmosis

    Thanks again, I'll try it and keep you posted.
  15. ultrazonestudios

    Ozmosis

    Here you have... dsdt-ssdt.zip Thanks a lot xpamamadeus !
×