Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About lofie127

  • Rank
    InsanelyMac Protégé
  1. Yosemite: Audio - Realtek ALC AppleHDA

    so all credit to toleda and friends... finally got audio on this mb to work, * Yosemite 10.10.1 * g14m-es2l ver 1.0 with the F9 bios. * chameleon boot loader : Chameleon 2.3svn (svn-r2510) (chameleon seems to work to better on this non oaf mb than clover) 1) First the DSDT, use this to set the audio layout_id - Extracted the original using maciasl - Patched using the patch pack for this mb from http://olarila.com/forum/packs.php (had to hand fix a couple of compile errors) - Patched the layout_id to 0x02 : "layout-id", Buffer (0x04) { 0x02, 0x00, 0x00, 0x00 }, (attached below) 2) Chameleon config Edit /Extra/org.chameleon.Boot.plist - Remove any HDAEnabler AND HDEFLayoutID - Set the boot {censored}, "PCIRootUID=1" and remove "npci=..." <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>EthernetBuiltIn</key> <string>Yes</string> <key>GraphicsEnabler</key> <string>No</string> <key>IGPEnabler</key> <string>No</string> <key>Kernel Flags</key> <string>kext-dev-mode=1 PCIRootUID=1 -v</string> <key>Legacy Logo</key> <string>no</string> <key>Timeout</key> <string>2</string> <key>GenerateCStates</key> <string>Yes</string> <key>GeneratePStates</key> <string>Yes</string> <key>UseKernelCache</key> <string>Yes</string> </dict> </plist> And delete the HDAenabler.dylib from /Extra/modules is empty. Important to reboot before the next step. 3) Run the AppleHDA patcher script (you can find it here) https://github.com/toleda/audio_RealtekALC audio_realtekALC-90_v2.0.4.command … Confirm Realtek ALC887 (y/n): y 887 Legacy/v100202 (y/n)?: n Enable HD4600 HDMI audio (y/n)?: n … Even though this mb has an ALC 888b - these setting worked (please correct if you think other settings would be better) So many thanks. Cheers A
  2. [Guide] [Mavericks & Yosemite] AMD Radeon HD5450

    here is what works for me. (Or what to do if you can not find an Info.plist to edit) Turns out to be quite straight forward, and simply a matter of editing the Info.plist files as mentioned already in this thread. The main problem is simply, like others, there is no Info.plist to modify for the AMD5000Controller.kext in /S/L/E. Using Pacifist to unpack the installer did not help either However looking in /S/L/E on the install USB which had been created using !!!!Bleep!!!! there is AMD5000Controller.kext with an Info.plist. Copy the AMD5000Controller.kext from you newly installed mavericks os disk /S/L/E to desktop Copy Info.plist + version.pllist from the USB installer/S/L/E/AMD5000Controller.kext/Contents to Desktop/AMD5000Controller.kext/Contents Edit Info.plist to add your card ID to IOPCIMatch as already mentioned in this thread. Install this kext using kextutiliity Set GraphicsEnabler=no in /Extra/org.chameleon.Boot.plist Reboot As for AMDRadeaonX3000.kext, Info.plist already exists and had my card id in there. That's all. No need to download kexts from anywhere. Thanks DrHurt for starting this thread. Cheers A