Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About stargex

  • Rank
    InsanelyMac Protégé
  1. Trying to get ATI 5650 Mobility to work.

    It was modifying my DSDT that I believe fixed the problem. I had help from MaLd0n. Haven't had a chance to work on hackintosh though lately. Hopefully will get time later this week.
  2. DSDT Auto-Patcher

    Alrighty. Well thanks for all the help! I know its got to be time consuming.
  3. DSDT Auto-Patcher

    There was nothing there with Wake. No output from the command.
  4. Trying to get ATI 5650 Mobility to work.

    Alright. I modified the bool.plist file to include that snippet of code and changed the 0xFFFF0000 to match my device id, using 0x00468086. This didn't seem to do anything. I did get a little farther. OS X is finally seeing my ATI 5650 card which it previously was not. Still is picking the Intel adapter to use instead of the ATI card. Am I missing something here? Now that OS X sees both is it possible to switch it?
  5. DSDT Auto-Patcher

    When I click sleep the mouse cursor disappears and comes back in a couple seconds and will not move ofor another couple seconds. Nothing more. I did find this in the kernel log: Apr 18 15:47:57 SquallyDocs-Mac-Pro kernel[0]: sizeof(IOHibernateImageHeader) == 512 Apr 18 15:47:57 SquallyDocs-Mac-Pro kernel[0]: Opened file /var/vm/sleepimage, size 6442450944, partition base 0x5c06e000, maxio 400000 ssd 0 Apr 18 15:47:57 SquallyDocs-Mac-Pro kernel[0]: hibernate image major 14, minor 3, blocksize 512, pollers 5 Apr 18 15:47:57 SquallyDocs-Mac-Pro kernel[0]: hibernate_alloc_pages flags 00000000, gobbling 0 pages Apr 18 15:47:57 SquallyDocs-Mac-Pro kernel[0]: hibernate_setup(0) took 0 ms Apr 18 15:47:58 SquallyDocs-Mac-Pro kernel[0]: System Doze Apr 18 15:48:09 SquallyDocs-Mac-Pro kernel[0]: AppleACPIBatteryManager::setPowerState(0xffffff800f8ba400, 0 -> 1) timed out after 10383 ms Apr 18 15:56:02 SquallyDocs-Mac-Pro kernel[0]: System Doze Apr 18 15:56:12 SquallyDocs-Mac-Pro kernel[0]: AppleACPIBatteryManager::setPowerState(0xffffff800f8ba400, 0 -> 1) timed out after 10386 ms Apr 18 15:56:46 SquallyDocs-Mac-Pro kernel[0]: System Doze Apr 18 15:56:57 SquallyDocs-Mac-Pro kernel[0]: AppleACPIBatteryManager::setPowerState(0xffffff800f8ba400, 0 -> 1) timed out after 10384 ms Not sure if it means much to you. Here is the output of ioreg: SquallyDocs-Mac-Pro:~ SquallyDoc$ ioreg -lw0 | grep CSTInfo | | "CSTInfo" = 19136773
  6. DSDT Auto-Patcher

    MaLd0n, I already have those values in my boot.plist with Yes on them. Here is the kextstat you asked for. Thanks for the help! kextstat.txt
  7. Trying to get ATI 5650 Mobility to work.

    I would love to get both working. Though if I have my IntelHD kexts installed I can't get to the desktop. It looks like it just hangs while booting with no errors when I have them. Once removed it worked just fine. I thought I'd work on getting my ATI card working as that is more important to me. Once that is done I'll move to the Intel card perhaps. I'll try adding the code to my to my boot.plist file tonight and see what that does (with the device ID replacement). I had at one time replaced it in the ATIRadeonX3000.kext but that didn't do anything. Probably because it wasn't an ATI card like you mentioned. Didn't know that file was just for disabling an ATI card.
  8. DSDT Auto-Patcher

    Hey MaLd0n, Thanks for the DSDT and the quick reply. I tried it out. It fixed my USB problem. Unfortunately I am still unable to put my laptop to sleep and still no Audio. On the plus side I can now boot without having a KP from AppleIntelCPUPowerManagement.kext when I don't have the NULLCPUPowerManagment.kext installed. I'm also seeing outputs about some sound problems while booting which I didn't see before. I've attached the kernel log if you are interested in looking at it. Also includes an attempt to put the computer to sleep at the end. Thanks again!
  9. Hey, I have seen that some people have been able to get their ATI 5650 Mobility cards to work. I have been unable to get mine working and was hoping to get some help. I have tried using both Lion kexts and the new Snow leopard MBP kexts. I am using Kabyl's boot as well. I think my problem is that Mac OS X just keeps picking up my Intel HD Graphics card instead of the ATI 5650 card. There is no switch in my BIOS to use only the ATI card. I have tried to disable my Intel card by adding the following to my ATIRadeonX3000.kext. <key>IOPCIClassMatch</key> <string>0x03000000&0xFFFF0000</string> However that doesn't seem to make a difference. Am I missing something here? Do the have the string incorrect? Is there another way to disable the Intel HD Graphics card? I have also noticed that when I run kextstat none of the ATI kext seem to be loaded. Is this normal? Not quite sure how the ATIRadeonX3000.kext is supposed to disable my Intel HD card if it isn't loading. Thanks for any help.
  10. DSDT Auto-Patcher

    I'm a little new to DSDTs. I tried running the Auto-Patcher for my HP Dv6t-3100 using the HP DV6 setting. However I seem to be getting compilation errors while running it. So I decided to post the errors here: [Line 2274 type Error message Object does not exist (SLPB)] [Line 13742 type Error message Object does not exist (\_SB.PCI0.RP05.J380)] Currently I am not using any DSDT. I'm having problems with sleep (mouse cursor disappears for a couple seconds and comes right back with nothing else happening), sound (nothing recognized...), and some USB ports do not work (left don't work, right are fine). I have attached the send_me file. Seems like some people have had success with fixing these via patched DSDTs. Think you could help? Thanks for your time. send_me.zip
  11. This worked for me, thanks!. Finally got to my desktop with the taptun_kernel on 10.6.7 with all CPUs and 64-bit! Now I just have audio, graphics hardware acceleration, and my left USB port doesn't work. Let's see what I can figure out!
  12. I seem to be having the same problem as ddduckman. I have tried what you suggested by removing the ATI kexts and turning off the GraphicsEnabler and to no avail. Even tried to use the Lion ATI kexts and Kabyl's RC5 branch. All it seems to do it hang on start. It was working for me in 10.6.3 but as soon as I try 10.6.7 I get this problem. Could it be related to using switchable GPU?
  13. Where you able to fix your problem at all? I believe I am having the same problem with my OS X install. It just seems to hang on startup with no errors, never going to the GUI.
  14. Well I got a little farther today. I tried using the legacy_kernel; however, I couldn't get that to work using busratio=20 (20 for my CPU). I then tried cpus=1 busratio=20 and that didn't work. I took a picture of the output I got. Little blurry as the screen is only on for a few seconds before a reboot. I also had the same problem while booting to 10.6.3. Bilieved this was also using the legacy_kernel since I am using the MIIF i5i3. In order to get that to boot I had use the arguments "-v maxmem=4096 arch=i386". Problem is I was unable to use my trackpad (I have only ever been able to use it once and that was via the i5i3 boot cd), any USB, or keyboard. So I couldn't go any farther. I then tried the mach_kernel; however I couldn't get anything going with that at all. Seemed to be unable to find the right version i think. I can grab a picture of it if it would help. Anyone have any ideas. I'm completely at a loss. I tried this all with and without the DSDT I made earlier...
  15. @Atlee, Actually my DSDT was created clean using Ubuntu. Thought this was supposed to create a clean DSDT that should work for my system.... Sorry still new to DSDTs. @all I'll try out what everyone suggested and see it it works for me tonight. Thanks!