Jump to content

George123

Members
  • Content count

    25
  • Joined

  • Last visited

About George123

  • Rank
    InsanelyMac Protégé
  1. George123

    Intel HD Graphics / GMA 5700

    Dear All, I am going to stop for a while. I tried so many times. It seems that appleintelhdgraphicsFB.kext is a big problem. I will wait for 10.6.5 update. Because some body said that even real macbookpro has problem with the video card. I think Apple company will correct it in the next version. stuart, No matter it is one screen or 4 screen. Could you try to use SYSTEM PROFILER to check the kext load? And a very useful link is http://www.insanelymac.com/forum/index.php?showtopic=208410 READ THIS: 6. Reboot, wait a while, or do whatever it takes to boot so the display is NOT right (stretched, wrong resolution, whatever). If your 'bad' display is so bad you cannot use it, first go to System Preferences -> Sharing, checkmark Screen Sharing, and enable a password under Computer Settings. Note the vnc:// address. Using a second computer, connect to the vnc:// address and continue the instructions remotely. If you're using Windows, use TightVNC. I have not tried it. Because I can control my desktop in the mass screen. Hope you can find what it is loaded. George123
  2. George123

    Intel HD Graphics / GMA 5700

    Dear All, After many times trying. I know why the AppleIntelHdGraphicsFB.kext does not loaded. The problem is SMBIOS.plist. If I set it to MacbookPro6,1 (here 6,1 is not 6.1), I can get 4 screens. If I set it to others, I can't enter into the desktop. I guess that Macbook6,1 is Nvidia +Intel 5700. If we can find correct smbios.plist (macbook or macbook air with 5700 only), we can get correct resolution. Please comments.
  3. George123

    Intel HD Graphics / GMA 5700

    Dear sockerkid, In my opinion, only AppleIntelHdGraphicsFB.kext + smbios.plist (macbookpro6.1). If I change 6.1 to 6.2 or what ever, I can't enter the desktop. I looked inside of AppleGraphicsPowerManagement.kext, only macbookpro6.1 and macbookpro6.2 has 00468086. I think smbios.plist is very important. Could you put my smbios.plist inside of 'Extra' and try again.
  4. George123

    Intel HD Graphics / GMA 5700

    Dear All, I tried again. I found that I have to use macbookpro smbios 6.1. And delete 0x428086 in AppleIntelHdGraphicsFB.kext. Then I can get AppleIntelHdGraphicsFB.kext loaded. But it is 4 screens. smbios.plist.zip If I do not use 6.1 smbios.plist or change it to 6.2, I will get Super IO:Probing NSC Super IO:Probing ITE Super IO:Probing Flintek Super IO:Probing SMSC Super IO:Probing Winbond Super IO:No supported Super I/O chip has been detected! PTKawainVi:started PTKawainVi:No nViddia graphics adapters found Error: CODE SIGNING: cs_invalid_page(0x33000): p=106[HardwareMonitor] clearing CS_VALID
  5. George123

    Intel HD Graphics / GMA 5700

    Dear sockerkid, dsdt.aml is not important for the 4 screen. I tried to delete every thing (including dsdt.aml, boot.plist, Appleintelgraphiccontrol.kext). The 4 screens are the same and no any changes. You must delete 00428086 in the appleintelHDgraphicsFB.kext. ONLY leave 00468086. I am sure you can get 4 screens. Both32 & 64 mode. Experience: If I leave appleintelHDgraphics.kext in the /S/L/E/ only. I can get normal screen without E/CI. In the kextload list, I can see appleintelHDgraphics.kext are loaded. If I put appleintelHDgraphicsFB.kext in /S/L/E/, I will get 4 screens. In the kextload list, I only can see appleintelHDgraphicsFB.kext are load. The appleintelHDgraphics.kext are not loaded. If we can load both kexts, I am sure we will succeed. I have not tried SAFARI 5. I will try it later.
  6. George123

    Intel HD Graphics / GMA 5700

    Dear sockerkid, I am sorry to reply your mail late. Recent weeks I was very busy for works. After read your post, I checked my x201i again. It seems that I lead you to wrong direction. 1. My system is 10.6.4 with 64 mode. 32 mode can't enter into the desktop. 2. Natit is not necessary. You can delete it. 3. You only need to add 00468086 in the info.plist of AppleIntelHDGraphicsFB.kext. Summary: run 64 mode, only leave AppleIntelHDGraphicsFB.kext in the /S/L/E. Even no AppleIntelHDGraphics.kext Try it. My new find: AppleIntelHDGraphics.kext does not loaded. Even I delete AppleIntelHDGraphics.kext, the desktop is four. So now I try to find a way to load AppleIntelHDGraphics.kext If I have any news, I will tell you.
  7. George123

    Intel HD Graphics / GMA 5700

    Dear All, Recent days I am busy for meeting. I have no time to try now. I will do it later. I attached my Natit file to you again. Because the Natit I attached before is not complete. What I was do is to change X3100 to GEN575. I guess that GEN575 is the name of Intel HD graphics. Hope it is complete. I tried it again. It seems that I can't boot with x32. With X32, the screen will never enter the desktop (four screen). Natit.kext.zip
  8. George123

    Intel HD Graphics / GMA 5700

    Dear sockerkid, I think we have to concentrate to load AppleIntelIntegratedFramebuffer.kext. So we have to find a way to add the GFX String in the com.boot file. Or to find a Natit. Until now I have not found it.
  9. George123

    Intel HD Graphics / GMA 5700

    Dear All, I tried different methods today. But I am failed in the end. I think I have to put the GFX String in the com.apple.Boot.plist. Because I can't load the AppleIntelIntegratedFramebuffer.kext. However, I made my own GFX string for my ATI X1600 long time ago according to an article. I can't find it now. Anyone can teach me how to generate my GFX String for the 5700MHD?
  10. George123

    Intel HD Graphics / GMA 5700

    Dear All, Although my 5700MHD does not work properly now, but I am very glad to share my experience. Hope we can solve this problem. My specification is: IBM X201i with i3 330M 5700MHD I installed 10.6.3 at the first. Then I updated it to 10.6.4 with Combo update package. However, after restart, I can't enter into the desktop. Fortunately, each time, before I do big updating, I will clone the system with Carbon Copy Cloner to the second or third partition. This is very useful backup for me. Then I entered the backup system and delete all the Intel graphic kexts. I can enter into the desktop now. I modified the plist in each kexts. (I change the code to 5700MHD) 00428086. After reboot, nothing happened. The kexts were not loaded. I think the kexts must be loaded. So I used a GMA950 Natit (I modified the code to 00428086). Then 4 screen happens. After that, no matter I use Natit or not, the screen is 4 screens. Only after deleted AppleIntelHDGraphicsFB.kext, the screen will go back without QE/CI. As sockerkid suggested, I installed GFXcardstatus. But it is too bad. The 4 screens shows only half screen. So I can't click the icon on the right up menu bar. I will study it later. I can't find the solution. But I 'd like to share my DSDT.AML. and other kexts. Hope they are helpful for all of you to find a good solution. By the way, I tried to change my frequency from 50Hz to 60Hz. It is same. Following is my kexts loaded. The AppleIntelIntegratedFramebuffer does not loaded. All my files. I can't guarantee the effect 5700MHD.zip The Natit file I used. (I change the X3100 item to Gen575.)Natit.kext.zip
  11. George123

    Intel HD Graphics / GMA 5700

    Dear All, I tried to put these kexts into the /S/L/E. But I got 4 screens. I tried to save the graphic card information into txt. It seems that the kexts were loaded. However, the VRAM is 288MB. Without the Kexts, the VRAM is only 64 MB. I think the problem is the share RAM. The RAM can't be fixed by the system. ANy comments on it? Intel HD Graphics: 芯片组型号: Intel HD Graphics 类型: GPU 总线: 内建 VRAM(总和): 288 MB 厂商: Intel (0x8086) 设备 ID: 0x0046 修正版 ID: 0x0002 显示器: 显示器: 分辨率: 1280 x 800 @ 50 Hz 像素深度: 32 位彩色 (ARGB8888) 主显示器: 是 镜像: 关 联机: 是 内建: 是
  12. George123

    Intel HD Graphics / GMA 5700

    My Laptop is X201i with 5700MHD. I tried to make the QE/CI works. However, I tried a lot of method and failed in the end. I can't understand why new macbook pro use the same graphics chips and my laptop can't use the driver. I guess that the DSDT must be modified to make it similar to macbook pro. Anybody knows how to make the QE/CI working on the machine?
  13. George123

    perfect ASUS Z96Js with 10.5.5

    (Solved. I have created my own GFX-String.Now the problem is I can't change the resolution.) Hi rickdekart, I studied your post for the X1600 71c5. But I can't make my X1600 71c5 working with QE & CI. My mac version is 10.5.5 updated from Ideneb 1.5.4. My X1600 working perfect under 10.5.2. After I move ATIinject and ATINDRV and OpenGL.Framework to 10.5.5, the QE & CI works. Ilife and Iwork works. However when I enter any games, it return to a black screen. But I can hear the sound. I guess that my driver is not compatible with 10.5.5. After search the solution on the net. I found your post. I also tried your Com.Apple.Boot.plist. But no QE & CI. COuld you help me to make a Com.APple.Boot.plist with my EDID? Thanks. raw_data.txt ioreg.txt versions.txt
  14. Hi Macnut, I tried to make my HP NX8420 working with dual cores. It is T2500. But I tried overs thirty times and only with CPUS=1 can working. I guess that the BIOS is not support dual cores with the OSX. Because the original Macbook with T2500. After I read all the topic, I have seen that ASUS users are lucky with the modified BIOS. Could you help me to modify my BIOS to work with DUAL CORES? My specification of LAPTOP is: Model: HP Compaq NX8420 CPU: Intel T2500 (Working with CPUS=1) Video: ATI X1600 (Working) Audio: AD1981HD (Only Output) sp40182.exe
  15. George123

    TSC sync XNU patch

    Dear All, I tried to make my T2500 working with dual cores. But I am failed. I have tried with cosmo1t's kernel 9.5. But it is stopped with kernel panic at the beginning. Some times I can login into the desktop successfully. But 80% of login stoped with: with '-tscsync -v' using 16384 buffer headers and 4096 cluster IO buffer headers with '-v' [TSC] delta:59 skipping Synchornization. (CPU1) Anyone can tell me what's wrong with my system? My laptop is: HP NX8420 CPU:T2500 Video Card: X1600 (working) Sound Card: ad1981hd (working with output) Wifi: Broardcom 4311 (working)
×