Jump to content
InsanelyMac Forum

Common Sense

Members
  • Content count

    218
  • Joined

  • Last visited

About Common Sense

  • Rank
    InsanelyMac Geek
  1. Common Sense

    APFS.efi without verbose boot

    Thanks modbin, that did the trick, the message is now gone Unfortunately I'm not at your expert level so I am not sure exactly how I can know which values to change. Is it simply that hex code 0x75 prints something, and whenever I find it I can disable the printout by changing to 0xEB?
  2. Common Sense

    APFS.efi without verbose boot

    Fantastic, thank you! I get one last annoying line because of my APFS fusion drive. Any chance you would be able to find: "fusion_wbc_startup:944: Fusion is started in regular mode"?
  3. Common Sense

    [pre-release] macOS High Sierra

    Well done! Could I please ask you to post your config.plist and DSDT.aml? I would like to take a peek at how your Intel HD IGPU configuration looks like. Cheers
  4. Common Sense

    [pre-release] macOS High Sierra

    Hello guys, After the computer has been idle for a while the monitor screen goes black, when clicking the mouse to get back to desktop it looks weird, please see attached picture. I have an Intel HD520. Everything works 100% except for this issue. Anyone knows what the problem could be? All help and suggestions will be greatly appreciated. Thanks Configuration: - Clover Intel IGPU injections disabled. - DSDT: IGPU device + injection of ig-platform-id 0x1916 as the _only_ injected property, without this it doesn't seem to work. - Lilu + DVMT fixup + Graphics Fixup. Tested without Grephics Fixup and same result. DVMT fixup is mandatory to boot the computer. - Clover version 4210.
  5. Common Sense

    Clover General discussion

    Nice job Sherlocks it works great New version 4003 seems to again break kext patching.
  6. Common Sense

    Clover General discussion

    It works for me too.
  7. Common Sense

    Clover General discussion

    It works great, thank you!
  8. Common Sense

    Clover General discussion

    Audio stops working when using 3994 and 3998. Works great with 3974 and 3994 + fix by Sherlock. I'm using CloverALC for the audio. I saw that there was another person who had this issue as well.
  9. Common Sense

    DSDT for Lenovo Ideapad 310: Can't get SATA to work

    Thanks for your help! It seems that changing something related to the IGPU solves the issue. Changing these lines: External (_SB_.PCI0.IGPU.CBLV, IntObj) // (from opcode) External (_SB_.PCI0.IGPU.CLID, UnknownObj) // (from opcode) External (_SB_.PCI0.IGPU.DD1F, UnknownObj) // (from opcode) External (_SB_.PCI0.IGPU.GLID, MethodObj) // 1 Arguments (from opcode) External (_SB_.PCI0.IGPU.GSCI, MethodObj) // 0 Arguments (from opcode) External (_SB_.PCI0.IGPU.GSSE, UnknownObj) // (from opcode) To these: External (_SB_.PCI0.GFX0.CBLV, IntObj) // (from opcode) External (_SB_.PCI0.GFX0.CLID, UnknownObj) // (from opcode) External (_SB_.PCI0.GFX0.DD1F, UnknownObj) // (from opcode) External (_SB_.PCI0.GFX0.GLID, MethodObj) // 1 Arguments (from opcode) External (_SB_.PCI0.GFX0.GSCI, MethodObj) // 0 Arguments (from opcode) External (_SB_.PCI0.GFX0.GSSE, UnknownObj) // (from opcode) Seems to fix the problem for some reason. Basically just renaming the Device (GFX0) to Device (IGPU) without renaming the other GFX0 references seemed to fix the problem with the hang during boot. I don't know why, and macOS is accelerated so the GPU is working. Maybe you guys that nows more about DSDT patching will know how this works Thanks for your help Arthur! It seems like I finally fixed the problem by changing something in the DSDT related to the IGPU. Acceleration works but it doesn't hang at boot like it did before. Very strange.
  10. Common Sense

    DSDT for Lenovo Ideapad 310: Can't get SATA to work

    Thanks for your help! Unfortunately it didn't work. What did you change? Unfortunately I cannot select AHCI mode I am afraid, I assume it is in AHCI mode since the DSDT from my desktop computer allows it to boot. Specs: Intel Core i3 6100U Intel HD520 Qualcomm Atheros QCA9377 8 GB DDR4 RAM 256 GB SATA SSD Realtek GBE ethernet Conexant HD audio
  11. Hello fellow hackintosh users! Please help me to take a look at the attached DSDT and see if there is anyway to get SATA working. It seems I have tried everything, I have reverted back to the original SAT0 device because all my attempts have been unsuccessful. The only time SATA has been working was when I by misstake left the wrong DSDT on the Clover USB stick. I left my DSDT for another computer on (ASROCK z87 Extreme 4) it and then it worked. I then spent many hours trying to analyse why it worked on that DSDT and to change the DSDT for the laptop accordingly. It's very strange. Thank you so much for any help! DSDT: https://www.dropbox.com/s/s9qadj11kjdijbf/DSDT.dsl?dl=0
  12. Common Sense

    El Capitan: Realtek ALC AppleHDA Audio

    Thanks for the reply Toleda. It works flawless, just a minor cosmetic detail. And as I understand it cannot be fixed by any other means than changing the source code in AppleHDA.kext. The screenshots were just showing how it looked like when it said Line In and Internal Microphone.
  13. Common Sense

    El Capitan: Realtek ALC AppleHDA Audio

    I noticed something strange, its a very minor bug and not very important. Same behaviour with CloverALC so it's probably related to the pin config and not to this injector kext. When I don't have my microphone plugged in the device is called "Internal Microphone" and has an extra option to remove ambient noise. Whenever I plug in my microphone it will be called "Line in" and the ambient noise reduction option will disappear. I can plug my microphone in and out and the input will keep switching between being recognised as a microphone and line input. I have an ALC1150 codec. When microphone is not plugged in: https://photos-6.dropbox.com/t/2/AADC5g6HugRURXYmm88HTx0Zxaig5qTQRVPdZSdr5V3U2g/12/105428026/png/32x32/3/1462460400/0/2/not%20plugged%20in.png/ELXuzVEY6zcgAigC/Imi1sIs_7C2WPrTCwuikTQ5heUGv-3X4-0Ht7Hv-1-Y?size_mode=3&size=1024x768 When microphone is plugged in: https://photos-5.dropbox.com/t/2/AAAj1d4um3PYhrnyxXcuXz2SAUigpSLaB-WsFzSUzaeOiw/12/105428026/png/32x32/3/1462460400/0/2/plugged%20in.png/ELXuzVEY6zcgAigC/9U3eJjrtK6TZlPjcYebA3c6iTCq5VhNUraDswU8M6wo?size_mode=3&size=1024x768 Update: works the same with AppleALC.kext method. It seems there is something wrong with the pin config.
  14. Common Sense

    Clover General discussion

    Works fine for me as well. 3507b restores the NVRAM functionality. Previous 2 clover releases did break NVRAM support. Before that it was never an issue.
  15. Common Sense

    USB 3.0 issue in El Capitan

    Thanks VCH888 it's working nicely with FakePCIID.kext + FakePCIID_XHCIMux.kext. Any chance you could add a multiplexing patch for FL1100 USB 3.0 chipset to the XHCIMux.kext? I really appreciate the information you make available on the forum, thanks for sharing your knowledge! (Thanks also to all other great people such as Rehabman who make it possible for us to run this great OS on our machines). /CS
×