Jump to content

samsonluk

Members
  • Content count

    52
  • Joined

  • Last visited

About samsonluk

  • Rank
    InsanelyMac Protégé

Contact Methods

  • Website URL
    http://

Profile Information

  • Location
    HK
  1. [100% Working] ATI Mobility Radeon HD 5470

    How you solve your initial problem? You shouldn't need injector or add device ID in ATI5000controller.kext for HD5470 to works.
  2. Lion GM 10.7 (11A511) "AICPMVers" = 19136773
  3. Seems not, if only the display problem I should able to logon via ssh...
  4. Thanks MaLd0n, Just applied your fixed dsdt, system can go to sleep - power light flashing slowly and fan turn off... but system still cannot return from sleep... After pushing the power button, I can hear DVD reading, power light turn solid but screen is blank and cannot ssh logon. I am on Lion GM and com.apple.Boot.plist modified as suggested: Kexts in /Extra/Extenstions: AppleACPIPS2Nub.kext FakeSMC.kext IOAHCIBlockStorageInjector.kext IONetworkingFamily.kext Additional Kexts in /S/L/E: VoodooBattery.kext VoodooPS2Controller.kext AppleACPIPlatform.kext (replaced by the vesion from 10.6.7 to get VoodooBattery to work) apart from the above all are vanilla kexts. Attached below with send_me.zip stuff captured before/after applying the fixed for your reference: send_me_Old.zip ---> Before apply your fixed DSDT send_me_New.zip ---> After apply your fixed DSDT BTW, how can I verify Speedstep is working or not?
  5. @MaLd0n, is it possible to fix Speedstep and wake up from sleep for Dell 14R w/Core i3? dsdt_stable_Dell_N14R.zip
  6. Where to define AppleBacklightAtBoot

    Anyone know from where can I define initial value of AppleBacklightAtBoot? Which kext or within DSDT?
  7. Editing custom personalities for ATI Radeon HD[45]xx

    Originally I tested my card only got display with "Eulemur" (even unmodified) and that's why I requested ^Andy^ here some time ago to create a "boot" for me, some how it became Chameleon default for HD5470M... I know there is another HD5470M variant only works with the default "Hoolock" and I still cannot figure out why because connectors type of "Hoolock" is completely unmatch with HD5470M and my card got a blank screen with it.
  8. [100% Working] ATI Mobility Radeon HD 5470

    The point is I also don't have a VGA monitor to connect but my VGA port shown as connected So you luck guy don't have my problems. I believe the brightness issue is something related with some setting in DSDT. It would be great if you can extract and upload your DSDT for me to study see if I can borrow some codes to fix mine.
  9. Editing custom personalities for ATI Radeon HD[45]xx

    My patched Eulemur is complete different from the original... I use it for modification because Chameleon use it as the default framebuffer for ATI 5470M
  10. [100% Working] ATI Mobility Radeon HD 5470

    Excellent! Do you have the following minor issues: 1) VGA shown as always connected while no monitor connect to VGA port 2) Brightness set as max. upon boot up / return from screen sleep I am not around my hackintosh at the moment, will get back when I have a chance to take a look the ioreg dump...
  11. [100% Working] ATI Mobility Radeon HD 5470

    For Lion they are in ATI5000controller.kext
  12. [100% Working] ATI Mobility Radeon HD 5470

    Interesting... Default Hoolock is completely unmatch with your BIOS decode: 0000000 00 04 00 00 04 06 00 00 00 01 00 00 21 03 05 01 Display Port 0000010 00 04 00 00 04 06 00 00 00 01 00 00 11 02 04 02 Display Port 0000020 04 00 00 00 14 02 00 00 00 01 00 00 02 04 01 03 DVI Senseid 01 which is defined as a Display Port in Hoolock is the only match with your HDMI port in the card. Is there any output to your HDMI? My patched Eulemur also don't have matched senseid with your LVDS, so it is normal for you don't get display from the main LCD screen while using mine. Can you save and upload IORegistryExplorer dump while testing different framebuffer?
  13. [100% Working] ATI Mobility Radeon HD 5470

    So you need to dump the BIOS and show the output... Are you booting 64bit? My patch only works under 64bit mode.
  14. [100% Working] ATI Mobility Radeon HD 5470

    Attached below is my patched ATI5000Controller.kext (Lion GM version 64bit) for HD5470 Mobility, it can be used with notebook having 3 display output ports: internal LVDS, HDMI & VGA. Please add the following to /Extra/com.apple.Boot.plist: <key>GraphicsEnabler</key> <string>Yes</string> <key>AtiConfig</key> <string>Eulemur</string> and use "-f -v" for the first reboot It may not works for you because senseid of each port maybe different even for card with the same module, if it doesn't works, you need to dump your video BIOS and correct the senseid byte as shown below: Personality of my patched framebuff appled to "Eulemur" as below: 0000000 02 00 00 00 40 00 00 00 09 01 00 00 12 01 00 04 0000010 00 08 00 00 00 02 00 00 00 01 00 00 20 00 01 01 0000020 10 00 00 00 10 00 00 00 00 00 00 00 10 10 02 08 If your video card match the following BIOS decode, it should use this patched kext without any modification: PCI ID: 1002:68e0 Connector at index 0 Type [@offset 45058]: LVDS (7) Encoder [@offset 45062]: INTERNAL_UNIPHY (0x1e) i2cid [@offset 45132]: 0x93, OSX senseid: 0x4 Connector at index 1 Type [@offset 45068]: HDMI-A (11) Encoder [@offset 45072]: INTERNAL_UNIPHY1 (0x20) i2cid [@offset 45155]: 0x90, OSX senseid: 0x1 Connector at index 2 Type [@offset 45078]: VGA (1) Encoder [@offset 45082]: INTERNAL_KLDSCP_DAC1 (0x15) i2cid [@offset 45182]: 0x97, OSX senseid: 0x8 HD5470_ATI5000Controller.kext.tar
  15. Editing custom personalities for ATI Radeon HD[45]xx

    In fact, I have test a few changes on the above line before this post and no help, that's why I asked... While remote connect with VNC I can actually see 2 desktops from the client side, and drag things between them works...
×