Jump to content

daavvis

Members
  • Content Count

    44
  • Joined

  • Last visited

Everything posted by daavvis

  1. daavvis

    Mac OS X Developer Preview 3

    my heart goes out to u man sorry to hear that... i really HATE when people die.... :(
  2. i think u should install vanilla and use a dsdt... most likely thats your problem. once you hae a dsdt in place you can delete disabler, rtc, voodoopstates, and any other power related kexts. i dont think u will have any more success until u go vanilla
  3. right on, i figured our board was made by dell cause through all my searching i havnt found any other manufacturer, and that clears up a lot of questions ive had... as far as that hack, i figured it wasnt important, cause i dont often have video issues, other than the occasional freeze up after sleep, most prominent when its plugged in... when it does freeze up, the screen will light up for a second, then go black and nothing works... im prettty sure ive done all the fixes for this in the dsdt so im not sure why this happens, thats why i was investigating this...
  4. http://www.osx86.es/?p=610 its a dsdt editor... it has a bunch of hacks you can choose from, and the "x3100 laptop hack is one of them, here is the hack and instructions Intel GMA X3100 Laptop hack Locate the graphics section of your DSDT (laptop/mobile) Example: (PEGP), it could also be AGP or IGP or something similar. (Use the search feature to locate the section or "Registry Info from the menu") Device (PEGP) { Name (_ADR, 0x00010000) Method (_PRT, 0, NotSerialized) { If (GPIC) { Return (Package (0x04) { Package (0x04) { 0xFFFF, Zero, Zero, 0x10 }, ......... the code continues............... The hack should be placed just below of the following code: Device (PEGP) { Name (_ADR, 0x00010000) Device (GFX) /* <------------- Hack begins */ { Name (_ADR, Zero) Method (_DSM, 4, NotSerialized) { Store (Package (0x54) { "device_type", Buffer (0x08) { "display" }, "model", Buffer (0x0D) { "X3100" }, "built-in", Buffer (One) { 0x01 }, "AAPL,backlightRestore", Buffer (0x04) { 0x01, 0x00, 0x00, 0x00 }, "AAPL,DisplayConfig", Buffer (0x20) { /* 0000 */ 0x13, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x01, /* 0008 */ 0x21, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, /* 0010 */ 0x41, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, /* 0018 */ 0x81, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 }, "AAPL,HasLid", Buffer (0x04) { 0x01, 0x00, 0x00, 0x00 }, "AAPL,HasPanel", Buffer (0x04) { 0x01, 0x00, 0x00, 0x00 }, "AAPL,NumDisplays", Buffer (0x04) { 0x04, 0x00, 0x00, 0x00 }, "AAPL,NumFramebuffers", Buffer (0x04) { 0x02, 0x00, 0x00, 0x00 }, "AAPL,SelfRefreshSupported", Buffer (0x04) { 0x01, 0x00, 0x00, 0x00 }, "AAPL,aux-power-connected", Buffer (0x04) { 0x01, 0x00, 0x00, 0x00 }, "AAPL,backlight-control", Buffer (0x04) { 0x01, 0x00, 0x00, 0x00 }, "AAPL00,blackscreen-preferences", Buffer (0x04) { 0x00, 0x00, 0x00, 0x08 }, "AAPL01,BacklightIntensity", Buffer (0x04) { 0x64, 0x00, 0x00, 0x00 }, "AAPL01,blackscreen-preferences", Buffer (0x04) { 0x00, 0x00, 0x00, 0x08 }, "AAPL01,BootDisplay", Buffer (0x04) { 0x01, 0x00, 0x00, 0x00 }, "AAPL01,CurrentDisplay", Buffer (0x04) { 0x00, 0x00, 0x00, 0x00 }, "AAPL01,DataJustify", Buffer (0x04) { 0x01, 0x00, 0x00, 0x00 }, "AAPL01,Depth", Buffer (0x04) { 0x20, 0x00, 0x00, 0x00 }, "AAPL01,Dither", Buffer (0x04) { 0x00, 0x00, 0x00, 0x00 }, "AAPL01,DualLink", Buffer (0x04) { 0x01, 0x00, 0x00, 0x00 }, "AAPL01,EDID", Buffer (0x80) { /* 0000 */ 0x00, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0x00, /* 0008 */ 0x06, 0x10, 0x5f, 0x9c, 0x00, 0x00, 0x00, 0x00, /* 0010 */ 0x08, 0x10, 0x01, 0x03, 0x80, 0x1d, 0x12, 0x78, /* 0018 */ 0x0A, 0x2f, 0x30, 0x97, 0x58, 0x53, 0x8b, 0x29, /* 0020 */ 0x25, 0x50, 0x54, 0x00, 0x00, 0x00, 0x01, 0x01, /* 0028 */ 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, /* 0030 */ 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0xBC, 0x1B, /* 0038 */ 0x00, 0xA0, 0x50, 0x20, 0x17, 0x30, 0x30, 0x20, /* 0040 */ 0x36, 0x00, 0x1E, 0xB3, 0x10, 0x00, 0x00, 0x18, /* 0048 */ 0x00, 0x00, 0x00, 0x0F, 0x00, 0x06, 0x10, 0x20, /* 0050 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, /* 0058 */ 0x0A, 0x20, 0x00, 0x00, 0x00, 0xFE, 0x00, 0x4C, /* 0060 */ 0x54, 0x31, 0x33, 0x33, 0x57, 0x58, 0x31, 0x2D, /* 0068 */ 0x00, 0x43, 0x41, 0x31, 0x00, 0x00, 0x00, 0xFE, /* 0070 */ 0x00, 0x43, 0x6F, 0x6C, 0x6F, 0x72, 0x20, 0x4C, /* 0078 */ 0x43, 0x44, 0x0A, 0x20, 0x20, 0x20, 0x00, 0xC2 }, "AAPL01,Height", Buffer (0x04) { 0x20, 0x03, 0x00, 0x00 }, "AAPL01,Interlace", Buffer (0x04) { 0x00, 0x00, 0x00, 0x00 }, "AAPL01,Inverter", Buffer (0x04) { 0x00, 0x00, 0x00, 0x00 }, "AAPL01,InverterCurrent", Buffer (0x04) { 0x00, 0x00, 0x00, 0x00 }, "AAPL01,InverterFrequency", Buffer (0x04) { 0x08, 0x52, 0x00, 0x00 }, "AAPL01,IODisplayMode", Buffer (0x04) { 0x00, 0x10, 0x00, 0x80 }, "AAPL01,LinkFormat", Buffer (0x04) { 0x00, 0x00, 0x00, 0x00 }, "AAPL01,LinkType", Buffer (0x04) { 0x00, 0x00, 0x00, 0x00 }, "AAPL01,Pipe", Buffer (0x04) { 0x01, 0x00, 0x00, 0x00 }, "AAPL01,PixelFormat", Buffer (0x04) { 0x00, 0x00, 0x00, 0x00 }, "AAPL01,Refresh", Buffer (0x04) { 0x3B, 0x00, 0x00, 0x00 }, "AAPL01,Stretched", Buffer (0x04) { 0x00, 0x00, 0x00, 0x00 }, "AAPL01,T0", Buffer (0x04) { 0x00, 0x00, 0x00, 0x00 }, "AAPL01,T1", Buffer (0x04) { 0x01, 0x00, 0x00, 0x00 }, "AAPL01,T2", Buffer (0x04) { 0xC8, 0x00, 0x00, 0x00 }, "AAPL01,T3", Buffer (0x04) { 0xC8, 0x00, 0x00, 0x00 }, "AAPL01,T4", Buffer (0x04) { 0x01, 0x00, 0x00, 0x00 }, "AAPL01,T5", Buffer (0x04) { 0x00, 0x00, 0x00, 0x00 }, "AAPL01,T6", Buffer (0x04) { 0x90, 0x01, 0x00, 0x00 }, "AAPL01,Width", Buffer (0x04) { 0x00, 0x05, 0x00, 0x00 } }, Local0) DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0)) Return (Local0) } } i tried to input this under the vid section and i got immediate kp's on boot. i had to boot into an install dvd and remove and replace the dsdt through the command line (stupid me replaced the dsdt without testing it first) the instructions are not very clear... also... ive been looking into trying to find who manufactures our motherboard... do we have a gigabyte board or is it actually made by dell? and thats good to know about the voodoohda driver... i did not understand how hdmi works but now i do thank you... im gonna plug it in to a tv today ill let you know how it works out but im expecting failure lol let me know if you think i should do something with this hack or leave it alone... must be some purpose for it if its in this software... you seem to know more than me, and i havnt been able to get much help from anyone, ever lol... im still learning code and what not, im very bright and have only been working on the hackintosh project for 3 months or so and have had a lot of success, just want to button up some minor issues...
  5. So wait, the voodoohda kext doesnt fix the hdmi? and do you know anything about the"x3100 laptop hack" on dsdtse and where i should put it? im not finding any agp (i cnow agp has been deleted because of the sleep screen prob)sort of device, except for vid device but im not sure if thats right...
  6. does anyone know if i should use the "x3100 laptop hack" thats in DSDTSE software? im not sure cause mine looks a lot different than the one in the example, and im not sure where it fits in... i do have the crt info removed, but im wondering if this hack will improve performance a wee bit...
  7. from what ive read its the way os x is set up, and i know some apples ship with 8 gb but im pretty sure only 4 gb can be installed during a system install... if im wrong i hope someone corrects me here... as far as hdmi, ive never tested mine so i have no idea, i thought it was working tho... can i ask which dsdt your using? ive uploaded 3 i think was just curious which one your using... here's the one i use now with my smbios list and boot.plist... put "x's" in for serial number u have to change that but this way u can use it if u want it... --edit... i just cleaned up my boot.plist, it was a bit messy and i didnt need the ethernet built in thing so heres the fixed one.... --edit 2-- does anyone know if i should implament the dsdtse x3100 laptop hack into my dsdt? im looking through it and im not sure if it fits, im not even sure where to input it cause mine looks a lot diferent than the example... anyone know? dsdtsmbiosboot.zip com.apple.Boot.plist.zip
  8. k im pretty sure u cant install os x with more than 4gb of ram... have to put it in after install... pretty sure.. and i dont think you need appleacpips2nub.kext. i believe if you are using a new enough voodoops2 you dont need it and last, i have searched far and wide and found no way to make the x3100 work in 64 bit mode. apple cut that option and i dont believe it will ever return, but be happy you dont have any other video probs lol hope that helps lol
  9. im sorry your correct my bad ill fix it in my signature... but yes evoreboot.. ill attach the one i use... works great for me, but keep in mind i have the (suprisingly rare it seems) x3100 (gm965) vid card so this may not work for you... im runnin 10.6.7 so im not sure y they say it wont work, and i got this one from the iatkos s3 disk (i think, havnt run iatkos in a long time, it was my first step into osx with my m1330, but since have moved to vanilla install, keeping kexts from iatkos that worked) and that was osx 10.6.3 i believe, so im not sure what thats about... ahhhh... i see:) i have no experience with that card, and i do feel lucky that i have a native supported video card (sort of, have to boot in 32 bit cause apple decided i dont deserve 64 bit because of said card and i was a victim of the "sleep trick" till i found the abundant mercy of the dsdt ) there is no anydsdt for the x3100 card on the first page tho, unfortunately, so i had to edit mine myself... no biggie... does the chameleon restart fix force your computer to do a bios check everytime you restart/shutdown, or is that problem just related to my video card? it was the most annoying thing ever and it drove me back to evoreboot... sucks it doesnt work for everyone... and as far as paying for os x... i think 30 bucks is not enough to give them for such wonderful software the price of os x and windows should be swapped, but to be honest, im not sure i would pay even 30$ for windows 7 lol EvOreboot.kext.zip
  10. READ MY POST AND SIGNATURE I AM USING RETAIL. i only used [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] from a cd to install from the retail disk, or as a backup bootloader when i mess with chameleon and break it lol. i understand there are other bootloaders that boot a retail cd, but thats the one that worked the best for me without any trouble. it doesnt matter what bootloader you use to install as long as u use chameleon and a dsdt when your done installing. (check my signature)... i think u misunderstood a LOT.... EVERYTHING WORKS (minus c-states duh lol)... even DEEP SLEEP... oh and one more thing, m1330 users will not have shutdown and reboot from any dsdt fix or any install guide. its only been fixed for the 1530's. for us m1330 guys, shutdown and restart DO WORK, BUT you need evorestart.kext. i know its a non vanilla extra kext to use but if it gives u restart and shutdown, and you dont have to remove it to update, and it will save your computer the trauma of pressing and holding the power button, why fight it....
  11. Hey im trying to build or modify a kext to work for this card... i dont really know where to start, other than maybe to add the device id to the io80211.kext with the devise id (some athros cards are supported), but i cant find the id that starts with "pci"... this is the information i have on the wireless usb adapter, i took it apart and copied the numbers from the chip, and also plugged it in to my m1330 (snow leopard) and copied the information from there as well: heres what i have anyone care to help? from chip: atheros ar9271-al1a DOS328C 1034 R.YS10AR3845 970YS10720SMT VER 1.2 and from system profiler: Product ID: 0x9030 Vendor ID: 0x0846 Version: 1.08 Serial Number: 12345 Speed: Up to 480 Mb/sec Manufacturer: NETGEAR WNA Location ID: 0xfd100000 Current Available (mA): 500 really hope someone can help me out here... i know quite a few people have this usb adapter (its a inexpensive 150n adapter) and id like to help us all out... i could buy a new card but i like this one....
  12. k gonna try it now ill let u know how it works edit... i think it works... i can type a ` and~ from the right key, but i cant get the icon for the keyboard back on the menu bar to check for sure, i click the box on the keyboard control panel, and it puts a check mark but it doesnt show up on the menu bar and when i close the keyboard control panel and open it again the box isnt checked anymore... edit 2- my keyborad was set to unknown keyboard. i changed it back to normal keyboard and i can get the icon back and look at the on screen keyboard, but the funny thing is, it looks the same, with the same misplaced charicters, but when i type i get the right ones lol... including shortcuts with "`/~" key... weird right?
  13. think i should try it on my m1330 or do u think it could be a bad idea
  14. right on... anyone know how the x3100 performs? its my last fear...
  15. wow i never noticed that is there a way to fix it my keyboard reads the same way...
  16. glad i could help u out with the 7 thing it was seriously one of the most annoying thing ever... i still have questions about hibernate mode 3 y will my computer hibernate from the "force hibernate widget" and sleep correctly with a closed lid, but only in hibernate mode 0? if i set to hibernate mode 3, it will restart as soon as it finishes loading the hibernate file... or wake up from ram sleep with a black screen and frozen up ...? oh and immo i switched to your voodoo card reader kext, im not sure what the difference was from the one i was using, but yours had a bunch more info than the one i was using in the info.plist... still shows no card reader under systems profiler, but it works great
  17. ok cool ty very much, i hate booting from a usb stick, and im formatted to guid, and its a laptop so i have only one drive... think im stuck with a usb stick or i wont be able to boot 10.6.7.. its cool, im gonna try and get another drive, and do everything with lion on its own drive and usb stick, that way i wont take the chance of not being able to boot anything.. im very curious to know if my dsdt is going to work for the x3100 card... it runs on factory kexts, but i was a victim or the "sleep display" problem, (fixed in the dsdt, hence my fear )so im hoping it will work right... anyone know how the performance of lion is with this video card? i play cod 4 regularly (doesnt play "amazing" but good enough;)), so im thinking it will be ok
  18. ok ive been following this topic, and have read the whole thing at least twice... i just want a bit of clarity here.. correct me if any of this is wrong... 1.) you can install dev 2 on a partitioned hard drive, but you must use a bootloader from a usb stick, the bootloader will not run from the hd.. 2) you can install dev 2 on a usb stick and run it 3) the only bootlaoders that will work are chameleon rc3 with netkas (sp?) boot file, xpc, [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] (not tony's), or the new anval. 4) do not open app store (unless your a dev.) 5) 10.7 dev will run on my computer (see specs in signature) 6) in order to boot from usb stick, you must format it from windows (was dreading this cause if u see my signature i dont have windows installed, but i just realized as im typing this that i take care of 4 windows pc's in this house... duh...) just wanna make sure i have all the facts i can find before i try, im sure theres quite a few people out there with my setup that would love to know it works and how... sorry if im annoying anyone...
  19. well i havnt even tried to install i was just waiting to see if it would be worth it, or if i should wait, but now with a slightly newer dev release out i think ima give it a shot if i can squeeze enough space out of my bursting hd and i have the Intel ICH8-M controller so im pretty sure its supported,,,
  20. hhhmmm and your using os_ninja's version of [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] right? that was my only idea...
  21. did u delete Extensions.mkext from /System/Library/Caches/com.apple.kext.caches/Startup as well. someone said they did that and [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] worked... post 75 HAH!! just downloaded the first one and was gonna give it a shot, maybe ill wait now lol
  22. ok cool so i can run it on a partitioned internal hd, but my question is what about [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] makes it work sometimes? what do the kp's look like? i use [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] to install but and it works really well with my machine, so it would be great if we could get it to function everytime.... and from what ive read and understand in order to get voodoops2 to work right you have to manually load it... im not positive tho... believe i read something about it in the first few pages of this topic...
  23. right on.... rats.... lol... has anyone been able to use it on a internal drive with multiple partitions? i have everything i need but im hesitant...
  24. so does that mean it will boot without the usb stick?
  25. Dude u guys are amazing!!! i only own the comp in my signature... and im not gonna try and run this until the bootloader is a little more polished.. but damn, i may not be waiting long.... Ty sooooo much!!! im if u want my help let me know, im gonna work on getting an external hd so i can give this a go and help out a bit, i know theres a lot of us that want lion bad....
×