Jump to content

idoc

Members
  • Content count

    64
  • Joined

  • Last visited

About idoc

  • Rank
    InsanelyMac Protégé
  1. I guess the point of my post was that the ASM 1042 will now work on a hackintosh with a simple plist hack to allow the Caldigit driver to load. The PXHCD kext doesn't work for this USB3 controller.
  2. I picked up a secondhand ET2210 and have been fiddling with 10.8 r3 today. It seems if you install a modified caldigit driver from Here and force it to load by removing extraneous matching in the info.plist (IOPCIClassMatch 0x0c033000 only) it will recognise the usb3 ports, at least it does on this rig.
  3. Almost there now. I think you should now be able to use the modified appleHDA from post #2 or #3. You may also need to use the ReggieSE scripts if no sound comes out but the correct devices are loaded.
  4. I've recompiled your dsdt with warnings removed but I don't think it will work, nonetheless, give it a go. Otherwise I recompiled kabyl's boot file with a fix for the 5870, I think it should fix the blank screen, try this with my dsdt.aml. The next tact to try would be removing the dsdt reference to alc888 and use HDAEnabler and ALC8xxHDA. Let me know what works. Archive.zip
  5. Does your DSDT compile on your machine? I get a string of errors when I try to compile it with DSDT Editor or DSDTSE and when I boot with your DSDT I similarly get no sound. Could you try my dsdt.aml file. dsdt.aml.zip
  6. Now that is strange. Could you upload your dsdt file for me to have a look at.
  7. I've installed AppleHDA Rollback and ALC8xxHDA with dsdt 888 and AppleHDA loads (albeit with incorrect devices in Sound Preferences), could you try this - please rebuild caches with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] at the same time. Let me know if AppleHDA now loads.
  8. Looks like AppleHDA.kext is still not loading (not present in kextstat and nothing attached to HDEF in ioreg). Could you use ioregexplorer and save an explorer file that way, I'd be interested in the info under the HDEF node. It is worth repairing permissions as this can stop AppleHDA.kext from loading. It would be worth trying AppleHDA 10.6.2 and my original extra folder and dsdt to see if this loads and then the binary hacked AppleHDA 10.6.6 if all goes well.
  9. Must be solvable, as I have exactly the same codec. Could you post your ioreg and kextstat. It sounds as if AppleHDA.kext isn't loading, you could try to manually load it with sudo kextload -v /S/L/E/AppleHDA.kext.
  10. Interestingly, and quite serendipitously I have all inputs working but not through the kext I posted before. This kext gives everything except internal microphone, but I accidentally forgot to rename a testing AppleHDA and installed it along side the previous AppleHDA (named AppleHDAjustintmic.kext) and it loads simultaneously with the main AppleHDA kext and picks up the internal mic! AppleHDAjustintmic.kext.zip
  11. Modified the AppleHDA further, now. All outputs correct headphone/internal speakers autodetect, create an aggregate device for quadrophonic sound. All inputs work external mic/audio line in autodetect. HDMI audio Sound assertion "kTypePinComplex != fType" failed in "/SourceCache/AppleHDA/AppleHDA-199.4.12/AppleHDA/AppleHDAWidget.cpp" at line 2013 goto Exit I think this is due to patching AD1988 instead of ALC885, but better results this way. AppleHDA.kext.zip
  12. idoc

    MSI GX660

    Detrimental I've definitely seen that error on my gx660r. I think I got around it by booting from a usb dvd drive rather than the bluray drive. I use a 10.6.3 retail disk.
  13. OK. I've updated to 10.6.6, now HDMI Audio works, as long as your HDMI is detected as such and not DP. At present I only have the internal microphone working (more experimenting required) but all outputs seem to work as expected. The only caveat here is that there is no sound on wake from sleep - I use sleepwatcher to run an init script to fire of reggie_se (need chud tools from here http://mac.softpedia.com/progDownload/Appl...load-1502.html), this means using the 32-bit kernel (but apps run in 64-bit) arch=i386 in chameleon. I've attached the required files. AppleHDA.kext in S/L/E/, my dsdt - you just need the Device (HDAU) and Method (_DSM, 4, NotSerialized) from Device(VGA) but it should work in its entirety, patched ATIFramebuffer.kext /S/L/E, boot.plist with graphicsenabler off and the init script to turn on the amp on node 0x14. audio.zip
  14. I think you will find this is dependent on the mac graphics drivers and pretty much in line with the findings on a genuine mac - snow leopard vs win7 under bootcamp. Changing your smbios settings makes a difference - i get the best performance with imac 11,3 spoofing (26 fps cinebench)
  15. idoc

    MSI GX660

    detri mental, I have the GX660R and the above boot line works everytime, so it may be difficult to offer any help. Have you set AHCI in BIOS? Maybe post a picture of the KP you get. Cheers Steve
×