Jump to content

leodm

Members
  • Content count

    67
  • Joined

  • Last visited

About leodm

  • Rank
    InsanelyMac Protégé
  1. GMA X4500

    Intel HD video is the on-die GPU integrated in i5/i7s sorry but they are different from 4500MHD now the question is how close these two are....
  2. so what's the error msg. u get when trying "kextload -t"? and, if the other ACPIPS2Nub driver loads for you, can you try to replace the driver content only(the ACPIPS2Nub file in Contents/MacOS) and see how it goes?
  3. sorry, turns out I'm using a modified AppleACPIPlatform kext(from Leo4All v2), so I replace it with the one found in Apple 10.5.2 update(is it the latest vanilla version?), and get the same dependency error... anyway, the fix is easy: root /System/Library/Extensions # kextload -t ACPIPS2Nub.kext kernel extension ACPIPS2Nub.kext has problems: Missing dependencies: { "com.apple.driver.AppleACPIPlatform" = "A valid compatible version of this dependency cannot be found" } Change the version# in Info.plist so it can match the current AppleACPIPlatform <key>OSBundleLibraries</key> <dict> <key>com.apple.driver.AppleACPIPlatform</key> <string>1.1.0</string> <key>com.apple.iokit.IOACPIFamily</key> <string>1.0.0d1</string> <key>com.apple.kernel.libkern</key> <string>1.1</string> </dict> <key>OSBundleRequired</key> To determine the current version#, other than looking it up in system profile->software->extensions, just check other bundled(and correct) plugin, in my case, it's "/System/Library/Extensions/AppleACPIPlatform.kext/Contents/PlugIns/AppleACPIEC.kext/Contents/Info.plist" Change "1.1.0" to "1.2.1" and try kextload again, the kext loads correctly. Delete kext cache, reboot. Done... To Aluminum Sponge: Sorry but I have no idea if you've changed the OSBundleLibraries section and still can't get it working...
  4. I think this deserve a dedicate thread. For the original ACPIPS2Nub kext, there is a slight problem which confuses some desktop users, let me quote my old post So here is the revised version, including the source code. which works on system WITHOUT PS/2 mouse. I hope all the major release could incorporate it in the future(and replace the old one). I've tested it on 10.5.1 Kalyway and 10.5.2 Leo4all release with great success. If you don't have USB keyboard or another PS/2 mouse around, replace the kext from installation dvd. It's NOT written by me, cant remember the original website now.... Greeting to the hacker who made it. ACPIPS2NubUpdate.zip
  5. yes, but that's not necessary with modified AppleACPIPlatform.
  6. I finally get this working on DESKTOP the trick is, u need to plug a PS2 mouse and PS2 KB at same time to get the KB working(the same old trick back to 2005 when OSX first met x86) for laptop this isn't a problem since it has trackpoint/touchpad connected as PS2 mouse, but on desktop, i always think i've done sth. wrong because everyone else says it works... I'm glad my current MB still has PS/2 mouse port, seems lots of newer MBs remove it and has PS2 KB port only. One thing I stick with PS/2 KB because it has same layout as standard apple kbs, ie. win=opt, alt=cmd, and on USB kbs, the 2 keys are reversed.
  7. By default, ICH8R in AHCI mode will work under OSX, no mods required in your case, the ICH8R is set to RAID instead of AHCI which might be the problem just fyi, when in AHCI, ICH8R vendor id=8086 and dev id=2821<-works out of box and in RAID, vendor id=8086, dev id=2822<-add dev id as in your post. in old IDE/compatible mode: not sure about dev id, but supposed no working without modification.
  8. the good choice would be: northbridge 945/965/975/P35 all should be fine southbridge: ich7/8/9R, without R also works, but kinda headache... onboard sound card: ALC or STAC so u can get all channels via AppleHDA video card: 7300LE
  9. this is essentially the same way we used it to install the tiger image back to 2005(wiki) but some has reported no go with this Leopard i havent tried it, just curious... http://forum.insanelymac.com/index.php?s=&...st&p=488608
  10. [Guide] Installing Leopard on a P5B-Plus

    just checked, p5b plus comes with 88E8056 onboard, which works under OS X i'm running p5b deluxe(most parts should be same), see my sig for more info for hardware drivers/efi etc.
  11. for anyone who used my guide to install EFI, there is a BIG mistake once u have vanilla kernel restored(and name it to /mach_kernel), u can't load system directly without EFI installed. So to install EFI, u need to enter single user mode with old patched kernel, this can be done by typing: mach_kernel.patched -s just add the kernel name so Leopard will load it(instead of mach_kernel, which is the vanilla one at this point) sorry about this!
  12. 10.5.1 is out, finally.

    if u inspect 10.5.1 update with Pacifist, u'll find they update drivers for ATI/NVIDIA and GMA950. And its known that some ATI cards are broken with this update, just restore the old kexts from 10.5.0. nvidia should have no problem, at least for my 7900GT.
  13. startupfiletool only writes to partition which is unmounted or mount as read only so if boot with -s, its perfect time, just proceed the ./starupfiletool thing, don't do "/sbin/mount -uw /" as it mounts / as read-write and startupfiletool will fail. if u do this in another OS X installation or from installation disc(not neccessary unless Leopard fails to boot), u need to umount target partition first.
  14. Shutdown problems

    after uninstall ntfs-3g/macfuse(yes, this will lose ntfs writing), all shutdown/reboot problem gone.
×