Jump to content
InsanelyMac Forum

Jaball

Members
  • Content count

    20
  • Joined

  • Last visited

About Jaball

  • Rank
    InsanelyMac Protégé
  • Birthday 02/05/1982

Contact Methods

  • ICQ
    8264997

Profile Information

  • Gender
    Male
  1. I see the AppleRTC binary got updated in 10.9.3 (but still shows version 2.0 on kext) - anything new patch-wise?
  2. Asus P6T SE, i7 920, Radeon 4850. Used the Lion install guides to install from another partition, prepared it using existing Lion setup (side note: MBR fix for Mountain Lion GM). FakeSMC from kozlek's latest HWSensors, DSDT by ErmaC. Booted the install using Chameleon 2.1 svn2003, Graphics Enabler=No and -x to keep it safe. Setup went fine, Mountain Lion booted fine using same safe settings, Lion was upgraded. Added deviceid of gfx card to ATI4800Controller.kext and switched Graphic Enabler=Yes with AtiConfig=Cardinal, fixed permissions and cache, QE/CI was back. Ethernet - official Lion driver from Realtek still causes kernel panics after some time (sigh), so went with the rock stable AppleRTL8169Ethernet.kext plugin from 10.6.8. Still works fine. Audio - I do not do rollbacks, up to 10.7.4 I used to edit AppleHDA.kext plist and xml files manually using files from ErmaC's guide and just binpatching it with HDA Wizard (or perl oneliner). But now the Platform and Layout xml files are zlib compressed - after a quick search I found this script. So audio works with the proper DSDT fix and Mountain Lion GM patched kext.
  3. Jaball

    HWSensors

    HWMonitor.app seems botched on my system (Asus P6T SE, i7 920, HD 4850, Lion 10.7.4) in the ef85da05b8 commit - launches and works in the background but the icon vanishes from menubar right after launch. Using Installer pkg, app from dc4c302ea9 commit works fine.
  4. Got the pack from kozlek: https://github.com/kozlek/HWSensors/zipball/master Used the Installer and checked those that apply - everything except GeforceX (got RadeonX) and that experimental advanced (read the notes, afair it's ACPIsensors OR SuperIOSensors). And the App, but not the HWMonitorExtra. Note: remove all iterations of present FakeSMC before launching install, its places the new FakeSMC/plugin bundle in S/L/E not E/E.
  5. P6T SE, 0908 BIOS With the above i7 920 DSDT: - SS works with all state generation set to „No” in Chameleon (goes to 12x when idle), but still uses for max the 21x multiplier - the „universal” one used the BIOS fixed one (20x) - no turbo - Flawless Sleep and Wake without extra kexts (perl binpatched AppleRTC 10.7.4 - no cmos corruption after reboot) - ~30s boottime for lion with UseKernelCache=Yes, no difference noted, Lion was always about 10s slower to boot comparing to SnowLeo for me (HDD) - Binpatched 10.7.4 AppleHDA with the ALC1200 plist edits, no noise on both jacks (there was some frontpanel/headphone noise with 3.3), mic works - no means of checking optical, not using it.
  6. Yep. Checked that and... no. Apparently it makes no difference, system still is downclocking when idle with every $State setting is off in org.chameleon.Boot.plist.
  7. According to HWMonitor SpeedStep is working for me (PStates and CStates in Chameleon, CSTUsingSystemIo=Y). And it sleeps and wakes fine and fully, no panics, no issues what-so-ever. Just noticed that it ignores the fixed x20 multiplier set in BIOS with turbo disabled - so the CPU works at 3,47GHz maxed out (still stable) at x21 multiplier accouting for the higher geekbench score.
  8. That would be me. i7 920 oced to 3,33GHz boots into Lion 10.7.4 fast with 3.3, geekbench score is 1k higher comparing to the old "universal" DSDT. Speedstep works fine 12-21x (2GHz-3,33GHz). Sleeps fine with no extra kexts.
  9. Yep, sadly these were mostly deleted from the board - backed up mine (yay) - the only links left working are here: http://www.insanelym...2 Still, mind it's a CPU&MoBo specific temporary solution. Well, at least for me. If someone got the rest of the lot, guess some P6T SE and Deluxe users would be obliged if they were posted here. In the linked thread above there are some working links for newer DSDT.aml versions for the two said MoBo's as well as older versions. You can play around with them (newer are dubbed 3.4 and 3.5 respectively, but are lager in size - 3.3 was a minimal stripped edit, the larger ones are likely to contain the code that gives the KP on 10.7.4).
  10. Working on a hunch - back in the day, Fabio prepared CPU-specific DSDT's for my MoBo (Asus P6T SE). I got the i7 920, so I used that one (version 3.3) with these settings in org.chameleon.Boot.plist: <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>Kernel Flags</key> <string>arch=X86_64</string> <key>EthernetBuiltIn</key> <string>Yes</string> <key>GraphicsEnabler</key> <string>Yes</string> <key>AtiConfig</key> <string>Cardinal</string> <key>Graphics Mode</key> <string>1440x900x32</string> </dict> </plist> thus omitting all P and C-state bootloader settings. AtiConfig is for my GPU obviously. Result: The DSDT is linked below. NOTE: ONLY FOR THE ASUS P6T SE MoBo WITH CORE i7 920 (2,66GHz Nehalem Core) CPU!!! http://dl.dropbox.co...Y_Fabio_3.3.zip
  11. Asus P6T SE, 0908 BIOS, chameleon 2.1 svn r1925 KP - first one after almost three years, PC based on Fabio's work mostly. Deleted the DSDT and Extra/*mkext... and KP. WAT!!!??? Digging in... editing org.chameleon.Boot.plist. BEFORE: <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>AtiConfig</key> <string>Cardinal</string> <key>CSTUsingSystemIO</key> <string>Yes</string> <key>EnableC2State</key> <string>Yes</string> <key>EnableC3State</key> <string>Yes</string> <key>EnableC4State</key> <string>Yes</string> <key>EthernetBuiltIn</key> <string>Yes</string> <key>GenerateCStates</key> <string>Yes</string> <key>GeneratePStates</key> <string>Yes</string> <key>Graphics Mode</key> <string>1440x900x32</string> <key>GraphicsEnabler</key> <string>Yes</string> <key>Kernel Flags</key> <string>arch=X86_64</string> </dict> </plist> AFTER: <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>AtiConfig</key> <string>Cardinal</string> <key>CSTUsingSystemIO</key> <string>No</string> <key>EnableC2State</key> <string>Yes</string> <key>EnableC3State</key> <string>Yes</string> <key>EnableC4State</key> <string>Yes</string> <key>EthernetBuiltIn</key> <string>Yes</string> <key>GenerateCStates</key> <string>Yes</string> <key>GeneratePStates</key> <string>No</string> <key>DropSSDT</key> <string>Yes</string> <key>Graphics Mode</key> <string>1440x900x32</string> <key>GraphicsEnabler</key> <string>Yes</string> <key>Kernel Flags</key> <string>arch=X86_64</string> </dict> </plist> Now it boots fine, including hardware accelerated gfx on my Radeon HD 4850 - on a sidenote, I can use CSTUsingSystemIO=Yes but it corrupts my monitor setup, not related to the problem at hand. LAN also works with AppleRTL8169Ethernet.kext from 10.6.8 in IONetworkingFamily.kext/Contents/PlugIns - So that leaves me with PStates and DropSSDT. An educated guess - it's only partially the fault of DSDT.aml (some residual PM strings?) - Apple changed something about the way they handle powerstates and I suspect that Chameleon also can't manage this...
  12. Same here, blank display with no boot selection screen (r1822 with Mt.Lion patch), SL and Lion working flawlessly with trunk/buildbot r1819. No time to dig-in and debug so reverted quickly.
  13. ATi Radeon 4850 = 224 (GV-R485OC-1GH gpu@733/mem@1066MHz; Core i7 920@3,33GHz; 10.7.2) Core i7 920@3,33GHz = 414
  14. Boot with -x at chameleon prompt. If that works, prolly You will be needing LegacyATI4800Controller.kext with correct dev id's for that 4870 in SLE and GraphicsEnabler=Y. Also, deleting ATI4500Controller and ATI4600Controller kexts from SLE is sometimes required. Rebuild cache and fix permissions after that and reboot.
×