Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About masa

  • Rank
    InsanelyMac Protégé
  1. Maybe you turned the time machine on but disconnected your external backup hard disk.
  2. I also have this problem, but randomly, not all the time. I guess that it has sth to do with google chrome, i don't want to test too much because i have to shut down my pc manually and my HDD has already given me some warnings.
  3. AppleHDA patching in Mountain Lion

    Thank you ErmaC, I just tested the updated kext but with no luck. It is very weird because when I use the AppleHDA, i will not be able to use any USB mouse or keyboard, I have to turn off my pc by the power button. I thought the DSDT is suspicious, but I can control my mouse if I just remove AppleHDA from /S/L/E with leaving the dsdt there. Tried 2 pattern of HDEF in dsdt, one just copied yours and my original shorter one with only ID modified. Could you give me some advice? Thanks!
  4. AppleHDA patching in Mountain Lion

    yes, that's my current status too, looking forward to a new solution.
  5. AppleHDA patching in Mountain Lion

    CutOffz, thanks for your information. I've tried that, still with no luck:(
  6. AppleHDA patching in Mountain Lion

    Thank you ErmaC. I just test your method on my P5Q-E, I could get sound output but with no input: there is digital input only and I can't use my mic. I tried use your patched kext file and modifying AppleHDA manually. Any advice will be appreciated, thank you. input.tiff output.tiff
  7. Hey guys, Have you got your P5Q auto-sleep work? I still have a "tty sleep preventer: /dev/console" problem on my P5Q-E, I'll really appreciate if you have some advices for me. Thanks. http://www.insanelymac.com/forum/index.php...p;#entry1569904
  8. Finally it is solved, even many new issues remained. I was being think that "USB devices prevent sleep" until i realized the "sleep" did have happend, USB devices just caused a wake-up. The method _PRW seems offer a function to wake up PC by the device which has the method. Here is what I did: 1) Remove Method _PRW from all USB device. (about 8 in my case) Identify the USB devices by address, lot of posts about this. 2) Also remove Method _PRW from device GBEC. Although I have no idea what it is, but I found if keep it there, the USB flash memory will prevent sleep too. As the evidence, I found this in log file: Other methods are untouched. You can see, there were multiple reasons caused wake up. After doing these, USB mouse or storage stoped to wake it up any more. Certainly I can't wake up my pc too, bu it doesn't matter. ---Issues remained---- 1. No auto-sleep. Monitor just turns off, but the system won't even i set the auto-sleep time to 1 min. (I waited for 2 min, should I be waiting longer?) 2. After waking up, SL give me a warning about usb removal. I've tried this but nothing get changed. ***if i disable "Energy Star 4.0C" in cmos setting, usb just keep connecting fine without any warning. but, the LED of USB HDD or mouse will keep turning on even I shut the power down. I hate it. 3. Now I can only weke it up by power button, but I can still see this in log file: It is weird because the system konw the "wake reason" IS "PWRB(power button)" but yet list up many "possible" reasons of wake-up. OK, I wish this would help people just like me and i still expect someone can help me to solve remained issues.
  9. Hello~~? Do i even have to remove _PRW to disable wake up on USB?
  10. Hi, guys, I got a problem and I've done everything i can but nothing got changed... Please give me you help, thank in advanc. Fist, my PC: 10.6.4@ Q9550/Asus P5Q-E(ICH10R)/GTX260/PS2 Keyboard/Logitech game mice G500. The problem is simple, just as title, if i let G500 pluging on and click "sleep", my PC just go to sleep but will wake up immediately itself. And if i unplug it then let SL go to sleep us keyboard, the sleep/wake-up function work like a charm. All USB bus are already "built-in". I gooled a lot and find a way to modify the USB device in DSDT, like this: http://www.insanelymac.com/forum/index.php?showtopic=209441 Here are my DSDT before/after modification: before: Device (EHC1) { Name (_ADR, 0x001D0002) OperationRegion (BAR0, PCI_Config, 0xC4, One) Field (BAR0, ByteAcc, NoLock, Preserve) { USBW, 2, Offset (0x01) } Method (_S3D, 0, NotSerialized) { If (LOr (LEqual (OSFL (), One), LEqual (OSFL (), 0x02))) { Return (0x02) } Else { Return (0x03) } } Method (_PSW, 1, NotSerialized) { If (Arg0) { Store (0x03, USBW) } Else { Store (Zero, USBW) } } Method (_PRW, 0, NotSerialized) { Return (GPRW (0x0C, 0x04)) } } after: Device (EHC1) { Name (_ADR, 0x001D0002) Name (_PRW, Package (0x02) { 0x0C, 0x04 }) } As you can see, i get rid of some method like _S3D to avoid waking up from any USB devices. I did this on all USB devices in DSDT. But, I got no luck, sleep won't retain over 2 seconds, and after waking up, OS warns me some stuff like removal an USB device correctly. If you have some idea, please let me know. Thank you very much! usbbus.tiff
  11. ADI AD2000b works with applehda

    Thank you all very much for sharing! I got my AD2000B working but sound lost after reboot...
  12. ADI AD2000b works with applehda

    Hi, thank you for share. but how can i get thoese kexts?
  13. ADI AD2000b works with applehda

    it won't work if its in /Extra/E, you just need to put it into S/L/E. Still waiting for the new version of AppleHDA works for snow leopard.
  14. Congratulations! But my GTX260 still invalid even i tried ATY_init or a string... Audio, Network... dont work too. maybe i should be waiting for a P5Q-E 's guide.
  15. Hi, fragreave, i must say its a display issue, i got completely same error with you, you should drive your display card or delete(move) those display kexts. my comp: p5q-e, q9550, gtx260+, because i dont know how to drive my card this time, i deleted NVDA50 & NVDAResman and got in desktop. now new problem is my SL 100% crashes within 1min from getting in desktop. i'll keep tring. FYI.