Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About dantesieg

  • Rank
    InsanelyMac Protégé

Profile Information

  • Gender
  1. OS X Lion 10.7.2 11C71--- 11C73 GM

    No problems here. I signed up for icloud using my hackbook. I am using RevoBoot, not chameleon. Using MacBookPro 6,2 for smbios, generated serial with Champlist. My ethernet was always en0 and seen as built in, no special steps taken. Also i use opendns. Here is my dsdt and ioreg. Archive.zip
  2. It works perfect, thank you gsly.
  3. Chameleon v2.1 (Main Trunk)

    I have same problem on Lion, AR9285 is not working with version 1200, also panic on restart about AirPortAtheros40.kext.
  4. Supported Graphics cards with Full QE/QI

    GT240M works fully (even brightness works without any extra kext) with those efi strings, you may have to customize device-path for your system. <key>PciRoot(0x0)/Pci(0x3,0x0)/Pci(0x0,0x0)</key> <dict> <key>@0,AAPL,blackscreen-preferences</key> <string>0x00000000</string> <key>@0,AAPL,boot-display</key> <string></string> <key>@0,NVDA,UnderscanMin</key> <string>0x00000052</string> <key>@0,NVMT</key> <data> DgP/IAYQzZyAB7AEIAiwB9AHAADTBLMEuQQAAIDaLQkAAAEB/wAAAAAAAAAA AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAD//wAAAAAAAED/EAUCAAAAAAAABAAI AAD/AwAAAAAAAAAAAACAB7AEgAewBA== </data> <key>@0,backlight-control</key> <string>0x00000001</string> <key>@0,built-in</key> <string></string> <key>@0,compatible</key> <string>NVDA,NVMac</string> <key>@0,connector-type</key> <string>0x00000002</string> <key>@0,device_type</key> <string>display</string> <key>@0,display-cfg</key> <string>0x00000103</string> <key>@0,fboffset</key> <string>0x00030000</string> <key>@0,name</key> <string>NVDA,Display-A</string> <key>@0,pwm-info</key> <data> AhgAZJBZAgAIUgAApRwAAAAEAAABAAAA </data> <key>@0,use-backlight-blanking</key> <string></string> <key>@1,AAPL,blackscreen-preferences</key> <string>0x00000000</string> <key>@1,NVDA,UnderscanMin</key> <string>0x00000052</string> <key>@1,can-hot-plug</key> <string></string> <key>@1,compatible</key> <string>NVDA,NVMac</string> <key>@1,connector-type</key> <string>0x00000400</string> <key>@1,device_type</key> <string>display</string> <key>@1,display-cfg</key> <string>0x0101ffff</string> <key>@1,name</key> <string>NVDA,Display-B</string> <key>AAPL,aux-power-connected</key> <string>0x00000001</string> <key>AAPL,backlight-control</key> <string>0x00000001</string> <key>AAPL,slot-name</key> <string>PCI Slot 1</string> <key>AAPL00,DataJustify</key> <string>0x00000001</string> <key>AAPL00,Dither</key> <string>0x00000000</string> <key>AAPL00,DualLink</key> <string>0x00000001</string> <key>AAPL00,Inverter</key> <string>0x00000000</string> <key>AAPL00,InverterFrequency</key> <string>0x00005208</string> <key>AAPL00,LinkFormat</key> <string>0x00000000</string> <key>AAPL00,LinkType</key> <string>0x00000000</string> <key>AAPL00,PixelFormat</key> <string>0x00000000</string> <key>AAPL00,T1</key> <string>0x00000000</string> <key>AAPL00,T2</key> <string>0x00000001</string> <key>AAPL00,T3</key> <string>0x000000c8</string> <key>AAPL00,T4</key> <string>0x000000c8</string> <key>AAPL00,T5</key> <string>0x00000001</string> <key>AAPL00,T6</key> <string>0x00000000</string> <key>AAPL00,T7</key> <string>0x00000190</string> <key>AAPL00,blackscreen-preferences</key> <string>0x00000000</string> <key>AAPL01,blackscreen-preferences</key> <string>0x00007270</string> <key>NVCAP</key> <data> BAAAAAAAAQD+AAAAAAAACgAAAAAAAAAA </data> <key>NVDA,Features</key> <string>0x00c806ff</string> <key>NVPM</key> <data> AQAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA= </data> <key>VRAM,memvendorID</key> <string>0x0001</string> <key>VRAM,totalsize</key> <string>0x40000000</string> <key>device_type</key> <string>NVDA,GeForce</string> <key>model</key> <string>Nvidia GeForce GT240M</string> <key>reg</key> <data> AAABAAAAAAAAAAAAAAAAAAAAAAAQAAECAAAAAAAAAAAAAAAAAAAAARQAAUIA AAAAAAAAAAAAAAAAAAAQHAABAgAAAAAAAAAAAAAAAAAAAAIkAAEBAAAAAAAA AAAAAAAAgAAAADAAAQIAAAAAAAAAAAAAAAAAAAIA </data> <key>rom-revision</key> <string>0x32333533</string> <key>subsystem-id</key> <string>0x000000c8</string> </dict>
  5. RevoBoot

    Thanks for help blackosx. Yes i use static dsdt. But i tried that too, same thing happens. DHP explained in there what is PinConfiguration but i don't understand what causes the difference between bootloaders.
  6. RevoBoot

    I know that, i just mean when i use "PinConfigurations" "0x00" in dsdt with both bootloaders, they give me different "outputs" like in the pictures. But it is not an important thing i think, at least for now.
  7. RevoBoot

    EDIT: solved, i was making a small mistake on PinConfiguration injection. But Revoboot generates non-working PinConfiguration, i solved it by using the one from Chameleon. I'm using Revoboot 1.0.21. I finally found a way to patch AppleHDA, so i added this code to my dsdt: Method (_DSM, 4, NotSerialized) { Store (Package (0x0C) { "codec-id", Buffer (0x04) { 0x72, 0x02, 0xEC, 0x10 }, "built-in", Buffer (One) { 0x00 }, "layout-id", Buffer (0x04) { 0x0C, 0x00, 0x00, 0x00 }, "model", Buffer (0x0F) { "Realtek ALC272" }, "device_type", Buffer (0x07) { "alc272" }, "PinConfigurations", Buffer (One) { 0x00 } }, Local0) DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0)) Return (Local0) } I booted using my usb stick with chameleon and it worked fine. Then i used Revobuilder to compile boot file, restarted, but sound didn't work. When i looked into IOReg i saw PinConfigurations is different with Chameleon and Revoboot. Then i tried adding efi strings but that didn't work with Revoboot. I even tried adding Chameleon's PinConfigurations to my dsdt or efi but that didn't work too. Left side Revoboot, other one Chameleon. What can be causing this? Thanks for helping.
  8. Here it is: ECDT.aml.zip
  9. It still works on me, but i don't have an HP and i don't use dsdt edit. It works if i use a MacbookPro 6.1 ECDT table, battery percent and time are normal.
  10. Chameleon v2.1 (Main Trunk)

    Will there be SSDT tables loading support?
  11. help on ALC272 - different config (ASPIRE5742)

    Try this VoodooHDA, my computer is different but my audio is ALC272 and only this one works on my machine. I hope it works for you too! Archive.zip
  12. DSDT Auto-Patcher

    @Maldon thank you so much! Happy new year!
  13. DSDT Auto-Patcher

    Hi Maldon, I've been trying to fix my dsdt, but there are so many errors, i could not figure it out. My problems are distorted sound when GenerateCStates=Yes is enabled in chameleon and sleep. And my motherboard is a Quanta TW8/SW8. Can it be fixed? Even if it can't, thanks for your help! send_me.zip
  14. AnVAL (ACPI Loader)

    @valv Actually, it is there since i'm using speedstep. When i quickly move my mouse it stops. I tried idlehalt=0 but then my computer become very slow. What can it be related? Sorry for my english by the way.