Jump to content
InsanelyMac Forum

ctn777

Members
  • Content count

    16
  • Joined

  • Last visited

About ctn777

  • Rank
    InsanelyMac Protégé
  1. Yep your tutorial got me started. Thanks for that ! Don't remember which bios I was using.
  2. Thanks, fixed! No problem, glad it worked out for you !
  3. With the keyboard backlight, you'll need to boot up in Windows, set the lighting with the dell/alienware software and it'll stay when using Mac Os. With the r2, I suspect your biggest issue would be the dual video cards being on at the same time. It's easier if you can disable the integrated like the r1.
  4. I've had that issue with the 10.6.3 retail DVD. The retail 10.6.0 works perfect. Also make sure it is set to switchable not discrete. With USB emulation enabled for the installation. Im not sure about the r2 but it works for the r1. Also when booting from USB, it works better with the mouse unplugged, sometimes it doesn't detect the flash stick with the mouse plugged in.
  5. ctn777

    m11x SL install guide

    Hi Everyone, For those that are interested. I have an Install guide for M11X R1. http://www.insanelymac.com/forum/index.php...=0#entry1579170 Cheers!
  6. Due to popular requests, I've decided to do a short write up. First off, I don't own a m11x anymore, I'm about to buy a Macbook Air actually. Secondly, this is mainly thanks to the great knowledge on InsanelyMac and other similar forums, I couldn't have done it on my own ! These are the steps I took to get 10.6.4 and all software updates on my M11X. I may have left out some steps, if I remember I'll put them in. Almost everything works. Here's an picture of QE working. I had BT turned off and sound muted but they work, I also used InsanelyMac's wallpaper I have provided my entire extra directory and the kexts I used. Everything I used will be in one of the two files: Kexts: M11X Kexts.zip Extras: Extra.zip Install Mac OS X 10.6.0 - Create 10.6.0 install flash disk - Run NetbookBootMaker_0.8.4RC1fix.zip on the install flash disk - make sure to set the following in the bios: - Switchable graphics - Enabled (doesn't like discrete when installing) - Usb Emulation - Enabled (so it detects the flash disk) - Install I'm not sure if this should be enabled here. Make sure Switchable graphics is set to Discrete for CE/CI and Usb Emulation - Disabled One more thing to note, these 2 settings have a tendency to reset to defaults and you will need to go into the bios to set them again every reboot. Not sure why this is the case. Post install - run NetbookInstaller 20100616212351.app.zip on the boot drive - check chameleon - check general extensions - check show Extra - run Chameleon RC5 (optional) - delete the 1201n dsdt from the extra directory. - copy m11x dsdt to extra directory - copy com.apple.Boot.plist to the extra directory - copy sleepenabler.kext to extras/General Extensions - remove Nvenabler.kext from extras (critical to get QE/CI working) - add 0xcaf to nvhdamh50.kext in SLE (don't think this is required) - install 10.6.4 combo update but don't restart. - trim SLE (delete unneeded ATI kexts) so it's under 256meg. Should be fixed in the latest NBI. - updateextras - reboot This should 100% be enabled here. Make sure Switchable graphics is set to Discrete for CE/CI and Usb Emulation - Disabled Post Install Install the following kexts: - voodooHDA via kext helper - VoodooHDA prefPane - voodooPowerMini via kext helper - AtherosL1cEthernet.kext (LAN) via kext helper - DellBluetoothHCI.1.2.pkg (Bluetooth) via the install package. Bluetooth fix (Turn bluetooth on/off) - edit IOBluetoothFamily.kext/Contents/PlugIns/BroadcomUSBBluetoothHCIController.kext/Contents/info.plist in SLE - search for Broadcom2046FamilyUSBBluetoothHCIController_37A - replace the following with the product id and vendor id of the bluetooth card. <key>idProduct</key> <integer>XXXXX</integer> <key>idVendor</key> <integer>XXXXX</integer> - save and run updateextras. - Sorry I dont't have a m11x to check this anymore. If trackpad does not work run Kext Utility. - I duplicated the GE directory into the E directory and ran Kext Utility. If all else fails, just use my entire Extra directory. What does not work: - DW1520 / WiFi (buy a DW1510 wireless to fix this) - SDHC slot - Video switching - Sleep (should be able to work but the proper kext but I didn't have time to try) Random boot hang is also fixed in the com.apple.Boot.plist. What works: - QE/CI - SD card - trackpad - usb 2.0 - vga out - webcam + facetime - audio - bluetooth - speedstep - restart/shutdown - fn keys Not sure (I didn't have time to test but I don't see why it shouldn't work): - Firewire - HDMI - DisplayPort. If you find the guide useful, please leave a comment.
  7. Has anyone tried this on the m11x?
  8. ctn777

    Alienware M11X

    I haven't tried sleep nor graphics switching. I never use sleep and I always keep it on discrete graphics. So far, the SD card slot doesn't work and the wifi doesn't work. I'm getting a DW1510 for wifi.
  9. ctn777

    Alienware M11X

    I got most of it working, just lacking wifi and the sd card reader. I ordered a 1510 from ebay, hoping to fix the wifi.
  10. ctn777

    Broadcom bcm43xx wireless driver [beta]

    Anyone had any luck with 43224?
  11. ctn777

    Alienware M11X

    I made major progress on the m11x. Got most of the hardware to work.
  12. ctn777

    Alienware M11X

    Nice Tutorial. Using A05 bios and USB EMULATION to Enabled. I followed most of it and managed to get QE working with the proper resolution, audio, keyboard, usb ports. Bluetooth, WLAN, trackpad doesn't work. I've been trying to use the latest version of NBI to work instead of the Asus 1201N Installer package v4.pkg. Kernel Panics on boot though. Anyone else have more luck?
  13. ctn777

    SL (now 10.6.3) on 1000h: no problem!

    Awesome thanks ! I got the 1000H running with 10.6.4 with everything working except video out. I get a white screen when I plug the vga cable in, not sure what I'm doing wrong.
  14. ctn777

    Introduce yourself.

    Hi I'm New to the forum from Australia. I'm trying to get osx86 on my eeepc working.
×