Jump to content

yozik

Members
  • Content count

    43
  • Joined

  • Last visited

About yozik

  • Rank
    InsanelyMac Protégé
  1. sure thing Let us know how the 10.12 install goes. I have been hesitant to update to 10.12 as the current install works well. Not sure I want to fight with audio kext if for some reason the one I have now doesn't work with 10.12.
  2. Ok I finally have built-in graphics working using the kexts from post 795 (linked off first post), here's what I've copied cd /System/Library/Extensions/AppleGraphicsPowerManagement.kext/Contents/ cp Info.plist Info.plist.org cp /Users/yozik/Downloads/10.8.2SLEEP/System/Library/Extensions/AppleGraphicsPowerManagement.kext/Contents/Info.plist . cd /Library/Extensions/ cp -R /Users/yozik/Downloads/10.8.2SLEEP/System/Library/Extensions/_OverrideNVDA* . cp -R /Users/yozik/Downloads/10.8.2SLEEP/System/Library/Extensions/Natit.kext . I also installed the nvidia web driver from nvidia's website - 346.03.04f02 I've set GraphicsEnabler to No I've removed the external graphics card and all is well
  3. ok noticed that the front USB ports weren't working. Read around online and found that it was due to SUB port restrictions. I edited /System/Library/Extensions/IOUSBHostFamily.kext/Contents/PlugIns/AppleUSBEHCIPCI.kext/Contents/Info.plist and removed the port-count and ports from both <key>Macmini4,1..... sections see http://www.insanelymac.com/forum/topic/306777-guide-usb-fix-el-capitan-1011/page-1for more details on how get USB ports working Better idea, instead of modifying the original kext that may get replaced on updates, lets copy the plugin to /L/E/ and add in the missing ports attached is an updated kext that should be placed in /L/E/ I've added the missing ports to macmini4 since that is the system definition I use AppleUSBEHCIPCI.kext.zip
  4. hi, Here is how I got 10.11.2 installed on to new second drive using the existing install on this system. what you'll need: El Capitan installer the latest un*beast installer for 10.11 enoch installer audio kext - see attachment kernel kext - see attachment files for /Extra - see attachment second hdd/ssd Extra.zip Kernels.zip Kexts.zip so I used a second hdd/ssd instead of a usb key as I had problems with this board booting from usb. on the second drive create two partitions: size the second partition at 9G and call it beast leave the first partition with the remainder and call it El Cap run un*beast installer: select the beast partition we just made select the El Capitan installer select UEFI Clover installer - we'll remove this later install once un*beast completes: find the device called "EFI" in finder side-bar remove everything in EFI directory leaving the EFI directory empty run the enoch installer select the beast device use standard install once enoch installer completes: copy over contents of the Extras attachment to /Volumes/beast/Extra/ copy over the Kernels directory to /Volumes/beast/System/Library/ reboot now on reboot you need to have your second drive selected as the boot device do this using the Esc key and selecting your second drive or switch the data cables around so that the second drive is now the first or switch boot order in bios at the boot prompt select beast to boot from run through installer and be sure to select El Cap as the install destination on reboot be sure that the second drive is the active one select El Cap from the boot menu run through first time setup once logged in use diskutil to delete beast partition run enoch installer and select El Cap as the destination drive and use standard install once enoch is complete repeat step 5 but this time use /Extra/ and /System/Library as the destinations copy over the kexts from the attachment to /Library/Extenstions/ rename /System/Library/Extensions/AppleHDA.kext to /System/Library/Extensions/AppleHDA.kext.bak reboot ensure that your new drive is the active one at the boot menu select El Cap and boot you should have working audio now
  5. Sorry if you posted this information already, can you list your system configuration? Custom bios mod, dsdt, custom kexts, etc. Thanks Yozik
  6. i-e motherboard revision using bios mod from fist page thus no DDSs chameleon: 2.2svn cpu and memory: Hardware Overview: Model Name: Mac mini Model Identifier: Macmini4,1 Processor Name: Quad-Core Intel Xeon Processor Speed: 2.50 GHz Number of Processors: 1 Total Number of Cores: 4 L2 Cache: 4 MB Memory: 8 GB Bus Speed: 1.33 GHz Boot ROM Version: MM41.0042.B03 SMC Version (system): 1.30f3 Serial Number (system): C02F7I80DD6H Hardware UUID: 5FFCAF86-9D64-5F3E-AB99-4BBECA44A7D7 audio: using applehda from post 795 for audio Intel High Definition Audio: Audio ID: 662 Speaker: Connection: 1/8-Inch Jack Internal Microphone: Connection: Internal External Microphone / iPhone Headset: Connection: 1/8-Inch Jack Line Input: Connection: 1/8-Inch Jack Headphone: Connection: 1/8-Inch Jack S/PDIF Optical Digital Audio Output: Connection: Combination Output video: Jaton GeForce 9500 GT: Chipset Model: Jaton GeForce 9500 GT Type: GPU Bus: PCIe Slot: Slot-1 PCIe Lane Width: x16 VRAM (Total): 1024 MB Vendor: NVIDIA (0x10de) Device ID: 0x0640 Revision ID: 0x00a1 ROM Revision: 62.94.45.00.A1 installation process: I used a second harddrive [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] 3.0.1 offical app from app store after [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] was done I copied over the org.chameleon.Boot.plist over to the second hdd upgraded 10.8 install -- yozik
  7. Yes. I just did an in-place upgrade last weekend. I can provide the steps I followed, org.chameleon.Boot.plist.org, and a listing of the /E/E and /S/L/E kexts that aren't stock. - Yozik
  8. I can't speak windows as the box is dedicated to osx only. Had issues a while back with the built in graphics so I went the route of external card. Most nvidia cards should out of the box with the 10.8.x install from what I have read. You may need to do graphicsenabled=yes on boot. Also verify that you have the correct boos for your board,maps there are multiple revisions of the board. Yozik
  9. I recently did a fresh install due to sDD failure. I have the latest 10.8.x installed. I'm not using the built in graphics, but a pci nvidia card. I'm using the bios mod from page 1.
  10. sorry I wasn't clearer before this is on 10.8.2 I guess we have different end goals, well maybe anyhow, I am thankful for your help and I am wiling to help out anyone with what ever I can I can say for ML 10.8.2 that the patched audio kext still works and that I had to use Chimera to boot if anyone else has questions please ask -- Yozik
  11. ok just wanted to be sure hmm still not working I get black screen, oh well. At lest I know the external card works with the updated drivers, so the only real modification is the AppleHDA that needs to be put back after updating. thanks for your help -- Yozik
  12. thanks trying this out now by injectors you mean the EFI string? that is all I have, along with the 10.7.5 NV* kexts, everything else is vanilla thanks Yozik
  13. ugokind I had tried out the 3.04 drivers and the installer kept saying that I already had the drivers installed, so I then opened the installer and ran the installer that is in it only to get black screen still. Guess I should ask what is the resolver? is it the two kexts that start with _ ? is there anything else I need? I'll try again maybe I missed the resolver part. glad the audio works for you thanks Yozik
  14. vicentj and ugokind I am attaching a tar of the AppleHDA kext that I have been able to use without issues. I'm currently using it in 10.8.2. What I did was remove the original AppleHDA.kext with the back up one that I have. Current status: so I update to 10.7.5 only to find out that the built-in video no longer works (black screen after boot up). Tried to replace the NVDAResman.kext as previously worked but this time no go. I dug up a geforce 8400 gs pcie and that worked with efi string. I then proceeded to do the extra hard drive with two partitions install method for installing 10.8. After my tries I finally got a working system. I basically had to remove the following kexts and replace them with the ones from 10.7.5 NVDAGF100Hal.kext NVDAGK100Hal.kext NVDANV50Hal.kext NVDAResman.kext NVSMU.kext I'm not certain which one(s) have the actual changes in them but I dont care at this point cause it's working fine. after the install I then replaced the AppleHDA.kext with the patched one I have attached to this post. I get audio out, video out with external card. the only other issue I have ran into is that I have to add npci=0x2000 to kernel flags system set up: I-E version of the board patched bios from the first page the patched AppleHDA the replaced NV* kexts from 10.7.5 and these three in /E/E: FakeSMC.kext NVEnabler64.kext ZEvOreboot.kext PCIE GeForce 8400 GS 512MB 8G RAM Intel Core 2 Duo Quad Q8300 Chimera 1.11.1 boot loader as needed for 10.8 so I have found - Yozik ps if needed I can post the NV* kexts I found that work for me if needed AppleHDA.kext.tar
×