Jump to content

Toooorch

Members
  • Content Count

    42
  • Joined

  • Last visited

About Toooorch

  • Rank
    InsanelyMac Protégé

Profile Information

  • Gender
    Male

Recent Profile Visitors

3,467 profile views
  1. https://github.com/RehabMan/OS-X-Clover-Laptop-Config/blob/master/config_UHD630.plist
  2. Toooorch

    WIFI DELL VOSTRO 15 3568

    If I found a correct thing then It has Intel Wireless-AC 3165 and it is not gonna work since Intel cards simply does not work on macOS. There are a few projects on github but nothing that really works :-) replace that with supported one and you are good to go.
  3. Toooorch

    App Store Updates

    That's ok. You should only consider the system updates like 13.13.6 > 13.13.7 that probably will need to update config/kexts/etc. I have good golden rule for this if you need the machine for work for example - don't update what works
  4. Toooorch

    Korg Nanokontrol2 - anybody?

    I can't say anything because you did not attached any config etc. but I guess (almost sure!) you need new USB patch for 13.13.6. Search forum...
  5. Toooorch

    control GTX1050M on ASUS ROG GL553VD

    ASUS ROG GL553VD uses optimus. So no luck with dedicated graphic card... you can only disable it and use integrated(ssdt/dsdt patch - use search). It won't work. Bad choice. https://www.notebookcheck.net/Asus-ROG-Strix-GL553VD-7700HQ-FHD-GTX-1050-Laptop-Review.200646.0.html
  6. Toooorch

    Asus Gl553VD mic issue

    Don't use same kext on both locations. That does not make any sense... You can use appleALC+LILU for audio output and voodooHDA for microphone. Same thing that I need to solve on my laptop Use search. Also the coddecCommander might need some additional settings/own profile...
  7. Hey everyone, I have decided to ask for help with my new laptop and more specifically with the DSDT patches for it because although I was able to apply some mandatory patches and everything went just fine but things could be better in my opinion and I want to improve my knowledge. This going to be long, sorry tl;dr > the problems and questions Few things about the laptop: i7 8750H - 6 Cores Coffee Lake NVIDIA GTX 1080 8GB - works fine with WEB drivers (even the 144Hz display and performance is really good) Intel Wireless-AC 9560 + BT5 > will be replaced with BCM943602BAED, now dongle USB2.0 HD UVC WebCam > works great Realtek ALC295 > AppleALC with layout 3 Samsung 512GB NVME > works great Trackpad - ELAN 1404 / pci8086,a368 & pci8086,a369 The problems and questions that I have: Trackpad/touchpad - from what I understood with my nights with IOreg - it is assembled from two devices actually (it has switchable trackpad - Numpad combo) The devices are pci8086,a368 & pci8086,a369. Tried to get them working by DSDT patch + VoodooIC2 since they are IC2 devices but the controller (pci8086,a368...) is probably unsupported? Shutdown with the restart - I tried to fix it using DSDT already because it is the well-known issue but the problem is that the "SB.PCI0.XHC.PMEE" is not presented in my DSDT. So after applying patch from RehabMan, I have the problem to compile the DSDT because of error. (Object does not exist \_SB.PCI0.XHC.PMEE). There are other XHC trees but nothing I can use instead I think. plugin type causes that I am unable to boot > this screen https://imgur.com/a/MdMvaUY I think it has to do something with the fact that ASUS has locked _MSR? in IOReg, I can see that EC0, IPIC don't have any kext/service loaded is that ok? I applied clover on the fly fixes but that did not change anything. AppleACPICPU is loaded under PROX@X instead of CPU, is that ok? I already applied some patches to the DSDT but since I am doing that for the very first time (I mean really "correctly") I am not sure if everything is fine. It would be great if someone can check IOReg/DSDT and tell if I should focus on something. I have attached send me created by utility Send me.app (Mald0n). I think it should include everything you need to check these things. https://www3.zippyshare.com/v/qOxWyRxj/file.html Also, I maintain GitHub repo for this if you are interested https://github.com/Toooorch/ROG-ZEPHYRUS-GX501 Thanks for any knowledge/advice anyone could help in advance! DSDT - Current - Audio, battery, windows10 and small patches.dsl
  8. Thanks! Still the same screen with versions https://imgur.com/a/MdMvaUY or something
  9. Hey, thanks! Can't boot now only without DSDT https://imgur.com/a/MdMvaUY
  10. Hey MaLdon, could you please take a look at my DSDT? Tried to apply some patches already but still not good and I am curious how far you can go with it. Used your clover (only deleted thing I think I really don't need) and run.app. Here are the files: https://www104.zippyshare.com/v/fCl7RDpm/file.html Hardware is laptop Asus ROG Zephyrus GX501 8th Gen Intel CPU CPU: i7 8750H Coffee Lake - 6 cores GPU: nVidia 1080 - no optimus - works only without g-sync and 144Hz display RAM: 24GB HDD: NVME 512MB Samsung SSD Trackpad: I2C (I believe this needs DSDT patch) should be ELAN/SA473I-12A4 BT: HCI 9.256 / LMP 9.256 work WiFi: Intel Wireless-AC 9560 - I know this simply wont work - resolved with usb wifi dongle Audio: ALC668 (voodoohda works great in this case) For whatever reason I had to add emu variable uefi 64 efi to clover drivers because otherwise the installer freeze at first stage of installation with error - Failed to SET NVRAM property > Target is not convertible to APFS (but system is already converted to APFS). emuVariableEfi solved that. Thanks in advance!
  11. Toooorch

    AptioMemoryFix

    Thanks for pointing me to your EFI! Almost same as I have. Tried to use your whole EFI (only had to add NVMe support) and I was able to pass the ******* screen but then on load, it stucks on "HID: Legacy shim 2" and then something like kernel panic on "Still waiting for root device". I am sure that this "progress" was caused by the older version of Clover because with the newer version I am not able to pass the ***** screen by anyway. My clover version is now Clover_v2.4k_r4114 and for example, Clover_v2.4k_r4220 is already bad for me. It is weird, don't know how to debug it or which direction I should go. I can't even update to newer version of macOS (10.13 17A365+) because it requires newer clover I think because otherwise, it has the "Still waiting for root device" issue. Added also my EFI for example on macOS 10.13 17A365 and clover 4114 it works perfectly and it is very stable. EFI.zip
  12. Toooorch

    AptioMemoryFix

    Weird, I tried to boot with the optiofix2 and slide=128 again (lowest possible slide which I calculated before is 129 for me ) and the same result as every time - stuck on screen with line of stars *********************************************************** But I can notice that after +-2 seconds that my RGB keyboard is being off.
  13. Toooorch

    AptioMemoryFix

    Wonder what else I can try because the only way to boot my system now is AptioFix2000.efi (stable for me, but does not work with newer clovers). With AptioMemoryFix from this thread I have 128/256 valid slides but only with latest RC versions (it shows 256/0 slides before RC12). I tried aptiofix2/3, not possible to boot... also tried to calculate the slide= parameter but it is not possible for my board obivously because all available slots are too wide. Any ideas? Thanks! or if we can improve the AptioMemoryFix I can test if needed. --- board: X99 Deluxe II CPU: 5820K RAM: 32GB G.skill Trident Z BIOS 4G decode enabled (and it really helped with stability) etc. this should be fine
×