Jump to content
InsanelyMac Forum

BartMan01

Members
  • Content count

    4
  • Joined

  • Last visited

About BartMan01

  • Rank
    InsanelyMac Protégé
  1. BartMan01

    New Driver for Realtek RTL8111

    After updating to 2.0.0d2, it seems my networking issues are pretty much resolved. I use VMWare and frequently have virtual machines running set use their own IP address (sharing the ethernet port as opposed to using NAT). Prior to this version, I was having frequent network issues either when running VM's or transferring very large files. With this version, it has been stable so far.
  2. BartMan01

    New Driver for Realtek RTL8111

    Lovely. Is there anything that can be done to mitigate the issue?
  3. BartMan01

    New Driver for Realtek RTL8111

    Having issues with my GA-X58A-UD5 built in Ethernet. I was getting very frequent occurances where Ethernet would just stop working. I put in the debug version of the driver and suprisingly things got much more stable with that. I have gone from several times a day to just once in the last few days. Still trying to catch it in the act with the debug driver in place (as opposed to a while after it happened with no clear idea what time it occured). One thing I am seeing a lot of in the logs is the following: Apr 3 05:52:38 Zeus kernel[0]: Ethernet [RealtekRTL8111]: Not enough descriptors. Stalling. Apr 3 05:52:38 Zeus kernel[0]: Ethernet [RealtekRTL8111]: Restart stalled queue! Apr 3 05:52:38 Zeus kernel[0]: Ethernet [RealtekRTL8111]: Not enough descriptors. Stalling. Apr 3 05:52:38 Zeus kernel[0]: Ethernet [RealtekRTL8111]: Restart stalled queue! Apr 3 05:52:38 Zeus kernel[0]: Ethernet [RealtekRTL8111]: Not enough descriptors. Stalling. Apr 3 05:52:38 Zeus kernel[0]: Ethernet [RealtekRTL8111]: Restart stalled queue! Apr 3 05:52:38 Zeus kernel[0]: Ethernet [RealtekRTL8111]: Not enough descriptors. Stalling. Apr 3 05:52:38 Zeus kernel[0]: Ethernet [RealtekRTL8111]: Restart stalled queue! Apr 3 05:52:38 Zeus kernel[0]: Ethernet [RealtekRTL8111]: Not enough descriptors. Stalling. ... no other RTL8111 entries, at this point I restarted the switch and: Apr 3 09:24:25 Zeus kernel[0]: Ethernet [RealtekRTL8111]: Link down on en0 Apr 3 09:24:25 Zeus kernel[0]: Ethernet [RealtekRTL8111]: Promiscuous mode disabled. Apr 3 09:24:32 Zeus kernel[0]: Ethernet [RealtekRTL8111]: Link up on en0, 1-Gigabit, Full-duplex, flow-control Apr 3 09:24:32 Zeus kernel[0]: Ethernet [RealtekRTL8111]: Promiscuous mode enabled. As far as I can tell the 'not enought descriptors' messages have not come back yet. I suspect that Ethernet stopped working at 5:52:38 when it stalled but did not restart the stalled queue. Any ideas? Suggestions on troubleshooting this? One thing I have thought of doing was swithing to the second ethernet port on the motherboard to see if it has the same issues. Worth a try? Thanks. Edit: Additional info: Been happening for a while. Tried replacing both cable and switch to rule them out. Very intermittent but seems to happen most often in the middle of large sustained file transfers.
×