Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About flapclock

  • Rank
    InsanelyMac Protégé
  1. This could be the same issue I'm seeing with AppleIntelFramebufferCapri.kext - the patched version included in the v0.3 extra kext archive locks my surface up at the bluetooth reponse. Try restoring the original AppleIntelFramebufferCapri.kext and repairing permissions.
  2. Thanks JahStories. If I attempt to use the patched AppleIntelFrameBufferCapri.kext my system won't boot. Any idea what might be causing this?
  3. (surfaceosx) Thanks again for the hard work JahStories, I'm loving Mavericks on my Surface Pro. If anyone else is struggling to get backlight, QE/QI and sleep working, I have a few changes to the v0.3 process that has resolved these issues for me. Don't install the AppleIntelFramebufferCapri.kext file in the "patched extra kext" linik. Use the config.plist attached - the one in the 0.3 link archive appears to be incorrect, where the ig-platform-id is 0x01660004 but 0x0166000A works for me. KextDrop ACPIBacklight.kext, copy dsdt.aml to EFI/CLOVER/ACPI/patched and generate a serial with CloverConfigurator as written in JahStories' instructions. Remember that you will also need RehabMan's NullEthernet.kext and a generated serial to access the apple store (https://github.com/RehabMan/OS-X-Null-Ethernet) YMMV, but this has resulted in a perfect Mavericks install for me! JahStories, happy for you to include this in your guide if you think it's correct and I'll edit my post if you consider this a parallel guide. Edit: turns out that the config.plist change was a red herring. config.plist.zip
  4. (surfaceosx) First up, thanks to JahStories and everyone who has contributed to this guide, osx on the surface pro is excellent! I'm having trouble getting v0.3 onto my surface pro. I've managed to get v0.2 + patches on there (booting from SSD), but attempting to install the v0.3 files results in the **** [iOBluetoothHCIController][searchForTransportEventTimeOutHandler] -- Missing Bluetooth Controller Transport! error that others have seen. I've narrowed this down to the appleintelframebuffercapri.kext (I can push the other kext, config.plist and dsdt - although the dsdt results in video distortion). I'm currently on Mavericks 1.9 without updates - is there a sequence that I'm missing here? Should I update to 1.9.2 before applying the v0.3 patches? I've tried (I think) to put the video id (0x1660009) as mentioned by CKtalon but this doesn't seem to do anything - not sure I'm doing it correctly though. I also edited the config.plist directly to no avail. Interestingly, once I have installed the appleintelframebuffercapri.kext file I can't roll back to a working state - deleting the kext from /S/L/E/ still results in the IOBluetoothHCIController error mentioned above. I'm also not sure that I've been generating the serial correctly in CloverConfigurator. I've opened the dsdt (v0.3) used the wizard to generate for Macbookair5,2, copied all data and then overwritten the dsdt. Is this the correct process? Thanks for any help!