Jump to content

lubeats

Members
  • Content Count

    30
  • Joined

  • Last visited

Posts posted by lubeats


  1. On 2/4/2020 at 8:11 AM, niknod said:

    Lubeats thank you very much for 

    Name: com.apple.driver.AppleGraphicsDevicePolicy
    Search: BA050000 00
    Replace: BA000000 00
    Comment: prevent AGDP from loading
    I been trying to get my Hdmi out for a year now and this patch fixed all my problems I also have Hdmi Audio once again
    THANK YOU.....

     

    Your welcome.

     


  2. Hi to everyone. I need help. Is possible to patch my DSDT to get a complete gestures in my laptop?

     

    Currently, I use ApplePS2SmartTouchPad.kext installed in /S/L/E

     

    I have touch functions but no complete gestures. My laptop is Lenovo Z70-80FG with Synaptics touchPad

     

    Gestures:

    - scrolling up/down

    - right clic with three fingers

    - open link with two fingers

    - open launchpad with three fingers down

    - hide/show dock with four fingers to left

    - moving objects or windows with double click hold pressing and without releasett

     

    I think that there is more gestures and I want to get it

     

    Attach a screenshot of trackpad status panel

    image.png.2c0f6bf2be6bd994f30cb9f9ca82be41.png


  3. @Bernardo415 en windows que controlador te aparece como dispositivo de audio? para que tengas audio de forma nativa primeramente tienes que identificar que integrado de sonido tienes, en windows puedes usar el Everest o el Sandra. En mac puedes usar SysInfo. Sería bueno que generes un reporte de HW en windows con cualquiera de los programas que te mencioné.


  4. Lo unico que instalo son 2 kexts a la ruta S/L/E 

     

    ApplePS2SmartTouchPad.kext  v4.6.8

    VoodooPS2Controller.kext  v1.8.34

     los puedes instalar con cualquier instalador de Kexts de tu preferencia.

     

    Ahora si voy a terminar de preparar mis archivos para proceder a instalar el macOS Mojave. 

     

    Mi proximo post será con las fotos del sistema :D 


  5. @MaLd0n I had the slide Computer Sleep mode in Never in System Preferences but I changed it, run your command file and nothing. I have the same problem. When I choose the Sleep option it shutdown, but it is stranger because it's turn off and when I press the Turn On button, It turn on like if it was in sleep and request me my password to enter. My system turn on with automatic mode without password. What do you think is happening?


  6. @MaLd0n You refer about this?

     

    image.png.2c9345e1ef427b1a9eb941b3f749ac15.png

    I don't remember how to know what kind of mobo I have

    I think you refer about the specs of Chipset like this for my GA-EP45T-UD3LR

     

    North Bridge: Intel P45 Express Chipset
    South Bridge: Intel ICH10R

     

    and when you refer for ICH10 is for that. is correct?

     

    Then I should to understand that I need to use you complete folder downloaded and use the config.plist suggested?

     

    image.png.289d12be620e3227b5cd70e22cea5907.png

     


  7. @MaLd0n this is my zip file recently generated and it has the latest clover update. I have to tell you that when You patched my DSDT file I patched it again with the txt content (for my sound card) that I attached here but it final DSDT doesn't have errors. I create a new file with your run. app and is the new file attached. If You patch my DSDT again tell me if necesary patch it for my sound card again. Thanks in advance.

    Send me lubeatss-iMac.zip

    HDEF_Patch.txt


  8. Hello MaLd0n, I need your support to fix my DSDT, I ran your app Olaria and I taken the DSDT generated to patch it and I deleted this line twice

    Store (Local0, Local0)

     

    after that I patched it for audio and afterwards I put it into my patched folder together with SSDT-0-CpuPm.aml and SSDT-1-CpuCst.aml to fix my problem with shutdown. It works sometimes, but almost always it continues turn on. 

     

    Please help me with that.

     

    My mainboard is an older Gigabyte GA-EP45T-UD3LR with OSX EL Capitan 10.11.6 with Intel Core 2 Quad Q9550 and I wish to update to macOS 10.13.6 but I think is impossible for the oldie processor.

     

    My graphic card is Gigabyte GeForce GT 430 1024 MB and I got 8 GB ram.

     

    I attached my zip file generated.Send me lubeatss-iMac.zip

    Send me lubeatss-iMac.zip


  9. Finally I could solve my problem without help. I made changes into System Preferences/Keyboard.  I forced change and it works with combination Fn+ F11 or F12.

     

    My current functional hot keys is

     

    F1 - Mute - by Default

    F2 - Decrease volume - by Default 

    F3 - Increase volume - by Default

    F4 - Close apps or current windows by Default

    F5 - nonfunctions

    F6 - On/Off Touchpad by Default

    F7 - nonfunctions

    F8 - Launchpad

    F9 - On/Off Display LED

    F10 + Fn - Show Desktop

    F11 - Decrease brightness

    F12 - Increase brightness

     

    That's all.

    Brightness Control Keys.png


  10. Hi Hervé,

    • Capri framebuffer kext is for IvyBridge HD4000 iGPUs
    • Azul framebuffer kext is for Haswell HD4200/4400/4600/etc. iGPUs
    • BDW framebuffer kext is for Broadwell HD5500/etc. iGPUs
    • SKL framebuffer kext is for Skylake iGPUs
    • and so on...

    I didn't know about this info and I have don't remember read this info before in any site, but  big thanks for this.

     

    Hervé, Did You remember that I wrote that with this KextsToPatch

     

    Name: com.apple.driver.AppleGraphicsDevicePolicy
    Search: BA050000 00
    Replace: BA000000 00
    Comment: prevent AGDP from loading

     

    I had VGA & HDMI output without problem. So, I started to do many changes one by one.

     

    First

    - Update my SMBIOS to MacBookPro12,1 and disabled the KextsToPatch above. Surprise, I had the same functionality as I had before with KextsToPatch but with this info into AppleIntelBDWGraphicsFramebuffer

     

    06002616 01030303              // layout 0x16260006, 3 x display ports
    00000800 02000000 30020000     // FB@0, port #0, LVDS (connector-type 0200 0000)
    01050B00 00040000 07050000     // FB@1, port #5, DP (connector-type 0004 0000)
    02040B00 00040000 07050000     // FB@2, port #6, DP (connector-type 0004 0000)

     

    When I connected my VGA Display, it taken port #6, DP (connector-type 0004 0000) and

    when I connected my HDMI TV,  it taken port #5, DP (connector-type 0004 0000)

     

    Second:

    - Deleted  several lines of KextsToPatch. I deleted in special  the AppleIntelBDWGraphicsFramebuffer because I unlocked my UEFI BIOS last year and I can change my dvmt manually and that KextsToPatch was in vain.

     

    image.png.2cbae717dd215c84cf7c7c58a79ce8e1.png 

     

    Third:

    - I patched my AppleIntelBDWGraphicsFramebuffer.kext and replaced in S/L/E

     

    Rebooted and after that the current config is

     

    06002616 01030303              // layout 0x16260006, 3 x display ports
    00000800 02000000 30020000     // FB@0, port #0, LVDS (connector-type 0200 0000)
    01050B00 00080000 07050000     // FB@1, port #5, DP (connector-type 0008 0000)
    02040B00 00040000 07050000     // FB@2, port #6, DP (connector-type 0004 0000)

     

    To finish I tried VGA & HDMI and it works like a charm o better say with the same functionality as it made the KextsToPatch before, with audio but without volume control and with 1366x768 res default and when I change to full HD res, I lose the main menu in border. That's normal or maybe is possible to get the main menu border like my display laptop with full HD?

     

    Would be possible to get volume control with HDMI or that's impossible? I read in another site that is impossible but maybe someone knows like to do it work.

     

    HDMI Output.png

     

    HDMI Ouput default.png

     

     

    VGA Output default.png

×