Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About AeroShark

  • Rank
    InsanelyMac Protégé

Profile Information

  • Gender
  1. Hey, thanks for the tutorial! I have the same model as you with the modded F1B BIOS and all, but with the lower res screen. Any chance I could get the DSDT without the dual-link patch? And/Or list of patches you applied or an undo of the dual-link patch so I can do it myself in the future? Also, did clover work good for you? EDIT: So I opened up the DSDT from your latest pack in MacIASL and just applied RehabMan's HD3000 low res patch since it removes the dual-link patch in the process, applied basic syntax patches to compile and used that. Not sure if it's correct but the dsdt loads and gives me full HD3000 graphics and sleep. To get brightness keys and left usb3.0 ports to work though, I had to use the corresponding kexts from your old pack. Do you still have to use these kexts or are DSDT patches supposed to take care of it now? I'm just wondering wether they were left out of the new pack by mistake, or if my hacky re-edit of your DSDT broke these features which you may gotten to work natively with your DSDT. If those two kexts were left out by mistake, are there any kexts or procedures I should be following from the old tutorial? Only other issues I've noticed so far are the occasional failed wake from sleep, volume level resetting to max if left idle for too long, and sometimes continual network drop-out over ethernet until reboot. Again, wondering if you see any of these issues with your DSDT? Also, if you get a chance later could you let me know what patches you've applied for DSDT in total now? It would help me understand what should and shouldn't be working, and even with playing around with clover. Great job on this all!! Laptop works nearly 100%!
  2. I can also confirm the patches not working for me (CPU: i3-4130, Mobo: ASUS H87i-Plus, Boot: Clover UEFI). I think it'd be fun to get OS X working on this particular box, but it's not critical for me. So if there is still interest from others in getting this to work I'd be interested to try various patches/suggestions. Although I'm not totally incompetent with having built 2 hackintosh in the past, I'm not advanced enough, or at least not familiar, with writing such patches.
  3. DV6-6090xx Mac OS X Lion Install Disc

    I agree! Bootloader is chimera 1.11.0, but I've also tried the 1.10.0 that comes in the latest [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] Kext Wizard didn't help either Repaired the disk, didn't help So I used kextstat to compare what kexts were loaded with and without kernel cache. Turns out ApplePS2Trackpad.kext (exists in the plugins folder within ApplePS2Controller.kext) is only loaded with the kernel cache enabled. Thus, all disabling the Kernel Cache was doing was causing ApplePS2Trackpad.kext to not be loaded. So the tackapd was only working without glitches because it was being treated as a mouse (without multitouch, which is the whole point of the trackpad). VoodooPS2 on the other hand, still loads its VoodooPS2Trackpad.kext with UseKernelCache=No. But it glitches in this case too. So any Trackpad kext will cause glitches with or without the Kernel Cache as long as there is no -f flag. Thus any multitouch funtionality would cause me glitches if there is no -f flag. Going back to using the -f flag, I'm able to get multitouch functionality without glitches So, current situation: can only get mutlitouch functionality without glitches by using the -f flag Using kextstat to compare what kexts were loaded with and without the -f flag, I found them to be identical. I'm not using an org.chameleon.Boot.plist so what is -f even doing?
  4. DV6-6090xx Mac OS X Lion Install Disc

    Sorry for the confusion, I was referencing trying to get certain other kexts to work. For now ignore it. For debugging purposes and to be clear, here is my latest setup: I patched my [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] Installer with OSInstall.mpkg so I could install OS X on my MBR partitioned hard drive. Then installed my vanilla OS X. Next, I booted into my installation using my [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] USB stick. Then, I placed the Extra folder you gave me to the root of my installation. I then installed the latest version of Chimera I removed AppleIntelCPUPowerManagement.kext from my S/L/E I deleted my caches by removing all files in /Library/Caches/ and ~/Library/Caches and /System/Library/Chaches I then installed AppleACPIPS2Nub.kext, ApplePS2Controller.kext, FakeSMC.kext, and a patched AppleIntelCPUPowerManagement.kext using Kext Utility which also rebuilt my Kernel Cache. Rebooting without my usb stick gave me the boot0 error, so booting into [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] off my usb stick, I unmouted my install partition and then entered in the terminal: cd /usr/standalone/i386 dd if=boot1h of=/dev/disk0s4 Rebooting without my usb stick worked, but trackpad glitches occur. I installed FanControl1.2.zip + EDID Notebook Installer 1.0.zip, deleted my caches, and rebuilt my Kernel Cache by running kext utility. Rebooting, trackpad glitches still occur I then removed org.chameleon.Boot.plist Reboot is now slow because Kernel Cache is not enabled but trackpad glitches do not occur in this case If I boot with the flag UseKernelCache=Yes, trackpad glitches come back So I guess my system is vanilla with the exception of a patched AppleIntelCPUPowerManagement.kext, ApplePS2Controller.kext, AppleACPIPS2Nub.kext, and a FakeSMC.kext. And obviously chimera with smbios.plist and DSDT. With the only things "Installed" being FanControl1.2.zip and EDID Notebook Installer 1.0.zip.
  5. DV6-6090xx Mac OS X Lion Install Disc

    Took care of a few intermittent graphics artifacts that would occur every few boots, thanks! Sadly, mouse glitches are still there with UseKernelCache=Yes
  6. DV6-6090xx Mac OS X Lion Install Disc

    Ok, I've made some small progress with this. First, i found that if I copy the PS2Keyboard, PS2Trackpad, and PS2Mouse kexts from the plugins directory in the PS2Controller kext, to S/L/E, I'm able to use a lot more versions of ApplePS2 and VoodooPS2 (before there were only a very select few versions that gave me ANY trackpad functionality). But the glitch problem still remains. Second, I found that by manually deleting the contents of ~/Library/Caches, /Library/Caches, and /System/Library/Caches, the glitching trackpad problems goes away as long as I don't boot with UseKernelCache=Yes in my org.chameleon.Boot.plist. I can even run kext utility to rebuild the Kernel/Kext Cache, as long as I don't actually use the UseKernelCache flag, I can keep booting. If I try to boot with UseKernelCache=Yes then the glitching problem comes back. As soon as I don't use UseKernelCache=Yes the glitching problem goes away again though. I'd like to be able to use the Kernel Chache. Any idea how i might go about fixing this? Thanks!
  7. DV6-6090xx Mac OS X Lion Install Disc

    Also, if I delete my org.chameleon.Boot.plist, my system will still boot normally (except for the longer boot time b/c it does not use the kernel cache), and with the usual trackpad problem. Then if I boot with -f my system boots with the SNB Framebuffer did not show up, unload Error and with perfect trackpad behavior like before. So it seems the -f is doing something else b/c org.chameleon.Boot.plist is not having an effect.
  8. DV6-6090xx Mac OS X Lion Install Disc

    Thanks! Doesn't seem to fix it though
  9. DV6-6090xx Mac OS X Lion Install Disc

    My bios version is F.1A, and here's my Extra and DSDT. Thanks a lot!
  10. DV6-6090xx Mac OS X Lion Install Disc

    Ok so after a lot of tries, I'm now able to get my mouse to behave properly if I boot with -f. This only works on my hard drive installation, and has no effect on the mouse behavior during the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] install (I'm thinking because of the Lion problems like you said, not sure why [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] uses the Extra/Extensions. Doesn't matter though since I only care about my final install). When I boot with -f I also get stuck with "SNB Framebuffer did not show up, unload" and then improper resolution when the system finally starts. It seems you were right about the problem being related to the KernelCahce, nice ! Is there anything I can do so that I don't have to boot with -f every time?
  11. DV6-6090xx Mac OS X Lion Install Disc

    Thanks for all you help! I'm gonna try a fresh install with a few different kexts and see if I can look into possible kernal cache problems.
  12. DV6-6090xx Mac OS X Lion Install Disc

    I'm using Lion. [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] creates an E/E on the install stick, but in the hard drive installation, [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] adds the extensions to S/L/E. In my last post I was describing the issue as it appears even during the installation process, running only off the installer stick. In that case there is an E/E, since ###### creates it, but the same problem persists on my completed installation where only S/L/E is used (no E/E).
  13. DV6-6090xx Mac OS X Lion Install Disc

    I tried a new usb stick from scratch, setting it up with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]. I tried repairing permissions, and booting with -f and UseKernelCache=No; none of which worked. I wouldn't think it could be a kext conflict since it's just a vanilla install + [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], and I checked in S/L/E and E/E and only saw the two Apple PS2 kexts in E/E; nothing (voodoo PS2 or Apple PS2) in S/L/E. Are there any other conflicts I should be looking for? I've gone through quite a few different PS2 kexts to no avail, do have any you think I should try? Any ways for me to debug further? Thanks for your help
  14. DV6-6090xx Mac OS X Lion Install Disc

    I'm not sure exactly what you mean but I am using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] with the app store Lion.
  15. DV6-6090xx Mac OS X Lion Install Disc

    Hi, I have an HP Pavilion dv6t-6100 CTO Quad Edition, Intel Core i7 2630QM, Switchable graphics (Intel HD and 6770M). I have this odd problem with my trackpad where it will skip across the screen or start rapidly inserting right-clicks whenever the cursor changes (arrow to text selection, or resizer cursor for instance). All other times it works fine. E.G. if the mouse moves from the desktop to a textbox (so the cursor changes from an arrow to a text selection cursor) or from the desktop to the corner of a window (changes from an arrow to a resizer arror), then the sporadic mouse behavior starts. This can occur even during the installation process by moving the cursor over a text box. This behavior does not occur when using an external mouse, or when disabling multitouch. I've tried several different ApplePS2 and VoodooPS2 kexts, and can't get anything to work. Does anybody know of this problem, or have any suggestions for a possible solution? I'd really appreciate it if anyone can help, I've searched and asked through many forums with no success. Thanks!