Jump to content

dudenesspa

Members
  • Content Count

    57
  • Joined

  • Last visited

Everything posted by dudenesspa

  1. Anyone find Web Drivers that work with 10.12.2 betas?
  2. I have managed to install Sierra on my Dell XPS 13 9343. I have everything working except: InjectIntel graphics and wifi. I used to use this iokit patch for each El Capitan update: "sudo perl -i.bak -pe ‘s|\xB8\x01\x00\x00\x00\xF6\xC1\x01\x0F\x85|\x33\xC0\x90\x90\x90\x90\x90\x90\x90\xE9|sg’ /System/Library/Frameworks/IOKit.framework/Versions/Current/IOKit sudo codesign -f -s – /System/Library/Frameworks/IOKit.framework/Versions/Current/IOKit" This patch no longer works. Anybody know how to edit this for Sierra? Secondly, my wifi no longer works. I was using Rehabman's FakePCIID and FakePCIID_Broadcom_WiFi.kext. The FakePCIID_XHCIMux.kext still works and loads but FakePCIID_Broadcom_WiFi.kext does not. Bluetooth still works just like in El Capitan. Anyone find a way to get BCM93452 working in Sierra? I know it's still early in the preview but I'd love to get it fully functional again.
  3. dudenesspa

    [pre-releases] macOS Sierra

    Anyone experiencing their files and folders icons looking they are all downloading with the bar at the bottom of the icon? It has been this way for me on two different hacks since DP3.
  4. dudenesspa

    [pre-releases] macOS Sierra

    I have a laptop that requires that I manually install update packages by going to Library/Updates and running all of the .pkgs. When I tried this for Sierra DP2, I was only able to run one of the packages; the other two had installation failures stating that the packages requires additional components to be installed. The installation failures occur with the firmware update and the actual update package. Anyone know how to get around this and get all packages to be installed successfully? Is there a more meta solution to allow my laptop to install through the App Store like a normal Mac?
  5. dudenesspa

    Dell XPS 13 9343 Touch thread

    For those trying out Sierra 10.12 with 3200x1800 screen, this is the new patch needed to get the screen working with retina resolutions and injectintel=yes: sudo perl -i.bak -pe 's|\xB8\x01\x00\x00\x00\xF6\xC1\x01\x0F\x85|\x33\xC0\x90\x90\x90\x90\x90\x90\x90\xE9|sg' /System/Library/Frameworks/CoreDisplay.framework/Versions/Current/CoreDisplay sudo codesign -f -s - /System/Library/Frameworks/CoreDisplay.framework/Versions/Current/CoreDisplay
  6. dudenesspa

    Dell XPS 13 9343 Sierra Installation

    I am using 16260006 device-id. Not sure about frame buffer. I had to set the pre-alloc to 96 when I first got this machine, then use the device id, then apply the iokit patch to get full functionality. It is not 4K but 3200x1800 but I use the Retina resolution 1600x900.
  7. dudenesspa

    Dell XPS 13 9343 Sierra Installation

    Thank you this worked!
  8. dudenesspa

    Dell XPS 13 9343 Sierra Installation

    I got no identity found after the second command.
  9. dudenesspa

    Gigabyte Z170X - Gaming 7 - Success Hackintosh

    Modify them how?
  10. dudenesspa

    Gigabyte Z170X - Gaming 7 - Success Hackintosh

    Anyone experience their system being super slow after waking from sleep? I used the general settings zip from the first post.
  11. dudenesspa

    Gigabyte Z170X - Gaming 7 - Success Hackintosh

    Andres ZeroCross Or anyone - can you explain what patches you applied to DSDT to get sleep/wake/shutdown working?
  12. Haha! I switched the 950 Pro to a PCIe adapter and it booted up in 10.11.4!
  13. I made it through upgrading to 10.11.4 but then I started getting the usbhostresources kp. Then I tried reinstalling from a 10.11.4 installer and then I got the NVMeGeneric.kext kernel panic. Hard to believe this has not been resolved.
  14. NVMeGeneric.kext kernel panic on El Cap 10.11.4. It "worked" on .1-.3 meaning I could at least get to login. Sometimes it will alternate with usbhostresources kp but I think that is more about my board and the kext I use made by someone else. My board is Gigabyte z170x gaming 7.
  15. Any progress on getting this driver to work with 10.11.4 and beyond without kernel panics and other issues? Any other NVME solutions come about recently?
  16. I just bought an SM951 256GB PCIe SSD to replace my XP941. Previously, I had modded my bios to include the Samsung EFI module and I could boot from the XP941. No such luck with the SM951. However, the SM951 is write able in OS X. Anyone try this? Different EFI module needed in bios?
  17. dudenesspa

    Dell XPS 13 9343 Touch thread

    Did anyone get the backlight keys to work? I'm messing with the DSDT desperately but cannot get them to work.
  18. dudenesspa

    OS X El Capitan DP's builds!

    I actually just got this to work by adding Kexts into "other" folder on EFI partition.
  19. dudenesspa

    OS X El Capitan DP's builds!

    Anyone who was getting gray screen with beach ball ever get passed it? I have swapped out the aptiofix with the one listed in this thread. I have put nv_disable=1 in boot flags which has always gotten me through before. . I am running gtx 980 TI and using nvidia web drivers. I have tried both from app and createinstallmedia. Can't get passed this screen. No kp that I can see.
  20. dudenesspa

    Yosemite AppleHDA HDMI Audio

    Thanks Toleda! Working HDMI audio and PM. True Hackintosh Master!
  21. dudenesspa

    Yosemite AppleHDA HDMI Audio

    Having trouble with HDMI audio using HD4600. I'm on El Capitan Beta 6. I've run the cloverALC command and added the SSDT to ACPI folder but still no HDMI audio sound. I have speaker sound. Here are my troubleshooting files. troubleshooting.zip
  22. dudenesspa

    OS X El Capitan DP's builds!

    Hi Toleda - I added the SSDT and still no luck. I posted my issue in a more appropriate thread. Can you take a look at my troubleshooting files? http://www.insanelymac.com/forum/topic/301137-yosemite-applehda-hdmi-audio/?p=2161868
  23. dudenesspa

    OS X El Capitan DP's builds!

    The command asks if you want to enable hdmi audio for 4600 and I said yes. I think I need to make dsdt edits as well. That's my next thing to try.
  24. dudenesspa

    OS X El Capitan DP's builds!

    Anyone have any luck with HDMI audio with HD4600? Using Toleda's CloverALC command. Kext patches show up, realtekALC inserted in kext folder on EFI partition, and AppleHDA.kext edited. Other sound outputs work, just not HDMI.
  25. Working well with rootless=0 and kext-dev-mode=1. Additionally for some users out there, Dell UP2715k 5k monitor sleeps and wakes successfully! Been waiting for that for a while!
×