Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About iMickk

  • Rank
    InsanelyMac Protégé
  1. Elan Touchpad Driver

    The new Elan Touchpad Driver V4 is uploaded here; http://forum.osxlatitude.com/index.php?/topic/1948-elan-touchpad-driver-mac-osx/. Nice work of EMlyDinEsH!
  2. [Lion] HDMI audio with GT220 don't works

    Does someone have a idea? I don't know how to fix it ... I have checked my HDMI device and codec id and it is the same as the ID in the AppleHDA.
  3. Hi , I have build an Hackintosh for use als HTPC. I have everything working, except my HDMI audio. The most important thing for me... I have tried many different methods, but I can't fix it. So I hope you could help me with HDMI audio in Lion. My specifications are in my signature and I will post my 'log' in this start post! I think my DSDT edits are good, because it shows up in Systemprofiler... But it doesn't show up in Systempreferences > Audio... Should it be a DSDT problem with PEG0 > PEGP or something? I didn't know how to edit that.. I did much research and I made a checklist of my research and the requirements for HDMI audio! Checklist: Systemprofiler > Displays screenshot Shows it Television = Yes? Yes Is everything good recognized of your GPU? Yes Systemprofiler > Audio screenshot Does it show your audio chip and correct inputs / outputs? Yes Does it show HDMI / Display port output? Yes Systempreferences > Displays screenshot Do you see 720p and 1080p output? Yes DSDT download DSDT Do you use a DSDT? Yes Do you have a HDAU section with HDA GFX? Yes Do you have a GFX0 section with HDA GFX? Yes Do you have a GFX0 section with @1,connector-type and @0,connector-type? Yes Do you have a working HDEF section in DSDT? Yes, works with AppleHDA kext IOREG download IOREG log Can you find an HDAU section in ioreg? Yes Is there a HDA GFX inside HDAU? Yes What is your HDMI device id? (from IOREG)? de 10 e2 0b (thats the device id inside AppleHDA). What is your HDMI codec id? (from IOREG)? 0a 00 de 10 (that's also the codec id inside AppleHDA). Other Have you connected the television to your HTPC (with HDMI cable)? Yes What do you use for GPU support? GraphicsEnabler How have you got normal audio working? (ALC 889)? With and modified AppleHDA kext from > http://www.insanelymac.com/forum/index.php?showtopic=140941). (search for ALC889 "(Gigabyte Sandy Bridge mother boards)") What version of AppleHDA do you use? version 2.1.1f12 Other downloads: Extra folder I hope you could help me to find a solution .
  4. DSDT Auto-Patcher

    I can't fix it :x. Your link is a useful (gigabyte) topic, but I can't find the right sections in my DSDT. Could you take a look at sleep / shutdown? Speedstep is something I will try to fix myself and later . I have added the WAK method to my DSDT, but it doesn't fix sleep . dsdt.aml.zip
  5. DSDT Auto-Patcher

    mobo: SuperMicro X8DAL-i You patched this DSDT, three day's ago . But only sleep doesn't work. (and sometimes restart / shutdown, but I think my BIOS isn't good configured). My kextstat is in my post before this:
  6. DSDT Auto-Patcher

    I will see or I get more KP's . I boot every time in -v! But could you look at sleep for this motherboard? Or it isn't possible?
  7. DSDT Auto-Patcher

    I run now without NullCPU kext, but sometimes I got a random KP. (not with NullCPU). Maybe native speed stepping isn't good in the DSDT? Here is my kextstat! kextstat.txt Edit: Without NullCPU shutdown and restart works by my friend! Strange, but nice (: Now we need to fix only speed stepping (native) and sleep! You send speed stepper, but this is an X58 motherboard. (1366 socket)?
  8. DSDT Auto-Patcher

    Thanks for your DSDT! Lion runs very good, but there are a few problems. Sleep, restart and shutdown doesn't work. Could you fix it in DSDT? What kind of logs do you need to fix it? I don't know what to upload .
  9. DSDT Auto-Patcher

    Hi! Thanks for your previous DSDT edits! My friend has bought a dual CPU system, could you edit his DSDT? He runs now with one processor, but after patched DSDT 2 processor's should be possible . (we have run it with dsdt patcher also, and now he can use 2 processors). But we attached the untouched DSDT. His audio chip is an ALC883, so ALC HDEF is enough . Thanks for your help! Do you have a donation page? mobo: SuperMicro X8DAL-i Send me: send_me.zip
  10. I can't get it working, not on Snow Leopard, not on Lion. Do you have suggestions? Maybe my device id (GT220) doesn't exist in the AppleHDA? Is it possible to see my HDMI device id in OS X? Or do I need to install Windows ;x.
  11. DSDT Auto-Patcher

    Damm, you bought an AMD processor for Hackintosh? You need to wait on a Legacy Kernel.. There is no support for AMD in the Vanilla Lion kernel. So it reboots automatically. Check blog.nawcom.com .
  12. Thanks, I shall try it! Do you use Lion or Snow Leopard? And could you upload your AppleHDA from the ALC889 PC? Then I use that kext to for my GT220 + ALC 889 + HDMI audio . I haven't tried HDMI audio in Windows, I shall try it tomorrow. And I will check my HDMI device id to . P.S. What means SNB? Secure Audio or something? Edit: Screenshot of hardware info in OS X. http://dl.dropbox.com/u/5688451/Schermafbe...%2017.51.06.png
  13. No problem . Thank you! Maybe a little fault in my DSDT edit? I didn't know what to do with PEG0 (PEGP, but for Sandy Bridge Gigabyte mobo).. I have renamed it to PEGP, maybe that isn't good? I'm now trying it with the AppleHDA kext from 10.6.3, that is the best for HDMI audio say some people. I will post my reports . Edit: With AppleHDA_v1.7.9 it doesn't work. It doesn't show up in Systemprofiler and I haven't any audio device in Systempreferences. My ALC889 ports are away to, but thats because I don't use an LegacyHDA / other kext. Only DSDT and patched AppleHDA normally. Maybe my HDMI device id is other then the HDMI device id in the AppleHDA? Can I see it in OS X?
  14. Yes I have an HDMI cable connected between my GT220 and my Sony TV. It shows up in Systemprofiler > Displays as Television = yes and I can choose 720p and 1080p video output. I'm now using an patched AppleHDA for the ALC889, maybe is that the problem? The version is 2.1.1 (GM). Can I see the HDMI device ID in OS X? Or do I need to install Windows :x? Maybe has my Gainward GT220 not an standard GT220 HDMI device id? Thanks for your help .
  15. What is the best AppleHDA to use in Lion? My HDMI audio shows up in Systemprofiler but not in Systempreferences > Audio. I see also HDAU / HDEF in my IOREG, so I think the DSDT patch is good! IOREG + DSDT Systemprofiler