Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About Kyle_C

  • Rank
    InsanelyMac Protégé
  1. Intel HD Graphics / GMA 5700

    I think it would be generally useful to get the full ioreg, that is the output files from this shell command, named ioreg-<name of plane>.txt for n in IOACPIPlane IOPower IODeviceTree IOService IOUSB ; do ioreg -lw300 -p $n > ioreg-$n.txt ; done And I'd particularly like to see just the IOService (so, run: ioreg -lw300 -p IOService > ioreg-filename.txt) under as many different external-monitor-attached-type situations as you can think of. Especially if you can get hold of lots of different cables and adapters for that and maybe try using the thunderbolt port like mini-dp for more than one connection. Thanks!
  2. Hey everyone, So I bought this laptop, an ASUS K53E (A1 model), in order to learn about how to do a hackintosh that is like the new 13" Macbook Pro, the first Mac with only integrated Intel graphics. Since this is very common now and these are also the cheapest PC laptops. If you look at my posts you'll see a lot of stuff on the HD Graphics 3000 support and figuring out all the details on that, and I have been helping out people with similar hardware. Anyway, my point is I'm a good guy, I didn't get this thing just to put OS X on and make some money. I'm selling this for slightly less than what I paid for it when it came out about a month ago. And it comes with a new, more compatible wireless card that I'm not figuring into the price. A friend was going to buy this but he changed his mind so I'm posting it here and his loss, your gain! $600 will exactly cover the next new Sandy Bridge laptop I want to get and do the same thing with! The hackintoshing addiction continues. This is a great deal, because this laptop is fast! Xbench score is 64, Geekbench 4790 or roughly same as a year old 15" macbook pro. (Also Cinebench roughly 9 fps/2.0 pts). So, I'll first give you the specs on the laptop in detail, then I will cover how well the hardware is supported by the installation of Lion that I have done. i3-2310m processor, Sandy Bridge w/ Intel HD Graphics 3000 15.6" LCD, glossy, LED backlit, 1366x768 4 GB 1333mhz DDR3, one sodimm slot open 2.5" 500 GB WDC Scorpio Blue hard drive dvd drive Intel HD Audio with ALC269 chip internal VGA camera on USB ports: 3x usb 2.0, lan, vga, hdmi, mic/spk, sd card half size mini-pcie slot with BCM94322-based Dell DW1510 (the wifi was originally some crummy Atheros card) 5200 mAh battery I have the following software installed (partition is MBR in case you want to add XP or something). Not everything is perfect, but this system is very new so expect these issues to get ironed out as time goes by (if you work at it!) Windows 7 (30 GB partition): no issues, all hardware works OS X Lion Developer Preview 3 (remaining space): integrated graphics: correct resolution, QE/CI and video/DVD acceleration supported, Itunes video plays VGA port does not work, HDMI port works (separate or mirrored) and is able to pull EDID data. There is very occasionally a little bit of corruption or artifacts on the screen. sleep and hibernation do not work. i'm not sure how much work it would be to fix this. screen: brightness: it boots up at about 50% then you can force it to full brightness, but beyond that no adjustment is currently possible. I haven't done much work on this, it probably can be fixed. Sleep on lid close has been disabled, but the backlight still goes off. hard drive power management is not supported with the WDC Scorpio Blue drive. hdapm has been used to prevent constant drive head parking. camera was installed upside down by ASUS, so image in iChat etc. is upside down the audio works fine, but when playing things on decent speakers some popping in the audio can be heard. using VoodooHDA. VoodooBattery is currently not working right with Lion. I expect this will be fixed soon. (http://www.projectosx.com/forum/index.php?showtopic=2145) touchpad prefpane doesn't work. Support for this type of touchpad still hasn't been added to VoodooPS2 as far as I know. wifi card has been solid, but 802.11n is untested. other issues: boot up is not as fast as it could be, and sometimes there is a KP on boot. you just have to try again. working without issue: DVD read/write, SD card reader, USB *Programs installed on OS X and Windows*: PM me for a full list. It is about 1 month old and the cosmetic condition is perfect. $600 firm. it's in Illinois, I'll ship it anywhere in the world, but you pay shipping. It won't be that much if you're in the US.
  3. Netbook hot key driver Asus Dell HP

    Thanks for taking a look. +-o EeePCWMIController <class EeePCWMIController> { "IOProbeScore" = 35 "CFBundleIdentifier" = "com.darwin.driver.EeePCWMIController" "IOProviderClass" = "IOACPIPlatformDevice" "IOClass" = "EeePCWMIController" "IOMatchCategory" = "IODefaultMatchCategory" "DataBlocks" = () "IONameMatch" = ("PNP0C14","pnp0c14") "IOPowerManagement" = {"MaxPowerState"=1,"CurrentPowerState"=1} "IONameMatched" = "PNP0C14" "WDG" = ({"object_id"="NB","flags"=2,"instance_count"=1,"UUID"="97845ED0-4E6D-11DE-8A39-0800200C9A66"},{"flags"=8,"notify_value"=255,"instance_count"=1,"UUID"="0B3CBB35-E3C2-45ED-91C2-4C5A6D195D1C"}) } Does this mean that for the volume keys I'm going to need to go through VoodooPS2? @fargerjaques, no luck with that one. dsdt.dsl.zip
  4. Intel HD Graphics / i7 2600

    Yeah it seems like BIOSes on new laptops have gotten really bad! I think mine literally has like 6 or 7 settings total. Thankfully AHCI mode for SATA was one of them, at least. Glad to see another success report!
  5. Netbook hot key driver Asus Dell HP

    This is really cool! I was going through my DSDT when I saw this PNP0C14 device, and when I found out that it is was for Windows Management Interface I was just about to rip out the whole section. But I figured I should search this forum first, and I found your extension! Unfortunately it's not working with my ASUS K53E. The kext loads and I see an EeePCWMIController under the AppleACPIPlatformExpert IOService. My WMI device in the DSDT doesn't even have an _STA method. Should I add one? If I press Fn+F2 I get a KP out of EeePCWMIController. None of the other fn keys do anything. I also tried using "NVIF" with the same results minus the KP (is this one just for laptops with Nvidia Optimus?). In IOService, I only see two entries under the "WDG" key. Are these the available key combos/actions? Would you mind posting the source code? I'd love to check it out. Also, it would be cool to see your complete AMW0 section so I can compare it with mine (although for me it's called ATKD). There are some horrendously complicated looking methods in this part of my DSDT. Who writes these things?!
  6. Intel HD Graphics / i7 2600

    Yeah, it's DP3. That's really interesting about the RAM. By the way, have you noticed artifacts getting worse with a warm restart? I may just be imagining it. And now I've gotten into the habit of always powering off for 10 seconds or so before booting again! Yeah that makes sense. Do real 2011 MBPs actually have 4 ports? LCD + two thunderbolt channels + ??
  7. Intel HD Graphics / i7 2600

    I haven't noticed any lagginess, so I guess I'm lucky. I have HDMI out working now, although still no VGA. Good enough! I think the only drawback I'm seeing with Lion is that my VoodooBattery doesn't work anymore, and I haven't really looked into that much. One tricky thing was that the SNB graphics seems to rely on AppleHDA.kext, but if you install VoodooHDA at the same time then you may get a KP at boot. So I used an AppleHDA disabler kext that I found on this forum.
  8. iTunes Video Playback in Lion

    FWIW, I don't have any issue with this using Intel HD Graphics 3000 in DP3. Maybe it has something to do with the Nvidia video acceleration kexts.
  9. Intel HD Graphics / i7 2600

    Ah, you've been digging up my old posts. That is gratifying! You did a great job of researching and pulling together a lot of useful information there. We've got a pretty good handle on the situation with SL now. I'm getting ready to join bcc9 in Lion-land, despite also being a little wary of running a major-version developer preview.
  10. Intel HD Graphics / i7 2600

    It's not yet clear whether the situation is really any different on a laptop compared to a desktop (aside from desktop processors with HD Graphics 2000 only, which is potentially an issue). My feeling is, if you get really bad distortions, AND you're using the AAPL,os-info fix (ie, the second to last item in my list above), then you should try Lion because we don't know how to fix the distortions. On the other hand, if you had 10.6.7 2011 MBP installed but didn't use the AAPL,os-info fix, yeah, it won't work. You just see some distortions in the console and never really get to the GUI. If you get a kernel panic while doing an update try removing ACPI_SMC_PlatformPlugin.kext as I mentioned in my notes. It is inside IOPlatformFamily.kext. edit: I call it console because I come from the Linux world. The black-and-white text-based interface that you see if you do a verbose boot and that you remain in when you boot single user. Is there a Mac name for that?
  11. Intel HD Graphics / i7 2600

    Correct me if I'm wrong, but I think AppleIntelHDGraphics is the part that contains the common denominator used by both Sandy Bridge macs and the earlier macs with hybrid Intel/Nvidia graphics. So it really does do stuff. Okay, thanks for clearing that up. I'll experiment with it a bit. I see screen artifacts now and then. Maybe it is a mild incarnation of the problem you have? I see two different types: a sort of checkered gray pattern that shows up in some windows (especially Microsoft Word), and lots of thin horizontal lines (especially on the desktop). It seems to be fairly random how badly I suffer from the problem on any particular boot: if I get a good one, there aren't any. Anyway, just thought I'd describe that in case you think your issue is related. I did my fresh install of 10.6.8, here are the notes I took. This is considerably simpler now that improved Sandy Bridge bootloaders are available. * use [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] to install SL retail ** I installed onto an MBR-formatted disk (here's a neat trick I just discovered: you can do this by plugging in a USB flash drive and then doing 'cd /Volumes/USBFLASH/ ; /System/Library/CoreServices/Installer.app/Contents/MacOS/Installer /System/Installation/Packages/OSInstall.mpkg'. No need to patch OSInstall.mpkg!) * remove ACPI_SMC_PlatformPlugin.kext (to prevent a KP during OS update), touch /System/Library/Extensions, and reboot * update to 10k524, but don't reboot * use [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] 3.6.0 to install fakesmc, nullcpupowermanagement and macbookpro8,1 definition * install chimera 1.4 * (because of my screwy hard drive) boot into linux to manually write the boot1h file) * add the device-properties string posted by lenovo3000 to the Boot plist * reboot with working graphics and proceed to install whatever other kexts I have the same SMboardproduct that you all have mentioned, the one from the MacBookPro8,1, but I still can't get anything to happen with 'detect displays'. I do have an AppleIntelFramebuffer device for the HDMI port in my ioreg, and when I plug in a monitor the screen flashes, but I don't end up with any additional IODisplayConnect device (I can see from a comparison of ioreg dumps that the 'display0' IODisplayConnect device for the LCD gets recreated with the same device details under a new id number, and that's it). I guess the next thing to try would be to fix my connector-type so that it is 0x800 instead of 0x400.
  12. Intel HD Graphics / i7 2600

    Hmm, I wasn't aware of that. It was doing it with vanilla 10.7.3 as well, but I never thought to remove the busratio boot argument so I'll try that. And I wasn't aware of dtrace, so thanks. (Although, it feels to me like it's an issue within the kernel since the whole UI locks up for a moment.)
  13. Intel HD Graphics / i7 2600

    Oh okay, interesting. Thanks for the info. Say, as long as I've got you here, do you mind if I go OT for a sec? I'm getting these little occasional lockups that last for like half a second. It seems to be associated with random access to the hard drive (I get dismal scores in the Xbench disk benchmarks, on the 4k random read test especially). I tried some DSDT changes to clear up IRQ conflicts on the SATA controller, and I think I managed to do that, but the problem remains. What is your opinion: should I continue to debug the problem or just try out a different hard drive and see if it goes away?
  14. Intel HD Graphics / i7 2600

    My original recipe was the 2011 Macbook version of 10.6.7 with 10.7.0 legacy kernel and reversion of the IOPCIFamily and System kexts (also ACPIPlatformSupport.kext, I think?) allowing this legacy kernel to work right. Now that Chameleon RC5 and Chimera 1.4 allow me to use a vanilla kernel I have ended up with a really messy mix of different kext versions, which is why I've decided to do a fresh install. So I'll get back to you.