Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About xela

  • Rank
    InsanelyMac Protégé

Profile Information

  • Gender
  • Location

Recent Profile Visitors

4,261 profile views
  1. Sorry I can't upload either, maybe the upgrade still in progress but I'll re-post later. For the brightness you can try shades for osx but is not a good solution. you can check out this thread ( I will try to fix the brightness when time permit.
  2. My systems need to wake up via power button too, same as in windows 10 ? I had the same issue also and understand it due to quick-sync not working on iGPU , will keep you posted if I have any advances.
  3. Alienware 15 R3 (G-SYNC 1070) with OS X 10.12.6 ESP Update 2018-0228-00 Changes: * Fix reboot when shutting down with USB hub or device connected. * Wifi patch to Global (#a), I travel a lot. aw15r3_ESP 2018-0228-00.zip
  4. The file posted here are for running serria but it should work with installation also ( i done it before).
  5. On Serria, try installing with cpus=1, nv_disable=1 and maxmem=4096 kernel boot flag. I continued using this flags until all driver are in. In my case for all aw13/15/17 series they need VoodooTSCSync.kext else KP when you remove cpus=1. I have not try HS yet but successful install had been reported.
  6. Oops ! VoodooTscSync.kext cancellation was a mistake, I still need it. I think all the remaining issues can be resolve, just need more system expert help and time. Time is something I am lacking due to work, just got back yesterday. In my case aw15r3 VDADecoderChecker test failed likely due IGPU initialization, so I think changing to my dsdt & ssdt is not going to help, also the dsdt is pretty much standard, all patches are now done on the fly. I also believe brightness on aw15r3 G-SYNC model can be fix, (http://www.insanelymac.com/forum/topic/323010-please-help-me-fix-brightness-control-nvidia-graphics-only-laptop/) I just do not have the skill and knowledge to comprehend their solution. I'll try again later. Thanks for sharing your experience, I 'll be posting my lastest aw13r3 ESP soon with some minor bug fix
  7. I am still not able to get brightness slider to show, is there anything else I should look at ? I am using macbookpro14,3 in smbios, had tried iMac14,2 to not avail. Thank You ! Laptop: Dell Alienware 15 r3, i7-7700HQ/Intel Kaby Lake rev. 05, BIOS 1.0.9, Intel® HD Graphics 630/ NVIDIA GeForce GTX 1070 (1920x1080) G-SYNC Panel 16GB RAM, Clover UEFI aw15r3_CLOVER 2018-0114.zip aw15r3.ioreg.zip
  8. Thanks ! one question, for Alienware 15 R3 G-Sync model where the video output (LCD Panel/HDMI/Mini Display Ports) are physically connected to the output of the discrete Nvidia GPU, bypassing the Intel GPU totally will have no hope using HDMI audio, correct ? Attached are the snapshots of DPCIManager output from aw15GS. I will upload aw13 series when is offline. Thanks !
  9. I think B0D4 to HDAU is not going to help with HDMI audio. As I understand in my case (Alienware 2017 Kaby Lake series), HDMI audio is tie to Nvidia GPU, verified in windows 10 and HDMI/Mini Display port are direct physical port of Nvidia GPU . Please correct me if I am wrong. Thanks !
  10. Still no slider. Meanwhile i will check if there is any conflict in config.plist and acpi aml file . Will report any new outcome. Thanks !
  11. Still no slider bar. Will check further and report back, Thanks ! aw15r3_ioreg 2018-0110-01.zip
  12. Computer: Dell Alienware 15 r3, i7-7700HQ/Intel Kaby Lake rev. 05, BIOS 1.0.9, Intel® HD Graphics 630/ NVIDIA GeForce GTX 1070 (1920x1080) G-SYNC Panel 16GB RAM, Clover UEFI Thank You ! aw15r3 2018-0110.ioreg.zip aw15r3_CLOVER 2018-0110.zip
  13. Another 1 here, Thanks in advance Computer: Dell Alienware 15 r3, i7-7700HQ/Intel Kaby Lake rev. 05, BIOS 1.0.9, Intel® HD Graphics 630/ NVIDIA GeForce GTX 1070 (1920x1080) G-SYNC Panel 16GB RAM, Clover UEFI aw15r3_CLOVER.zip
  14. Alienware 13 R3 with OS X 10.12.6 ESP Update 2018-0109-00 The following kexts were updated: - AppleALC.kext - FakePCIID_Broadcom_WiFi.kext - FakePCIID_XHCIMux.kext (unnecessary) - FakePCIID.kext - IntelGraphicsFixup.kext - Lilu.kext - NvidiaGraphicsFixup.kext Video Hardware Encoding added - Install shiki.kext with boot argument: shikigva=60 (https://github.com/vit9696/Shiki/issues/12) Audio: - Audio layout change to 11 (13 no longer work with latest AppleALC.kext for some reason) and install alc_fix. If audio does not work consistently using ssdt injection, try installing HDAEnabler11.kext & remove injection in config.plist. Power Management: - HWP Value = 0x80003801 (http://www.insanelymac.com/forum/topic/321021-guide-hwpintel-speed-shift-enable-with-full-power-management/page-4) - OR install injector-freqVectorsEdit.sh - LPC id added for Alienware13 & 15 into SSDT-LPC.aml Outstanding issues: Can anybody help ? - Graphics glitch on external display after wake from sleep (only on GTX 1060, 1070 is good) - HDMI/Mini DisplayPort audio Notes: - Special Thanks to pure.wisdom for pointing out my errors and helping this little alien closer to macbookpro. - Credits and thanks to those people in the community who developed patches, kexts, scripts and bootloaders! Piker-Alpha, RehabMan, Mieze, Macmerc, Netkas and many more !!! aw13r3_ESP 2018-0109-00.zip injector-freqVectorsEdit.sh.zip alc_fix.zip HDAEnabler11.kext.zip