Jump to content
InsanelyMac Forum

is44c

Members
  • Content count

    27
  • Joined

  • Last visited

About is44c

  • Rank
    InsanelyMac Protégé
  1. is44c

    DSDT Battery Patch for ASUS R556LD-XX480H

    Thanks RehabMan. I found the guide. Do I need to be an ASL programmer to understand it?
  2. is44c

    DSDT Battery Patch for ASUS R556LD-XX480H

    Rehabman, I had followed some of your guides and has made almost everything Yosemite works on my Dell i3148 Inspiron 2in1 including the touchscreen. The only thing didn't work was the battery. Always show 100% with Power Adaptor plugged in. I have tried the AC adaptor FIX, LPC fix, Mutex Fix, OS Fix and many of the battery patches from your git but still can't make it work. Below is my system configuration. I was able to use XPS13 battery patch to make the battery work on my XPS 18. I think it is probably due to the EC vendor difference that most of the patch not work. I believe I got a Nuvoton in this 2in1 laptop. Wonder if you can help. Thanks very much! 4th Generation Intel Core i3-4010U processor 4 GB DDR3L RAM 500 GB 5400 rpm Hard Drive, Built in Wireless b/g/n 12-inch Screen
  3. is44c

    Touch screens and Yosemite

    I have installed Yosemite on Dell XPS18 9Q33. Touchscreen controller is obviously running but there is always a ghost clicking on upper left corner. With this ghost clicking point and my finger, it does seem I have at least two fingers touch working with Yosemite built in driver...
  4. Also L322x works now too. I have copied the Extra folder from my working L321x and paste to the OSX USB drive and it boots with -x -v. The remaining is just like what I have done for L321x following Doix's guide. I searched and found the UEFI string for HD4000 and it indeed works!
  5. I got sleep to work on XPS 13 (L321x) now. Turns out I need to do drop SSDT to get the power management to work and like for the Lion, I had standby and hibernate disabled though. (Did not turn them on again to check as I can live with sleep only)
  6. Doix, I think you might be interested to know that I had figured out why the XPS13 cypress TP has issues with the cursor jumping around. I found it is due to the ApplePS2Trackpad plugin that is embedded in the ApplePS2Controller. Once I remove it, the issue is gone. It is the same for both Lion and ML. Also I found why TP works when I UseKernelCache=No. For some reason, the ApplePS2Trackpad is not loaded with this flag... I managed to get ML installed on XPS 13 L321x but the AICPUPM does not work and sleep neither. Still have problems with VoodooHDA but seems KernelCache helps reduce the cold boot crashes quite a lot at least...
  7. DoiX, I tried to delete sleep image by using the following cmd and suddenly sleeps works. Perhaps you know why but it is good to get sleep working in any case! pmset -a standby 0 hibernatemode 0
  8. Thanks DoiX. A stupid question: how do I attach a file? In fact the VoodooHDA I used is a standard 0.2.7.3 from the animal package. The patcher actually replace the voodooHDA.kext within the loader with 0.2.7.3 and I guess the 0.2.7.3 is not changed. I can attach it if I know how to attach a file.
  9. DoiX, I guess I won't spend time on the wake for XPS 13 but as 10.7.4 boots quite fast with KernelCache on, it would be great if I can make it work with VoodooPS2. Any further hint on why VoodooPS2 won't work with KernelCache?
  10. Finally got the ALC 275 to work with VoodooHDA. Looks like I am not alone in the KP with VoodooHDA. I patched version 0.2.7.3 (older version gives me KP sometimes still) with VoodooHDA patcher and use voodoo loader to load VoodooHDA whenever I would need audio. I have watched a full movie with no problem. Looks like this would work... http://www.insanelymac.com/forum/index.php?showtopic=263819&st=0
  11. I tried to patch the LegacyHDA.kext to let the ALC275 codec work on XPS13. I used ubuntu to retrieve the codec details and follow the guide to come out the strings for the my hardware layout but still no luck. Here is the string I have ended up with. I would greatly appreciate if anyway can provide any insight. Codec: Realtek ALC275 Address: 0 Vendor Id: 0x10ec0275 = 283902581 <01271c30 01271d09 01271ea6 01271f90 01371cf0 01371d11 01371e11 01371f41 01471c50 01471d00 01471e01 01471f00 01571c1f 01571d10 01571e21 01571f02 01671cf0 01671d11 01671e11 01671f41 01871c20 01871d18 01871ea1 01871f02 01971cf0 01971d11 01971e11 01971f41 01a71cf0 01a71d11 01a71e11 01a71f41 01b71cf0 01b71d11 01b71e11 01b71f41 01d71cf0 01d71d00 01d71e00 01d71f40 01e71cf0 01e71d11 01e71e11 01e71f41 01470c02>
  12. Except that Youtube always stop after 10 seconds' playback but I suspect it is because the lack of Audio driver. I saw similar behavior under 10.6.7 but after installing a working VoodooHDA, I can play Youtube normally. Thanks very much for all the help and advice here!
  13. Well looks like my HD 3000 is running well. The OS X version is 10.7.4
  14. It is there and I did repair permissions and rebuild cache but still get com.apple.driver.AppleIntelHD3000Graphics - library kext com.apple.iokit.IOGraphicsFamily not found. Jun 7 19:47:48 localhost kernel[0]: Can't load kext com.apple.driver.AppleIntelHD3000Graphics - failed to resolve library dependencies. Jun 7 19:47:48 localhost kernel[0]: Kext com.apple.driver.AppleIntelHD3000Graphics failed to load (0xdc00800e). Jun 7 19:47:48 localhost kernel[0]: Failed to load kext com.apple.driver.AppleIntelHD3000Graphics (error 0xdc00800e). Jun 7 19:47:48 localhost kernel[0]: Kext com.apple.driver.AppleHDAController - library kext com.apple.iokit.IOGraphicsFamily not found. Jun 7 19:47:48 localhost kernel[0]: Can't load kext Is there any way I can tell if Graphics is fully working?
×